# Fehler Update SQLSTATE\[42S21\]

**URL:** <https://forum.shopware.com/t/fehler-update-sqlstate-42s21/26980>\
**Category:** Installation/Einstieg\
**Created:** [6. Mai 2015 um 20:50 UTC](https://forum.shopware.com/t/fehler-update-sqlstate-42s21/26980 "2015-05-06T20:50:33Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![Matthias88](https://avatars.discourse-cdn.com/v4/letter/m/5f9b8f/32.png) [@Matthias88](https://forum.shopware.com/u/Matthias88)\
**Post date:** [6. Mai 2015 um 20:50 UTC](https://forum.shopware.com/t/fehler-update-sqlstate-42s21/26980/1 "2015-05-06T20:50:33Z")

</div>

Beim Updaten auf Shopware 5 erhalte ich folgende Fehlermeldung: Could not apply migration: SQLSTATE[42S21]: Column already exists: 1060 Duplicate column name ‘extended\_editor’ Leider habe ich in der Suchfunktion nichts gefunden. Wie kann ich den Fehler beheben? Vielen Dank im Voraus.

---

<div class="post-metadata">

**Author:** ![Matthias88](https://avatars.discourse-cdn.com/v4/letter/m/5f9b8f/32.png) [@Matthias88](https://forum.shopware.com/u/Matthias88)\
**Post date:** [10. Mai 2015 um 03:05 UTC](https://forum.shopware.com/t/fehler-update-sqlstate-42s21/26980/2 "2015-05-10T03:05:41Z")

</div>

Habe das Problem jetzt selber gelöst. Nochmal für Mitleser. Habe per FTP den Ordner assets/migration kontrolliert. Die Datei, bei der der Fehler angegeben wurde, war korrekt angelegt. Danach in phpmyadmin die Tabelle s\_schema\_version aufgerufen, und in der Datenzeile, in der Spalte error\_msg, die Fehlermeldung auf NULL gesetzt. Danach aktualisiert und das Update lief durch.

---

<div class="post-metadata">

**Author:** ![style-frames](https://avatars.discourse-cdn.com/v4/letter/s/dfb087/32.png) [@style-frames](https://forum.shopware.com/u/style-frames)\
**Post date:** [10. September 2015 um 19:23 UTC](https://forum.shopware.com/t/fehler-update-sqlstate-42s21/26980/3 "2015-09-10T19:23:10Z")

</div>

Guten Abend, ioh habe gerade das gleiche Problem, Update 4.1.4 auf 4.2.4. Could not apply migration: SQLSTATE[42S21]: Column already exists: 1060 Duplicate column name ‚extended\_editor‘ Please try to fix this error and restart the update. Response {„success“:false,„deltaFile“:"/www/htdocs/w01134ed/update/assets/migrations/101-add-extended-editor-field.php",„deltaVersion“:101,„deltaLabel“:„add-extended-editor-field“,„errorMsg“:„Could not apply migration: SQLSTATE[42S21]: Column already exists: 1060 Duplicate column name ‚extended\_editor‘“} Wenn ich in phpmyadmin die Spalte auf „Null“ setze, ändert sich leider nichts. Jemand eine Idee? Liebe Grüße, Daniel
