# Fehler seit Update von 5.23 auf 5.25

**URL:** https://forum.shopware.com/t/fehler-seit-update-von-5-23-auf-5-25/39428
**Category:** Allgemein
**Created:** [30. August 2016 um 11:18 UTC](https://forum.shopware.com/t/fehler-seit-update-von-5-23-auf-5-25/39428 "2016-08-30T11:18:26Z")
**Posts on this page:** 19
**Page:** 1

<div class="post-metadata">

### Author: ![trilou](https://avatars.discourse-cdn.com/v4/letter/t/7bcc69/32.png) [@trilou](https://forum.shopware.com/u/trilou)
#### Post date: [30. August 2016 um 11:18 UTC](https://forum.shopware.com/t/fehler-seit-update-von-5-23-auf-5-25/39428/1 "2016-08-30T11:18:26Z")

</div>

Hallo,

bitte um Hilfe, danke schon mal im Voraus. Bin hier etwas überfordert.

Ich bekomme stündlich (oder mehr) Fehler-Meldungen mit folgendem Inhalt:  
(Newsletter geht einwandfrei)

Danke  
Tom

ERROR

Message:

exception ‚Shopware\Components\CSRFTokenValidationException‘ with message ‚The provided X-CSRF-Token is invalid. Please go back, reload the page and try again.‘ in /DB/www.meineseite.com/engine/Shopware/Components/CSRFTokenValidator.php:161  
Stack trace:  
#0 [internal function]: Shopware\Components\CSRFTokenValidator-\>checkFrontendTokenValidation(Object(Enlight\_Controller\_ActionEventArgs))  
#1 /DB/www.meineseite.com/engine/Library/Enlight/Event/Handler/Default.php(91): call\_user\_func(Array, Object(Enlight\_Controller\_ActionEventArgs))  
#2 /DB/www.meineseite.com/engine/Library/Enlight/Event/EventManager.php(214): Enlight\_Event\_Handler\_Default-\>execute(Object(Enlight\_Controller\_ActionEventArgs))  
#3 /DB/www.meineseite.com/engine/Library/Enlight/Controller/Action.php(143): Enlight\_Event\_EventManager-\>notify(‚Enlight\_Control…‘, Object(Enlight\_Controller\_ActionEventArgs))  
#4 /DB/www.meineseite.com/engine/Library/Enlight/Controller/Dispatcher/Default.php(523): Enlight\_Controller\_Action-\>dispatch(‚indexAction‘)  
#5 /DB/www.meineseite.com/engine/Library/Enlight/Controller/Front.php(223): Enlight\_Controller\_Dispatcher\_Default-\>dispatch(Object(Enlight\_Controller\_Request\_RequestHttp), Object(Enlight\_Controller\_Response\_ResponseHttp))  
#6 /DB/www.meineseite.com/engine/Shopware/Kernel.php(176): Enlight\_Controller\_Front-\>dispatch()  
#7 /DB/www.meineseite.com/vendor/symfony/http-kernel/HttpCache/HttpCache.php(487): Shopware\Kernel-\>handle(Object(Symfony\Component\HttpFoundation\Request), 1, true)  
#8 /DB/www.meineseite.com/engine/Shopware/Components/HttpCache/AppCache.php(255): Symfony\Component\HttpKernel\HttpCache\HttpCache-\>forward(Object(Symfony\Component\HttpFoundation\Request), true, NULL)  
#9 /DB/www.meineseite.com/vendor/symfony/http-kernel/HttpCache/HttpCache.php(258): Shopware\Components\HttpCache\AppCache-\>forward(Object(Symfony\Component\HttpFoundation\Request), true)  
#10 /DB/www.meineseite.com/vendor/symfony/http-kernel/HttpCache/HttpCache.php(275): Symfony\Component\HttpKernel\HttpCache\HttpCache-\>pass(Object(Symfony\Component\HttpFoundation\Request), true)  
#11 /DB/www.meineseite.com/engine/Shopware/Components/HttpCache/AppCache.php(133): Symfony\Component\HttpKernel\HttpCache\HttpCache-\>invalidate(Object(Symfony\Component\HttpFoundation\Request), true)  
#12 /DB/www.meineseite.com/vendor/symfony/http-kernel/HttpCache/HttpCache.php(206): Shopware\Components\HttpCache\AppCache-\>invalidate(Object(Symfony\Component\HttpFoundation\Request), true)  
#13 /DB/www.meineseite.com/engine/Shopware/Components/HttpCache/AppCache.php(114): Symfony\Component\HttpKernel\HttpCache\HttpCache-\>handle(Object(Symfony\Component\HttpFoundation\Request), 1, true)  
#14 /DB/www.meineseite.com/shopware.php(101): Shopware\Components\HttpCache\AppCache-\>handle(Object(Symfony\Component\HttpFoundation\Request))  
#15 {main}

Time:

2016-08-30T13:09:47.969248+0200

Channel:

core

request:

{  
&nbsp;&nbsp;&nbsp; „uri“: „/newsletter“,  
&nbsp;&nbsp;&nbsp; „method“: „POST“,  
&nbsp;&nbsp;&nbsp; „query“: {  
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; „module“: „frontend“,  
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; „controller“: „newsletter“,  
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; „action“: „index“  
&nbsp;&nbsp;&nbsp; },  
&nbsp;&nbsp;&nbsp; „post“: {  
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; „subscribeToNewsletter“: „1“,  
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; „newsletter“: „[email@example.org](mailto:email@example.org)“  
&nbsp;&nbsp;&nbsp; }  
}

session:

{  
&nbsp;&nbsp;&nbsp; „sessionId“: „c2229d51fe03a798349df97cf4ddd382c22ebf70ae3521998562622ffecac68e“,  
&nbsp;&nbsp;&nbsp; „sArea“: null,  
&nbsp;&nbsp;&nbsp; „sCountry“: null,  
&nbsp;&nbsp;&nbsp; „sState“: null,  
&nbsp;&nbsp;&nbsp; „X-CSRF-Token“: „CjcWttJ1sKdpdLHa2ys4xmgjh4hDvB“,  
&nbsp;&nbsp;&nbsp; „Bot“: false,  
&nbsp;&nbsp;&nbsp; „sOutputNet“: false,  
&nbsp;&nbsp;&nbsp; „moptMandateData“: null  
}

shopId:

1

shopName:

Hauptshop Ã–sterreich

//edit DN: E-Mail-Adresse anonymisiert

---

<div class="post-metadata">

### Author: ![trilou](https://avatars.discourse-cdn.com/v4/letter/t/7bcc69/32.png) [@trilou](https://forum.shopware.com/u/trilou)
#### Post date: [30. August 2016 um 11:21 UTC](https://forum.shopware.com/t/fehler-seit-update-von-5-23-auf-5-25/39428/2 "2016-08-30T11:21:16Z")

</div>

Danke für die anonymisierung! Die Mail Adressen wechseln immer…

---

<div class="post-metadata">

### Author: ![trilou](https://avatars.discourse-cdn.com/v4/letter/t/7bcc69/32.png) [@trilou](https://forum.shopware.com/u/trilou)
#### Post date: [30. August 2016 um 11:46 UTC](https://forum.shopware.com/t/fehler-seit-update-von-5-23-auf-5-25/39428/3 "2016-08-30T11:46:08Z")

</div>

Niemand eine Idee?

---

<div class="post-metadata">

### Author: ![Synonymous](https://avatars.discourse-cdn.com/v4/letter/s/57b2e6/32.png) [@Synonymous](https://forum.shopware.com/u/Synonymous)
#### Post date: [30. August 2016 um 12:05 UTC](https://forum.shopware.com/t/fehler-seit-update-von-5-23-auf-5-25/39428/4 "2016-08-30T12:05:23Z")

</div>

1. Lass Dir Zeit - das ist ein Forum und kein Chat 🙂
2. [https://forum.shopware.com/discussion/comment/170764](https://forum.shopware.com/discussion/comment/170764)

---

<div class="post-metadata">

### Author: ![trilou](https://avatars.discourse-cdn.com/v4/letter/t/7bcc69/32.png) [@trilou](https://forum.shopware.com/u/trilou)
#### Post date: [30. August 2016 um 12:25 UTC](https://forum.shopware.com/t/fehler-seit-update-von-5-23-auf-5-25/39428/5 "2016-08-30T12:25:53Z")

</div>

An Bots dachte ich schon. IP (immer dieselbe) kommt aus Amsterdam.  
Kann man das abstellen… ohne jetzt “die Fehler an den Shopbetreiber” zu deaktivieren?  
&nbsp;

---

<div class="post-metadata">

### Author: ![TimmeHosting](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/timmehosting/32/15580_2.png) [@TimmeHosting](https://forum.shopware.com/u/TimmeHosting)
#### Post date: [31. August 2016 um 08:15 UTC](https://forum.shopware.com/t/fehler-seit-update-von-5-23-auf-5-25/39428/6 "2016-08-31T08:15:37Z")

</div>

Du könntest die IP per iptables (Firewall) sperren (sofern Du root-Zugriff auf den Server hast) oder Deinen Webserver entsprechend konfigurieren, daß er bei Anfragen von dieser IP einen 403 (Forbidden) zurückgibt.

Falls Du Apache nutzt: [Deny visitors by IP address - Apache .htaccess Guide, Tutorials & Examples](http://www.htaccess-guide.com/deny-visitors-by-ip-address/)

Und im Falle von nginx: [http://www.cyberciti.biz/faq/linux-unix-nginx-access-control-howto/](http://www.cyberciti.biz/faq/linux-unix-nginx-access-control-howto/)

![](https://europe1.discourse-cdn.com/flex013/uploads/shopware/original/1X/385eaa628505df573ebf33722f780335f53ac1b2.png)

Timme Hosting - schnelles nginx-Hosting

[www.timmehosting.de](https://timmehosting.de/)

---

<div class="post-metadata">

### Author: ![Synonymous](https://avatars.discourse-cdn.com/v4/letter/s/57b2e6/32.png) [@Synonymous](https://forum.shopware.com/u/Synonymous)
#### Post date: [31. August 2016 um 15:48 UTC](https://forum.shopware.com/t/fehler-seit-update-von-5-23-auf-5-25/39428/7 "2016-08-31T15:48:49Z")

</div>

Wobei dass Sperren nur für kurze Zeit das Problem löst - selten mehr als 24 Stunden. Das ist&nbsp;jedenfalls meine bisherige Erfahrung.

---

<div class="post-metadata">

### Author: ![MIRR\_DE](https://avatars.discourse-cdn.com/v4/letter/m/c4cdca/32.png) [@MIRR\_DE](https://forum.shopware.com/u/MIRR_DE)
#### Post date: [31. August 2016 um 20:21 UTC](https://forum.shopware.com/t/fehler-seit-update-von-5-23-auf-5-25/39428/8 "2016-08-31T20:21:53Z")

</div>

Also ich bekomme die Meldungen auch, allerdings erst seit dem Update von 5.2.2 auf 5.2.6 heute.

Wenn es ein Bot wäre, müssten die Meldungen doch eigentlich auch bereits vorher gekommen sein, oder?

---

<div class="post-metadata">

### Author: ![Synonymous](https://avatars.discourse-cdn.com/v4/letter/s/57b2e6/32.png) [@Synonymous](https://forum.shopware.com/u/Synonymous)
#### Post date: [1. September 2016 um 05:29 UTC](https://forum.shopware.com/t/fehler-seit-update-von-5-23-auf-5-25/39428/9 "2016-09-01T05:29:23Z")

</div>

Nicht wenn Du beim Update die CSRF-Settings oder die Konfiguration für Benachrichtigungen (unwissentlich) geändert hast…

---

<div class="post-metadata">

### Author: ![MIRR\_DE](https://avatars.discourse-cdn.com/v4/letter/m/c4cdca/32.png) [@MIRR\_DE](https://forum.shopware.com/u/MIRR_DE)
#### Post date: [1. September 2016 um 07:02 UTC](https://forum.shopware.com/t/fehler-seit-update-von-5-23-auf-5-25/39428/10 "2016-09-01T07:02:14Z")

</div>

Mmh… also die config.php ist unverändert und die Benachrichtigungen waren vorher ebenfalls bereits an.

Ich stelle aber gerade fest, dass die Meldung nicht nur vom Newsletter kommt, sondern ebenfalls von&nbsp;SwagBrowserLanguage.

```
{
    "uri": "/widgets/SwagBrowserLanguage/redirect",
    "method": "POST",
    "query": {
        "module": "widgets",
        "controller": "SwagBrowserLanguage",
        "action": "redirect"
    },
    "post": {
        "controllerName": "index",
        "moduleName": "",
        "modalTitle": "Automatic forwarding available",
        "modalURL": "/widgets/SwagBrowserLanguage/getModal"
    }
}

```

&nbsp;

---

<div class="post-metadata">

### Author: ![trilou](https://avatars.discourse-cdn.com/v4/letter/t/7bcc69/32.png) [@trilou](https://forum.shopware.com/u/trilou)
#### Post date: [1. September 2016 um 11:36 UTC](https://forum.shopware.com/t/fehler-seit-update-von-5-23-auf-5-25/39428/11 "2016-09-01T11:36:32Z")

</div>

Besten Dank mal für die Infos. Bekomme die Errors immer noch… 6-15 mal am Tag… aber eben erst seit dem Update auf 5.25…

Schon eigenartig… she eich wie MIRR\_DE, die wären sicher vorher auch gekommen…

---

<div class="post-metadata">

### Author: ![Goethe](https://avatars.discourse-cdn.com/v4/letter/g/dec6dc/32.png) [@Goethe](https://forum.shopware.com/u/Goethe)
#### Post date: [1. September 2016 um 13:45 UTC](https://forum.shopware.com/t/fehler-seit-update-von-5-23-auf-5-25/39428/12 "2016-09-01T13:45:27Z")

</div>

Den gleichen Fehler haben wir (und wohl noch viele andere Shopbetreiber) auch… Ich habe noch keine Lösung gefunden… ![Frown](https://forum.shopware.com/plugins/CKEditor/plugins/smiley/images/frown.png "Frown") ![Thumb-down](https://forum.shopware.com/plugins/CKEditor/plugins/smiley/images/thumb-down.png "Thumb-down")

---

<div class="post-metadata">

### Author: ![trilou](https://avatars.discourse-cdn.com/v4/letter/t/7bcc69/32.png) [@trilou](https://forum.shopware.com/u/trilou)
#### Post date: [1. September 2016 um 13:47 UTC](https://forum.shopware.com/t/fehler-seit-update-von-5-23-auf-5-25/39428/13 "2016-09-01T13:47:04Z")

</div>

Ja das klingt ganz nach den Shopware Guys… hallo???

---

<div class="post-metadata">

### Author: ![Synonymous](https://avatars.discourse-cdn.com/v4/letter/s/57b2e6/32.png) [@Synonymous](https://forum.shopware.com/u/Synonymous)
#### Post date: [1. September 2016 um 17:00 UTC](https://forum.shopware.com/t/fehler-seit-update-von-5-23-auf-5-25/39428/14 "2016-09-01T17:00:13Z")

</div>

Also für mich sieht es so aus als wären diese Requests nichts Neues, nur das sie bisher keine Notification ausgelöst haben. Schaut mal in Euren access logs nach, ob es diese Requests auch&nbsp;schon vor dem Update gab.

---

<div class="post-metadata">

### Author: ![MIRR\_DE](https://avatars.discourse-cdn.com/v4/letter/m/c4cdca/32.png) [@MIRR\_DE](https://forum.shopware.com/u/MIRR_DE)
#### Post date: [2. September 2016 um 11:03 UTC](https://forum.shopware.com/t/fehler-seit-update-von-5-23-auf-5-25/39428/15 "2016-09-02T11:03:05Z")

</div>

Also das sind meine letzten einträge im access\_ssl\_log&nbsp;hinsichtlich des POST Newsletter Requests:

```
106.39.17.106 - - [02/Sep/2016:12:24:34 +0200] "GET / HTTP/1.0" 200 14741 "-" "Mozilla/5.0 (Windows NT 5.1; rv:7.0.1) Gecko/20100101 Firefox/7.0.1"
106.39.17.106 - - [02/Sep/2016:12:24:39 +0200] "POST /newsletter HTTP/1.0" 400 13429 "http://werbeartikel-welt.com/" "Mozilla/5.0 (Windows NT 5.1; rv:7.0.1) Gecko/20100101 Firefox/7.0.1"

```

Die Meldung bzgl. SwagBrowserLanguage kommt z.B. von:

```
80.141.20.190 - - [02/Sep/2016:12:29:45 +0200] "GET /csrftoken HTTP/1.0" 200 685 "https://werbeartikel-welt.com/" "Mozilla/5.0 (Windows NT 6.1; rv:48.0) Gecko/20100101 Firefox/48.0"
80.141.20.190 - - [02/Sep/2016:12:29:45 +0200] "GET /widgets/index/refreshStatistic?requestPage=/&requestController=index&referer=https://www.wlw.de/profile/werbeartikel-welt-ug-1808055?category_id=157877&q=Werbeartikel+mit+Logo&callback=jQuery21403351552018520719_1472812185843&_=1472812185844 HTTP/1.0" 200 648 "https://werbeartikel-welt.com/" "Mozilla/5.0 (Windows NT 6.1; rv:48.0) Gecko/20100101 Firefox/48.0"
80.141.20.190 - - [02/Sep/2016:12:29:45 +0200] "GET /favicon.ico HTTP/1.0" 500 8457 "-" "Mozilla/5.0 (Windows NT 6.1; rv:48.0) Gecko/20100101 Firefox/48.0"
80.141.20.190 - - [02/Sep/2016:12:29:45 +0200] "POST /widgets/SwagBrowserLanguage/redirect HTTP/1.0" 400 868 "https://werbeartikel-welt.com/" "Mozilla/5.0 (Windows NT 6.1; rv:48.0) Gecko/20100101 Firefox/48.0"

```

Wird dadurch jetzt eine Notiication ausgelöst und früher nicht?

---

<div class="post-metadata">

### Author: ![Synonymous](https://avatars.discourse-cdn.com/v4/letter/s/57b2e6/32.png) [@Synonymous](https://forum.shopware.com/u/Synonymous)
#### Post date: [2. September 2016 um 11:56 UTC](https://forum.shopware.com/t/fehler-seit-update-von-5-23-auf-5-25/39428/16 "2016-09-02T11:56:45Z")

</div>

Du solltest in der Historie schauen, bevor das Update gemacht wurde…

---

<div class="post-metadata">

### Author: ![MIRR\_DE](https://avatars.discourse-cdn.com/v4/letter/m/c4cdca/32.png) [@MIRR\_DE](https://forum.shopware.com/u/MIRR_DE)
#### Post date: [2. September 2016 um 14:24 UTC](https://forum.shopware.com/t/fehler-seit-update-von-5-23-auf-5-25/39428/17 "2016-09-02T14:24:32Z")

</div>

Sorry. Da sind dieselben, bzw. halt ähnliche&nbsp;Requests drinnen.

---

<div class="post-metadata">

### Author: ![canetti2](https://avatars.discourse-cdn.com/v4/letter/c/a8b319/32.png) [@canetti2](https://forum.shopware.com/u/canetti2)
#### Post date: [19. September 2016 um 08:51 UTC](https://forum.shopware.com/t/fehler-seit-update-von-5-23-auf-5-25/39428/18 "2016-09-19T08:51:26Z")

</div>

Wir haben leider das selbe Problem - ca. 15 - 30 Errormails pro Tag seit dem Update auf 5.2.3 (oder 5.2.2). Wir haben auch schon den Shopware-Support in der Angelegenheit kontaktiert. Die waren auch ratlos und konnten uns auch nicht mitteilen, wie der Fehler ausgelöst wird.

sehr nervig…

---

<div class="post-metadata">

### Author: ![ROKAStore](https://avatars.discourse-cdn.com/v4/letter/r/b487fb/32.png) [@ROKAStore](https://forum.shopware.com/u/ROKAStore)
#### Post date: [29. September 2016 um 19:30 UTC](https://forum.shopware.com/t/fehler-seit-update-von-5-23-auf-5-25/39428/19 "2016-09-29T19:30:00Z")

</div>

Same here, wobei der Fehler bei mir nur mit „/en/newsletter“ auftritt… wahnsinnig nervig, da ich die Error-Mails wegen „echten“ Fehlern eigentlich anlassen möchte.
