# Fehler nach Update auf 4.2 /  Shopware\\Kernel / Appcache

**URL:** <https://forum.shopware.com/t/fehler-nach-update-auf-4-2-shopware-kernel-appcache/18402>\
**Category:** Shopware 3.5\
**Tags:** installation--gettin\
**Created:** [12. Februar 2014 um 18:21 UTC](https://forum.shopware.com/t/fehler-nach-update-auf-4-2-shopware-kernel-appcache/18402 "2014-02-12T18:21:46Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![ChrisTV](https://avatars.discourse-cdn.com/v4/letter/c/ebca7d/32.png) [@ChrisTV](https://forum.shopware.com/u/ChrisTV)\
**Post date:** [12. Februar 2014 um 18:21 UTC](https://forum.shopware.com/t/fehler-nach-update-auf-4-2-shopware-kernel-appcache/18402/1 "2014-02-12T18:21:46Z")

</div>

Hallo liebes Forum, nach dem Update auf die neue, aktuelle 4.2 Version erscheint leider folgende Fehlermitteilung (ein Zugriff auf das Front- und Backend ist auch nicht mehr möglich): Fatal error: Call to undefined method Shopware\Kernel::getApp() in /xxx/www.meinshop.com/shop/engine/Shopware/Components/HttpCache/AppCache.php on line 229 Hat jemand evtl. einen Tipp, wie ich diesen Fehler beheben kann? Besten Dank und viele Grüße Chris

---

<div class="post-metadata">

**Author:** ![ChrisTV](https://avatars.discourse-cdn.com/v4/letter/c/ebca7d/32.png) [@ChrisTV](https://forum.shopware.com/u/ChrisTV)\
**Post date:** [13. Februar 2014 um 19:29 UTC](https://forum.shopware.com/t/fehler-nach-update-auf-4-2-shopware-kernel-appcache/18402/2 "2014-02-13T19:29:57Z")

</div>

Mhh, niemand eine Idee? 😢

---

<div class="post-metadata">

**Author:** ![Stephan\_Schirmer](https://avatars.discourse-cdn.com/v4/letter/s/b77776/32.png) [@Stephan\_Schirmer](https://forum.shopware.com/u/Stephan_Schirmer)\
**Post date:** [17. Februar 2014 um 20:14 UTC](https://forum.shopware.com/t/fehler-nach-update-auf-4-2-shopware-kernel-appcache/18402/3 "2014-02-17T20:14:58Z")

</div>

Habe das gleiche Problem! Keine eine Idee? @ChrisTV Hast Du es gelöst? Viele Grüße Stephan \_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_ Shopware 4.1.4 auf 4.2.1 PHP 5.4 / FastCGI

---

<div class="post-metadata">

**Author:** ![ChrisTV](https://avatars.discourse-cdn.com/v4/letter/c/ebca7d/32.png) [@ChrisTV](https://forum.shopware.com/u/ChrisTV)\
**Post date:** [17. Februar 2014 um 20:18 UTC](https://forum.shopware.com/t/fehler-nach-update-auf-4-2-shopware-kernel-appcache/18402/4 "2014-02-17T20:18:05Z")

</div>

Hallo Stephan, das Problem an sich konnte ich leider nur durch eine Neu-Installation lösen. Den Fehler an sich, konnte ich nicht beheben bzw. nachvollziehen. Sorry, aber vielleicht hat hier doch jemand noch eine Lösung. Viele Grüße Chris
