# Fehler nach Umstellung auf PHP 7.4 - Shop nicht mehr erreichbar

**URL:** https://forum.shopware.com/t/fehler-nach-umstellung-auf-php-7-4-shop-nicht-mehr-erreichbar/90714
**Category:** Shopware 5
**Created:** [5. Oktober 2021 um 14:45 UTC](https://forum.shopware.com/t/fehler-nach-umstellung-auf-php-7-4-shop-nicht-mehr-erreichbar/90714 "2021-10-05T14:45:14Z")
**Posts on this page:** 11
**Page:** 1

<div class="post-metadata">

### Author: ![bavaritalian](https://avatars.discourse-cdn.com/v4/letter/b/a9adbd/32.png) [@bavaritalian](https://forum.shopware.com/u/bavaritalian)
#### Post date: [5. Oktober 2021 um 14:45 UTC](https://forum.shopware.com/t/fehler-nach-umstellung-auf-php-7-4-shop-nicht-mehr-erreichbar/90714/1 "2021-10-05T14:45:15Z")

</div>

Hallo, ich hab hier eine Shopware 5.6.10 Installation bei all-inkl gehostet, die läuft auf PHP 7.3. Möchte nun auf Shopware 5.7.x updaten, dazu vorher im KAS die PHP-Version auf 7.4 umgestellt. Dann komme ich aber nicht mehr in den Shop. Frontend gibt nur einen 500 aus, Backend diese Fehlermeldung:

Ups! Ein Fehler ist aufgetreten!  
Die nachfolgenden Hinweise sollten Ihnen weiterhelfen.

Zend\_Session::start() - /www/htdocs/w013bXYZ/XYZ.de/engine/Library/Zend/Session.php(Line:468): Error #2 session\_start(): Failed to read session data: files (path: tcp://127.0.0.1:6379?prefix=EMSM:) in engine/Library/Zend/Session.php on line 481

Stack trace:  
#0 engine/Shopware/Plugins/Default/Backend/Auth/Bootstrap.php(374): Zend\_Session::start(Array)  
#1 engine/Library/Enlight/Event/Handler/Plugin.php(145): Shopware\_Plugins\_Backend\_Auth\_Bootstrap-\>onInitResourceBackendSession(Object(Enlight\_Event\_EventArgs))  
#2 engine/Library/Enlight/Event/EventManager.php(251): Enlight\_Event\_Handler\_Plugin-\>execute(Object(Enlight\_Event\_EventArgs))  
#3 engine/Shopware/Components/DependencyInjection/Container.php(204): Enlight\_Event\_EventManager-\>notifyUntil(‚Enlight\_Bootstr…‘, Object(Enlight\_Event\_EventArgs))  
#4 engine/Shopware/Components/DependencyInjection/Container.php(160): Shopware\Components\DependencyInjection\Container-\>doLoad(‚backendsession‘, ‚backendsession‘)  
#5 engine/Shopware/Plugins/Default/Backend/Auth/Bootstrap.php(391): Shopware\Components\DependencyInjection\Container-\>load(‚backendsession‘)  
#6 engine/Library/Enlight/Event/Handler/Plugin.php(145): Shopware\_Plugins\_Backend\_Auth\_Bootstrap-\>onInitResourceAuth(Object(Enlight\_Event\_EventArgs))  
#7 engine/Library/Enlight/Event/EventManager.php(251): Enlight\_Event\_Handler\_Plugin-\>execute(Object(Enlight\_Event\_EventArgs))  
#8 engine/Shopware/Components/DependencyInjection/Container.php(204): Enlight\_Event\_EventManager-\>notifyUntil(‚Enlight\_Bootstr…‘, Object(Enlight\_Event\_EventArgs))  
#9 engine/Shopware/Components/DependencyInjection/Container.php(141): Shopware\Components\DependencyInjection\Container-\>doLoad(‚auth‘, ‚auth‘, 1)  
#10 engine/Library/Enlight/Plugin/Bootstrap.php(116): Shopware\Components\DependencyInjection\Container-\>get(‚auth‘)  
#11 engine/Shopware/Plugins/Default/Backend/Auth/Bootstrap.php(457): Enlight\_Plugin\_Bootstrap-\>get(‚auth‘)  
#12 engine/Shopware/Plugins/Default/Backend/Auth/Bootstrap.php(426): Shopware\_Plugins\_Backend\_Auth\_Bootstrap-\>getCurrentLocale()  
#13 engine/Shopware/Plugins/Default/Backend/Auth/Bootstrap.php(214): Shopware\_Plugins\_Backend\_Auth\_Bootstrap-\>initLocale()  
#14 engine/Library/Enlight/Event/Handler/Plugin.php(145): Shopware\_Plugins\_Backend\_Auth\_Bootstrap-\>onPreDispatchBackend(Object(Enlight\_Controller\_ActionEventArgs))  
#15 engine/Library/Enlight/Event/EventManager.php(214): Enlight\_Event\_Handler\_Plugin-\>execute(Object(Enlight\_Controller\_ActionEventArgs))  
#16 engine/Library/Enlight/Controller/Action.php(169): Enlight\_Event\_EventManager-\>notify(‚Enlight\_Control…‘, Object(Enlight\_Controller\_ActionEventArgs))  
#17 engine/Library/Enlight/Controller/Dispatcher/Default.php(478): Enlight\_Controller\_Action-\>dispatch(‚indexAction‘)  
#18 engine/Library/Enlight/Controller/Front.php(228): Enlight\_Controller\_Dispatcher\_Default-\>dispatch(Object(Enlight\_Controller\_Request\_RequestHttp), Object(Enlight\_Controller\_Response\_ResponseHttp))  
#19 engine/Shopware/Kernel.php(188): Enlight\_Controller\_Front-\>dispatch()  
#20 vendor/symfony/http-kernel/HttpCache/SubRequestHandler.php(102): Shopware\Kernel-\>handle(Object(Symfony\Component\HttpFoundation\Request), 1, true)  
#21 vendor/symfony/http-kernel/HttpCache/HttpCache.php(453): Symfony\Component\HttpKernel\HttpCache\SubRequestHandler::handle(Object(Shopware\Kernel), Object(Symfony\Component\HttpFoundation\Request), 1, true)  
#22 engine/Shopware/Components/HttpCache/AppCache.php(261): Symfony\Component\HttpKernel\HttpCache\HttpCache-\>forward(Object(Symfony\Component\HttpFoundation\Request), true, NULL)  
#23 vendor/symfony/http-kernel/HttpCache/HttpCache.php(238): Shopware\Components\HttpCache\AppCache-\>forward(Object(Symfony\Component\HttpFoundation\Request), true)  
#24 engine/Shopware/Components/HttpCache/AppCache.php(102): Symfony\Component\HttpKernel\HttpCache\HttpCache-\>pass(Object(Symfony\Component\HttpFoundation\Request), true)  
#25 shopware.php(122): Shopware\Components\HttpCache\AppCache-\>handle(Object(Symfony\Component\HttpFoundation\Request))  
#26 {main}

Wenn ich im [all-inkl.com](http://all-inkl.com) KAS die PHP-Version wieder auf 7.3 zurückstelle, läuft der Shop wieder aber so ist ja kein Update der SW-Version möglich.

---

<div class="post-metadata">

### Author: ![hinnack](https://avatars.discourse-cdn.com/v4/letter/h/49beb7/32.png) [@hinnack](https://forum.shopware.com/u/hinnack)
#### Post date: [5. Oktober 2021 um 14:56 UTC](https://forum.shopware.com/t/fehler-nach-umstellung-auf-php-7-4-shop-nicht-mehr-erreichbar/90714/2 "2021-10-05T14:56:52Z")

</div>

Hast Du es schon mal mit PHP 8 versucht ?  
Soll ja angeblich auch mit der 5.7 laufen.

Pardon - Denkfehler meinerseits.  
PHP 8 läuft ja gar nicht mit der 5.6

---

<div class="post-metadata">

### Author: ![bavaritalian](https://avatars.discourse-cdn.com/v4/letter/b/a9adbd/32.png) [@bavaritalian](https://forum.shopware.com/u/bavaritalian)
#### Post date: [5. Oktober 2021 um 15:03 UTC](https://forum.shopware.com/t/fehler-nach-umstellung-auf-php-7-4-shop-nicht-mehr-erreichbar/90714/3 "2021-10-05T15:03:18Z")

</div>

Ja, ich hatte versuchsweise dann auch mal auf PHP8 gestellt, was aber erwartungsgemäß erst recht nicht funktionierte.

---

<div class="post-metadata">

### Author: ![sonic](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/sonic/32/25728_2.png) [@sonic](https://forum.shopware.com/u/sonic)
#### Post date: [5. Oktober 2021 um 15:10 UTC](https://forum.shopware.com/t/fehler-nach-umstellung-auf-php-7-4-shop-nicht-mehr-erreichbar/90714/4 "2021-10-05T15:10:34Z")

</div>

Eigentlich ist das kein Problem mit SW 5.6 und PHP 7.3 auf 7.4 bei AllInkl.  
Scheint eher ein Cache Problem zu sein?  
Bach dem Umstellen mal den production\_xxx Ordner unter var/cache löschen.

Von PHP8 würde ich im Moment bei All-Inkl. noch die Finger lassen. Da werden so ziemlich alle Einstellungen in der .htaccess noch ignoriert

---

<div class="post-metadata">

### Author: ![bavaritalian](https://avatars.discourse-cdn.com/v4/letter/b/a9adbd/32.png) [@bavaritalian](https://forum.shopware.com/u/bavaritalian)
#### Post date: [5. Oktober 2021 um 15:14 UTC](https://forum.shopware.com/t/fehler-nach-umstellung-auf-php-7-4-shop-nicht-mehr-erreichbar/90714/5 "2021-10-05T15:14:53Z")

</div>

Cache direkt vor dem Umstellen der PHP-Version via Shopware Backend gelöscht: Problem besteht weiterhin.

production\_xxx Ordner unter var/cache gelöscht direkt nach dem Umstellen der PHP-Version: Problem besteht weiterhin.

---

<div class="post-metadata">

### Author: ![SCOOPEX](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/scoopex/32/18328_2.png) [@SCOOPEX](https://forum.shopware.com/u/SCOOPEX)
#### Post date: [5. Oktober 2021 um 17:04 UTC](https://forum.shopware.com/t/fehler-nach-umstellung-auf-php-7-4-shop-nicht-mehr-erreichbar/90714/6 "2021-10-05T17:04:48Z")

</div>

Hallo,

lt. Fehlermeldung hast Du Redis aktiv und es gibt wohl Probleme mit dem Dienst oder der Redis Unterstützung bei der dort installierten PHP 7.4 Version, da die Sessions nicht gespeichert werden können.

Kommentiere die Redis Zeilen mal in Deiner config.php aus - danach unter /var/cache den production\_xxxx Ordner löschen oder umbenennen.

Viele Grüße

---

<div class="post-metadata">

### Author: ![bavaritalian](https://avatars.discourse-cdn.com/v4/letter/b/a9adbd/32.png) [@bavaritalian](https://forum.shopware.com/u/bavaritalian)
#### Post date: [5. Oktober 2021 um 22:07 UTC](https://forum.shopware.com/t/fehler-nach-umstellung-auf-php-7-4-shop-nicht-mehr-erreichbar/90714/7 "2021-10-05T22:07:27Z")

</div>

Der all-inkl Support konnte es klären: Redis / APCu waren im PHP 7.4 Modul auf diesem Server nicht installiert. Wurde nachgeholt. Jetzt läuft’s.

---

<div class="post-metadata">

### Author: ![Moin](https://avatars.discourse-cdn.com/v4/letter/m/c89c15/32.png) [@Moin](https://forum.shopware.com/u/Moin)
#### Post date: [6. Oktober 2021 um 09:45 UTC](https://forum.shopware.com/t/fehler-nach-umstellung-auf-php-7-4-shop-nicht-mehr-erreichbar/90714/8 "2021-10-06T09:45:34Z")

</div>

Welches Hosting hast du bei all inkl., weil da gibt es kein APCu Cache für Shopware!  
Hast du einen eigenen Server?

---

<div class="post-metadata">

### Author: ![bavaritalian](https://avatars.discourse-cdn.com/v4/letter/b/a9adbd/32.png) [@bavaritalian](https://forum.shopware.com/u/bavaritalian)
#### Post date: [6. Oktober 2021 um 17:11 UTC](https://forum.shopware.com/t/fehler-nach-umstellung-auf-php-7-4-shop-nicht-mehr-erreichbar/90714/9 "2021-10-06T17:11:14Z")

</div>

Ja, ich hab einen eigenen Server gebucht, da gehen dann einige Sache die in den Shared Hosting Tarifen nicht verfügbar sind.

---

<div class="post-metadata">

### Author: ![Moin](https://avatars.discourse-cdn.com/v4/letter/m/c89c15/32.png) [@Moin](https://forum.shopware.com/u/Moin)
#### Post date: [7. Oktober 2021 um 06:58 UTC](https://forum.shopware.com/t/fehler-nach-umstellung-auf-php-7-4-shop-nicht-mehr-erreichbar/90714/10 "2021-10-07T06:58:53Z")

</div>

Welcher Server und wat kostet es? Ein bissel Werbung darf sein!

---

<div class="post-metadata">

### Author: ![bavaritalian](https://avatars.discourse-cdn.com/v4/letter/b/a9adbd/32.png) [@bavaritalian](https://forum.shopware.com/u/bavaritalian)
#### Post date: [7. Oktober 2021 um 08:10 UTC](https://forum.shopware.com/t/fehler-nach-umstellung-auf-php-7-4-shop-nicht-mehr-erreichbar/90714/11 "2021-10-07T08:10:13Z")

</div>

Tarifübersicht der Server findest du hier: [Server-Hosting: Managed Server, Webserver: Server-Hosting Preise & Tarife - ALL-INKL.COM](https://m.all-inkl.com/server/uebersicht/)

Fü meine Zwecke genügt der kleinste davon. Aber das muss jeder selbst entscheiden.
