# Fehler in Cronjob Search, bzw. RefreshSearchIndex

**URL:** <https://forum.shopware.com/t/fehler-in-cronjob-search-bzw-refreshsearchindex/41819>\
**Category:** Administration\
**Created:** [29. November 2016 um 15:11 UTC](https://forum.shopware.com/t/fehler-in-cronjob-search-bzw-refreshsearchindex/41819 "2016-11-29T15:11:23Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![MIRR\_DE](https://avatars.discourse-cdn.com/v4/letter/m/c4cdca/32.png) [@MIRR\_DE](https://forum.shopware.com/u/MIRR_DE)\
**Post date:** [29. November 2016 um 15:11 UTC](https://forum.shopware.com/t/fehler-in-cronjob-search-bzw-refreshsearchindex/41819/1 "2016-11-29T15:11:23Z")

</div>

Hallo,

ich erhalte in den beiden Cronjobs „Shopware\_CronJob\_Search“ und „Shopware\_CronJob\_RefreshSearch“ jeweils anhängende Fehlermeldung.  
Der „\_Search“ sollte meines Wissens nach von dem „\_RefreshSearch“ abgelöst worden sein, löschen kann ich ihn jedoch nicht. Das aber nur am Rande.

Das „Ergebnis“ ist recht lang, deshalb hier ein Link zur TXT-Datei auf Dropbox: [Fehler-Datei](https://www.dropbox.com/s/t3acqkai2nvjwpz/Shopware_Cronjob_RefreshSearch_Error.txt?dl=0)

Hier der Endausschnitt mit dem Fehler:

```
Start:
array (
  'error' => 'An exception occurred while executing \'INSERT IGNORE INTO s_search_index (keywordID, elementID, fieldID)

Ende:
SQLSTATE[42000]: Syntax error or access violation: 1064 You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near \'as elementID, 11 as fieldID FROM s_search_keywords sk WHERE sk.keyword IN (\'smok\' at line 15',
)

Stack trace:

#0 vendor/doctrine/dbal/lib/Doctrine/DBAL/Connection.php(996): Doctrine\DBAL\DBALException::driverExceptionDuringQuery(Object(Doctrine\DBAL\Driver\PDOMySql\Driver), Object(PDOException), 'INSERT IGNORE I...', Array)
#1 engine/Shopware/Bundle/SearchBundleDBAL/SearchTerm/SearchIndexer.php(203): Doctrine\DBAL\Connection->executeUpdate('INSERT IGNORE I...')
#2 engine/Shopware/Plugins/Default/Core/RebuildIndex/Bootstrap.php(234): Shopware\Bundle\SearchBundleDBAL\SearchTerm\SearchIndexer->build()
#3 engine/Library/Enlight/Event/Handler/Plugin.php(149): Shopware_Plugins_Core_RebuildIndex_Bootstrap->refreshSearchIndex(Object(Shopware_Components_Cron_CronJob))
#4 engine/Library/Enlight/Event/EventManager.php(251): Enlight_Event_Handler_Plugin->execute(Object(Shopware_Components_Cron_CronJob))
#5 engine/Library/Enlight/Components/Cron/Manager.php(258): Enlight_Event_EventManager->notifyUntil('Shopware_CronJo...', Object(Shopware_Components_Cron_CronJob))
#6 engine/Shopware/Plugins/Default/Core/Cron/Cron.php(52): Enlight_Components_Cron_Manager->runJob(Object(Enlight_Components_Cron_Job))
#7 engine/Library/Enlight/Controller/Action.php(159): Shopware_Controllers_Backend_Cron->indexAction()
#8 engine/Library/Enlight/Controller/Dispatcher/Default.php(523): Enlight_Controller_Action->dispatch('indexAction')
#9 engine/Library/Enlight/Controller/Front.php(223): Enlight_Controller_Dispatcher_Default->dispatch(Object(Enlight_Controller_Request_RequestHttp), Object(Enlight_Controller_Response_ResponseHttp))
#10 engine/Shopware/Kernel.php(177): Enlight_Controller_Front->dispatch()
#11 vendor/symfony/http-kernel/HttpCache/HttpCache.php(487): Shopware\Kernel->handle(Object(Symfony\Component\HttpFoundation\Request), 1, true)
#12 engine/Shopware/Components/HttpCache/AppCache.php(255): Symfony\Component\HttpKernel\HttpCache\HttpCache->forward(Object(Symfony\Component\HttpFoundation\Request), true, NULL)
#13 vendor/symfony/http-kernel/HttpCache/HttpCache.php(258): Shopware\Components\HttpCache\AppCache->forward(Object(Symfony\Component\HttpFoundation\Request), true)
#14 engine/Shopware/Components/HttpCache/AppCache.php(103): Symfony\Component\HttpKernel\HttpCache\HttpCache->pass(Object(Symfony\Component\HttpFoundation\Request), true)
#15 shopware.php(113): Shopware\Components\HttpCache\AppCache->handle(Object(Symfony\Component\HttpFoundation\Request))
#16 {main}

```

Ich hoffe ihr könnt mir helfen.

Viele Grüße,

Manuel

---

<div class="post-metadata">

**Author:** ![tny](https://avatars.discourse-cdn.com/v4/letter/t/da6949/32.png) [@tny](https://forum.shopware.com/u/tny)\
**Post date:** [29. November 2016 um 18:17 UTC](https://forum.shopware.com/t/fehler-in-cronjob-search-bzw-refreshsearchindex/41819/2 "2016-11-29T18:17:48Z")

</div>

Schließe mich hier an, hab den gleichen Fehler (mit Intelligente Suche Plugin). Bisher keine Zeit gehabt zu schauen woher es kommt. (Also klar, die ElementIds fehlen, aber warum)&nbsp;Vllt. findet sich ja hier die Lösung

---

<div class="post-metadata">

**Author:** ![Moritz\_Naczenski](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/moritz_naczenski/32/7792_2.png) [@Moritz\_Naczenski](https://forum.shopware.com/u/Moritz_Naczenski)\
**Post date:** [29. November 2016 um 18:51 UTC](https://forum.shopware.com/t/fehler-in-cronjob-search-bzw-refreshsearchindex/41819/3 "2016-11-29T18:51:18Z")

</div>

Man besten leert ihr mal in der s\_crontab das ergebnisfeld und führt den Cronjob nochmal neu aus. Die Meldung bleibt immer im Feld, auch wenn er danach durchläuft. So kann&nbsp;man ausschließen, dass es ein temporäres Problem war.

---

<div class="post-metadata">

**Author:** ![MIRR\_DE](https://avatars.discourse-cdn.com/v4/letter/m/c4cdca/32.png) [@MIRR\_DE](https://forum.shopware.com/u/MIRR_DE)\
**Post date:** [29. November 2016 um 18:56 UTC](https://forum.shopware.com/t/fehler-in-cronjob-search-bzw-refreshsearchindex/41819/4 "2016-11-29T18:56:07Z")

</div>

> [@Moritz Naczenski schrieb:](https://forum.shopware.com/profile/14574/Moritz%20Naczenski "Moritz%20Naczenski")
> 
> Man besten leert ihr mal in der s\_crontab das ergebnisfeld und führt den Cronjob nochmal neu aus. Die Meldung bleibt immer im Feld, auch wenn er danach durchläuft. So kann&nbsp;man ausschließen, dass es ein temporäres Problem war.

Das habe ich bereits gemacht, bringt aber leider nichts. Der Fehler ist derselbe.&nbsp;

---

<div class="post-metadata">

**Author:** ![Sonja\_EH](https://avatars.discourse-cdn.com/v4/letter/s/47e85d/32.png) [@Sonja\_EH](https://forum.shopware.com/u/Sonja_EH)\
**Post date:** [30. Mai 2023 um 11:07 UTC](https://forum.shopware.com/t/fehler-in-cronjob-search-bzw-refreshsearchindex/41819/5 "2023-05-30T11:07:03Z")

</div>

@MIRR_DE Hi habe das gleiche Problem. Wie konntest du es lösen?

hab auch ständig abgebrochenen Cronjob mit Fehler:  
array (  
‚error‘ =\> 'An exception occurred while executing 'INSERT IGNORE INTO s\_search\_index (keywordID, elementID, fieldID)

SELECT sk.id as keywordID, 985 as elementID, 5 as fieldID FROM s\_search\_keywords sk WHERE sk.keyword IN ('1001')

UNION ALL

und unten  
SQLSTATE[42000]: Syntax error or access violation: 1064 memory exhausted near 'sk.id as keywordID, 9495 as elementID, 5 as fieldID FROM s\_search\_keywords sk…' at line 15995’,  
)

wir haben das Limit schon komplett von oben nach unten immer wieder geändert… aber es ist trotzdem immer wieder der gleiche Fehler…  
Wäre dankbar um Hilfe… Agentur konnte mir nicht helfen

---

<div class="post-metadata">

**Author:** ![Sonja\_EH](https://avatars.discourse-cdn.com/v4/letter/s/47e85d/32.png) [@Sonja\_EH](https://forum.shopware.com/u/Sonja_EH)\
**Post date:** [31. Mai 2023 um 07:17 UTC](https://forum.shopware.com/t/fehler-in-cronjob-search-bzw-refreshsearchindex/41819/6 "2023-05-31T07:17:00Z")

</div>

oder @Moritz_Naczenski kannst du mir dazu nochmal was sagen?  
lg  
SONJA
