# Fehler beim Update auf 5.4.0

**URL:** <https://forum.shopware.com/t/fehler-beim-update-auf-5-4-0/51447>\
**Category:** Installation/Einstieg\
**Created:** [28. Februar 2018 um 17:55 UTC](https://forum.shopware.com/t/fehler-beim-update-auf-5-4-0/51447 "2018-02-28T17:55:14Z")\
**Posts on this page:** 19\
**Page:** 1

<div class="post-metadata">

**Author:** ![piratenkiste](https://avatars.discourse-cdn.com/v4/letter/p/a8b319/32.png) [@piratenkiste](https://forum.shopware.com/u/piratenkiste)\
**Post date:** [28. Februar 2018 um 17:55 UTC](https://forum.shopware.com/t/fehler-beim-update-auf-5-4-0/51447/1 "2018-02-28T17:55:14Z")

</div>

Hallo, ich hab gerade im Backend das Connect Plugin upgedatet und danach gleich das Neue Update auf 5.4.0 gestartet und bekomme promt bei der Installation eine Fehlermeldung:

Slim Application Error

The application could not run because of the following error:

Details

**Type:** &nbsp;Doctrine\DBAL\DBALException

**Message:** &nbsp;An exception occurred while executing ‚SELECT s0\_.id AS id\_0, s0\_.main\_id AS main\_id\_1, s0\_.category\_id AS category\_id\_2, s0\_.name AS name\_3, s0\_.title AS title\_4, s0\_.position AS position\_5, s0\_.host AS host\_6, s0\_.base\_path AS base\_path\_7, s0\_.base\_url AS base\_url\_8, s0\_.hosts AS hosts\_9, s0\_.secure AS secure\_10, s0\_.always\_secure AS always\_secure\_11, s0\_.secure\_host AS secure\_host\_12, s0\_.secure\_base\_path AS secure\_base\_path\_13, s0\_.template\_id AS template\_id\_14, s0\_.`default` AS default\_15, s0\_.active AS active\_16, s0\_.customer\_scope AS customer\_scope\_17, s0\_.id AS id\_18, s0\_.main\_id AS main\_id\_19, s0\_.category\_id AS category\_id\_20, s0\_.name AS name\_21, s0\_.title AS title\_22, s0\_.position AS position\_23, s0\_.host AS host\_24, s0\_.base\_path AS base\_path\_25, s0\_.base\_url AS base\_url\_26, s0\_.hosts AS hosts\_27, s0\_.secure AS secure\_28, s0\_.always\_secure AS always\_secure\_29, s0\_.secure\_host AS secure\_host\_30, s0\_.secure\_base\_path AS secure\_base\_path\_31, s0\_.template\_id AS template\_id\_32, s0\_.`default` AS default\_33, s0\_.active AS active\_34, s0\_.customer\_scope AS customer\_scope\_35, s1\_.id AS id\_36, s1\_.main\_id AS main\_id\_37, s1\_.category\_id AS category\_id\_38, s1\_.name AS name\_39, s1\_.title AS title\_40, s1\_.position AS position\_41, s1\_.host AS host\_42, s1\_.base\_path AS base\_path\_43, s1\_.base\_url AS base\_url\_44, s1\_.hosts AS hosts\_45, s1\_.secure AS secure\_46, s1\_.always\_secure AS always\_secure\_47, s1\_.secure\_host AS secure\_host\_48, s1\_.secure\_base\_path AS secure\_base\_path\_49, s1\_.template\_id AS template\_id\_50, s1\_.`default` AS default\_51, s1\_.active AS active\_52, s1\_.customer\_scope AS customer\_scope\_53, s2\_.id AS id\_54, s2\_.locale AS locale\_55, s2\_.language AS language\_56, s2\_.territory AS territory\_57, s3\_.id AS id\_58, s3\_.currency AS currency\_59, s3\_.name AS name\_60, s3\_.standard AS standard\_61, s3\_.factor AS factor\_62, s3\_.templatechar AS templatechar\_63, s3\_.symbol\_position AS symbol\_position\_64, s3\_.position AS position\_65, s4\_.id AS id\_66, s4\_.template AS template\_67, s4\_.name AS name\_68, s4\_.description AS description\_69, s4\_.author AS author\_70, s4\_.license AS license\_71, s4\_.esi AS esi\_72, s4\_.style\_support AS style\_support\_73, s4\_.emotion AS emotion\_74, s4\_.version AS version\_75, s4\_.plugin\_id AS plugin\_id\_76, s4\_.parent\_id AS parent\_id\_77, s5\_.id AS id\_78, s5\_.template AS template\_79, s5\_.name AS name\_80, s5\_.description AS description\_81, s5\_.author AS author\_82, s5\_.license AS license\_83, s5\_.esi AS esi\_84, s5\_.style\_support AS style\_support\_85, s5\_.emotion AS emotion\_86, s5\_.version AS version\_87, s5\_.plugin\_id AS plugin\_id\_88, s5\_.parent\_id AS parent\_id\_89, s6\_.id AS id\_90, s6\_.currency AS currency\_91, s6\_.name AS name\_92, s6\_.standard AS standard\_93, s6\_.factor AS factor\_94, s6\_.templatechar AS templatechar\_95, s6\_.symbol\_position AS symbol\_position\_96, s6\_.position AS position\_97, s7\_.id AS id\_98, s7\_.groupkey AS groupkey\_99, s7\_.description AS description\_100, s7\_.tax AS tax\_101, s7\_.taxinput AS taxinput\_102, s7\_.mode AS mode\_103, s7\_.discount AS discount\_104, s7\_.minimumorder AS minimumorder\_105, s7\_.minimumordersurcharge AS minimumordersurcharge\_106, s8\_.id AS id\_107, s8\_.template AS template\_108, s8\_.name AS name\_109, s8\_.description AS description\_110, s8\_.author AS author\_111, s8\_.license AS license\_112, s8\_.esi AS esi\_113, s8\_.style\_support AS style\_support\_114, s8\_.emotion AS emotion\_115, s8\_.version AS version\_116, s8\_.plugin\_id AS plugin\_id\_117, s8\_.parent\_id AS parent\_id\_118, s0\_.main\_id AS main\_id\_119, s0\_.template\_id AS template\_id\_120, s0\_.document\_template\_id AS document\_template\_id\_121, s0\_.category\_id AS category\_id\_122, s0\_.locale\_id AS locale\_id\_123, s0\_.currency\_id AS currency\_id\_124, s0\_.customer\_group\_id AS customer\_group\_id\_125, s0\_.fallback\_id AS fallback\_id\_126, s1\_.main\_id AS main\_id\_127, s1\_.template\_id AS template\_id\_128, s1\_.document\_template\_id AS document\_template\_id\_129, s1\_.category\_id AS category\_id\_130, s1\_.locale\_id AS locale\_id\_131, s1\_.currency\_id AS currency\_id\_132, s1\_.customer\_group\_id AS customer\_group\_id\_133, s1\_.fallback\_id AS fallback\_id\_134, s4\_.parent\_id AS parent\_id\_135, s4\_.plugin\_id AS plugin\_id\_136, s5\_.parent\_id AS parent\_id\_137, s5\_.plugin\_id AS plugin\_id\_138, s8\_.parent\_id AS parent\_id\_139, s8\_.plugin\_id AS plugin\_id\_140 FROM s\_core\_shops s0\_ LEFT JOIN s\_core\_shops s1\_ ON s0\_.main\_id = s1\_.id LEFT JOIN s\_core\_locales s2\_ ON s0\_.locale\_id = s2\_.id LEFT JOIN s\_core\_currencies s3\_ ON s0\_.currency\_id = s3\_.id LEFT JOIN s\_core\_templates s4\_ ON s0\_.template\_id = s4\_.id LEFT JOIN s\_core\_templates s5\_ ON s0\_.document\_template\_id = s5\_.id LEFT JOIN s\_core\_shop\_currencies s9\_ ON s0\_.id = s9\_.shop\_id LEFT JOIN s\_core\_currencies s6\_ ON s6\_.id = s9\_.currency\_id LEFT JOIN s\_core\_customergroups s7\_ ON s0\_.customer\_group\_id = s7\_.id LEFT JOIN s\_core\_templates s8\_ ON s1\_.template\_id = s8\_.id LEFT JOIN s\_core\_shop\_currencies s11\_ ON s1\_.id = s11\_.shop\_id LEFT JOIN s\_core\_currencies s10\_ ON s10\_.id = s11\_.currency\_id WHERE s0\_.active = 1 AND s0\_.`default` = 1 ORDER BY s0\_.main\_id ASC, s0\_.position ASC, s6\_.position ASC, s6\_.id ASC‘: SQLSTATE[42S22]: Column not found: 1054 Unknown column ‚s0\_.always\_secure‘ in ‚field list‘

**File:** &nbsp;/var/www/clients/client2555/web5278/web/vendor/doctrine/dbal/lib/Doctrine/DBAL/DBALException.php

**Line:** &nbsp;119

…

&nbsp;

Hat jemand eine Idee ?&nbsp; Bin schon echt am verzeifeln…

Vielen Dank im Voraus !!!

&nbsp;

&nbsp;

&nbsp;

---

<div class="post-metadata">

**Author:** ![hsoebbing](https://avatars.discourse-cdn.com/v4/letter/h/898d66/32.png) [@hsoebbing](https://forum.shopware.com/u/hsoebbing)\
**Post date:** [28. Februar 2018 um 19:03 UTC](https://forum.shopware.com/t/fehler-beim-update-auf-5-4-0/51447/2 "2018-02-28T19:03:44Z")

</div>

Hi @piratenkiste‍,

Wann tritt dieser Fehler denn auf? Lösche bitte einmal den Cache, der Fehler klingt ein bisschen als ob die Änderung an der Datenbank erfolgreich war aber noch der alte Cache aktiv ist.

---

<div class="post-metadata">

**Author:** ![piratenkiste](https://avatars.discourse-cdn.com/v4/letter/p/a8b319/32.png) [@piratenkiste](https://forum.shopware.com/u/piratenkiste)\
**Post date:** [1. März 2018 um 05:41 UTC](https://forum.shopware.com/t/fehler-beim-update-auf-5-4-0/51447/3 "2018-03-01T05:41:04Z")

</div>

Hallo, das wäre schön wenn ich dies machen könnte - ich komme nicht ins Backend hinein. Ich hatte gestern die Version 5.3.7 und habe das connect plugin aktualisiert - dies blieb aber hängen und danach dachte ich mir das ich das aktuelle Update 5.4 gleich per ftp hinterherschieben kann. Transfer geglückt - dann kommt die Meldung kurz hinter dem Installationsprozess “Aufräumen” recovery/update/index.php/cleanup. Jetzt ist mein Shop immer noch im Wartungsmodus und ich kann nicht eingreifen.&nbsp;&nbsp;

Bitte um Lösung !!!

---

<div class="post-metadata">

**Author:** ![piratenkiste](https://avatars.discourse-cdn.com/v4/letter/p/a8b319/32.png) [@piratenkiste](https://forum.shopware.com/u/piratenkiste)\
**Post date:** [1. März 2018 um 05:47 UTC](https://forum.shopware.com/t/fehler-beim-update-auf-5-4-0/51447/4 "2018-03-01T05:47:18Z")

</div>

…bei der Grundeinstellung hatte ich meine IP eingetragen aber ich komme jetzt nicht mehr hinein - ist es möglich meine IP in der DB per php einzugeben ???

---

<div class="post-metadata">

**Author:** ![piratenkiste](https://avatars.discourse-cdn.com/v4/letter/p/a8b319/32.png) [@piratenkiste](https://forum.shopware.com/u/piratenkiste)\
**Post date:** [1. März 2018 um 06:40 UTC](https://forum.shopware.com/t/fehler-beim-update-auf-5-4-0/51447/5 "2018-03-01T06:40:29Z")

</div>

> [@piratenkiste schrieb:](https://forum.shopware.com/profile/22766/piratenkiste "piratenkiste")
> 
> …bei der Grundeinstellung hatte ich meine IP eingetragen aber ich komme jetzt nicht mehr hinein - ist es möglich meine IP in der DB per php einzugeben ???..habe nun die passende Tabelle in der DB&nbsp;s\_core\_config\_values (ID 255) gefunden und meine IP eingetragen - leider ohne Erfolg.

---

<div class="post-metadata">

**Author:** ![Rednaxela](https://avatars.discourse-cdn.com/v4/letter/r/ad7895/32.png) [@Rednaxela](https://forum.shopware.com/u/Rednaxela)\
**Post date:** [1. März 2018 um 06:49 UTC](https://forum.shopware.com/t/fehler-beim-update-auf-5-4-0/51447/6 "2018-03-01T06:49:09Z")

</div>

Spiel doch das Backup ein und mach das Update erstmal in einer Kopie vom Shop.

---

<div class="post-metadata">

**Author:** ![Gesundwuerzen](https://avatars.discourse-cdn.com/v4/letter/g/8c91f0/32.png) [@Gesundwuerzen](https://forum.shopware.com/u/Gesundwuerzen)\
**Post date:** [1. März 2018 um 07:20 UTC](https://forum.shopware.com/t/fehler-beim-update-auf-5-4-0/51447/7 "2018-03-01T07:20:04Z")

</div>

> **[Shopware 5: Cache manuell leeren - Tipps & Tricks | netgrade](https://netgrade.de/shopware-5-wie-kann-ich-den-cache-manuell-leeren/)**
>
> Shopware Backend nicht ereichbar - so können Sie ihr Shopware 5 Cache manuell über FTP leeren ✓ hilfreiche Tipps & Tricks ➤Jetzt informieren!

&nbsp;

---

<div class="post-metadata">

**Author:** ![enerSpace](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/enerspace/32/13552_2.png) [@enerSpace](https://forum.shopware.com/u/enerSpace)\
**Post date:** [1. März 2018 um 12:41 UTC](https://forum.shopware.com/t/fehler-beim-update-auf-5-4-0/51447/8 "2018-03-01T12:41:00Z")

</div>

> [@Gesundwürzen schrieb:](https://forum.shopware.com/profile/19890/Gesundw%C3%BCrzen "Gesundw%C3%BCrzen")
> 
> [https://netgrade.de/shopware-5-wie-kann-ich-den-cache-manuell-leeren/](https://netgrade.de/shopware-5-wie-kann-ich-den-cache-manuell-leeren/)
> 
> &nbsp;

Wieso darf man die production\_\* Ordner nicht löschen? Meines wissens werden die Ordner neu angelegt und können daher gelöscht werden.

Der CLI befehl: /bin/console sw:cache:clear macht auch nichts anderes.

VG

![image](https://europe1.discourse-cdn.com/flex013/uploads/shopware/original/1X/bb8958d17f9f7c07e111287f43ec676d699d0799.png)  
enerSpace Webhosting  
Tel.: +49 511 - 219 568 76 | Web:&nbsp;[https://www.enerspace.de](https://www.enerspace.de/)

---

<div class="post-metadata">

**Author:** ![h\_lohaus](https://avatars.discourse-cdn.com/v4/letter/h/a587f6/32.png) [@h\_lohaus](https://forum.shopware.com/u/h_lohaus)\
**Post date:** [1. März 2018 um 12:54 UTC](https://forum.shopware.com/t/fehler-beim-update-auf-5-4-0/51447/9 "2018-03-01T12:54:31Z")

</div>

Hi,

das Feld „always\_secure“ wurde mit dem Update entferent.

Du hast also kein Backup eingespielt.  
Mit dem richtigem Backup sollte dein Shop wieder laufen.

Gruß Heiner

---

<div class="post-metadata">

**Author:** ![kulli](https://avatars.discourse-cdn.com/v4/letter/k/a3d4f5/32.png) [@kulli](https://forum.shopware.com/u/kulli)\
**Post date:** [4. März 2018 um 16:09 UTC](https://forum.shopware.com/t/fehler-beim-update-auf-5-4-0/51447/10 "2018-03-04T16:09:20Z")

</div>

5.4

Das gleiche hier nach installieren des Connect-plugins:

Beim Speichern von Artikeln:

```
Fehlgeschlagen

Während des Speicherns ist ein Fehler aufgetreten:An exception occurred while executing 'SELECT t0.id AS id_1, t0.article_id AS article_id_2, t0.article_detail_id AS article_detail_id_3, t0.shop_id AS shop_id_4, t0.source_id AS source_id_5, t0.export_status AS export_status_6, t0.export_message AS export_message_7, t0.exported AS exported_8, t0.category AS category_9, t0.purchase_price AS purchase_price_10, t0.fixed_price AS fixed_price_11, t0.update_price AS update_price_12, t0.update_image AS update_image_13, t0.update_long_description AS update_long_description_14, t0.update_short_description AS update_short_description_15, t0.update_additional_description AS update_additional_description_16, t0.update_name AS update_name_17, t0.update_main_image AS update_main_image_18, t0.last_update AS last_update_19, t0.last_update_flag AS last_update_flag_20, t0.group_id AS group_id_21, t0.is_main_variant AS is_main_variant_22, t0.purchase_price_hash AS purchase_price_hash_23, t0.offer_valid_until AS offer_valid_until_24, t0.stream AS stream_25, t0.cron_update AS cron_update_26, t0.revision AS revision_27, t0.article_id AS article_id_28, t0.article_detail_id AS article_detail_id_29 FROM s_plugin_connect_items t0 WHERE t0.article_detail_id = ? LIMIT 1' with params [1392]: SQLSTATE[42S22]: Column not found: 1054 Unknown column 't0.update_main_image' in 'field list'

```

&nbsp;

Ins backend komme ich ganz normal; cache ist natürlich geleert, auch manuell…

Auch Deinstallieren von Connect bringt nichts mit den artikeln funktioniert so gut wie gar nichts mehr:

```
Ups! Ein Fehler ist aufgetreten!

Die nachfolgenden Hinweise sollten Ihnen weiterhelfen.

Unable to load template snippet 'backend/article/controller/connect.js' in engine/Library/Smarty/sysplugins/smarty_internal_templatebase.php on line 127
Stack trace:

#0 engine/Library/Enlight/View/Default.php(300): Smarty_Internal_TemplateBase->fetch()
#1 engine/Library/Enlight/Controller/Plugins/ViewRenderer/Bootstrap.php(216): Enlight_View_Default->render(Object(Enlight_Template_Default))
#2 engine/Library/Enlight/Controller/Plugins/ViewRenderer/Bootstrap.php(242): Enlight_Controller_Plugins_ViewRenderer_Bootstrap->renderTemplate(Object(Enlight_Template_Default))
#3 engine/Library/Enlight/Controller/Plugins/ViewRenderer/Bootstrap.php(136): Enlight_Controller_Plugins_ViewRenderer_Bootstrap->render()
#4 engine/Library/Enlight/Event/Handler/Default.php(91): Enlight_Controller_Plugins_ViewRenderer_Bootstrap->onPostDispatch(Object(Enlight_Controller_ActionEventArgs))
#5 engine/Library/Enlight/Event/EventManager.php(220): Enlight_Event_Handler_Default->execute(Object(Enlight_Controller_ActionEventArgs))
#6 engine/Library/Enlight/Controller/Action.php(235): Enlight_Event_EventManager->notify('Enlight_Control...', Object(Enlight_Controller_ActionEventArgs))
#7 engine/Library/Enlight/Controller/Dispatcher/Default.php(549): Enlight_Controller_Action->dispatch('loadAction')
#8 engine/Library/Enlight/Controller/Front.php(222): Enlight_Controller_Dispatcher_Default->dispatch(Object(Enlight_Controller_Request_RequestHttp), Object(Enlight_Controller_Response_ResponseHttp))
#9 engine/Shopware/Kernel.php(215): Enlight_Controller_Front->dispatch()
#10 vendor/symfony/http-kernel/HttpCache/HttpCache.php(486): Shopware\Kernel->handle(Object(Symfony\Component\HttpFoundation\Request), 1, true)
#11 engine/Shopware/Components/HttpCache/AppCache.php(268): Symfony\Component\HttpKernel\HttpCache\HttpCache->forward(Object(Symfony\Component\HttpFoundation\Request), true, NULL)
#12 vendor/symfony/http-kernel/HttpCache/HttpCache.php(253): Shopware\Components\HttpCache\AppCache->forward(Object(Symfony\Component\HttpFoundation\Request), true)
#13 engine/Shopware/Components/HttpCache/AppCache.php(105): Symfony\Component\HttpKernel\HttpCache\HttpCache->pass(Object(Symfony\Component\HttpFoundation\Request), true)
#14 shopware.php(118): Shopware\Components\HttpCache\AppCache->handle(Object(Symfony\Component\HttpFoundation\Request))
#15 {main}

```

dann mal ran ans backup…

---

<div class="post-metadata">

**Author:** ![SebastianKloepper](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/sebastiankloepper/32/21435_2.png) [@SebastianKloepper](https://forum.shopware.com/u/SebastianKloepper)\
**Post date:** [4. März 2018 um 16:20 UTC](https://forum.shopware.com/t/fehler-beim-update-auf-5-4-0/51447/11 "2018-03-04T16:20:34Z")

</div>

Naja. Die zweite Meldung sagt ja, dass ein Template nicht geladen werden konnte. Da ist Connect auf jeden Fall noch im Cache vorhanden.

Wenn wir bei Connect bleiben und du es deinstallieren kannst, dann sollte Cache leeren (am besten manuell) danach auf jeden Fall alle Funktionen wiederherstellen.

Sollte das nicht der Fall sein, dann liegt es woanders dran. Ich vermute aber, dann bekommst du auch eine andere Meldung.

Ich konnte&nbsp;das Problem bei mir zumindest gerade nicht nachstellen mit dem Update auf 5.4. Das habe ich heute noch in zwei Umgebungen gemacht&nbsp;

Ich würde auf jeden Fall empfehlen, hier dem Problem nachzugehen. Das Backup würde ich nur im Notfall zurückspielen. Die aktuelle Meldung deutet&nbsp;auf ein kleineres, schnell lösbares Problem hin.

PS: Du hast auch eine neue Meldung. Das hier behandelte war ja ein anderer Fehler bzgl. SSL Definition&nbsp;

---

<div class="post-metadata">

**Author:** ![kulli](https://avatars.discourse-cdn.com/v4/letter/k/a3d4f5/32.png) [@kulli](https://forum.shopware.com/u/kulli)\
**Post date:** [4. März 2018 um 16:37 UTC](https://forum.shopware.com/t/fehler-beim-update-auf-5-4-0/51447/12 "2018-03-04T16:37:19Z")

</div>

Auf 5.4 bin ich mit dem shop schon seit vorgestern, der Fehler kam mit dem Installieren des Connect-Plugins

Nach dem Einspielen des Datenbackups von gestern und leeren aller Cache (manuell)

leider nun folgendes :

```
Ups! Ein Fehler ist aufgetreten! Die nachfolgenden Hinweise sollten Ihnen weiterhelfen. SQLSTATE[42S22]: Column not found: 1054 Unknown column 's_articles_details.laststock' in 'field list' in engine/Library/Zend/Db/Statement/Pdo.php on line 224 Stack trace: #0 engine/Library/Zend/Db/Statement.php(297): Zend_Db_Statement_Pdo->_execute(Array) #1 engine/Library/Zend/Db/Adapter/Abstract.php(470): Zend_Db_Statement->execute(Array) #2 engine/Library/Zend/Db/Adapter/Pdo/Abstract.php(232): Zend_Db_Adapter_Abstract->query('\n SE...', Array) #3 engine/Library/Enlight/Components/Db/Adapter/Pdo/Mysql.php(96): Zend_Db_Adapter_Pdo_Abstract->query('\n SE...', Array) #4 engine/Library/Zend/Db/Adapter/Abstract.php(744): Enlight_Components_Db_Adapter_Pdo_Mysql->query('\n SE...', Array) #5 engine/Shopware/Components/MultiEdit/Resource/Product/DqlHelper.php(330): Zend_Db_Adapter_Abstract->fetchRow('\n SE...', Array) #6 engine/Shopware/Components/MultiEdit/Resource/Product/Filter.php(208): Shopware\Components\MultiEdit\Resource\Product\DqlHelper->getProductForListing(1810) #7 engine/Shopware/Components/MultiEdit/Resource/Product.php(112): Shopware\Components\MultiEdit\Resource\Product\Filter->filter(Array, 0, '25', Array) #8 engine/Shopware/Controllers/Backend/ArticleList.php(359): Shopware\Components\MultiEdit\Resource\Product->filter(Array, 0, '25', Array) #9 engine/Library/Enlight/Controller/Action.php(193): Shopware_Controllers_Backend_ArticleList->filterAction() #10 engine/Library/Enlight/Controller/Dispatcher/Default.php(549): Enlight_Controller_Action->dispatch('filterAction') #11 engine/Library/Enlight/Controller/Front.php(222): Enlight_Controller_Dispatcher_Default->dispatch(Object(Enlight_Controller_Request_RequestHttp), Object(Enlight_Controller_Response_ResponseHttp)) #12 engine/Shopware/Kernel.php(215): Enlight_Controller_Front->dispatch() #13 vendor/symfony/http-kernel/HttpCache/HttpCache.php(486): Shopware\Kernel->handle(Object(Symfony\Component\HttpFoundation\Request), 1, true) #14 engine/Shopware/Components/HttpCache/AppCache.php(268): Symfony\Component\HttpKernel\HttpCache\HttpCache->forward(Object(Symfony\Component\HttpFoundation\Request), true, NULL) #15 vendor/symfony/http-kernel/HttpCache/HttpCache.php(253): Shopware\Components\HttpCache\AppCache->forward(Object(Symfony\Component\HttpFoundation\Request), true) #16 engine/Shopware/Components/HttpCache/AppCache.php(105): Symfony\Component\HttpKernel\HttpCache\HttpCache->pass(Object(Symfony\Component\HttpFoundation\Request), true) #17 shopware.php(118): Shopware\Components\HttpCache\AppCache->handle(Object(Symfony\Component\HttpFoundation\Request)) #18 {main}  

```

könnte das was mit dem OPcache zu tun haben ? (nur so ein Bauchgefühl)

Der Shop ist jetzt leider komplett down;&nbsp;

---

<div class="post-metadata">

**Author:** ![SebastianKloepper](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/sebastiankloepper/32/21435_2.png) [@SebastianKloepper](https://forum.shopware.com/u/SebastianKloepper)\
**Post date:** [4. März 2018 um 17:17 UTC](https://forum.shopware.com/t/fehler-beim-update-auf-5-4-0/51447/13 "2018-03-04T17:17:24Z")

</div>

Da passt ja was nicht. Das kann Cache schon sein.

Die Meldung sagt jetzt ja, dass ein Datenbank Feld fehlt. Das heißt, dass Cache bzw Files auf dem Server von 5.4 sind, die Datenbank aber 5.3.x

Du musst immer beides zurückspielen. Dateien und Datenbank müssen an einen leeren, sauberen Ort. Sonst gibt es grundsätzlich Probleme.

Daher hatte ich eher dazu geraten, das jeweilige Problem zu untersuchen und im besten Fall abzustellen, bevor ein Teil aus einem Backup wiederherstellt wird.&nbsp;

Jetzt wird es natürlich etwas kniffliger, da ich auch nicht genau sagen kann, was in welchen Zeilen zurückgespielt wurde.

Sauberste wäre vermutlich jetzt tatsächlich alles aus dem Backup sauber zurückzuspielen :-(&nbsp;

Wenn alles bereits komplett zurückgesetzt wurde, kann es eigentlich nur am Cache liegen (Server und Lokal) - Wichtig ist immer, dass der jeweilige Rücksicherungsort sauber war zuvor

---

<div class="post-metadata">

**Author:** ![kulli](https://avatars.discourse-cdn.com/v4/letter/k/a3d4f5/32.png) [@kulli](https://forum.shopware.com/u/kulli)\
**Post date:** [4. März 2018 um 19:00 UTC](https://forum.shopware.com/t/fehler-beim-update-auf-5-4-0/51447/14 "2018-03-04T19:00:49Z")

</div>

Alles gelöscht und neu aufgespielt - funktioniert wieder !

löst aber nicht das Problem mit Connect-Plugin

---

<div class="post-metadata">

**Author:** ![kulli](https://avatars.discourse-cdn.com/v4/letter/k/a3d4f5/32.png) [@kulli](https://forum.shopware.com/u/kulli)\
**Post date:** [7. März 2018 um 04:32 UTC](https://forum.shopware.com/t/fehler-beim-update-auf-5-4-0/51447/15 "2018-03-07T04:32:05Z")

</div>

Naja - wen Du Lesen könntest würdest Du nicht so einen Müll schreiben !

---

<div class="post-metadata">

**Author:** ![rpatzel](https://avatars.discourse-cdn.com/v4/letter/r/57b2e6/32.png) [@rpatzel](https://forum.shopware.com/u/rpatzel)\
**Post date:** [7. März 2018 um 12:16 UTC](https://forum.shopware.com/t/fehler-beim-update-auf-5-4-0/51447/16 "2018-03-07T12:16:19Z")

</div>

Scheint ein Standardsatz zu sein…

---

<div class="post-metadata">

**Author:** ![machart](https://avatars.discourse-cdn.com/v4/letter/m/ed8c4c/32.png) [@machart](https://forum.shopware.com/u/machart)\
**Post date:** [13. April 2018 um 17:25 UTC](https://forum.shopware.com/t/fehler-beim-update-auf-5-4-0/51447/17 "2018-04-13T17:25:55Z")

</div>

Hallo allerseits, ich hab auch denselben Fehler wie der Threadersteller,

ich hab ein Testsystem aufgesetzt, und dann nach Leitfaden des Updates vorgegangen, Update Url aufgerufen nachdem ich alle Plugins aktualisiert oder entfernt habe.

Nach dem Datenbank Update kommt dann auf der done Seite folgender Fehler:

Column not found: 1054 Unknown column ‘s0\_.always\_secure’ in ‘field list’

**File:** &nbsp;/usr/www/users/weilac/vendor/doctrine/dbal/lib/Doctrine/DBAL/DBALException.php

**Line:** &nbsp;131

&nbsp;

Manuell per Shell Production Ordner gelöscht neu aufgerufen immernoch. Kann mir jemand sagen woher das Doctrine sich im Query Builder das Schema holt, oder warum er weiterhin versucht&nbsp; .always\_secure aufzurufen wenn es das Feld angeblich nicht mehr gibt? Doctrine Cache wurde ja geleert, mit welcher Config oder wo das Schema generell abliegt, mit dem es erstellt wird wäre hilfreich.&nbsp;

&nbsp;

mit freundlichen Grüßen, Macharts

---

<div class="post-metadata">

**Author:** ![silbermann](https://avatars.discourse-cdn.com/v4/letter/s/b4bc9f/32.png) [@silbermann](https://forum.shopware.com/u/silbermann)\
**Post date:** [4. Mai 2018 um 19:44 UTC](https://forum.shopware.com/t/fehler-beim-update-auf-5-4-0/51447/18 "2018-05-04T19:44:08Z")

</div>

Ich habe aktuell auch das Problem mit den unkown columns, ich bekomme den Shop nicht von All inkl zu Strato umgezogen.

---

<div class="post-metadata">

**Author:** ![kulli](https://avatars.discourse-cdn.com/v4/letter/k/a3d4f5/32.png) [@kulli](https://forum.shopware.com/u/kulli)\
**Post date:** [5. Mai 2018 um 03:05 UTC](https://forum.shopware.com/t/fehler-beim-update-auf-5-4-0/51447/19 "2018-05-05T03:05:13Z")

</div>

Und was hat das mit dem Thema zu tun ? Mach bitte für Deine Probleme einen eiigenen Beitrag auf und schildere ganz genau das Problem.

Eventuell hilft schon die Forensuche.
