# Fehler beim Öffnen der Grundeinstellungen, fehlende Lizenz für die Community-Edition?

**URL:** https://forum.shopware.com/t/fehler-beim-offnen-der-grundeinstellungen-fehlende-lizenz-fur-die-community-edition/43108
**Category:** Programmierung
**Created:** [25. Januar 2017 um 14:08 UTC](https://forum.shopware.com/t/fehler-beim-offnen-der-grundeinstellungen-fehlende-lizenz-fur-die-community-edition/43108 "2017-01-25T14:08:33Z")
**Posts on this page:** 2
**Page:** 1

<div class="post-metadata">

### Author: ![Imanuel](https://avatars.discourse-cdn.com/v4/letter/i/7bcc69/32.png) [@Imanuel](https://forum.shopware.com/u/Imanuel)
#### Post date: [25. Januar 2017 um 14:08 UTC](https://forum.shopware.com/t/fehler-beim-offnen-der-grundeinstellungen-fehlende-lizenz-fur-die-community-edition/43108/1 "2017-01-25T14:08:33Z")

</div>

Hi,

ich bin PHP-Entwickler, aber mit Shopware leider völlig unerfahren. Ich wurde jetzt aber dennoch nach Hilfe gefragt, weil ein Kunde ein Problem mit seiner Installation hat: Beim Klick im Backend auf „Grundeinstellungen“ erscheint die Fehlermeldung „Unable to load template snippet ‚backend/config/app.js|backend/config/controller/license.js‘“ (komplette Fehlermeldung weiter unten).

Ein Update auf 5.2.15 (von 5.2.12) hat nichts geändert.  
„backend/config/app.js“ habe hier hier gefunden: „themes/Backend/ExtJs/backend/config/app.js“. Die Datei ist mit der Version aus dem Installationspaket identisch.  
Eine Datei „backend/config/controller/license.js“ habe ich nicht gefunden, auch nicht im Installationspaket.

Ich vermute, daß hier etwas mit der Community-Edition durcheinander gekommen ist - diese ist nämlich installiert, aber unter „Fragezeichen -\> Über Shopware“ steht: „under commercial / proprietary license“.  
Shopware hat am Telefon bestätigt, daß hier etwas von Community-Edition stehen sollte - anhand der Datei „themes/Backend/ExtJs/backend/index/controller/main.js“ habe ich nachvollzogen, daß als Edition nicht „CE“ vermerkt ist, sondern „“ - also nichts. Ich vermute, daß das die Ursache für die fehlende Datei „license.js“ sein könnte.

In der Tabelle „s\_core\_licenses“ ist nur ein Eintrag eines Themes - müsste hier noch ein Eintrag für eine Community-Lizenz stehen?

Viele Grüße  
Imanuel

&nbsp;

Hier der gesamte Fehlertext:

```
Ups! Ein Fehler ist aufgetreten!

Die nachfolgenden Hinweise sollten Ihnen weiterhelfen.

Unable to load template snippet 'backend/config/app.js|backend/config/controller/license.js' in engine/Library/Smarty/sysplugins/smarty_internal_templatebase.php on line 127
Stack trace:

#0 engine/Library/Enlight/View/Default.php(274): Smarty_Internal_TemplateBase->fetch()
#1 engine/Library/Enlight/Controller/Plugins/ViewRenderer/Bootstrap.php(216): Enlight_View_Default->render(Object(Enlight_Template_Default))
#2 engine/Library/Enlight/Controller/Plugins/ViewRenderer/Bootstrap.php(242): Enlight_Controller_Plugins_ViewRenderer_Bootstrap->renderTemplate(Object(Enlight_Template_Default))
#3 engine/Library/Enlight/Controller/Plugins/ViewRenderer/Bootstrap.php(136): Enlight_Controller_Plugins_ViewRenderer_Bootstrap->render()
#4 [internal function]: Enlight_Controller_Plugins_ViewRenderer_Bootstrap->onPostDispatch(Object(Enlight_Controller_ActionEventArgs))
#5 engine/Library/Enlight/Event/Handler/Default.php(91): call_user_func(Array, Object(Enlight_Controller_ActionEventArgs))
#6 engine/Library/Enlight/Event/EventManager.php(214): Enlight_Event_Handler_Default->execute(Object(Enlight_Controller_ActionEventArgs))
#7 engine/Library/Enlight/Controller/Action.php(202): Enlight_Event_EventManager->notify('Enlight_Control...', Object(Enlight_Controller_ActionEventArgs))
#8 engine/Library/Enlight/Controller/Dispatcher/Default.php(523): Enlight_Controller_Action->dispatch('indexAction')
#9 engine/Library/Enlight/Controller/Front.php(223): Enlight_Controller_Dispatcher_Default->dispatch(Object(Enlight_Controller_Request_RequestHttp), Object(Enlight_Controller_Response_ResponseHttp))
#10 engine/Shopware/Kernel.php(179): Enlight_Controller_Front->dispatch()
#11 vendor/symfony/http-kernel/HttpCache/HttpCache.php(487): Shopware\Kernel->handle(Object(Symfony\Component\HttpFoundation\Request), 1, true)
#12 engine/Shopware/Components/HttpCache/AppCache.php(255): Symfony\Component\HttpKernel\HttpCache\HttpCache->forward(Object(Symfony\Component\HttpFoundation\Request), true, NULL)
#13 vendor/symfony/http-kernel/HttpCache/HttpCache.php(258): Shopware\Components\HttpCache\AppCache->forward(Object(Symfony\Component\HttpFoundation\Request), true)
#14 engine/Shopware/Components/HttpCache/AppCache.php(103): Symfony\Component\HttpKernel\HttpCache\HttpCache->pass(Object(Symfony\Component\HttpFoundation\Request), true)
#15 shopware.php(117): Shopware\Components\HttpCache\AppCache->handle(Object(Symfony\Component\HttpFoundation\Request))
#16 {main}

```

&nbsp;

---

<div class="post-metadata">

### Author: ![t2oh4e](https://avatars.discourse-cdn.com/v4/letter/t/a5b964/32.png) [@t2oh4e](https://forum.shopware.com/u/t2oh4e)
#### Post date: [25. Januar 2017 um 14:45 UTC](https://forum.shopware.com/t/fehler-beim-offnen-der-grundeinstellungen-fehlende-lizenz-fur-die-community-edition/43108/2 "2017-01-25T14:45:00Z")

</div>

Die&nbsp;backend/config/controller/license.js ist ein Teil des Lizenzmanagers. Klingt als wäre der defekt. Würde ich mal neu herunterladen: [http://store.shopware.com/swaglicense/shopware-lizenz-manager.html](http://store.shopware.com/swaglicense/shopware-lizenz-manager.html)

Da der vermutlich schon für das System “gekauft” wurde kannst du ihn auch einfach im jeweiligen Store Account nochmal herunterladen.&nbsp;

Die Community Edition braucht keine Lizenz, daher muss dafür auch nirgendwo was eingetragen werden.
