# Fehler beim deaktivieren von Plugins, Serverkonfig?

**URL:** <https://forum.shopware.com/t/fehler-beim-deaktivieren-von-plugins-serverkonfig/102552>\
**Category:** Sonstiges\
**Created:** [18. Januar 2024 um 09:09 UTC](https://forum.shopware.com/t/fehler-beim-deaktivieren-von-plugins-serverkonfig/102552 "2024-01-18T09:09:35Z")\
**Posts on this page:** 13\
**Page:** 1

<div class="post-metadata">

**Author:** ![u.laufer](https://avatars.discourse-cdn.com/v4/letter/u/779978/32.png) [@u.laufer](https://forum.shopware.com/u/u.laufer)\
**Post date:** [18. Januar 2024 um 09:09 UTC](https://forum.shopware.com/t/fehler-beim-deaktivieren-von-plugins-serverkonfig/102552/1 "2024-01-18T09:09:35Z")

</div>

Hallo Zusammen,  
ich habe ein Problem auf unserem Server. Dachte dass die Installation irgendwie defekt ist und habe in einem neuen Paket ein neues Shopware 6.5.7.3 aufgesetzt. Leider kommt der gleiche Fehler:

Internal Server Error  
There is no extension able to load the configuration for „enqueue“ (in „/var/www/vhosts/DOMAIN.de/httpdocs/vendor/shopware/core/Framework/Resources/config/packages/enqueue.yaml“). Looked for namespace „enqueue“, found „„framework“, „twig“, „monolog“, „shopware“, „elasticsearch“, „storefront““ in /var/www/vhosts/DOMAIN.de/httpdocs/vendor/shopware/core/Framework/Resources/config/packages/enqueue.yaml (which is loaded in resource „/var/www/vhosts/DOMAIN.de/httpdocs/vendor/shopware/core/Framework/Resources/config/packages/enqueue.yaml“).

Administration  
6.5.7.3  
Dashboard  
Kataloge  
Bestellungen  
Kunden  
Inhalte  
Marketing  
Erweiterungen  
Store  
Meine Erweiterungen  
Einstellungen  
Verkaufskanäle

Headless  
DOMAIN

## Inaktive Erweiterungen ausblenden

Ebenfalls gibt es Probleme wenn der Cache geleert wird, dass dann der Shop nicht mehr erreichbar ist. Ich habe hier das Forum durchsucht und alles mögliche probiert, leider ohne Erfolg. Ich vermute, dass irgendwas an der Serverkonfig oder den Berechtigungen falsch ist. OPCache wurde auch schon geleert… könnt ihr mir helfen?

Vielen Dank

---

<div class="post-metadata">

**Author:** ![web-grips](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/web-grips/32/22792_2.png) [@web-grips](https://forum.shopware.com/u/web-grips)\
**Post date:** [18. Januar 2024 um 12:12 UTC](https://forum.shopware.com/t/fehler-beim-deaktivieren-von-plugins-serverkonfig/102552/2 "2024-01-18T12:12:23Z")

</div>

Vermutlich stimmt an der Installation oder dem Server etwas nicht, das müsste man sich direkt bei dir mal ansehen, da es viele Ursachen geben kann. Welcher Hoster, PHP? Seit wann tritt das auf? Was wurde vorher gemacht? Manchmal mverhakt sich der ShopwareStore und muss via Konsole repariert werden. Liebe Grüße Oliver ([web-grips.de](http://web-grips.de))

---

<div class="post-metadata">

**Author:** ![u.laufer](https://avatars.discourse-cdn.com/v4/letter/u/779978/32.png) [@u.laufer](https://forum.shopware.com/u/u.laufer)\
**Post date:** [18. Januar 2024 um 12:34 UTC](https://forum.shopware.com/t/fehler-beim-deaktivieren-von-plugins-serverkonfig/102552/3 "2024-01-18T12:34:53Z")

</div>

Ich habe ein Backup gemacht und es auf einem anderen Server eingespielt… Nach anpassen der Konfig lief das. Ich vermute Berechtigungsprobleme oder so was… Gibt es ein Tool um die nötigen Berechtigungen zu prüfen und evtl. wieder herzustellen? Habe auch versucht über die DB ein Plugin zu deaktivieren, also von 1 auf 0 gesetzt. Dann habe ich wieder Fehler 500 und der Shop ist weg! Gruss Uli

---

<div class="post-metadata">

**Author:** ![web-grips](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/web-grips/32/22792_2.png) [@web-grips](https://forum.shopware.com/u/web-grips)\
**Post date:** [19. Januar 2024 um 10:11 UTC](https://forum.shopware.com/t/fehler-beim-deaktivieren-von-plugins-serverkonfig/102552/4 "2024-01-19T10:11:03Z")

</div>

Du kannst Plugins statt über die DB am besten über die SSH-Konsole verwalten: [Shopware 6 - Nutzung der CLI Befehle](https://docs.shopware.com/de/shopware-6-de/tutorials-und-faq/shopware-cli)  
Tool zum Vergleich weiß ich jetzt nicht, aber vergleiche doch mal beide Server und passe die abweichenden Berechtigungen dann via Ordner an.

---

<div class="post-metadata">

**Author:** ![u.laufer](https://avatars.discourse-cdn.com/v4/letter/u/779978/32.png) [@u.laufer](https://forum.shopware.com/u/u.laufer)\
**Post date:** [19. Januar 2024 um 10:40 UTC](https://forum.shopware.com/t/fehler-beim-deaktivieren-von-plugins-serverkonfig/102552/5 "2024-01-19T10:40:50Z")

</div>

hat leider nix gebracht… über SSH. Ich checke jetzt mal die Berechtigungen lt. Ordner. Danke für den Tip.

---

<div class="post-metadata">

**Author:** ![u.laufer](https://avatars.discourse-cdn.com/v4/letter/u/779978/32.png) [@u.laufer](https://forum.shopware.com/u/u.laufer)\
**Post date:** [22. Januar 2024 um 11:24 UTC](https://forum.shopware.com/t/fehler-beim-deaktivieren-von-plugins-serverkonfig/102552/6 "2024-01-22T11:24:22Z")

</div>

war leider auch erfolglos. Alle Berechtigungen sind OK. App-URL gecheckt, worker gecheckt etc. komme leider nicht weiter.

---

<div class="post-metadata">

**Author:** ![web-grips](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/web-grips/32/22792_2.png) [@web-grips](https://forum.shopware.com/u/web-grips)\
**Post date:** [22. Januar 2024 um 11:40 UTC](https://forum.shopware.com/t/fehler-beim-deaktivieren-von-plugins-serverkonfig/102552/7 "2024-01-22T11:40:41Z")

</div>

Wurden Anpassungen an .yaml Dateien gemacht?  
Wie sieht diese bei dir aus, eventuell ein Syntaxfehler?  
vendor/shopware/core/Framework/Resources/config/packages/enqueue.yaml

---

<div class="post-metadata">

**Author:** ![u.laufer](https://avatars.discourse-cdn.com/v4/letter/u/779978/32.png) [@u.laufer](https://forum.shopware.com/u/u.laufer)\
**Post date:** [22. Januar 2024 um 12:25 UTC](https://forum.shopware.com/t/fehler-beim-deaktivieren-von-plugins-serverkonfig/102552/8 "2024-01-22T12:25:34Z")

</div>

ich hab da nix geändert. so sieht sie aus:

enqueue:  
default:  
transport:  
dsn: „null:“  
factory\_service: Shopware\Core\Framework\MessageQueue\Enqueue\ConnectionFactoryFactory  
client: ~  
consumption:  
# the time in milliseconds queue consumer waits for a message  
receive\_timeout: 1000

---

<div class="post-metadata">

**Author:** ![web-grips](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/web-grips/32/22792_2.png) [@web-grips](https://forum.shopware.com/u/web-grips)\
**Post date:** [22. Januar 2024 um 12:47 UTC](https://forum.shopware.com/t/fehler-beim-deaktivieren-von-plugins-serverkonfig/102552/9 "2024-01-22T12:47:56Z")

</div>

Die Datei gehört glaube ich nicht zur Basisinstallation von SW und ist für eine erweiterte Konfiguration gedacht. Du kannst die Datei mal umbennen und es ohne testen. Ansonsten auch mal die Plugins deaktivieren und testen.

---

<div class="post-metadata">

**Author:** ![u.laufer](https://avatars.discourse-cdn.com/v4/letter/u/779978/32.png) [@u.laufer](https://forum.shopware.com/u/u.laufer)\
**Post date:** [22. Januar 2024 um 12:54 UTC](https://forum.shopware.com/t/fehler-beim-deaktivieren-von-plugins-serverkonfig/102552/10 "2024-01-22T12:54:05Z")

</div>

OK, jetzt habe ich sie umbenannt dann kommt ein anderer Fehler beim deaktivieren eines beliebigen Plugins:

Internal Server Error

Compile Error: Declaration of Symfony\Component\Cache\Adapter\DoctrineAdapter::doFetch(array $ids) must be compatible with Symfony\Component\Cache\Adapter\AbstractAdapter::doFetch(array $ids): Traversable|array

---

<div class="post-metadata">

**Author:** ![web-grips](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/web-grips/32/22792_2.png) [@web-grips](https://forum.shopware.com/u/web-grips)\
**Post date:** [22. Januar 2024 um 13:10 UTC](https://forum.shopware.com/t/fehler-beim-deaktivieren-von-plugins-serverkonfig/102552/11 "2024-01-22T13:10:22Z")

</div>

Eventuell ist die Datei auch „übrig“ von der Installation, bei der etwas schief gegangen ist. Ist es eine Neuinstallation oder ein Update? Welche PHP-Version? Tritt das auch ohne Plugins auf? Das muss man sich im Detail ansehen.

---

<div class="post-metadata">

**Author:** ![u.laufer](https://avatars.discourse-cdn.com/v4/letter/u/779978/32.png) [@u.laufer](https://forum.shopware.com/u/u.laufer)\
**Post date:** [22. Januar 2024 um 15:01 UTC](https://forum.shopware.com/t/fehler-beim-deaktivieren-von-plugins-serverkonfig/102552/12 "2024-01-22T15:01:39Z")

</div>

tritt bei 8.2.14 und bei 8.3.1 auf… Es ist eine Neuinstallation. Ich kann die Plugins leider nicht abschalten. Weder über die DB noch über den Admin.

---

<div class="post-metadata">

**Author:** ![web-grips](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/web-grips/32/22792_2.png) [@web-grips](https://forum.shopware.com/u/web-grips)\
**Post date:** [23. Januar 2024 um 08:12 UTC](https://forum.shopware.com/t/fehler-beim-deaktivieren-von-plugins-serverkonfig/102552/13 "2024-01-23T08:12:30Z")

</div>

Das ist echt ungewöhnlich und liegt dann vielleicht doch am Hosting selbst.
