# Fehler bei Update von 4.3.6 auf 5

**URL:** <https://forum.shopware.com/t/fehler-bei-update-von-4-3-6-auf-5/27197>\
**Category:** Installation/Einstieg\
**Created:** [13. Mai 2015 um 09:30 UTC](https://forum.shopware.com/t/fehler-bei-update-von-4-3-6-auf-5/27197 "2015-05-13T09:30:17Z")\
**Posts on this page:** 13\
**Page:** 1

<div class="post-metadata">

**Author:** ![robertos](https://avatars.discourse-cdn.com/v4/letter/r/97f17d/32.png) [@robertos](https://forum.shopware.com/u/robertos)\
**Post date:** [13. Mai 2015 um 09:30 UTC](https://forum.shopware.com/t/fehler-bei-update-von-4-3-6-auf-5/27197/1 "2015-05-13T09:30:17Z")

</div>

Hallo, hier eine Fehlermeldung, die ich gerade beim versuchsweisen Update bekommen haben: Error Received the following error message: Could not apply migration: SQLSTATE[HY000]: General error: 1005 Can’t create table ‘usrdb\_robcvaxj2.#sql-75c9\_25f1f’ (errno: 121) Please try to fix this error and restart the update. Response {“valid”:false,“errorMsg”:“Could not apply migration: SQLSTATE[HY000]: General error: 1005 Can’t create table ‘usrdb\_robcvaxj2.#sql-75c9\_25f1f’ (errno: 121)”} Grüße Robert

---

<div class="post-metadata">

**Author:** ![SebastianKloepper](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/sebastiankloepper/32/21435_2.png) [@SebastianKloepper](https://forum.shopware.com/u/SebastianKloepper)\
**Post date:** [13. Mai 2015 um 10:25 UTC](https://forum.shopware.com/t/fehler-bei-update-von-4-3-6-auf-5/27197/2 "2015-05-13T10:25:27Z")

</div>

Hi, hast du ggf. MySQL 5.6? Dann müsste man diesen Commit einbauen: [https://github.com/shopware/shopware/co … 332a218f1d](https://github.com/shopware/shopware/commit/8d41c67b88432252368813671a07bf332a218f1d) Sebastian

---

<div class="post-metadata">

**Author:** ![robertos](https://avatars.discourse-cdn.com/v4/letter/r/97f17d/32.png) [@robertos](https://forum.shopware.com/u/robertos)\
**Post date:** [13. Mai 2015 um 13:39 UTC](https://forum.shopware.com/t/fehler-bei-update-von-4-3-6-auf-5/27197/3 "2015-05-13T13:39:19Z")

</div>

Der 4.3.6er Shop luaft mit MySQL 5.3 Noch eine Idee?

---

<div class="post-metadata">

**Author:** ![TimmeHosting](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/timmehosting/32/15580_2.png) [@TimmeHosting](https://forum.shopware.com/u/TimmeHosting)\
**Post date:** [13. Mai 2015 um 13:47 UTC](https://forum.shopware.com/t/fehler-bei-update-von-4-3-6-auf-5/27197/4 "2015-05-13T13:47:18Z")

</div>

Prüfe mal, ob die Festplatte voll ist und ob die Berechtigungen im /var/lib/mysql-Ordner (inkl. Unterordnern) stimmen. Wenn das alles paßt, solltest Du einen Festplattencheck durchführen, evtl. gibt es Fehler im Dateisystem (die man oft reparieren kann), oder die Festplatte gibt langsam ihren Geist auf.

---

<div class="post-metadata">

**Author:** ![SebastianKloepper](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/sebastiankloepper/32/21435_2.png) [@SebastianKloepper](https://forum.shopware.com/u/SebastianKloepper)\
**Post date:** [13. Mai 2015 um 13:49 UTC](https://forum.shopware.com/t/fehler-bei-update-von-4-3-6-auf-5/27197/5 "2015-05-13T13:49:58Z")

</div>

Hallo, Mindestanforderung für Shopware 5 ist MySQL 5.5 Sebastian

---

<div class="post-metadata">

**Author:** ![robertos](https://avatars.discourse-cdn.com/v4/letter/r/97f17d/32.png) [@robertos](https://forum.shopware.com/u/robertos)\
**Post date:** [13. Mai 2015 um 15:45 UTC](https://forum.shopware.com/t/fehler-bei-update-von-4-3-6-auf-5/27197/6 "2015-05-13T15:45:16Z")

</div>

so, bin noch einmal am testen. MySQL 5.5 läuft Jetzt gehe ich über die Konsole, habe das Update entpackt und starte über php die Datenbankaktualisierung. Dabei erhalte ich wieder eine Fehlermeldung: PHP Parse error: syntax error, unexpected T\_STRING, expecting T\_CONSTANT\_ENCAPSED\_STRING or ‘(’ in \*\*\*/recovery/update/index.php on line 31 Und nu?

---

<div class="post-metadata">

**Author:** ![SebastianKloepper](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/sebastiankloepper/32/21435_2.png) [@SebastianKloepper](https://forum.shopware.com/u/SebastianKloepper)\
**Post date:** [13. Mai 2015 um 16:03 UTC](https://forum.shopware.com/t/fehler-bei-update-von-4-3-6-auf-5/27197/7 "2015-05-13T16:03:21Z")

</div>

Hi, die Meldung kommt wenn die PHP Version nicht passt. Du musst du sicherstellen, dass bei Ausführung / Aufruf über Konsole auch mit der richtigen PHP Version ausgeführt wird. Sebastian

---

<div class="post-metadata">

**Author:** ![robertos](https://avatars.discourse-cdn.com/v4/letter/r/97f17d/32.png) [@robertos](https://forum.shopware.com/u/robertos)\
**Post date:** [13. Mai 2015 um 16:51 UTC](https://forum.shopware.com/t/fehler-bei-update-von-4-3-6-auf-5/27197/8 "2015-05-13T16:51:52Z")

</div>

In der .htaccess ist definitiv die 5.5 eingetragen diese Version läuft laut Backend auch. Ich werde es noch einmal mit der 5.6 probieren

---

<div class="post-metadata">

**Author:** ![SebastianKloepper](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/sebastiankloepper/32/21435_2.png) [@SebastianKloepper](https://forum.shopware.com/u/SebastianKloepper)\
**Post date:** [13. Mai 2015 um 17:01 UTC](https://forum.shopware.com/t/fehler-bei-update-von-4-3-6-auf-5/27197/9 "2015-05-13T17:01:34Z")

</div>

Hi, das was in der htaccess steht, hat ja nicht unbedingt Auswirkung auf deine Console. Da musst du ggf. den Aufruf auch anders machen, damit die richtigen Voraussetzungen greifen. Ansonsten einfach per Browser durchlaufen lassen. Das sollte ja auf jeden Fall auch gehen Sebastian

---

<div class="post-metadata">

**Author:** ![vjzechi](https://avatars.discourse-cdn.com/v4/letter/v/ba8739/32.png) [@vjzechi](https://forum.shopware.com/u/vjzechi)\
**Post date:** [28. Mai 2015 um 23:51 UTC](https://forum.shopware.com/t/fehler-bei-update-von-4-3-6-auf-5/27197/10 "2015-05-28T23:51:06Z")

</div>

habe das gleiche Problem… wenn ich die Geschichte im Browser aufrufe bekomme ich nur: svwrap Revision: 1.48 Error in line 819 security: script is world-writable und wenn ich das ganze per SSH starten will kommt folgendes: `php recovery/update/index.php X-Powered-By: PHP/4.4.9 Content-type: text/html  
**Parse error** : syntax error, unexpected T\_STRING, expecting T\_CONSTANT\_ENCAPSED\_STRING or '(' in **/SHOPFOLDERDOMAIN/recovery/update/index.php** on line **31**  
` habe SW5.0 RC3 installiert PHP Version 5.6.8 MySQL Software-Version: 5.5.43 - Source distribution hat kein anderer das Problem??? die Geschichte ist ja erst frisch aufgesetzt! Module sind nur die Std sachen drinnen und cleverreach^^ sollte man die vorher deaktivieren / löschen? das wäre ja echt mühsam^^ wäre für eure Hilfe echt dankbar! LG

---

<div class="post-metadata">

**Author:** ![vjzechi](https://avatars.discourse-cdn.com/v4/letter/v/ba8739/32.png) [@vjzechi](https://forum.shopware.com/u/vjzechi)\
**Post date:** [28. Mai 2015 um 23:54 UTC](https://forum.shopware.com/t/fehler-bei-update-von-4-3-6-auf-5/27197/11 "2015-05-28T23:54:20Z")

</div>

habe gerade noch ausprobiert PHP auf 5.6.9 zu stellen… und siehe da ich komme in den updater rein per browser… jetzt habe ich den nächsten fehler: “ERROR: SQLSTATE[HY000] [2002] php\_network\_getaddresses: getaddrinfo failed: Name or service not known”

---

<div class="post-metadata">

**Author:** ![chris\_52](https://avatars.discourse-cdn.com/v4/letter/c/b19c9b/32.png) [@chris\_52](https://forum.shopware.com/u/chris_52)\
**Post date:** [8. November 2015 um 19:43 UTC](https://forum.shopware.com/t/fehler-bei-update-von-4-3-6-auf-5/27197/12 "2015-11-08T19:43:38Z")

</div>

Hallo, diesen Fehler habe ich jetzt auch. Hab den ganzen Tag daran gesessen, die Datenbank von mySQL 5.1 auf 5.5 upzudaten. Jetzt lief alles (in der Version 4.3.6.), da wollte ich noch eben (!) auf 5.1 updaten. Systemvoraussetzungen waren alle grün. Wie ist die Lösung?

---

<div class="post-metadata">

**Author:** ![Moritz\_Naczenski](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/moritz_naczenski/32/7792_2.png) [@Moritz\_Naczenski](https://forum.shopware.com/u/Moritz_Naczenski)\
**Post date:** [8. November 2015 um 21:56 UTC](https://forum.shopware.com/t/fehler-bei-update-von-4-3-6-auf-5/27197/13 "2015-11-08T21:56:14Z")

</div>

Hallo, die Meldung kommt ja erstmal auch wieder vom Server. Wenn ich nach getaddrinfo php google findet man relativ viele mögliche Ursachen bei der Serverkonfiguration. Hier bspw.: [http://stackoverflow.com/questions/3018 … ame-or-ser](http://stackoverflow.com/questions/30182984/sqlstatehy000-2002-php-network-getaddresses-getaddrinfo-failed-name-or-ser) Ich würde mal schauen welchen Datenbank-Host du in der config.php angegeben hast. Moritz
