# Fehler bei Shopware 6 install

**URL:** https://forum.shopware.com/t/fehler-bei-shopware-6-install/87634
**Category:** Installation / Einstieg
**Created:** [12. Mai 2021 um 16:40 UTC](https://forum.shopware.com/t/fehler-bei-shopware-6-install/87634 "2021-05-12T16:40:19Z")
**Posts on this page:** 10
**Page:** 1

<div class="post-metadata">

### Author: ![foliendesign-hafner](https://avatars.discourse-cdn.com/v4/letter/f/6a8cbe/32.png) [@foliendesign-hafner](https://forum.shopware.com/u/foliendesign-hafner)
#### Post date: [12. Mai 2021 um 16:40 UTC](https://forum.shopware.com/t/fehler-bei-shopware-6-install/87634/1 "2021-05-12T16:40:19Z")

</div>

Hallo Community,

leider bekomme ich bei dem Installieren auf meinem Server bei Strato diese Fehlermeldung.  
Das Setup bleibt bei 130-770 stehen und bringt diese Fehlermeldung.

Error

Received an error message.  
**URL:** importDatabase  
**Message:** Internal Server Error

Please try to fix this error and restart the update.

### Response

{„valid“:false,„errorMsg“:„An exception occurred while executing ‚ALTER TABLE `order` MODIFY COLUMN `language_id` BINARY(16) NOT NULL‘:\n\nSQLSTATE[42S22]: Column not found: 1054 Unknown column ‚`sw6`.`o`.`price`‘ in ‚CHECK‘“}

konfig  
Ubunto 18.04.5 LTS  
MariaDB v10.4.19  
PHP v8.0.5

wer hat einen solchen Fehler schon gehabt, bzw. gelöst

---

<div class="post-metadata">

### Author: ![cdweb-net](https://avatars.discourse-cdn.com/v4/letter/c/439d5e/32.png) [@cdweb-net](https://forum.shopware.com/u/cdweb-net)
#### Post date: [12. Mai 2021 um 19:23 UTC](https://forum.shopware.com/t/fehler-bei-shopware-6-install/87634/2 "2021-05-12T19:23:47Z")

</div>

Habe den gleichen Fehler, komme da auch nicht mehr weiter. Die Konfig ist bei mir dieselbe, bis auf PHP da habe ich 7.4.

---

<div class="post-metadata">

### Author: ![schindler-tk](https://avatars.discourse-cdn.com/v4/letter/s/c4cdca/32.png) [@schindler-tk](https://forum.shopware.com/u/schindler-tk)
#### Post date: [13. Mai 2021 um 09:33 UTC](https://forum.shopware.com/t/fehler-bei-shopware-6-install/87634/3 "2021-05-13T09:33:13Z")

</div>

Leider ist bei mir dasselbe Probs. Nachdem das Update von 6.3.4 schon nicht klappte, hab ich gedacht, da ich noch im Aufbau bin, nimm gleich die 6.4 und ärgere dich nicht weiter rum. Tja Pustekuchen war´s. Ich bin ein Umsteiger von xt, wenn ich das geahnt hätte…

Config:  
Centos 7.9, Maria DB 10.5, PHP 7.4

Kurze Info wann es denn nun geht, wäre super.

---

<div class="post-metadata">

### Author: ![oneunity](https://avatars.discourse-cdn.com/v4/letter/o/8edcca/32.png) [@oneunity](https://forum.shopware.com/u/oneunity)
#### Post date: [13. Mai 2021 um 09:42 UTC](https://forum.shopware.com/t/fehler-bei-shopware-6-install/87634/4 "2021-05-13T09:42:05Z")

</div>

Hab den gleichen Fehler… ☹

---

<div class="post-metadata">

### Author: ![schindler-tk](https://avatars.discourse-cdn.com/v4/letter/s/c4cdca/32.png) [@schindler-tk](https://forum.shopware.com/u/schindler-tk)
#### Post date: [13. Mai 2021 um 21:37 UTC](https://forum.shopware.com/t/fehler-bei-shopware-6-install/87634/5 "2021-05-13T21:37:11Z")

</div>

Der Fehler tritt im 2. Schritt bei der DB Migration auf (Tabelle 192).

Ich hatte auf dem selben Server noch eine Testumgebung mit der 6.3.5.2 drauf. Diese hab ich problemlos auf die 6.4. updaten können. Hab dann den ganzen Inhalt gepackt, Datenbankzuordnung auf meine andere Domain gemacht, Inhalte „drüben“ ausgepackt und sh. da…es läuft.

Hab dann in der Konfiguration die entsprechenden Änderungen vorgenommen und jetzt funzt alles.

Für mich stellt sich die Frage warum in der selben Serverumgebung und trotz neu erstellter Domain die Installation auf der einen klappt und auf der anderen nicht.

---

<div class="post-metadata">

### Author: ![oneunity](https://avatars.discourse-cdn.com/v4/letter/o/8edcca/32.png) [@oneunity](https://forum.shopware.com/u/oneunity)
#### Post date: [14. Mai 2021 um 11:47 UTC](https://forum.shopware.com/t/fehler-bei-shopware-6-install/87634/6 "2021-05-14T11:47:47Z")

</div>

Wer lesen kann,…

in den Anforderungn von SW6 ist zu finden:

```
MySQL 5.7.21 oder höher
Die MySQL Versionen 8.0.20 und 8.0.21 sind auf Grund von technischen Problemen in diesen Versionen nicht kompatibel. 

```

oder

```
MariaDB 10.3.22 oder höher
Die MariaDB Versionen **10.3.29, 10.4.19 und 10.5.10** sind auf Grund von technischen Problemen in diesen Versionen nicht kompatibel. 

```

Also kein Wunder, wenn es bei uns nicht klappt.

---

<div class="post-metadata">

### Author: ![cdweb-net](https://avatars.discourse-cdn.com/v4/letter/c/439d5e/32.png) [@cdweb-net](https://forum.shopware.com/u/cdweb-net)
#### Post date: [14. Mai 2021 um 12:29 UTC](https://forum.shopware.com/t/fehler-bei-shopware-6-install/87634/7 "2021-05-14T12:29:08Z")

</div>

Also die Anforderungen passen bei mir, habe MariaDB 10.4 installiert.

Geht aber trotzdem nicht.

---

<div class="post-metadata">

### Author: ![farhad\_m](https://avatars.discourse-cdn.com/v4/letter/f/278dde/32.png) [@farhad\_m](https://forum.shopware.com/u/farhad_m)
#### Post date: [28. Mai 2021 um 22:06 UTC](https://forum.shopware.com/t/fehler-bei-shopware-6-install/87634/8 "2021-05-28T22:06:34Z")

</div>

> [@oneunity](#):
>
> `10.3.22 o`

Hab den gleichen Fehler… MariaDB 10.3.29 installiert. Wie habt ihr die Fehler behoben?

 ![s1](https://europe1.discourse-cdn.com/flex013/uploads/shopware/original/2X/2/2dba02e9eab2073dff6bded52bf35e0fc0e96da7.jpeg)

---

<div class="post-metadata">

### Author: ![foliendesign-hafner](https://avatars.discourse-cdn.com/v4/letter/f/6a8cbe/32.png) [@foliendesign-hafner](https://forum.shopware.com/u/foliendesign-hafner)
#### Post date: [9. Juni 2021 um 12:07 UTC](https://forum.shopware.com/t/fehler-bei-shopware-6-install/87634/9 "2021-06-09T12:07:57Z")

</div>

Hallo Community,  
hab heute die Version 6.4.1.0 getestet, und siehe da man kann die ohne Probleme installieren!!

---

<div class="post-metadata">

### Author: ![DBL](https://avatars.discourse-cdn.com/v4/letter/d/a9adbd/32.png) [@DBL](https://forum.shopware.com/u/DBL)
#### Post date: [14. Juli 2022 um 19:37 UTC](https://forum.shopware.com/t/fehler-bei-shopware-6-install/87634/10 "2022-07-14T19:37:42Z")

</div>

Habe das Problem beim Update von der 6.4.7.0 auf die neue 6.4.13.0.

Plugins sind soweit alles kompatibel, bzw. aktualisiert.  
Vor dem Update sind alle Plugins deaktiviert.

Während der Datenbankmigration erhalte ich den Fehler aus dem Original Post.

Infos zur Datenbank:

- Server: Localhost via UNIX socket
- Server-Typ: MariaDB
- Server-Version: 10.5.16-MariaDB-1:10.5.16+maria~focal-log - [mariadb.org](http://mariadb.org) binary distribution
- Protokoll-Version: 10

PHP ist die Version 7.4.30.

Hat jemand ähnliche Probleme?
