# Fehler bei Import von Datensatzerweiterung  The media file extension "txt" is not allowed.

**URL:** <https://forum.shopware.com/t/fehler-bei-import-von-datensatzerweiterung-the-media-file-extension-txt-is-not-allowed/53364>\
**Category:** Programmierung\
**Created:** [8. Juni 2018 um 11:26 UTC](https://forum.shopware.com/t/fehler-bei-import-von-datensatzerweiterung-the-media-file-extension-txt-is-not-allowed/53364 "2018-06-08T11:26:07Z")\
**Posts on this page:** 9\
**Page:** 1

<div class="post-metadata">

**Author:** ![azmf](https://avatars.discourse-cdn.com/v4/letter/a/b5ac83/32.png) [@azmf](https://forum.shopware.com/u/azmf)\
**Post date:** [8. Juni 2018 um 11:26 UTC](https://forum.shopware.com/t/fehler-bei-import-von-datensatzerweiterung-the-media-file-extension-txt-is-not-allowed/53364/1 "2018-06-08T11:26:07Z")

</div>

Hallo

Ich konnte fast alle Bilder via csv importieren, bei knapp 200 Artikel/Varianten tritt aber og. Fehler auf.  
Die Spalten der CSV sehen exakt genauso aus wie bei denen wo es klappt. Auch sind die Bilder genauso gespeichert…Wie kann ich das gelöst bekommen?

Grüße

---

<div class="post-metadata">

**Author:** ![vanwittlaer](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/vanwittlaer/32/8499_2.png) [@vanwittlaer](https://forum.shopware.com/u/vanwittlaer)\
**Post date:** [9. Juni 2018 um 09:22 UTC](https://forum.shopware.com/t/fehler-bei-import-von-datensatzerweiterung-the-media-file-extension-txt-is-not-allowed/53364/2 "2018-06-09T09:22:50Z")

</div>

Der Import ist schwierig zu debuggen. Das die Fehlermeldung einfach so stimmt und die Dateien mit .txt-Endung abgelegt sind kann nicht sein? Ansonsten: irgendeinen Unterschied zu denen, wo der Import klappt, wird es geben. Da ist dein detektivischer Spürsinn gefragt.

Happy selling,

Geert

---

<div class="post-metadata">

**Author:** ![schreibwaren-ihlee](https://avatars.discourse-cdn.com/v4/letter/s/5f8ce5/32.png) [@schreibwaren-ihlee](https://forum.shopware.com/u/schreibwaren-ihlee)\
**Post date:** [28. Juli 2018 um 16:24 UTC](https://forum.shopware.com/t/fehler-bei-import-von-datensatzerweiterung-the-media-file-extension-txt-is-not-allowed/53364/3 "2018-07-28T16:24:42Z")

</div>

Ich klinke mich mal ein, seit heute bei mir auch der fehler, kann keinerlei Bilder mehr per import/export Modul laden…

Fehler beim Import  
The media file extension „txt“ is not allowed.

&nbsp;

Neuste Version von SW (5.4.6) installiert, PHP 7.2 etc…

&nbsp;

Sonja

---

<div class="post-metadata">

**Author:** ![Moritz\_Naczenski](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/moritz_naczenski/32/7792_2.png) [@Moritz\_Naczenski](https://forum.shopware.com/u/Moritz_Naczenski)\
**Post date:** [28. Juli 2018 um 16:34 UTC](https://forum.shopware.com/t/fehler-bei-import-von-datensatzerweiterung-the-media-file-extension-txt-is-not-allowed/53364/4 "2018-07-28T16:34:54Z")

</div>

Da wird eines der Bilder nicht mehr existieren und keinen 404 zurückgeben, sondern im Browser irgendeinen Text anzeigen.

---

<div class="post-metadata">

**Author:** ![schreibwaren-ihlee](https://avatars.discourse-cdn.com/v4/letter/s/5f8ce5/32.png) [@schreibwaren-ihlee](https://forum.shopware.com/u/schreibwaren-ihlee)\
**Post date:** [28. Juli 2018 um 17:27 UTC](https://forum.shopware.com/t/fehler-bei-import-von-datensatzerweiterung-the-media-file-extension-txt-is-not-allowed/53364/5 "2018-07-28T17:27:29Z")

</div>

War das nicht mal so, das wenn kein Bild existierte, das dieser Datensatz dann einfach übersprungen wurde bzw. dann einfach keine Bildausgabe erfolgte?

Also ich erinnere mich daran, das es noch nie Probleme gab wenn es mal kein Bild gab, dann im Admin Filtern „Artikel ohne Bilder“ manuell rein… fertig.

Na dann finde ich leider, ist es ein Rückschritt… Aktuell sind es ca. 300 Artikel (Bilder), habe einen Pfad zu dem Bilderordner wo ca. 5000 Bilder drin sind, normal wäre doch dann, bild nicht da… überspringen… weiter mit nächsten… ??

Aber trotzdem erst mal Danke für die info,

---

<div class="post-metadata">

**Author:** ![Moritz\_Naczenski](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/moritz_naczenski/32/7792_2.png) [@Moritz\_Naczenski](https://forum.shopware.com/u/Moritz_Naczenski)\
**Post date:** [28. Juli 2018 um 18:51 UTC](https://forum.shopware.com/t/fehler-bei-import-von-datensatzerweiterung-the-media-file-extension-txt-is-not-allowed/53364/6 "2018-07-28T18:51:16Z")

</div>

Wenn der Server einen 404 zurückgibt, wenn das Bild nicht existiert, dann wird auch weitergemacht. Wenn der Server aber etwas zurückgibt - bspw. Einen Text im Browser mit dem mimetype Text, dann kann das Probleme machen. Würde mal dienbetrecfende url überprüfen, sollte ja über die Nummer wo der stehenbleibt leicht gehen.

---

<div class="post-metadata">

**Author:** ![schreibwaren-ihlee](https://avatars.discourse-cdn.com/v4/letter/s/5f8ce5/32.png) [@schreibwaren-ihlee](https://forum.shopware.com/u/schreibwaren-ihlee)\
**Post date:** [28. Juli 2018 um 19:07 UTC](https://forum.shopware.com/t/fehler-bei-import-von-datensatzerweiterung-the-media-file-extension-txt-is-not-allowed/53364/7 "2018-07-28T19:07:09Z")

</div>

Habe ich gemacht, betraf 2 Bilder, rufe ich den Link (die Bilder existieren wirklich nicht) direkt auf, kommt folgende Meldung

[Klick mich](https://schreibwaren-guenstig.de/bilderimport/8532118.jpg)

```
Fatal error: Uncaught exception 'Enlight_Controller_Exception' with message 'Controller "bilderimport" not found' in /var/www/vhosts/schreibwaren-guenstig.de/httpdocs/engine/Library/Enlight/Controller/Dispatcher/Default.php:507 Stack trace: #0 /var/www/vhosts/schreibwaren-guenstig.de/httpdocs/engine/Library/Enlight/Controller/Front.php(222): Enlight_Controller_Dispatcher_Default->dispatch(Object(Enlight_Controller_Request_RequestHttp), Object(Enlight_Controller_Response_ResponseHttp)) #1 /var/www/vhosts/schreibwaren-guenstig.de/httpdocs/engine/Shopware/Kernel.php(215): Enlight_Controller_Front->dispatch() #2 /var/www/vhosts/schreibwaren-guenstig.de/httpdocs/vendor/symfony/http-kernel/HttpCache/HttpCache.php(486): Shopware\Kernel->handle(Object(Symfony\Component\HttpFoundation\Request), 1, true) #3 /var/www/vhosts/schreibwaren-guenstig.de/httpdocs/engine/Shopware/Components/HttpCache/AppCache.php(268): Symfony\Component\HttpKernel\HttpCache\HttpCache->forward(Object(Symfony\Component\HttpFoundation\Request), true, NULL) #4 in /var/www/vhosts/schreibwaren-guenstig.de/httpdocs/engine/Library/Enlight/Controller/Dispatcher/Default.php on line 507

```

Zum Verleich einen anderen Link (Bild) im gleichen Verzeichnis:

[Klick mich](https://schreibwaren-guenstig.de/bilderimport/8532021.jpg)

---

<div class="post-metadata">

**Author:** ![Moritz\_Naczenski](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/moritz_naczenski/32/7792_2.png) [@Moritz\_Naczenski](https://forum.shopware.com/u/Moritz_Naczenski)\
**Post date:** [28. Juli 2018 um 19:20 UTC](https://forum.shopware.com/t/fehler-bei-import-von-datensatzerweiterung-the-media-file-extension-txt-is-not-allowed/53364/8 "2018-07-28T19:20:01Z")

</div>

Du hast das debugging in der config.php noch aktiviert, daher kommt da ein Fehler. Mach das mal aus.

---

<div class="post-metadata">

**Author:** ![schreibwaren-ihlee](https://avatars.discourse-cdn.com/v4/letter/s/5f8ce5/32.png) [@schreibwaren-ihlee](https://forum.shopware.com/u/schreibwaren-ihlee)\
**Post date:** [28. Juli 2018 um 19:26 UTC](https://forum.shopware.com/t/fehler-bei-import-von-datensatzerweiterung-the-media-file-extension-txt-is-not-allowed/53364/9 "2018-07-28T19:26:31Z")

</div>

aaah, ok, danke für den Hinweis, werde ich gleich mal machen…

Sonja
