# Fehler bei Datenbankanbindung

**URL:** https://forum.shopware.com/t/fehler-bei-datenbankanbindung/19542
**Category:** Shopware 3.5
**Tags:** installation--gettin
**Created:** [4. April 2014 um 09:55 UTC](https://forum.shopware.com/t/fehler-bei-datenbankanbindung/19542 "2014-04-04T09:55:59Z")
**Posts on this page:** 10
**Page:** 1

<div class="post-metadata">

### Author: ![eslamica](https://avatars.discourse-cdn.com/v4/letter/e/c89c15/32.png) [@eslamica](https://forum.shopware.com/u/eslamica)
#### Post date: [4. April 2014 um 09:55 UTC](https://forum.shopware.com/t/fehler-bei-datenbankanbindung/19542/1 "2014-04-04T09:55:59Z")

</div>

Nachdem ich den Fehler der Nicht-Erkennung von ionCube mal ignoriert habe und weiter geklickt habe, scheitere ich leider schon beim nächsten Punkt - obwohl ich schon mehrfach Datenbankanbindungen für andere Shops (Gambio) und Blogs durchgeführt habe auf dem gleichen 1&1-Paket. Hier der Screenshot der Shopware-Fehlermeldung: Alle Daten dort sind korrekt (auch das PW) und wurden mir genauso von 1&1 übergeben. Ist bisher das erste Mal, dass sowas nicht klappt. Woran könnte es liegen? Viele Grüße

---

<div class="post-metadata">

### Author: ![EikeBrandtWarneke](https://avatars.discourse-cdn.com/v4/letter/e/cdc98d/32.png) [@EikeBrandtWarneke](https://forum.shopware.com/u/EikeBrandtWarneke)
#### Post date: [4. April 2014 um 10:02 UTC](https://forum.shopware.com/t/fehler-bei-datenbankanbindung/19542/2 "2014-04-04T10:02:16Z")

</div>

Da kann dir nur 1&1 weiterhelfen. Viele Grüße

---

<div class="post-metadata">

### Author: ![eslamica](https://avatars.discourse-cdn.com/v4/letter/e/c89c15/32.png) [@eslamica](https://forum.shopware.com/u/eslamica)
#### Post date: [4. April 2014 um 10:06 UTC](https://forum.shopware.com/t/fehler-bei-datenbankanbindung/19542/3 "2014-04-04T10:06:37Z")

</div>

Wie genau sollen die mir weiterhelfen bzw. was genau soll ich denen sagen? Weil alle anderen Datenbanken auf dem gleichen Server lassen sich problemlos mit den jeweiligen Seiten/Anwendungen verbinden. Ist jetzt exklusiv ein Shopware-Problem.

---

<div class="post-metadata">

### Author: ![drakon](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/drakon/32/7724_2.png) [@drakon](https://forum.shopware.com/u/drakon)
#### Post date: [4. April 2014 um 10:12 UTC](https://forum.shopware.com/t/fehler-bei-datenbankanbindung/19542/4 "2014-04-04T10:12:46Z")

</div>

Hallo, so eine seltsame Serverbezeichung habe ich noch nie gesehen. Üblicherweise lautet das nur „localhost“ oder eben „127.0.0.1“. Probiers einfach mal.

---

<div class="post-metadata">

### Author: ![eslamica](https://avatars.discourse-cdn.com/v4/letter/e/c89c15/32.png) [@eslamica](https://forum.shopware.com/u/eslamica)
#### Post date: [4. April 2014 um 10:17 UTC](https://forum.shopware.com/t/fehler-bei-datenbankanbindung/19542/5 "2014-04-04T10:17:37Z")

</div>

Das wars 😃 Keine Ahnung wieso, wird mir als Adresse in 1&1 angezeigt und habe ich bisher immer so gemacht. Vielleicht ignorieren die anderen Anwendungen die Zeichen danach. Danke dir!

---

<div class="post-metadata">

### Author: ![eslamica](https://avatars.discourse-cdn.com/v4/letter/e/c89c15/32.png) [@eslamica](https://forum.shopware.com/u/eslamica)
#### Post date: [4. April 2014 um 10:22 UTC](https://forum.shopware.com/t/fehler-bei-datenbankanbindung/19542/6 "2014-04-04T10:22:18Z")

</div>

Tja, zu früh gefreut. Zwar wurde einfach “Localhost” akzeptiert und danach der DB-Import komplett durchgeführt, aber danach kam die Lizenzauswahl, in der ich einfach nur “Shopware Community Version(Lizenz: Open-Source AGPL)” ausgewählt habe und weiter gedrückt habe. Ergebnis ist die folgende Fehlermeldung: [quote]Database-Error!: SQLSTATE[HY000] [2054] Connecting to 3.22, 3.23 & 4.0 servers is not supported[/quote] Das wiederum verstehe ich aber gar nicht. Eben hat er doch den DB-Import selbst komplett durchgeführt, und die Datenbank ist natürlich sowieso MySQL-Version 5.1.73. Was nun?

---

<div class="post-metadata">

### Author: ![drakon](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/drakon/32/7724_2.png) [@drakon](https://forum.shopware.com/u/drakon)
#### Post date: [4. April 2014 um 10:33 UTC](https://forum.shopware.com/t/fehler-bei-datenbankanbindung/19542/7 "2014-04-04T10:33:18Z")

</div>

Hallo, dann stimmt die Adresse noch nicht ganz. Er versucht wohl auf den falschen Datenbanktyp zuzugreifen. Evtl. gehört das “/tmp/mysql5.sock” in das Feld “Datenbank Socket” Wie gesagt, einfach testen. In einer neuen Datenbank kann man ja erst mal nichts kaputt machen 🙂

---

<div class="post-metadata">

### Author: ![eslamica](https://avatars.discourse-cdn.com/v4/letter/e/c89c15/32.png) [@eslamica](https://forum.shopware.com/u/eslamica)
#### Post date: [4. April 2014 um 10:48 UTC](https://forum.shopware.com/t/fehler-bei-datenbankanbindung/19542/8 "2014-04-04T10:48:42Z")

</div>

Habe ich gemacht, und danach bin ich bis zum nächsten Schritt gekommen, dann kam der gleiche Fehler nochmal, als ich die Admin-Daten geändert habe. Anschließend wieder alles von vorne, diesmal kam kein Fehler und ich kam bis zum Schluss durch, samt Meldung der erfolgreichen Installation. Woran liegt das alles? Leider scheint es aber dennoch Probleme zu geben, siehe der hier installierte Shop: [Your text to link here…](http://sw.eslamica.de/) Man versuche mal auf „Mein Konto“ zu klicken oder sonstwo…bei mir klappt gar nichts. Bin ich der erste mit dieser Art von stufenweise gehäuften Fehlern? 🙂 Viele Grüße

---

<div class="post-metadata">

### Author: ![eslamica](https://avatars.discourse-cdn.com/v4/letter/e/c89c15/32.png) [@eslamica](https://forum.shopware.com/u/eslamica)
#### Post date: [4. April 2014 um 10:57 UTC](https://forum.shopware.com/t/fehler-bei-datenbankanbindung/19542/9 "2014-04-04T10:57:06Z")

</div>

Einfach jeder Link führt ins Leere, wie ich jetzt gemerkt habe, trotz angeblich erfolgreicher Installation. Vielleicht hat der Installer die DB doch nicht richtig kontaktiert, kann man das auch manuell in gewissen PHP-Dateien anstellen, so wie ich es von Gambio kenne? Oder wird das nichts bringen?

---

<div class="post-metadata">

### Author: ![eslamica](https://avatars.discourse-cdn.com/v4/letter/e/c89c15/32.png) [@eslamica](https://forum.shopware.com/u/eslamica)
#### Post date: [4. April 2014 um 11:10 UTC](https://forum.shopware.com/t/fehler-bei-datenbankanbindung/19542/10 "2014-04-04T11:10:48Z")

</div>

Ok, konnte es selbst lösen, ich musste die htaccess anpassen.
