# Fehler bei Datenbank Update

**URL:** https://forum.shopware.com/t/fehler-bei-datenbank-update/27368
**Category:** Installation/Einstieg
**Created:** [18. Mai 2015 um 17:14 UTC](https://forum.shopware.com/t/fehler-bei-datenbank-update/27368 "2015-05-18T17:14:20Z")
**Posts on this page:** 10
**Page:** 1

<div class="post-metadata">

### Author: ![GodGaming](https://avatars.discourse-cdn.com/v4/letter/g/bc79bd/32.png) [@GodGaming](https://forum.shopware.com/u/GodGaming)
#### Post date: [18. Mai 2015 um 17:14 UTC](https://forum.shopware.com/t/fehler-bei-datenbank-update/27368/1 "2015-05-18T17:14:20Z")

</div>

Hallo, ich habe vorhin das Passwort meiner DB bei meinen Hoster und in der config.php geändert. Allerdings kam jetzt beim Update von SW4 auf SW5 folgendes: [quote]Error Received the following error message: Could not apply migration: SQLSTATE[HY000]: General error: 1005 Can’t create table ‘usrdb\_godnrulp.#sql-176a\_47283e’ (errno: 121) Please try to fix this error and restart the update. Response {“valid”:false,“errorMsg”:“Could not apply migration: SQLSTATE[HY000]: General error: 1005 Can’t create table ‘usrdb\_godnrulp.#sql-176a\_47283e’ (errno: 121)”}[/quote] Bitte um Hilfe, vielen Dank!

---

<div class="post-metadata">

### Author: ![Moritz\_Naczenski](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/moritz_naczenski/32/7792_2.png) [@Moritz\_Naczenski](https://forum.shopware.com/u/Moritz_Naczenski)
#### Post date: [18. Mai 2015 um 17:26 UTC](https://forum.shopware.com/t/fehler-bei-datenbank-update/27368/2 "2015-05-18T17:26:48Z")

</div>

Hallo, Das ist in der Regel ein Problem der Datenbank, z.B der MySQL strict Mode. Dazu gibt es mit 5.0.1 eine Anpassung von uns. Am besten machst du mal ein Update direkt auf den 5.0.1 RC. Moritz

---

<div class="post-metadata">

### Author: ![GodGaming](https://avatars.discourse-cdn.com/v4/letter/g/bc79bd/32.png) [@GodGaming](https://forum.shopware.com/u/GodGaming)
#### Post date: [18. Mai 2015 um 17:29 UTC](https://forum.shopware.com/t/fehler-bei-datenbank-update/27368/3 "2015-05-18T17:29:58Z")

</div>

> [@Moritz Naczenski](#):
>
> Hallo, Das ist in der Regel ein Problem der Datenbank, z.B der MySQL strict Mode. Dazu gibt es mit 5.0.1 eine Anpassung von uns. Am besten machst du mal ein Update direkt auf den 5.0.1 RC. Moritz

---

<div class="post-metadata">

### Author: ![GodGaming](https://avatars.discourse-cdn.com/v4/letter/g/bc79bd/32.png) [@GodGaming](https://forum.shopware.com/u/GodGaming)
#### Post date: [18. Mai 2015 um 17:52 UTC](https://forum.shopware.com/t/fehler-bei-datenbank-update/27368/4 "2015-05-18T17:52:59Z")

</div>

Auch bei 5.0.1 RC selbes Problem wie Oben.☹

---

<div class="post-metadata">

### Author: ![TimmeHosting](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/timmehosting/32/15580_2.png) [@TimmeHosting](https://forum.shopware.com/u/TimmeHosting)
#### Post date: [18. Mai 2015 um 20:28 UTC](https://forum.shopware.com/t/fehler-bei-datenbank-update/27368/5 "2015-05-18T20:28:09Z")

</div>

Prüfe mal, ob noch ausreichend Festplattenplatz vorhanden ist. Wenn das nicht das Problem ist, führe mal einen Dateisystemcheck durch.

---

<div class="post-metadata">

### Author: ![GodGaming](https://avatars.discourse-cdn.com/v4/letter/g/bc79bd/32.png) [@GodGaming](https://forum.shopware.com/u/GodGaming)
#### Post date: [18. Mai 2015 um 20:59 UTC](https://forum.shopware.com/t/fehler-bei-datenbank-update/27368/6 "2015-05-18T20:59:16Z")

</div>

[quote=“TimmeHosting”]Prüfe mal, ob noch ausreichend Festplattenplatz vorhanden ist. Wenn das nicht das Problem ist, führe mal einen Dateisystemcheck durch.[/quote] Speicherplatz ist noch genug vorhanden. Wie führe ich den Dateisystemcheck durch?

---

<div class="post-metadata">

### Author: ![ottscho](https://avatars.discourse-cdn.com/v4/letter/o/7ba0ec/32.png) [@ottscho](https://forum.shopware.com/u/ottscho)
#### Post date: [28. Mai 2015 um 15:34 UTC](https://forum.shopware.com/t/fehler-bei-datenbank-update/27368/7 "2015-05-28T15:34:31Z")

</div>

Konnte das Problem gelöst werden? Ich habe das gleiche Problem. Speicher ist noch verfügbar und manuell kann ich in der DB neue Tabellen erstellen. Es erscheint aber über das Update Script ebenfalls: `{"valid":false,"errorMsg":"Could not apply migration: SQLSTATE[HY000]: General error: 1005 Can't create table 'usrdb\_bott.#sql-16ec\_1360819' (errno: 121)"} ` Ein Dateisystemcheck kann ich nicht durchführen, ich habe keinen SSH Zugriff.

---

<div class="post-metadata">

### Author: ![SebastianKloepper](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/sebastiankloepper/32/21435_2.png) [@SebastianKloepper](https://forum.shopware.com/u/SebastianKloepper)
#### Post date: [28. Mai 2015 um 17:38 UTC](https://forum.shopware.com/t/fehler-bei-datenbank-update/27368/8 "2015-05-28T17:38:28Z")

</div>

Hallo, es kann eigentlich nur folgendes sein: 1. Strict Mode 2. Foreign Keys defekt (Reparatur Script im Wiki) 3. kein Speicherplatz mehr 4. Datenbank MySQL zu alt (Systemvoraussetzungen) 5. SQL Delta Problen, da Datenbank schon Änderungen beinhaltet ([http://wiki.shopware.com/Shopware-Updat … \_1378.html](http://wiki.shopware.com/Shopware-Updates-Debuggen-von-Fehlern-und-FAQ%5C_detail%5C_1378.html) s\_schema\_version Tabelle) Das einmal checken und sollte mindestens eines zutreffen Sebastian

---

<div class="post-metadata">

### Author: ![ottscho](https://avatars.discourse-cdn.com/v4/letter/o/7ba0ec/32.png) [@ottscho](https://forum.shopware.com/u/ottscho)
#### Post date: [28. Mai 2015 um 17:56 UTC](https://forum.shopware.com/t/fehler-bei-datenbank-update/27368/9 "2015-05-28T17:56:19Z")

</div>

Danke. ja, es lag an den Foreign Keys. Nun lief das Update durch. Aber nach löschen des “update-assets” Ordners kommt trotzdem noch die Wartungsseite. Gibt es noch irgendwo eine Lock Datei?

---

<div class="post-metadata">

### Author: ![SebastianKloepper](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/sebastiankloepper/32/21435_2.png) [@SebastianKloepper](https://forum.shopware.com/u/SebastianKloepper)
#### Post date: [28. Mai 2015 um 18:00 UTC](https://forum.shopware.com/t/fehler-bei-datenbank-update/27368/10 "2015-05-28T18:00:52Z")

</div>

Hi, ist komisch. Hatte ich noch nie. Schau mal in die shopware.php Da kannst du sehen, in welchen Fällen due wartungsseite kommt Sebastian
