# Fehler bei anderen Zahlungsmethoden nach Installation des neuen PayPal-Plugin

**URL:** <https://forum.shopware.com/t/fehler-bei-anderen-zahlungsmethoden-nach-installation-des-neuen-paypal-plugin/56062>\
**Category:** Administration\
**Created:** [29. Oktober 2018 um 11:31 UTC](https://forum.shopware.com/t/fehler-bei-anderen-zahlungsmethoden-nach-installation-des-neuen-paypal-plugin/56062 "2018-10-29T11:31:29Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![indigo](https://avatars.discourse-cdn.com/v4/letter/i/dec6dc/32.png) [@indigo](https://forum.shopware.com/u/indigo)\
**Post date:** [29. Oktober 2018 um 11:31 UTC](https://forum.shopware.com/t/fehler-bei-anderen-zahlungsmethoden-nach-installation-des-neuen-paypal-plugin/56062/1 "2018-10-29T11:31:29Z")

</div>

Ich habe das neue Plugin PayPal 1.1.1 installiert. Dies sollte man ja vor eiem Update auf die 5.5.x machen. Plugin läuft soweit.&nbsp;

Leider wird bei Auswahl der anderen Zahlmethoden (Nachname, Vorkasse, etc.) keine finish Seite mehr angezeigt.

Nach click auf “bestellen” lande ich in der URL “/checkout/finish” und bekomme&nbsp;folgende Fehlermeldung:

**Diese Seite funktioniert nicht  
Seite&nbsp;kann diese Anfrage momentan nicht verarbeiten.  
HTTP ERROR 500**

Hat jemand ähnliche Probleme?

---

<div class="post-metadata">

**Author:** ![indigo](https://avatars.discourse-cdn.com/v4/letter/i/dec6dc/32.png) [@indigo](https://forum.shopware.com/u/indigo)\
**Post date:** [1. November 2018 um 12:11 UTC](https://forum.shopware.com/t/fehler-bei-anderen-zahlungsmethoden-nach-installation-des-neuen-paypal-plugin/56062/2 "2018-11-01T12:11:55Z")

</div>

Leider ist der Fehler immer noch da.

Es betrifft alle im Shop Standard vorhandenen Zahlarten. Also Vorkasse, Nachnahme, etc.

Das alles erst nachdem „Paypal Update auf die neue 1.1.1“

Hat irgendjemand eine Idee wo ich noch nach der Fehlerursachee suchen kann?

Sonst muss ich auf die alten Paypal Versionen downgraden und komplett bei der SW Version 5.4.6. bleiben. Dann ist aber der Endpunkt für SW erreicht. Schade eigentlich.

Ein Wechsel auf ein&nbsp;anderes System war eigentlich nicht geplant.

---

<div class="post-metadata">

**Author:** ![sonic](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/sonic/32/25728_2.png) [@sonic](https://forum.shopware.com/u/sonic)\
**Post date:** [1. November 2018 um 12:34 UTC](https://forum.shopware.com/t/fehler-bei-anderen-zahlungsmethoden-nach-installation-des-neuen-paypal-plugin/56062/3 "2018-11-01T12:34:55Z")

</div>

In der Regel beheben sich Fehler ja auch nicht von alleine innerhalb von 3 Tagen.  
Wenn es ein genereller Fehler wäre, hätten sicherlich schon Andere hier davon berichtet.

Detailierte Fehlerlogs könnten da schon hilfreich sein - und bei einen 500er hinterlässt der Server sicherlich einen Eintrag in seinen Server-Logs (nicht Shopware Log !).  
Vielleicht wäre es möglich, diese zu besorgen - dann kann ggf. auch individuell geholfen werden&nbsp; ![Wink](https://forum.shopware.com/plugins/CKEditor/plugins/smiley/images/wink.png "Wink")  
Unabhängig davon bitte auch in /var/logs gucken, ob es dort eine&nbsp;plugin\_production-2018-xx-yy.log und/oder core\_production-2018-xx-yy.log gibt, die zeitlich einen Eintrag zum Fehler hat.

P.S.: In NRW ist heute ein religiöser Feiertag, da wird sich von SW heute keiner melden&nbsp; ![Wink](https://forum.shopware.com/plugins/CKEditor/plugins/smiley/images/wink.png "Wink")

> **[Shopware Dokumentation](https://docs.shopware.com/de)**

---

<div class="post-metadata">

**Author:** ![indigo](https://avatars.discourse-cdn.com/v4/letter/i/dec6dc/32.png) [@indigo](https://forum.shopware.com/u/indigo)\
**Post date:** [1. November 2018 um 12:47 UTC](https://forum.shopware.com/t/fehler-bei-anderen-zahlungsmethoden-nach-installation-des-neuen-paypal-plugin/56062/4 "2018-11-01T12:47:35Z")

</div>

Hast ja Recht. Aber das Prob nervt schon etwas. ![Wink](https://europe1.discourse-cdn.com/flex013/uploads/shopware/original/1X/b3785da0cbf2c8566cb535dcf55b2730b5224899.png "Wink")

Hier mal die core\_produktion-2018-11-1.log

```
[2018-11-01 09:44:58] core.CRITICAL: The provided X-CSRF-Token for path "/checkout/saveShippingPayment/sTarget/checkout/sTargetAction/index" is invalid. Please go back, reload the page and try again. [] {"uid":"daf5a02"}
[2018-11-01 09:44:58] core.CRITICAL: The provided X-CSRF-Token for path "/checkout/saveShippingPayment/sTarget/checkout/sTargetAction/index" is invalid. Please go back, reload the page and try again. [] {"uid":"daf5a02"}
[2018-11-01 09:44:58] core.ERROR: Shopware\Components\CSRFTokenValidationException: The provided X-CSRF-Token for path "/checkout/saveShippingPayment/sTarget/checkout/sTargetAction/index" is invalid. Please go back, reload the page and try again. in /www/htdocs/w00a566d/store/D1/new/engine/Shopware/Components/CSRFTokenValidator.php:149 Stack trace: #0 /www/htdocs/w00a566d/store/D1/new/engine/Library/Enlight/Event/Handler/Default.php(91): Shopware\Components\CSRFTokenValidator->checkFrontendTokenValidation(Object(Enlight_Controller_ActionEventArgs)) #1 /www/htdocs/w00a566d/store/D1/new/engine/Library/Enlight/Event/EventManager.php(220): Enlight_Event_Handler_Default->execute(Object(Enlight_Controller_ActionEventArgs)) #2 /www/htdocs/w00a566d/store/D1/new/engine/Library/Enlight/Controller/Action.php(176): Enlight_Event_EventManager->notify('Enlight_Control...', Object(Enlight_Controller_ActionEventArgs)) #3 /www/htdocs/w00a566d/store/D1/new/engine/Library/Enlight/Controller/Dispatcher/Default.php(549): Enlight_Controller_Action->dispatch('saveShippingPay...') #4 /www/htdocs/w00a566d/store/D1/new/engine/Library/Enlight/Controller/Front.php(222): Enlight_Controller_Dispatcher_Default->dispatch(Object(Enlight_Controller_Request_RequestHttp), Object(Enlight_Controller_Response_ResponseHttp)) #5 /www/htdocs/w00a566d/store/D1/new/engine/Shopware/Kernel.php(215): Enlight_Controller_Front->dispatch() #6 /www/htdocs/w00a566d/store/D1/new/vendor/symfony/http-kernel/HttpCache/HttpCache.php(486): Shopware\Kernel->handle(Object(Symfony\Component\HttpFoundation\Request), 1, true) #7 /www/htdocs/w00a566d/store/D1/new/engine/Shopware/Components/HttpCache/AppCache.php(268): Symfony\Component\HttpKernel\HttpCache\HttpCache->forward(Object(Symfony\Component\HttpFoundation\Request), true, NULL) #8 /www/htdocs/w00a566d/store/D1/new/vendor/symfony/http-kernel/HttpCache/HttpCache.php(253): Shopware\Components\HttpCache\AppCache->forward(Object(Symfony\Component\HttpFoundation\Request), true) #9 /www/htdocs/w00a566d/store/D1/new/vendor/symfony/http-kernel/HttpCache/HttpCache.php(270): Symfony\Component\HttpKernel\HttpCache\HttpCache->pass(Object(Symfony\Component\HttpFoundation\Request), true) #10 /www/htdocs/w00a566d/store/D1/new/engine/Shopware/Components/HttpCache/AppCache.php(143): Symfony\Component\HttpKernel\HttpCache\HttpCache->invalidate(Object(Symfony\Component\HttpFoundation\Request), true) #11 /www/htdocs/w00a566d/store/D1/new/vendor/symfony/http-kernel/HttpCache/HttpCache.php(201): Shopware\Components\HttpCache\AppCache->invalidate(Object(Symfony\Component\HttpFoundation\Request), true) #12 /www/htdocs/w00a566d/store/D1/new/engine/Shopware/Components/HttpCache/AppCache.php(116): Symfony\Component\HttpKernel\HttpCache\HttpCache->handle(Object(Symfony\Component\HttpFoundation\Request), 1, true) #13 /www/htdocs/w00a566d/store/D1/new/shopware.php(122): Shopware\Components\HttpCache\AppCache->handle(Object(Symfony\Component\HttpFoundation\Request)) #14 {main} [] {"uid":"daf5a02"}

```

Kannst du damit etwas anfangen?

Wie kann denn das Paypal plugin die anderen zahlungsarten derart stören?

---

<div class="post-metadata">

**Author:** ![sonic](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/sonic/32/25728_2.png) [@sonic](https://forum.shopware.com/u/sonic)\
**Post date:** [1. November 2018 um 13:02 UTC](https://forum.shopware.com/t/fehler-bei-anderen-zahlungsmethoden-nach-installation-des-neuen-paypal-plugin/56062/5 "2018-11-01T13:02:30Z")

</div>

Keine Ahnung - benutze selber noch das alte PayPal und hänge bei 5.4.6. Das „neue“ mag ich aus diversen Gründen nicht.  
Warum was wie blockt, kann da eher einer von den Experten geben.  
Der X-CSRF-T dürfte nicht den 500er verursachen - ggf. nur ein Hinweis für einen Folgefehler. Bei einem „500er“ dürfte Shopware schon selber nicht mehr in der Lage sein, einen Log zu schreiben. Von daher musst Du mal gucken, was im Error-Log vom Server ist. Ggf. mal den Hoster um Rat fragen.  
&nbsp;

Wobei mich der Pfad schon arg an All-Inkl. erinnert. Wenn ja, musst Du Dir via htaccess den Error-Log aktivieren.  
[Domains, Webspace, Domain Webhosting, Server-Hosting Provider ALL-INKL](https://all-inkl.com/wichtig/htaccessgenerator/) ganz unten

Edit:  
Unabhängig davon:  
Testshop SW 5.5.2 mit PayPal 1.1.1 und „Vorkasse“. Zahlart auf „Vorkasse“ eingestellt und erfolgreich eine Bestellung durchgeführt.  
Das dürfte wohl was individuelles sein, was sich mit PayPal ggf. beisst.
