# Fehler Artikel-Export

**URL:** <https://forum.shopware.com/t/fehler-artikel-export/9118>\
**Category:** Shopware 3.5\
**Tags:** administration\
**Created:** [9. Oktober 2012 um 10:12 UTC](https://forum.shopware.com/t/fehler-artikel-export/9118 "2012-10-09T10:12:57Z")\
**Posts on this page:** 17\
**Page:** 1

<div class="post-metadata">

**Author:** ![elvitas](https://avatars.discourse-cdn.com/v4/letter/e/f9ae1b/32.png) [@elvitas](https://forum.shopware.com/u/elvitas)\
**Post date:** [9. Oktober 2012 um 10:12 UTC](https://forum.shopware.com/t/fehler-artikel-export/9118/1 "2012-10-09T10:12:57Z")

</div>

Hallo Community, seit Shopware 4 habe ich beim Artikel-Export folgenden Fehler: SQLSTATE[42S22]: Column not found: 1054 Unknown column ‘p.price’ in ‘field list’ in Zend/Db/Statement/Pdo.php on line 234 Stack trace: #0 Zend/Db/Statement.php(300): Zend\_Db\_Statement\_Pdo-\>\_execute(Array) #1 Zend/Db/Adapter/Abstract.php(479): Zend\_Db\_Statement-\>execute(Array) #2 Zend/Db/Adapter/Pdo/Abstract.php(238): Zend\_Db\_Adapter\_Abstract-\>query(’? SE…’, Array) #3 Enlight/Components/Db/Adapter/Pdo/Mysql.php(75): Zend\_Db\_Adapter\_Pdo\_Abstract-\>query(’? SE…’, Array) #4 Shopware/Controllers/Backend/ImportExport.php(660): Enlight\_Components\_Db\_Adapter\_Pdo\_Mysql-\>query(’? SE…’) #5 Shopware/Controllers/Backend/ImportExport.php(287): Shopware\_Controllers\_Backend\_ImportExport-\>exportArticlesFlat(‘csv’) #6 Enlight/Controller/Action.php(135): Shopware\_Controllers\_Backend\_ImportExport-\>exportArticlesAction() #7 Enlight/Controller/Dispatcher/Default.php(521): Enlight\_Controller\_Action-\>dispatch(‘exportArticlesA…’) #8 Enlight/Controller/Front.php(214): Enlight\_Controller\_Dispatcher\_Default-\>dispatch(Object(Enlight\_Controller\_Request\_RequestHttp), Object(Enlight\_Controller\_Response\_ResponseHttp)) #9 Shopware/Bootstrap.php(79): Enlight\_Controller\_Front-\>dispatch() #10 Enlight/Application.php(192): Shopware\_Bootstrap-\>run() #11 shopware.php(74): Enlight\_Application-\>run() #12 {main} Alle Updates, aktuell 4.0.3, haben nichts geholfen. Der Kategorien-Export klappt. Leider weiß ich nicht ganz genau, was ich machen muss, um den Fehler zu beheben. Von was für einem Preis ist die Rede, und was ist damit? Ich hoffe Ihr könnt helfen… 🙂

---

<div class="post-metadata">

**Author:** ![elvitas](https://avatars.discourse-cdn.com/v4/letter/e/f9ae1b/32.png) [@elvitas](https://forum.shopware.com/u/elvitas)\
**Post date:** [12. Oktober 2012 um 12:45 UTC](https://forum.shopware.com/t/fehler-artikel-export/9118/2 "2012-10-12T12:45:36Z")

</div>

Ergänzung: Der Artikel-Export funktioniert als xml Datei. Nur wenn ich es als csv oder Excel Datei exportieren will, kommt die o.g. Fehlermeldung. Hat jemand eine Idee, was das Problem sein könnte?

---

<div class="post-metadata">

**Author:** ![desbl](https://avatars.discourse-cdn.com/v4/letter/d/43a26b/32.png) [@desbl](https://forum.shopware.com/u/desbl)\
**Post date:** [3. Dezember 2012 um 00:03 UTC](https://forum.shopware.com/t/fehler-artikel-export/9118/3 "2012-12-03T00:03:09Z")

</div>

Der Fehler tritt auch bei mir auf. Hat jemand eine Idee? Grüße

---

<div class="post-metadata">

**Author:** ![DanielNogel](https://avatars.discourse-cdn.com/v4/letter/d/96bed5/32.png) [@DanielNogel](https://forum.shopware.com/u/DanielNogel)\
**Post date:** [3. Dezember 2012 um 08:35 UTC](https://forum.shopware.com/t/fehler-artikel-export/9118/4 "2012-12-03T08:35:15Z")

</div>

Hallo, das Problem kann auftreten, wenn das Kürzel der Standard-Kundengruppen “EK” geändert wird. Dieses Kürzel darf nicht geändert werden, ab 4.0.5. ist dies auch nicht mehr möglich. Schöne Grüße, Daniel

---

<div class="post-metadata">

**Author:** ![svhch](https://avatars.discourse-cdn.com/v4/letter/s/ecd19e/32.png) [@svhch](https://forum.shopware.com/u/svhch)\
**Post date:** [17. März 2013 um 00:17 UTC](https://forum.shopware.com/t/fehler-artikel-export/9118/5 "2013-03-17T00:17:56Z")

</div>

Bei mir tritt das gleiche Problem auf, jedoch habe ich den Kundengruppen kürzel “EK” nicht geändert, unter der Shopware Version 4.0.6 bricht der Produkt Export mit folgender Fehlermeldung ab. --------------------------------------------------------------------------------------- n Doctrine/ORM/AbstractQuery.php on line 467 Stack trace: #0 Shopware/Models/Shop/Repository.php(275): Doctrine\ORM\AbstractQuery-\>getOneOrNullResult() #1 Shopware/Controllers/Backend/ImportExport.php(536): Shopware\Models\Shop\Repository-\>getActiveDefault() #2 Shopware/Controllers/Backend/ImportExport.php(287): Shopware\_Controllers\_Backend\_ImportExport-\>exportArticlesFlat(‘excel’) #3 Enlight/Controller/Action.php(135): Shopware\_Controllers\_Backend\_ImportExport-\>exportArticlesAction() #4 Enlight/Controller/Dispatcher/Default.php(521): Enlight\_Controller\_Action-\>dispatch(‘exportArticlesA…’) #5 Enlight/Controller/Front.php(214): Enlight\_Controller\_Dispatcher\_Default-\>dispatch(Object(Enlight\_Controller\_Request\_RequestHttp), Object(Enlight\_Controller\_Response\_ResponseHttp)) #6 Shopware/Bootstrap.php(79): Enlight\_Controller\_Front-\>dispatch() #7 Enlight/Application.php(192): Shopware\_Bootstrap-\>run() #8 shopware.php(74): Enlight\_Application-\>run() #9 {main} --------------------------------------------------------------------------------------- LG Däni

---

<div class="post-metadata">

**Author:** ![system](https://europe1.discourse-cdn.com/flex013/uploads/shopware/original/3X/2/9/29c7587ba660f00e4995d1743162782e5d6d8653.svg) [@system](https://forum.shopware.com/u/system)\
**Post date:** [9. April 2013 um 21:33 UTC](https://forum.shopware.com/t/fehler-artikel-export/9118/6 "2013-04-09T21:33:46Z")

</div>

[quote=„Daniel Nögel“]Hallo, das Problem kann auftreten, wenn das Kürzel der Standard-Kundengruppen „EK“ geändert wird. Dieses Kürzel darf nicht geändert werden, ab 4.0.5. ist dies auch nicht mehr möglich. Schöne Grüße, Daniel[/quote] Hallo, hätte jemand eine Idee was damit tun ? Habe gesehen dass dieses Fehler hier schon früher war bei 4.0.4 (im Forum). Hat jemand eine Lösung gefunden? Bei mir ist dies heute passiert im 4.0.6, habe den update auf 4.0.7 probiert aber die Fehler ist immer da. Notiz: die „EK“ wurde auch nie geändert. Eine Idee ? Vielen Dank im Vorab MfG. Michal Masek Ups! Ein Fehler ist aufgetreten! Die nachfolgenden Hinweise sollten Ihnen weiterhelfen. SQLSTATE[42S22]: Column not found: 1054 Unknown column ‚p.price‘ in ‚field list‘ in Zend/Db/Statement/Pdo.php on line 234 Stack trace: #0 Zend/Db/Statement.php(300): Zend\_Db\_Statement\_Pdo-\>\_execute(Array) #1 Zend/Db/Adapter/Abstract.php(479): Zend\_Db\_Statement-\>execute(Array) #2 Zend/Db/Adapter/Pdo/Abstract.php(238): Zend\_Db\_Adapter\_Abstract-\>query(’? SE…’, Array) #3 Enlight/Components/Db/Adapter/Pdo/Mysql.php(75): Zend\_Db\_Adapter\_Pdo\_Abstract-\>query(’? SE…’, Array) #4 Shopware/Controllers/Backend/ImportExport.php(661): Enlight\_Components\_Db\_Adapter\_Pdo\_Mysql-\>query(’? SE…’) #5 Shopware/Controllers/Backend/ImportExport.php(287): Shopware\_Controllers\_Backend\_ImportExport-\>exportArticlesFlat(‚csv‘) #6 Enlight/Controller/Action.php(135): Shopware\_Controllers\_Backend\_ImportExport-\>exportArticlesAction() #7 Enlight/Controller/Dispatcher/Default.php(521): Enlight\_Controller\_Action-\>dispatch(‚exportArticlesA…‘) #8 Enlight/Controller/Front.php(214): Enlight\_Controller\_Dispatcher\_Default-\>dispatch(Object(Enlight\_Controller\_Request\_RequestHttp), Object(Enlight\_Controller\_Response\_ResponseHttp)) #9 Shopware/Bootstrap.php(79): Enlight\_Controller\_Front-\>dispatch() #10 Enlight/Application.php(192): Shopware\_Bootstrap-\>run() #11 shopware.php(74): Enlight\_Application-\>run() #12 {main}

---

<div class="post-metadata">

**Author:** ![system](https://europe1.discourse-cdn.com/flex013/uploads/shopware/original/3X/2/9/29c7587ba660f00e4995d1743162782e5d6d8653.svg) [@system](https://forum.shopware.com/u/system)\
**Post date:** [9. April 2013 um 23:32 UTC](https://forum.shopware.com/t/fehler-artikel-export/9118/7 "2013-04-09T23:32:38Z")

</div>

Hallo alle, bei mir die Fehler gefunden, dies war durch die Einstellung im Shopeinstellung-\>Kundengruppen-\>Shopkunden(EK) - Rabatt-Modus aktiviert. Nach dem deaktivieren funktioniert wieder. Wahrscheinlich ein Bug zum fixen. Grüsse Michal Masek

---

<div class="post-metadata">

**Author:** ![svhch](https://avatars.discourse-cdn.com/v4/letter/s/ecd19e/32.png) [@svhch](https://forum.shopware.com/u/svhch)\
**Post date:** [30. April 2013 um 11:56 UTC](https://forum.shopware.com/t/fehler-artikel-export/9118/8 "2013-04-30T11:56:43Z")

</div>

Hallo Masek vielen Dank für deinen Hinweis, dass deaktivieren dieser Funktion war auch bei mir Erfolgreich, nun kann ich die Daten wieder exportieren. LG Daniel

---

<div class="post-metadata">

**Author:** ![zero111181](https://avatars.discourse-cdn.com/v4/letter/z/f4b2a3/32.png) [@zero111181](https://forum.shopware.com/u/zero111181)\
**Post date:** [4. Mai 2013 um 15:16 UTC](https://forum.shopware.com/t/fehler-artikel-export/9118/9 "2013-05-04T15:16:37Z")

</div>

Bei mir war aus auch dieser Fehler vielen Dank

---

<div class="post-metadata">

**Author:** ![Sysgrade\_GmbH](https://avatars.discourse-cdn.com/v4/letter/s/ee7513/32.png) [@Sysgrade\_GmbH](https://forum.shopware.com/u/Sysgrade_GmbH)\
**Post date:** [22. Februar 2014 um 14:04 UTC](https://forum.shopware.com/t/fehler-artikel-export/9118/10 "2014-02-22T14:04:29Z")

</div>

Für alle, die das gleiche Problem haben: der Fehler liegt an der Rabattfunktion für die Kundengruppe “Endkunden” - bei aktiviertem Rabattmodus ist kein Artikelexport möglich (nachgestellt mit Shopware 4.1.2 und 4.1.3). Die Lösung liegt darin, temporär den Rabattmodus für die Kundengruppe “EK” zu deaktivieren.

---

<div class="post-metadata">

**Author:** ![impuls](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/impuls/32/13698_2.png) [@impuls](https://forum.shopware.com/u/impuls)\
**Post date:** [26. Februar 2014 um 11:02 UTC](https://forum.shopware.com/t/fehler-artikel-export/9118/11 "2014-02-26T11:02:28Z")

</div>

Danke, am Rabattmodus lag es bei mir ebenfalls. Schön wäre es natürlich, das mal zu beheben 😉

---

<div class="post-metadata">

**Author:** ![Mario\_Bolt](https://avatars.discourse-cdn.com/v4/letter/m/aca169/32.png) [@Mario\_Bolt](https://forum.shopware.com/u/Mario_Bolt)\
**Post date:** [15. Oktober 2014 um 08:35 UTC](https://forum.shopware.com/t/fehler-artikel-export/9118/12 "2014-10-15T08:35:27Z")

</div>

Wir haben für diese Verhalten einmal ein Bugticket erstellt: [http://jira.shopware.de/?ticket=SW-9517](http://jira.shopware.de/?ticket=SW-9517)

---

<div class="post-metadata">

**Author:** ![RiminiCentro](https://avatars.discourse-cdn.com/v4/letter/r/258eb7/32.png) [@RiminiCentro](https://forum.shopware.com/u/RiminiCentro)\
**Post date:** [6. Juli 2015 um 11:48 UTC](https://forum.shopware.com/t/fehler-artikel-export/9118/13 "2015-07-06T11:48:03Z")

</div>

Hallo Habe das selbe Problem mit der selben Fehlermeldung: SQLSTATE[42S22]: Column not found: 1054 Unknown column ‚d.impressions‘ in ‚field list‘ in Zend/Db/Statement/Pdo.php on line 234 Stack trace: #0 Zend/Db/Statement.php(303): Zend\_Db\_Statement\_Pdo-\>\_execute(Array) #1 Zend/Db/Adapter/Abstract.php(480): Zend\_Db\_Statement-\>execute(Array) #2 Zend/Db/Adapter/Pdo/Abstract.php(238): Zend\_Db\_Adapter\_Abstract-\>query(’\n SE…’, Array) #3 Enlight/Components/Db/Adapter/Pdo/Mysql.php(75): Zend\_Db\_Adapter\_Pdo\_Abstract-\>query(’\n SE…’, Array) #4 Shopware/Controllers/Backend/ImportExport.php(718): Enlight\_Components\_Db\_Adapter\_Pdo\_Mysql-\>query(’\n SE…’) #5 Shopware/Controllers/Backend/ImportExport.php(343): Shopware\_Controllers\_Backend\_ImportExport-\>exportArticlesFlat(‚csv‘) #6 Enlight/Controller/Action.php(159): Shopware\_Controllers\_Backend\_ImportExport-\>exportArticlesAction() #7 Enlight/Controller/Dispatcher/Default.php(528): Enlight\_Controller\_Action-\>dispatch(‚exportArticlesA…‘) #8 Enlight/Controller/Front.php(228): Enlight\_Controller\_Dispatcher\_Default-\>dispatch(Object(Enlight\_Controller\_Request\_RequestHttp), Object(Enlight\_Controller\_Response\_ResponseHttp)) #9 Shopware/Kernel.php(145): Enlight\_Controller\_Front-\>dispatch() #10 vendor/symfony/http-kernel/Symfony/Component/HttpKernel/HttpCache/HttpCache.php(471): Shopware\Kernel-\>handle(Object(Symfony\Component\HttpFoundation\Request), 1, true) #11 Shopware/Components/HttpCache/AppCache.php(256): Symfony\Component\HttpKernel\HttpCache\HttpCache-\>forward(Object(Symfony\Component\HttpFoundation\Request), true, NULL) #12 vendor/symfony/http-kernel/Symfony/Component/HttpKernel/HttpCache/HttpCache.php(242): Shopware\Components\HttpCache\AppCache-\>forward(Object(Symfony\Component\HttpFoundation\Request), true) #13 Shopware/Components/HttpCache/AppCache.php(102): Symfony\Component\HttpKernel\HttpCache\HttpCache-\>pass(Object(Symfony\Component\HttpFoundation\Request), true) #14 shopware.php(109): Shopware\Components\HttpCache\AppCache-\>handle(Object(Symfony\Component\HttpFoundation\Request)) #15 {main} Leider hat das Vorgehen bei mir nicht funktioniert. Bei mir ist der Rabattmodus für EK auf inaktiv. Trotzdem kann ich Artikel per CSV nicht deaktivieren. Ich versende SW 4.3.6. Auch updaten kann ich nicht. Ich denke mal, das hängt alles irgendwie zusammen. Irgendwo an der Datenbank. Hat jemand ne Idee für mich? Bei meinem zweiten Shop beim gleichen Host, funktioniert alles einwandfrei: Updates, Export… Vielen Dank im Voraus. Gruss Giulio

---

<div class="post-metadata">

**Author:** ![RiminiCentro](https://avatars.discourse-cdn.com/v4/letter/r/258eb7/32.png) [@RiminiCentro](https://forum.shopware.com/u/RiminiCentro)\
**Post date:** [26. August 2015 um 08:31 UTC](https://forum.shopware.com/t/fehler-artikel-export/9118/14 "2015-08-26T08:31:59Z")

</div>

Bitte helft mir… Bin kein Informatiker. Keine Ahnung von HTML und so. Was kann ich tun, um wieder exportieren und updaten zu können?

---

<div class="post-metadata">

**Author:** ![brettvormkopp](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/brettvormkopp/32/7788_2.png) [@brettvormkopp](https://forum.shopware.com/u/brettvormkopp)\
**Post date:** [2. Februar 2017 um 12:43 UTC](https://forum.shopware.com/t/fehler-artikel-export/9118/15 "2017-02-02T12:43:56Z")

</div>

Leider wurde das Ticket dazu ([https://issues.shopware.com/issues/SW-9517](https://issues.shopware.com/issues/SW-9517)) geschlossen und der Fehler existiert noch. Gibts einen Grund warum der Export nicht funktionieren sollte wenn die Rabattfunktion eingeschalten ist. Man kann&nbsp;im Shop schlecht im laufenenden Betrieb die Rabatte deaktivieren. Gibt es eine Lösung?

Danke und Gruss

---

<div class="post-metadata">

**Author:** ![SebastianKloepper](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/sebastiankloepper/32/21435_2.png) [@SebastianKloepper](https://forum.shopware.com/u/SebastianKloepper)\
**Post date:** [2. Februar 2017 um 12:49 UTC](https://forum.shopware.com/t/fehler-artikel-export/9118/16 "2017-02-02T12:49:21Z")

</div>

Hi,

bei dem genannten Ticket gibt es z.B. zwei Gründe:

1. Es handelt sich um den alten Core Import/Export. Wurde abgelöst durch das Plugin Import/Export Advanced. (Die Core-Integration wird auch in einem kommenden Update vom Quelltext her komplett entfernt.

2. Die Standardkundengruppe darf niemals im Rabatt-Modus laufen. Dann kann in der Systemkundegruppe (EK) kein Preis mehr hinterlegt werden. Man nimmt also dem System die Preise weg und der Rabatt (bezieht sich immer auf EK) kann keine Preise mehr finden.

Sebastian

---

<div class="post-metadata">

**Author:** ![brettvormkopp](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/brettvormkopp/32/7788_2.png) [@brettvormkopp](https://forum.shopware.com/u/brettvormkopp)\
**Post date:** [2. Februar 2017 um 12:53 UTC](https://forum.shopware.com/t/fehler-artikel-export/9118/17 "2017-02-02T12:53:43Z")

</div>

Ah, danke. dass es das alte ist hab ich gar nicht gesehen. Wieso liefert ihr das überhaupt als Standard aus wenn es ein neues gibt? Trotzdem Danke erstmal!
