# Fatal Error bei Registrierung

**URL:** <https://forum.shopware.com/t/fatal-error-bei-registrierung/56240>\
**Category:** Administration\
**Created:** [6. November 2018 um 08:49 UTC](https://forum.shopware.com/t/fatal-error-bei-registrierung/56240 "2018-11-06T08:49:01Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![dechateau](https://avatars.discourse-cdn.com/v4/letter/d/f17d59/32.png) [@dechateau](https://forum.shopware.com/u/dechateau)\
**Post date:** [6. November 2018 um 08:49 UTC](https://forum.shopware.com/t/fatal-error-bei-registrierung/56240/1 "2018-11-06T08:49:01Z")

</div>

Hi zusammen,

wir haben seit 2 Tagen nun etwa folgende Fehlermeldung bei der Registrierung:

```
Fatal error: Uncaught TypeError: Argument 1 passed to Symfony\Component\Form\AbstractType::setDefaultOptions() must be an instance of Symfony\Component\OptionsResolver\OptionsResolverInterface, instance of Symfony\Component\OptionsResolver\OptionsResolver given, called in /usr/www/users/.../wkshop/vendor/symfony/form/ResolvedFormType.php on line 253 and defined in /usr/www/users/.../wkshop/vendor/symfony/form/AbstractType.php:47 Stack trace: #0 /usr/www/users/.../wkshop/vendor/symfony/form/ResolvedFormType.php(253): Symfony\Component\Form\AbstractType->setDefaultOptions(Object(Symfony\Component\OptionsResolver\OptionsResolver)) #1 /usr/www/users/.../wkshop/vendor/symfony/form/ResolvedFormType.php(248): Symfony\Component\Form\ResolvedFormType->getOptionsResolver() #2 /usr/www/users/.../wkshop/vendor/symfony/form/ResolvedFormType.php(156): Symfony\Component\Form\ResolvedFormType->getOptionsResolver() #3 /usr/www/users/.../wkshop/vendor/symfony/form/FormFactory.php(107): Symfony\Component\Form\R in /usr/www/users/.../wkshop/vendor/symfony/form/AbstractType.php on line 47

```

Der Fehler tritt auf sobald man das Anmeldeformular abschickt und man wird auf die Seite weitergeleitet:&nbsp;[Registrierung | Der Werkzeugkönig](https://www.wzk24.de/register/saveRegister/sTarget/account/sTargetAction/index)  
Plugins haben wir bereits alle deaktiviert und auch den Sicherheitsmodus verwendet. Das Template für die Anmeldung haben wir auch nicht geändert.&nbsp;

Um eine schnelle Hilfe wären wir sehr verbunden. Unsere Shopware Version ist noch die&nbsp; **5.4.5** &nbsp;

Viele Grüße,

Denis

---

<div class="post-metadata">

**Author:** ![dechateau](https://avatars.discourse-cdn.com/v4/letter/d/f17d59/32.png) [@dechateau](https://forum.shopware.com/u/dechateau)\
**Post date:** [6. November 2018 um 09:59 UTC](https://forum.shopware.com/t/fatal-error-bei-registrierung/56240/2 "2018-11-06T09:59:24Z")

</div>

Update:

Der Fehler tritt nur unter PHP 7.0 auf. Unter 5.6 nicht. Unser Hoster ist Hetzner. Seitens Hetzner Support soll es ein Bug in Shopware sein. Das erschließt sich mir aber nicht, da es vorher einwandfrei funktionierte

---

<div class="post-metadata">

**Author:** ![alexwid](https://avatars.discourse-cdn.com/v4/letter/a/9fc348/32.png) [@alexwid](https://forum.shopware.com/u/alexwid)\
**Post date:** [7. November 2018 um 09:15 UTC](https://forum.shopware.com/t/fatal-error-bei-registrierung/56240/3 "2018-11-07T09:15:48Z")

</div>

Hi,

wir haben den selben Fehler (dachte zuerst es liegt an einem neu installierten Payment Modul), scheint aber nicht so zu sein …&nbsp;

Wenn sich bei dir was ergibt, bin ich über Feedback dankbar 🙂

---

<div class="post-metadata">

**Author:** ![dechateau](https://avatars.discourse-cdn.com/v4/letter/d/f17d59/32.png) [@dechateau](https://forum.shopware.com/u/dechateau)\
**Post date:** [7. November 2018 um 11:39 UTC](https://forum.shopware.com/t/fatal-error-bei-registrierung/56240/4 "2018-11-07T11:39:30Z")

</div>

> [@alexwid schrieb:](https://forum.shopware.com/profile/30070/alexwid "alexwid")
> 
> Hi,
> 
> wir haben den selben Fehler (dachte zuerst es liegt an einem neu installierten Payment Modul), scheint aber nicht so zu sein …&nbsp;
> 
> Wenn sich bei dir was ergibt, bin ich über Feedback dankbar ![:)](https://dub1.discourse-cdn.com/flex013/resources/emoji/smile.png ":)")

Erste Hilfe gab es erstmal durch ein Downgrade von PHP 7 auf PHP 5.6&nbsp;
