# Erstinstallation / Neuinstallation - 404 Fehler - Dokumentenstamm ist schon auf puplic gesetzt

**URL:** https://forum.shopware.com/t/erstinstallation-neuinstallation-404-fehler-dokumentenstamm-ist-schon-auf-puplic-gesetzt/104230
**Category:** Shopware 6 (German)
**Created:** [9. Juni 2024 um 11:58 UTC](https://forum.shopware.com/t/erstinstallation-neuinstallation-404-fehler-dokumentenstamm-ist-schon-auf-puplic-gesetzt/104230 "2024-06-09T11:58:24Z")
**Posts on this page:** 9
**Page:** 1

<div class="post-metadata">

### Author: ![SD2](https://avatars.discourse-cdn.com/v4/letter/s/7bcc69/32.png) [@SD2](https://forum.shopware.com/u/SD2)
#### Post date: [9. Juni 2024 um 11:58 UTC](https://forum.shopware.com/t/erstinstallation-neuinstallation-404-fehler-dokumentenstamm-ist-schon-auf-puplic-gesetzt/104230/1 "2024-06-09T11:58:24Z")

</div>

Hallo liebe Leute,

ich bin gerade dabei von SW5 zu SW6 zu wechseln und teste gerade ein bisschen rum.  
Aktuell bin ich noch am Installieren… 🙂

Das Installieren hat eigentlich mittlerweile geklappt, nachdem ich die richtige PHP Version (8.3) genommen habe.

Problem ist jetzt allerdings, dass die Installation zwar abgeschlossen ist, aber der Shop einen „404 Not Found“ Fehler zeigt, wenn ich die Seite aufrufen möchte.  
 ![404](https://europe1.discourse-cdn.com/flex013/uploads/shopware/original/3X/1/8/18e7e7a40f665478090793405d518c6ae42261f8.png)

**Dokumentenstamm wurde bereits auf public geändert.**

Komischerweise wird die Backendseite ganz normal aufgerufen wenn ich sie ansteuere  
[https://meineSeite.de/admin](https://meineSeite.de/admin)

Um aber in das Frontend zu kommen, muss ich immer [https://meineSeite.de/public](https://meineSeite.de/public) eingeben.  
Wie gesagt, der Dokumentenstamm ist umgeleitet auf public , trotzdem will es immer noch das public in der url haben ☹

Habe auch testweise mal eine phpinfo.php Datei angelegt zum schauen ob die richtig angezeigt wird (habe ich in den public Ordner gelegt) und die kann ich auch aufrufen ohne public in der url  
[https://meineSeite.de/phpinfo.php](https://meineSeite.de/phpinfo.php)

Hat jemand einen Tipp für mich?

---

<div class="post-metadata">

### Author: ![Max\_Shop](https://avatars.discourse-cdn.com/v4/letter/m/58f4c7/32.png) [@Max\_Shop](https://forum.shopware.com/u/Max_Shop)
#### Post date: [9. Juni 2024 um 12:00 UTC](https://forum.shopware.com/t/erstinstallation-neuinstallation-404-fehler-dokumentenstamm-ist-schon-auf-puplic-gesetzt/104230/2 "2024-06-09T12:00:48Z")

</div>

Eventuell musst du auf public/public verweisen, falls du bei der Installation einen Fehler begangen hast.

Ansonsten mal nur mit http und/oder www. versuchen.

---

<div class="post-metadata">

### Author: ![SD2](https://avatars.discourse-cdn.com/v4/letter/s/7bcc69/32.png) [@SD2](https://forum.shopware.com/u/SD2)
#### Post date: [9. Juni 2024 um 12:08 UTC](https://forum.shopware.com/t/erstinstallation-neuinstallation-404-fehler-dokumentenstamm-ist-schon-auf-puplic-gesetzt/104230/3 "2024-06-09T12:08:45Z")

</div>

danke für die Antwort.  
Wenn ich auf public/public verweise, dann sollte es sicher kappen, dass habe ich noch nicht probiert weil es meiner Meinung nach auch nicht die Lösung ist.

Irgendwo ist da noch ein Fehler der das eigentliche Problem verursacht 🤔

Ein anderer User hatte dieses Problem wohl auch und anscheinend ein den Einstellungen etwas gefunden was es gelöst hat… hat aber nicht geschrieben was ☹

> [@Fehlermeldung nach Erstinstallation Shopware 6.6.1.1](https://forum.shopware.com/t/fehlermeldung-nach-erstinstallation-shopware-6-6-1-1/103804):
>
> The server returned a „404 Not Found“. Wer kann helfen?

---

<div class="post-metadata">

### Author: ![Anotherone](https://avatars.discourse-cdn.com/v4/letter/a/6de8d8/32.png) [@Anotherone](https://forum.shopware.com/u/Anotherone)
#### Post date: [9. Juni 2024 um 18:35 UTC](https://forum.shopware.com/t/erstinstallation-neuinstallation-404-fehler-dokumentenstamm-ist-schon-auf-puplic-gesetzt/104230/4 "2024-06-09T18:35:09Z")

</div>

Zeig mal bitte Deinen Virtual Host Eintrag dafür. Kurios, das der Admin geht, aber das Frontend nicht.

---

<div class="post-metadata">

### Author: ![SD2](https://avatars.discourse-cdn.com/v4/letter/s/7bcc69/32.png) [@SD2](https://forum.shopware.com/u/SD2)
#### Post date: [9. Juni 2024 um 18:54 UTC](https://forum.shopware.com/t/erstinstallation-neuinstallation-404-fehler-dokumentenstamm-ist-schon-auf-puplic-gesetzt/104230/5 "2024-06-09T18:54:29Z")

</div>

mhh also „Virtual Host Eintrag“ sagt mir jetzt nix 😅  
was ist das?

Dann kann ich es sicher finden 🤔

---

<div class="post-metadata">

### Author: ![Anotherone](https://avatars.discourse-cdn.com/v4/letter/a/6de8d8/32.png) [@Anotherone](https://forum.shopware.com/u/Anotherone)
#### Post date: [9. Juni 2024 um 18:59 UTC](https://forum.shopware.com/t/erstinstallation-neuinstallation-404-fehler-dokumentenstamm-ist-schon-auf-puplic-gesetzt/104230/6 "2024-06-09T18:59:47Z")

</div>

Das ist der Eintrag, wo der Domain ein Verzeichnis zugeordnet wird. Ist das ein Hosting oder ein „eigener“ Server?

---

<div class="post-metadata">

### Author: ![SD2](https://avatars.discourse-cdn.com/v4/letter/s/7bcc69/32.png) [@SD2](https://forum.shopware.com/u/SD2)
#### Post date: [9. Juni 2024 um 19:01 UTC](https://forum.shopware.com/t/erstinstallation-neuinstallation-404-fehler-dokumentenstamm-ist-schon-auf-puplic-gesetzt/104230/7 "2024-06-09T19:01:58Z")

</div>

ist ein Hosting bei netcup

„Eintrag, wo der Domain ein Verzeichnis zugeordnet wir“  
Ist doch der Dokumentenstamm?

---

<div class="post-metadata">

### Author: ![Anotherone](https://avatars.discourse-cdn.com/v4/letter/a/6de8d8/32.png) [@Anotherone](https://forum.shopware.com/u/Anotherone)
#### Post date: [9. Juni 2024 um 19:09 UTC](https://forum.shopware.com/t/erstinstallation-neuinstallation-404-fehler-dokumentenstamm-ist-schon-auf-puplic-gesetzt/104230/8 "2024-06-09T19:09:12Z")

</div>

Ja. Das Problem könnte sein, das in einer Virtual Host Einstellung bestimmte Einstellungen für das Hauptverzeichnis (eine Ebene oberhalb von public) gemacht werden, der „DocumentRoot“ (der Startpunkt) ist dann aber das public-Verzeichnis. Kenne bei Netcup nur die Rootserver, kannst Du mal einen Screenshot von den Einstellungen bei Netcup machen?

---

<div class="post-metadata">

### Author: ![kontakt25](https://avatars.discourse-cdn.com/v4/letter/k/e0b2c6/32.png) [@kontakt25](https://forum.shopware.com/u/kontakt25)
#### Post date: [8. Oktober 2024 um 11:31 UTC](https://forum.shopware.com/t/erstinstallation-neuinstallation-404-fehler-dokumentenstamm-ist-schon-auf-puplic-gesetzt/104230/9 "2024-10-08T11:31:29Z")

</div>

Für alle einmal zur Info.  
Bei der ersten Installation wird ein Verkaufskanal angelegt.  
Da die Umstellung des Dokumentenpfad auf public erst nach der Installation erfolgt,  
sind in dem Verkaufskanal die Domains mit [https://domain.de/public](https://domain.de/public) hinterlegt.  
Das müsst ihr dann auf die Domain ändern. Also Domain ohne public hinterlegen.  
Dann funktioniert es.
