# Error Received an error message. URL: importDatabase

**URL:** <https://forum.shopware.com/t/error-received-an-error-message-url-importdatabase/60513>\
**Category:** Installation / Einstieg\
**Created:** [18. Juli 2019 um 09:49 UTC](https://forum.shopware.com/t/error-received-an-error-message-url-importdatabase/60513 "2019-07-18T09:49:14Z")\
**Posts on this page:** 12\
**Page:** 1

<div class="post-metadata">

**Author:** ![kanuma](https://avatars.discourse-cdn.com/v4/letter/k/ce7236/32.png) [@kanuma](https://forum.shopware.com/u/kanuma)\
**Post date:** [18. Juli 2019 um 09:49 UTC](https://forum.shopware.com/t/error-received-an-error-message-url-importdatabase/60513/1 "2019-07-18T09:49:14Z")

</div>

Moin,

wollte gerade SW6 über den neuen Installer installieren, leider ohne Erfolg.&nbsp;

Hoster: AIXPRO

Error

Received an error message.  
URL:&nbsp;importDatabase  
Message:&nbsp;

Please try to fix this error and restart the update.

Response

```
 &nbsp;

```

Slim Application Error

The application could not run because of the following error:

Details

Type: Doctrine\DBAL\DBALException

Message: An exception occurred while executing 'INSERT IGNORE INTO migration (`class`, `creation_timestamp`) VALUES (‚Shopware\Core\Migration\Migration1536232600Language‘,‚1536232600‘), (‚Shopware\Core\Migration\Migration1536232610Locale‘,‚1536232610‘), (‚Shopware\Core\Migration\Migration1536232620SalesChannelType‘,‚1536232620‘), (‚Shopware\Core\Migration\Migration1536232630PropertyGroup‘,‚1536232630‘), (‚Shopware\Core\Migration\Migration1536232640Currency‘,‚1536232640‘), (‚Shopware\Core\Migration\Migration1536232650CustomerGroup‘,‚1536232650‘), (‚Shopware\Core\Migration\Migration1536232660Tax‘,‚1536232660‘), (‚Shopware\Core\Migration\Migration1536232670Unit‘,‚1536232670‘), (‚Shopware\Core\Migration\Migration1536232680Rule‘,‚1536232680‘), (‚Shopware\Core\Migration\Migration1536232690Version‘,‚1536232690‘), (‚Shopware\Core\Migration\Migration1536232700VersionCommit‘,‚1536232700‘), (‚Shopware\Core\Migration\Migration1536232710Integration‘,‚1536232710‘),

[…]

(‚Shopware\Core\Migration\Migration1562579120ProductAvailableFields‘,‚1562579120‘), (‚Shopware\Core\Migration\Migration1562684474AddDeliveryTime‘,‚1562684474‘), (‚Shopware\Core\Migration\Migration1562841035AddProductChildCount‘,‚1562841035‘), (‚Shopware\Core\Migration\Migration1562933907ContactForm‘,‚1562933907‘), (‚Shopware\Core\Migration\Migration1563180880AddDefaultThumbnailSizes‘,‚1563180880‘);’: SQLSTATE[42S02]: Base table or view not found: 1146 Table ‚shopware6.migration‘ doesn’t exist

File: /var/www/vhosts/xxx/dev6.xxx/public/recovery/common/vendor/doctrine/dbal/lib/Doctrine/DBAL/DBALException.php

Line: 172

---

<div class="post-metadata">

**Author:** ![kanuma](https://avatars.discourse-cdn.com/v4/letter/k/ce7236/32.png) [@kanuma](https://forum.shopware.com/u/kanuma)\
**Post date:** [18. Juli 2019 um 09:52 UTC](https://forum.shopware.com/t/error-received-an-error-message-url-importdatabase/60513/2 "2019-07-18T09:52:42Z")

</div>

![](https://europe1.discourse-cdn.com/flex013/uploads/shopware/original/2X/d/df7a87cf00be5247e87dd87e57e4eb3e182bdcd7.png)

---

<div class="post-metadata">

**Author:** ![Moritz\_Naczenski](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/moritz_naczenski/32/7792_2.png) [@Moritz\_Naczenski](https://forum.shopware.com/u/Moritz_Naczenski)\
**Post date:** [18. Juli 2019 um 09:57 UTC](https://forum.shopware.com/t/error-received-an-error-message-url-importdatabase/60513/3 "2019-07-18T09:57:24Z")

</div>

Das liegt an deiner DB Version.

> **[Fehler bei Installation - Datenbank](https://forum.shopware.com/discussion/comment/250172/#Comment_250172)**
>
> Wir haben für den nächsten Installer ein Ticket aufgemacht, sodass die DB-Version im Installer abgefragt wird. Shopware 6 wird nur mit MySQL5.7 und neuer oder MariaDB 10.3 und neuer laufen. 10.3 ist bereits fast 2,5 Jahre alt.

---

<div class="post-metadata">

**Author:** ![kanuma](https://avatars.discourse-cdn.com/v4/letter/k/ce7236/32.png) [@kanuma](https://forum.shopware.com/u/kanuma)\
**Post date:** [18. Juli 2019 um 10:00 UTC](https://forum.shopware.com/t/error-received-an-error-message-url-importdatabase/60513/4 "2019-07-18T10:00:15Z")

</div>

**AIXPRO** hat sich bereits bei mir gemeldet :-). **Wie immer super Service!**

---

<div class="post-metadata">

**Author:** ![brettvormkopp](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/brettvormkopp/32/7788_2.png) [@brettvormkopp](https://forum.shopware.com/u/brettvormkopp)\
**Post date:** [3. Oktober 2019 um 07:24 UTC](https://forum.shopware.com/t/error-received-an-error-message-url-importdatabase/60513/5 "2019-10-03T07:24:01Z")

</div>

Moin, ich würde mich hier mal reinhängen mit einem Error bei der frischen Erst-Installation&nbsp;

> Datenbank Installation: Schritt&nbsp;124&nbsp;von&nbsp;250

```
Error
Received an error message.
URL: importDatabase
Message: Internal Server Error

Please try to fix this error and restart the update.
Response
{"valid":false,"errorMsg":"An exception occurred while executing '\n REPLACE INTO `media_folder_configuration_media_thumbnail_size` (`media_folder_configuration_id`, `media_thumbnail_size_id`)\n VALUES (?, ?)\n ' with params [\"\\x3a\\x60\\xdc\\x26\\x2e\\x5b\\x42\\x21\\x85\\xf4\\xb9\\x6f\\x84\\x11\\x17\\x2a\", \"\\xe8\\x8d\\xf4\\x14\\x59\\x4a\\x4d\\x5c\\xb6\\xb3\\xd4\\x68\\x16\\xcf\\x2e\\x49\"]:\n\nSQLSTATE[23000]: Integrity constraint violation: 1452 Cannot add or update a child row: a foreign key constraint fails (`sw6`.`media_folder_configuration_media_thumbnail_size`, CONSTRAINT `fk.media_folder_configuration_media_thumbnail_size.conf_id` FOREIGN KEY (`media_folder_configuration_id`) REFERENCES `media)"}

```

- Shopware 6 EA
- PHP 7.3.10
- MariaDB 10.4.8
- CentOS 7

Ich bräuchte Nachhilfe warum hier schon der Foreign Key eine Rolle spielt? Danke und Gruss

---

<div class="post-metadata">

**Author:** ![brettvormkopp](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/brettvormkopp/32/7788_2.png) [@brettvormkopp](https://forum.shopware.com/u/brettvormkopp)\
**Post date:** [3. Oktober 2019 um 07:36 UTC](https://forum.shopware.com/t/error-received-an-error-message-url-importdatabase/60513/6 "2019-10-03T07:36:08Z")

</div>

**EDIT: vorheriger Shopware 6 EA war von Juli, hier die Fehlermeldung mit der heutigen Shopware 6 EA**

> Datenbank-Installation: Schritt&nbsp;125&nbsp;von&nbsp;274

```
Error
Received an error message.
URL: importDatabase
Message: Internal Server Error

Please try to fix this error and restart the update.
Response
{"valid":false,"errorMsg":"An exception occurred while executing '\n REPLACE INTO `media_folder_configuration_media_thumbnail_size` (`media_folder_configuration_id`, `media_thumbnail_size_id`)\n VALUES (?, ?)\n ' with params [\"\\x97\\xd3\\x0b\\x3f\\x52\\x39\\x41\\xae\\x8b\\x9f\\xd9\\x9f\\x78\\xe1\\x49\\xdb\", \"\\x41\\x1f\\x1e\\xa7\\xc6\\x18\\x41\\x22\\xbe\\xda\\x1b\\xc1\\x28\\xfb\\x0a\\xd1\"]:\n\nSQLSTATE[23000]: Integrity constraint violation: 1452 Cannot add or update a child row: a foreign key constraint fails (`sw6`.`media_folder_configuration_media_thumbnail_size`, CONSTRAINT `fk.media_folder_configuration_media_thumbnail_size.conf_id` FOREIGN KEY (`media_folder_configuration_id`) REFERENCES `media)"}

```

&nbsp;

---

<div class="post-metadata">

**Author:** ![Moritz\_Naczenski](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/moritz_naczenski/32/7792_2.png) [@Moritz\_Naczenski](https://forum.shopware.com/u/Moritz_Naczenski)\
**Post date:** [3. Oktober 2019 um 08:00 UTC](https://forum.shopware.com/t/error-received-an-error-message-url-importdatabase/60513/7 "2019-10-03T08:00:24Z")

</div>

Hast du die Datenbank mal leer gemacht und von vorne gestartet?  
Die Meldung sagt ja nur, er kann einen Eintrag nicht erzeugen wg. eines Foreign Keys. Typischerweise wenn die Datenbank nicht leer war vor Installation.

---

<div class="post-metadata">

**Author:** ![brettvormkopp](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/brettvormkopp/32/7788_2.png) [@brettvormkopp](https://forum.shopware.com/u/brettvormkopp)\
**Post date:** [3. Oktober 2019 um 08:10 UTC](https://forum.shopware.com/t/error-received-an-error-message-url-importdatabase/60513/8 "2019-10-03T08:10:27Z")

</div>

Hi, ich habe innerhalb der Installationsroutine eine Datenbank angelegt und auch eine DB per Hand angelegt. Habe es mehrfach versucht. Das Ergebnis bleibt leider gleich. Die DB installiert sich komplett (denk ich zumindest, wenn die letzte Tabelle „version\_commit\_data“ heisst? Ich komme jedoch hier nicht aus der Installationsroutine heraus :-/

Wenn ich den obigen fehlgeschlagenen&nbsp;Befehl per Hand eingebe, Dann bekomme ich zurück, dass die Daten zu lang sind:

```
REPLACE INTO `media_folder_configuration_media_thumbnail_size` (`media_folder_configuration_id`, `media_thumbnail_size_id`) VALUES ("\\x97\\xd3\\x0b\\x3f\\x52\\x39\\x41\\xae\\x8b\\x9f\\xd9\\x9f\\x78\\xe1\\x49\\xdb", "\\x41\\x1f\\x1e\\xa7\\xc6\\x18\\x41\\x22\\xbe\\xda\\x1b\\xc1\\x28\\xfb\\x0a\\xd1")

```

Wofür stehen die Zeichen überhaupt? Dank und Gruss

---

<div class="post-metadata">

**Author:** ![Moritz\_Naczenski](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/moritz_naczenski/32/7792_2.png) [@Moritz\_Naczenski](https://forum.shopware.com/u/Moritz_Naczenski)\
**Post date:** [3. Oktober 2019 um 08:14 UTC](https://forum.shopware.com/t/error-received-an-error-message-url-importdatabase/60513/9 "2019-10-03T08:14:04Z")

</div>

Das Statement kannst du nicht so einfach kopieren, da das Binärwerte sind, die können dort nur nicht korrekt ausgegeben werden.

Müsste ja diese Migration sein:&nbsp;[platform/Migration1563180880AddDefaultThumbnailSizes.php at b597f32b5e70e0513744c368211c9a770dce14d0 · shopware/platform · GitHub](https://github.com/shopware/platform/blob/b597f32b5e70e0513744c368211c9a770dce14d0/src/Core/Migration/Migration1563180880AddDefaultThumbnailSizes.php)

Konnte jetzt so keinen&nbsp;genauen Grund erkennen, warum das fehlschlagen sollte. Habe zwar lokal MariaDB 10.3 aber das sollte keinen wirklichen Unterschied machen, Hat der Nutzer irgendwelche einegschränkten Rechte?

---

<div class="post-metadata">

**Author:** ![brettvormkopp](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/brettvormkopp/32/7788_2.png) [@brettvormkopp](https://forum.shopware.com/u/brettvormkopp)\
**Post date:** [3. Oktober 2019 um 08:21 UTC](https://forum.shopware.com/t/error-received-an-error-message-url-importdatabase/60513/10 "2019-10-03T08:21:20Z")

</div>

Mhh. Er ist root und hat full access/privileges. An der&nbsp;Datenbank habe ich heute gearbeitet. Hatte heute von MariaDB 5.5 \> 10.0.30 \> 10.4.8 geupdatet. Alle Shops etc. funktionieren auch… Ich werde das mal checken ob es bei den Updates einen Privilegien-„Verfall“ gibt? Wie komme ich denn aus der Installationsroutine heraus? Recovery löschen?

Danke und Gruss

---

<div class="post-metadata">

**Author:** ![Moritz\_Naczenski](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/moritz_naczenski/32/7792_2.png) [@Moritz\_Naczenski](https://forum.shopware.com/u/Moritz_Naczenski)\
**Post date:** [3. Oktober 2019 um 08:34 UTC](https://forum.shopware.com/t/error-received-an-error-message-url-importdatabase/60513/11 "2019-10-03T08:34:21Z")

</div>

Kannst ja am besten die Installation komplett löschen oder?

Ansonsten hab ichs gerade nicht im Kopf wie das in SW6 gelöst ist.&nbsp;

---

<div class="post-metadata">

**Author:** ![brettvormkopp](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/brettvormkopp/32/7788_2.png) [@brettvormkopp](https://forum.shopware.com/u/brettvormkopp)\
**Post date:** [3. Oktober 2019 um 08:37 UTC](https://forum.shopware.com/t/error-received-an-error-message-url-importdatabase/60513/12 "2019-10-03T08:37:10Z")

</div>

Fehler gelöst. Habe beim MariaDB-Update den „mysql\_upgrade“ Befehl vergessen. Sry 😛
