# Error-Log

**URL:** <https://forum.shopware.com/t/error-log/42741>\
**Category:** Installation/Einstieg\
**Created:** [12. Januar 2017 um 14:06 UTC](https://forum.shopware.com/t/error-log/42741 "2017-01-12T14:06:39Z")\
**Posts on this page:** 7\
**Page:** 1

<div class="post-metadata">

**Author:** ![shopware\_vc\_user](https://avatars.discourse-cdn.com/v4/letter/s/6f9a4e/32.png) [@shopware\_vc\_user](https://forum.shopware.com/u/shopware_vc_user)\
**Post date:** [12. Januar 2017 um 14:06 UTC](https://forum.shopware.com/t/error-log/42741/1 "2017-01-12T14:06:39Z")

</div>

Hallo,

ich habe vorab die Datenbank mit der Kollation utf8\_unicode\_ci aufgesetzt.

Die Installationsroutine ist bis fertigstellen gekommen.

&nbsp;

Dann kam ein interner Server-Error.

> Internal Server Error
> 
> The server encountered an internal error or misconfiguration and was unable to complete your request.
> 
> Please contact the server administrator, [service@webmailer.de](mailto:service@webmailer.de) and inform them of the time the error occurred, and anything you might have done that may have caused the error.
> 
> More information about this error may be available in the server error log.

&nbsp;

&nbsp;

Innerhalb der Installationsroutine&nbsp; via Installer folgende Error-Logs beim Provi:

> 12.01.2017 14:49:20 [test-content.de](http://test-content.de) [client 89.16.22.0] Premature end of script headers: index.php, referer: [http://test-content.de/shopware/recovery/install/index.php/configuration/](http://test-content.de/shopware/recovery/install/index.php/configuration/) 12.01.2017 14:51:42 [test-content.de](http://test-content.de) [client 89.16.22.0] Premature end of script headers: index.php, referer: [http://test-content.de/shopware/recovery/install/index.php/configuration/](http://test-content.de/shopware/recovery/install/index.php/configuration/) 12.01.2017 14:52:12 [test-content.de](http://test-content.de) [client 89.16.22.0] RuntimeException: Identifier DB not initialized yet in /mnt/webu/d1/98/56814398/htdocs/shopware/recovery/install/src/ContainerProvider.php:163, referer: [http://test-content.de/shopware/recovery/install/index.php/configuration/](http://test-content.de/shopware/recovery/install/index.php/configuration/) 12.01.2017 14:52:12 [test-content.de](http://test-content.de) [client 89.16.22.0] Stack trace:, referer: [http://test-content.de/shopware/recovery/install/index.php/configuration/](http://test-content.de/shopware/recovery/install/index.php/configuration/) 12.01.2017 14:52:12 [test-content.de](http://test-content.de) [client 89.16.22.0] #0 /mnt/webu/d1/98/56814398/htdocs/shopware/recovery/common/vendor/pimple/pimple/src/Pimple/Container.php(113): Shopware\Recovery\Install\ContainerProvider-\>Shopware\Recovery\Install\{closure}(Object(Pimple\Container)), referer: [http://test-content.de/shopware/recovery/install/index.php/configuration/](http://test-content.de/shopware/recovery/install/index.php/configuration/) 12.01.2017 14:52:12 [test-content.de](http://test-content.de) [client 89.16.22.0] #1 /mnt/webu/d1/98/56814398/htdocs/shopware/recovery/install/src/ContainerProvider.php(146): Pimple\Container-\>offsetGet(‚db‘), referer: [http://test-content.de/shopware/recovery/install/index.php/configuration/](http://test-content.de/shopware/recovery/install/index.php/configuration/) 12.01.2017 14:52:12 [test-content.de](http://test-content.de) [client 89.16.22.0] #2 /mnt/webu/d1/98/56814398/htdocs/shopware/recovery/common/vendor/pimple/pimple/src/Pimple/Container.php(113): Shopware\Recovery\Install\ContainerProvider-\>Shopware\Recovery\Install\{closure}(Object(Pimple\Container)), referer: [http://test-content.de/shopware/recovery/install/index.php/configuration/](http://test-content.de/shopware/recovery/install/index.php/configuration/) 12.01.2017 14:52:12 [test-content.de](http://test-content.de) [client 89.16.22.0] #3 /mnt/webu/d1/98/56814398/htdocs/shopware/recovery/install/src/app.php(439): Pimple\Container-\>offsetGet(‚theme.service‘), referer: [http://test-content.de/shopware/recovery/install/index.php/configuration/](http://test-content.de/shopware/recovery/install/index.php/configuration/) 12.01.2017 14:52:12 [test-content.de](http://test-content.de) [client 89.16.22.0] #4 [internal function]: {closure}(), referer: [http://test-content.de/shopware/recovery/install/index.php/configuration/](http://test-content.de/shopware/recovery/install/index.php/configuration/) 12.01.2017 14:52:12 [test-content.de](http://test-content.de) [client 89.16.22.0] #5 /mnt/webu/d1/98/56814398/htdocs/shopware/recovery/common/vendor/slim/slim/Slim/Route.php(462): call\_user\_func\_array(Object(Closure), Array), referer: [http://test-content.de/shopware/recovery/install/index.php/configuration/](http://test-content.de/shopware/recovery/install/index.php/configuration/) 12.01.2017 14:52:12 [test-content.de](http://test-content.de) [client 89.16.22.0] #6 /mnt/webu/d1/98/56814398/htdocs/shopware/recovery/common/vendor/slim/slim/Slim/Slim.php(1326): Slim\Route-\>dispatch(), referer: [http://test-content.de/shopware/recovery/install/index.php/configuration/](http://test-content.de/shopware/recovery/install/index.php/configuration/) 12.01.2017 14:52:12 [test-content.de](http://test-content.de) [client 89.16.22.0] #7 /mnt/webu/d1/98/56814398/htdocs/shopware/recovery/common/vendor/slim/slim/Slim/Middleware/Flash.php(85): Slim\Slim-\>call(), referer: [http://test-content.de/shopware/recovery/install/index.php/configuration/](http://test-content.de/shopware/recovery/install/index.php/configuration/) 12.01.2017 14:52:12 [test-content.de](http://test-content.de) [client 89.16.22.0] #8 /mnt/webu/d1/98/56814398/htdocs/shopware/recovery/common/vendor/slim/slim/Slim/Middleware/MethodOverride.php(92): Slim\Middleware\Flash-\>call(), referer: [http://test-content.de/shopware/recovery/install/index.php/configuration/](http://test-content.de/shopware/recovery/install/index.php/configuration/) 12.01.2017 14:52:12 [test-content.de](http://test-content.de) [client 89.16.22.0] #9 /mnt/webu/d1/98/56814398/htdocs/shopware/recovery/common/vendor/slim/slim/Slim/Middleware/PrettyExceptions.php(67): Slim\Middleware\MethodOverride-\>call(), referer: [http://test-content.de/shopware/recovery/install/index.php/configuration/](http://test-content.de/shopware/recovery/install/index.php/configuration/) 12.01.2017 14:52:12 [test-content.de](http://test-content.de) [client 89.16.22.0] #10 /mnt/webu/d1/98/56814398/htdocs/shopware/recovery/common/vendor/slim/slim/Slim/Slim.php(1271): Slim\Middleware\PrettyExceptions-\>call(), referer: [http://test-content.de/shopware/recovery/install/index.php/configuration/](http://test-content.de/shopware/recovery/install/index.php/configuration/) 12.01.2017 14:52:12 [test-content.de](http://test-content.de) [client 89.16.22.0] #11 /mnt/webu/d1/98/56814398/htdocs/shopware/recovery/install/index.php(74): Slim\Slim-\>run(), referer: [http://test-content.de/shopware/recovery/install/index.php/configuration/](http://test-content.de/shopware/recovery/install/index.php/configuration/) 12.01.2017 14:52:12 [test-content.de](http://test-content.de) [client 89.16.22.0] #12 {main}, referer: [http://test-content.de/shopware/recovery/install/index.php/configuration/](http://test-content.de/shopware/recovery/install/index.php/configuration/)

Dazu noch folgende Frontendausgabe:

> **Slim Application Error**
> 
> The application could not run because of the following error:
> 
> Details
> 
> **Type:** &nbsp;RuntimeException
> 
> **Message:** &nbsp;Identifier DB not initialized yet
> 
> **File:** &nbsp;/mnt/webu/d1/98/56814398/htdocs/shopware/recovery/install/src/ContainerProvider.php
> 
> **Line:** &nbsp;163
> 
> Trace
> 
> #0 /mnt/webu/d1/98/56814398/htdocs/shopware/recovery/common/vendor/pimple/pimple/src/Pimple/Container.php(113): Shopware\Recovery\Install\ContainerProvider-\>Shopware\Recovery\Install{closure}(Object(Pimple\Container))
> 
> #1 /mnt/webu/d1/98/56814398/htdocs/shopware/recovery/install/src/ContainerProvider.php(146): Pimple\Container-\>offsetGet(‚db‘)
> 
> #2 /mnt/webu/d1/98/56814398/htdocs/shopware/recovery/common/vendor/pimple/pimple/src/Pimple/Container.php(113): Shopware\Recovery\Install\ContainerProvider-\>Shopware\Recovery\Install{closure}(Object(Pimple\Container))
> 
> #3 /mnt/webu/d1/98/56814398/htdocs/shopware/recovery/install/src/app.php(439): Pimple\Container-\>offsetGet(‚theme.service‘)
> 
> #4 [internal function]: {closure}()
> 
> #5 /mnt/webu/d1/98/56814398/htdocs/shopware/recovery/common/vendor/slim/slim/Slim/Route.php(462): call\_user\_func\_array(Object(Closure), Array)
> 
> #6 /mnt/webu/d1/98/56814398/htdocs/shopware/recovery/common/vendor/slim/slim/Slim/Slim.php(1326): Slim\Route-\>dispatch()
> 
> #7 /mnt/webu/d1/98/56814398/htdocs/shopware/recovery/common/vendor/slim/slim/Slim/Middleware/Flash.php(85): Slim\Slim-\>call()
> 
> #8 /mnt/webu/d1/98/56814398/htdocs/shopware/recovery/common/vendor/slim/slim/Slim/Middleware/MethodOverride.php(92): Slim\Middleware\Flash-\>call()
> 
> #9 /mnt/webu/d1/98/56814398/htdocs/shopware/recovery/common/vendor/slim/slim/Slim/Middleware/PrettyExceptions.php(67): Slim\Middleware\MethodOverride-\>call()
> 
> #10 /mnt/webu/d1/98/56814398/htdocs/shopware/recovery/common/vendor/slim/slim/Slim/Slim.php(1271): Slim\Middleware\PrettyExceptions-\>call()
> 
> #11 /mnt/webu/d1/98/56814398/htdocs/shopware/recovery/install/index.php(74): Slim\Slim-\>run()
> 
> #12 {main}
> 
> &nbsp;
> 
> Der Installer hat on top noch folgendes Systemproblem ausgegeben:
> 
> &nbsp;
> 
> &nbsp;
> 
> &nbsp;
> 
> &nbsp;
> 
> Hat jemand die gleichen bzw. ähnliche Installationsprobleme gehabt?

---

<div class="post-metadata">

**Author:** ![Moritz\_Naczenski](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/moritz_naczenski/32/7792_2.png) [@Moritz\_Naczenski](https://forum.shopware.com/u/Moritz_Naczenski)\
**Post date:** [12. Januar 2017 um 16:03 UTC](https://forum.shopware.com/t/error-log/42741/2 "2017-01-12T16:03:13Z")

</div>

Hast du das Zip denn direkt auf dem Server entpackt?  
Häufig fehlen einfach Dateien durch den Upload.

---

<div class="post-metadata">

**Author:** ![shopware\_vc\_user](https://avatars.discourse-cdn.com/v4/letter/s/6f9a4e/32.png) [@shopware\_vc\_user](https://forum.shopware.com/u/shopware_vc_user)\
**Post date:** [12. Januar 2017 um 20:10 UTC](https://forum.shopware.com/t/error-log/42741/3 "2017-01-12T20:10:23Z")

</div>

Hi, super lieben Dank für deine Antwort.

Also ich habe die .zip (hab sie umbenannt ) auf dem Sever via .php

```
   $zip = new ZipArchive;
   $res = $zip->open('setup.zip');
   if ($res === TRUE) {
      $zip->extractTo('./');
      $zip->close();
      echo 'Das Entpacken war erfolgreich';
   } else {
      echo 'Fehler beim Entpacken!';
   }

```

entpackt, d.h. ich darf von einer Vollständigkeit ausgehen.

Ich telefoniere morgen mit dem Provi bezüglich des Screenshots weiter oben (Systemvorrausetzungen).

---

<div class="post-metadata">

**Author:** ![shopware\_vc\_user](https://avatars.discourse-cdn.com/v4/letter/s/6f9a4e/32.png) [@shopware\_vc\_user](https://forum.shopware.com/u/shopware_vc_user)\
**Post date:** [12. Januar 2017 um 22:19 UTC](https://forum.shopware.com/t/error-log/42741/4 "2017-01-12T22:19:22Z")

</div>

Den Punkt mit dem ionCube Loader hab ich gelöst. Ist jetzt Version 6.0 drauf.

Das Auslesen des Speichers bekommt man mit der Löschung folgender Zeile innerhalb der **System.xml** weg (habe aber die Installation noch nicht finalisiert bis ich alle Systemvoraussetzungen erfüllt habe mach ich nicht weiter):

Der aktuelle Pfad für die&nbsp; **System.xml** in Version 5: engine / Shopware / Components / Check / Data

```
        disk_free_spacecore5 GB1

```

**Mein Problem ist aktuell noch die mod\_rewite-Geschichte.**

In der .htaccess steht eindeutig:

```
RewriteEngine on

```

---

<div class="post-metadata">

**Author:** ![TimmeHosting](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/timmehosting/32/15580_2.png) [@TimmeHosting](https://forum.shopware.com/u/TimmeHosting)\
**Post date:** [13. Januar 2017 um 13:52 UTC](https://forum.shopware.com/t/error-log/42741/5 "2017-01-13T13:52:33Z")

</div>

Daß bei mod\_rewrite eine Warnung angezeigt wird, kann vorkommen, da würde ich mir erst einmal keine Gedanken machen. Das Problem, um das Du Dir zuallererst Gedanken machen solltest, ist die zweite Warnung - offensichtlich hast Du keinen freien Speicherplatz mehr, und so kannst Du Shopware natürlich nicht installieren (vermutlich noch nicht einmal komplett entpacken).

![](https://europe1.discourse-cdn.com/flex013/uploads/shopware/original/1X/385eaa628505df573ebf33722f780335f53ac1b2.png)

Timme Hosting - schnelles nginx-Hosting

[www.timmehosting.de](https://timmehosting.de/)

---

<div class="post-metadata">

**Author:** ![shopware\_vc\_user](https://avatars.discourse-cdn.com/v4/letter/s/6f9a4e/32.png) [@shopware\_vc\_user](https://forum.shopware.com/u/shopware_vc_user)\
**Post date:** [13. Januar 2017 um 19:11 UTC](https://forum.shopware.com/t/error-log/42741/6 "2017-01-13T19:11:25Z")

</div>

Hi, danke für deinen&nbsp; Antwort. Ich habe noch gut 30 Gb frei?!

---

<div class="post-metadata">

**Author:** ![Hille](https://avatars.discourse-cdn.com/v4/letter/h/87869e/32.png) [@Hille](https://forum.shopware.com/u/Hille)\
**Post date:** [13. Januar 2017 um 21:02 UTC](https://forum.shopware.com/t/error-log/42741/7 "2017-01-13T21:02:13Z")

</div>

Führe doch mal als root folgendes aus

```
a2enmod rewrite

/etc/init.d/apache2 restart 

```

&nbsp;

Du bist dir sicher, das die Partition (evtl. LVM), auf der Shopware liegt, wirklich noch 30GB freien Speicher hat? Poste mal diese Ausgabe

&nbsp;

```
df -h

```

&nbsp;
