# Error 500 nach update 6.4

**URL:** <https://forum.shopware.com/t/error-500-nach-update-6-4/88000>\
**Category:** Shopware 6 (German)\
**Created:** [30. Mai 2021 um 20:00 UTC](https://forum.shopware.com/t/error-500-nach-update-6-4/88000 "2021-05-30T20:00:46Z")\
**Posts on this page:** 10\
**Page:** 1

<div class="post-metadata">

**Author:** ![nicknl](https://avatars.discourse-cdn.com/v4/letter/n/3bc359/32.png) [@nicknl](https://forum.shopware.com/u/nicknl)\
**Post date:** [30. Mai 2021 um 20:00 UTC](https://forum.shopware.com/t/error-500-nach-update-6-4/88000/1 "2021-05-30T20:00:46Z")

</div>

Hallo Freunde,

nach dem Update eines Webshops von 6.3.5.3 auf 6.4 erhalte ich einen Fehler 500. Könnten Sie mir bitte auf meinem Weg helfen?

Dies stammt aus dem Log:

```
[2021-05-30 13:25:12] php.CRITICAL: Fatal Error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 16777224 bytes) {"exception":"[object] (Symfony\\Component\\ErrorHandler\\Error\\OutOfMemoryError(code: 0): Error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 16777224 bytes) at /home/mydomain/domains/domain.de/public_html/vendor/sabberworm/php-css-parser/lib/Sabberworm/CSS/Parsing/ParserState.php:285)"} []

```

[2021-05-30 13:31:05] php.CRITICAL: Uncaught Error: Too few arguments to function Swag\PayPal\Util\Lifecycle\Update::\_\_construct(), 5 passed in /home/mydomain/domains/domain.de/public\_html/custom/plugins/SwagPayPal/src/SwagPayPal.php on line 166 and exactly 8 expected {„exception“:"[object] (ArgumentCountError(code: 0): Too few arguments to function Swag\PayPal\Util\Lifecycle\Update::\_\_construct(), 5 passed in /home/mydomain/domains/domain.de/public\_html/custom/plugins/SwagPayPal/src/SwagPayPal.php on line 166 and exactly 8 expected at /home/mydomain/domains/domain.de/public\_html/custom/plugins/SwagPayPal/src/Util/Lifecycle/Update.php:71)"}

[2021-05-30 13:35:34] request.ERROR: Uncaught PHP Exception Symfony\Component\HttpKernel\Exception\NotFoundHttpException: „No route found for „GET /dealers“ (from „[https://domain.de/public/")"](https://domain.de/public/%22)%22) at /home/mydomain/domains/domain.de/public\_html/vendor/symfony/http-kernel/EventListener/RouterListener.php line 136 {„exception“:“[object] (Symfony\Component\HttpKernel\Exception\NotFoundHttpException(code: 0): No route found for „GET /dealers“ (from „[https://domain.de/public/](https://domain.de/public/)“) at /home/mydomain/domains/domain.de/public\_html/vendor/symfony/http-kernel/EventListener/RouterListener.php:136, Symfony\Component\Routing\Exception\ResourceNotFoundException(code: 0): No routes found for „/dealers/“. at /home/mydomain/domains/domain.de/public\_html/vendor/symfony/routing/Matcher/Dumper/CompiledUrlMatcherTrait.php:70)“}

Vielen dank im Vorraus!

Nick

---

<div class="post-metadata">

**Author:** ![SmartStylez](https://avatars.discourse-cdn.com/v4/letter/s/a88e4f/32.png) [@SmartStylez](https://forum.shopware.com/u/SmartStylez)\
**Post date:** [31. Mai 2021 um 03:40 UTC](https://forum.shopware.com/t/error-500-nach-update-6-4/88000/2 "2021-05-31T03:40:02Z")

</div>

Kommst du noch ins Backend und könntest du mal bitte versuchen, das PayPal Plugin zu deaktivieren?

---

<div class="post-metadata">

**Author:** ![nicknl](https://avatars.discourse-cdn.com/v4/letter/n/3bc359/32.png) [@nicknl](https://forum.shopware.com/u/nicknl)\
**Post date:** [31. Mai 2021 um 05:36 UTC](https://forum.shopware.com/t/error-500-nach-update-6-4/88000/3 "2021-05-31T05:36:37Z")

</div>

Leider funktioniert die Backend Zugriffe auch nicht. Kann ich den manuell deaktivieren?

---

<div class="post-metadata">

**Author:** ![SmartStylez](https://avatars.discourse-cdn.com/v4/letter/s/a88e4f/32.png) [@SmartStylez](https://forum.shopware.com/u/SmartStylez)\
**Post date:** [31. Mai 2021 um 06:15 UTC](https://forum.shopware.com/t/error-500-nach-update-6-4/88000/4 "2021-05-31T06:15:38Z")

</div>

Ja klar, über die Datenbank in der Tabelle plugin den Wert active auf 0 setzen.

---

<div class="post-metadata">

**Author:** ![nicknl](https://avatars.discourse-cdn.com/v4/letter/n/3bc359/32.png) [@nicknl](https://forum.shopware.com/u/nicknl)\
**Post date:** [31. Mai 2021 um 07:38 UTC](https://forum.shopware.com/t/error-500-nach-update-6-4/88000/5 "2021-05-31T07:38:47Z")

</div>

Jetzt offnët sich wieder die Seite.  
Aber es fehtl noch am Backend.  
Ich kann gerade einloggen, aber es gibt dann einem Blank Page und logt sich dann wieder automatisch aus.

---

<div class="post-metadata">

**Author:** ![SmartStylez](https://avatars.discourse-cdn.com/v4/letter/s/a88e4f/32.png) [@SmartStylez](https://forum.shopware.com/u/SmartStylez)\
**Post date:** [31. Mai 2021 um 08:04 UTC](https://forum.shopware.com/t/error-500-nach-update-6-4/88000/6 "2021-05-31T08:04:08Z")

</div>

Welche Fehlermeldung erhältst du jetzt?

---

<div class="post-metadata">

**Author:** ![nicknl](https://avatars.discourse-cdn.com/v4/letter/n/3bc359/32.png) [@nicknl](https://forum.shopware.com/u/nicknl)\
**Post date:** [31. Mai 2021 um 08:20 UTC](https://forum.shopware.com/t/error-500-nach-update-6-4/88000/7 "2021-05-31T08:20:46Z")

</div>

Leider gar keine!  
Wo kann ich die fehler meldung sehen?

---

<div class="post-metadata">

**Author:** ![SmartStylez](https://avatars.discourse-cdn.com/v4/letter/s/a88e4f/32.png) [@SmartStylez](https://forum.shopware.com/u/SmartStylez)\
**Post date:** [31. Mai 2021 um 09:54 UTC](https://forum.shopware.com/t/error-500-nach-update-6-4/88000/8 "2021-05-31T09:54:51Z")

</div>

In der Logdatei, schau‘ mal im Verzeichnis /var/log/ auf dem Server.

---

<div class="post-metadata">

**Author:** ![munter1506](https://avatars.discourse-cdn.com/v4/letter/m/839c29/32.png) [@munter1506](https://forum.shopware.com/u/munter1506)\
**Post date:** [9. Mai 2022 um 07:49 UTC](https://forum.shopware.com/t/error-500-nach-update-6-4/88000/10 "2022-05-09T07:49:43Z")

</div>

Wie wurde dieses Problem am Ende gelöst? Stehe aktuell vor dem selben Problem seit dem Update auf 6.4.11.1

---

<div class="post-metadata">

**Author:** ![BoyCom](https://avatars.discourse-cdn.com/v4/letter/b/919ad9/32.png) [@BoyCom](https://forum.shopware.com/u/BoyCom)\
**Post date:** [12. Mai 2022 um 08:43 UTC](https://forum.shopware.com/t/error-500-nach-update-6-4/88000/11 "2022-05-12T08:43:00Z")

</div>

Bei dem Update gab es bei mir das selbe Problem.  
Backend geht bei mir.

Deaktiviere alle Plugins. Dann sollte der Shop erreichbar sein.  
Danach aktivierst du nacheinander die Plugins. Bei mir war es das Sicherheitsplugin.
