# Error 500 Einstellungen cache / performance

**URL:** <https://forum.shopware.com/t/error-500-einstellungen-cache-performance/89194>\
**Category:** Allgemein\
**Created:** [16. Juli 2021 um 14:55 UTC](https://forum.shopware.com/t/error-500-einstellungen-cache-performance/89194 "2021-07-16T14:55:12Z")\
**Posts on this page:** 14\
**Page:** 1

<div class="post-metadata">

**Author:** ![Partylook](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/partylook/32/14203_2.png) [@Partylook](https://forum.shopware.com/u/Partylook)\
**Post date:** [16. Juli 2021 um 14:55 UTC](https://forum.shopware.com/t/error-500-einstellungen-cache-performance/89194/1 "2021-07-16T14:55:12Z")

</div>

Hallo zusammen,

Ich bekomme immer wieder Error 500 wenn ich nach Einstellungen → cache / performance → cache / performance gehen möchte. Wenn ich da auf OK klicke und nach Cache gehe ist da nichts drin hat jemand eine idee was hier schief laufen könnte? Ich denke, es ist seit dem Update auf 5.7.2, aber ich bin mir nicht sicher, da ich es nicht so oft ansehen.

Danke im Voraus, Ron

---

<div class="post-metadata">

**Author:** ![SmartStylez](https://avatars.discourse-cdn.com/v4/letter/s/a88e4f/32.png) [@SmartStylez](https://forum.shopware.com/u/SmartStylez)\
**Post date:** [16. Juli 2021 um 15:54 UTC](https://forum.shopware.com/t/error-500-einstellungen-cache-performance/89194/2 "2021-07-16T15:54:12Z")

</div>

Ich habe dieses Phänomen mit PHP 8 beobachten können, mit PHP 7.4 tritt es nicht auf.

---

<div class="post-metadata">

**Author:** ![MarkusFischer](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/markusfischer/32/13693_2.png) [@MarkusFischer](https://forum.shopware.com/u/MarkusFischer)\
**Post date:** [16. Juli 2021 um 15:57 UTC](https://forum.shopware.com/t/error-500-einstellungen-cache-performance/89194/3 "2021-07-16T15:57:24Z")

</div>

Hallo Ron,  
wenn Du das Formular aufrufst, bekommst Du eine Meldung, die Du mit OK bestätigen musst? Dann wäre die Meldung wichtig.  
Außerdem kannst Du unter **Einstellungen \> Systeminfo** nachsehen, ob auf einer der dortigen Seiten ein Fehler oder ein Hinweis angezeigt wird. Gibt es ausführlichere Log-Einträge unter **Einstellungen \> Logfile**?

Und zu SmartStylez Hinweis: Diese PHP Versionen sind nicht mit 5.7.x kompatibel: PHP 7.3.x / 7.4.x / 8.0 (7.2.x, 7.3.7, 7.4.14 und 8.0.1 sind nicht kompatibel) siehe [https://docs.shopware.com/de/shopware-5-de/tutorials-und-faq/systemanforderungen-hosting](https://docs.shopware.com/de/shopware-5-de/tutorials-und-faq/systemanforderungen-hosting)

Markus

---

<div class="post-metadata">

**Author:** ![Partylook](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/partylook/32/14203_2.png) [@Partylook](https://forum.shopware.com/u/Partylook)\
**Post date:** [16. Juli 2021 um 16:26 UTC](https://forum.shopware.com/t/error-500-einstellungen-cache-performance/89194/4 "2021-07-16T16:26:48Z")

</div>

Super SmartStylez! Tatsächlich tritt das Problem nur mit PHP 8 auf, zurück zu 7.4.2 und es ist weg. Danke dir, hoffe Shopware behebt dies in einem nächsten Update.

Schönes Wochenende, Grüße Ron

---

<div class="post-metadata">

**Author:** ![Partylook](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/partylook/32/14203_2.png) [@Partylook](https://forum.shopware.com/u/Partylook)\
**Post date:** [16. Juli 2021 um 16:29 UTC](https://forum.shopware.com/t/error-500-einstellungen-cache-performance/89194/5 "2021-07-16T16:29:50Z")

</div>

Danke MarkusFischer, mit 7.4.2 und es ist weg. Danke dir, hoffe Shopware behebt dies in einem nächsten Update.

Schönes Wochenende, Grüße Ron

---

<div class="post-metadata">

**Author:** ![SmartStylez](https://avatars.discourse-cdn.com/v4/letter/s/a88e4f/32.png) [@SmartStylez](https://forum.shopware.com/u/SmartStylez)\
**Post date:** [16. Juli 2021 um 16:52 UTC](https://forum.shopware.com/t/error-500-einstellungen-cache-performance/89194/6 "2021-07-16T16:52:28Z")

</div>

Interessanterweise nutzen wir einen offiziellen Hoster mit PHP 8.0.3 und der Fehler tritt auch auf.

---

<div class="post-metadata">

**Author:** ![Partylook](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/partylook/32/14203_2.png) [@Partylook](https://forum.shopware.com/u/Partylook)\
**Post date:** [17. Juli 2021 um 07:22 UTC](https://forum.shopware.com/t/error-500-einstellungen-cache-performance/89194/7 "2021-07-17T07:22:29Z")

</div>

Unser offiziellen Hoster mit PHP 8.0.8 und der Fehler tritt da auch auf, also was MarkusFischer und Shopware angeben stimmt nicht.

---

<div class="post-metadata">

**Author:** ![MarkusFischer](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/markusfischer/32/13693_2.png) [@MarkusFischer](https://forum.shopware.com/u/MarkusFischer)\
**Post date:** [19. Juli 2021 um 07:24 UTC](https://forum.shopware.com/t/error-500-einstellungen-cache-performance/89194/8 "2021-07-19T07:24:33Z")

</div>

Leider hattest Du nicht angegeben, welche Meldung Du erhältst, bevor Du OK gedrückt hast.

Wenn ein Fehler auftritt, ist es notwendig, dass er nachvollzogen werden kann. Nur so lässt sich eingrenzen, was den Fehler verursacht. Und nur so lässt sich die Ursache beheben.

Es ist leider bereits mehrfach aufgetreten, dass Plugins Fehler verursacht haben, weil in der Prüfung vor dem Update übersehen wurde, dass das Plugin nicht kompatibel war.

Falls es Dir noch vorliegt, also bitte gern die Meldung und die Umstände, wie sie in Shopware auftraten an unsere Entwicklung melden. Hilfreich sind in dem Zusammenhang auch die technischen Informationen:

- Welche PHP Version wurde eingesetzt
- Welche MySQL Version (oder welche MariaDB Version)?
- Welcher Server Apache / Nginx

Alle, die mit Shopware arbeiten, dürfen gern unseren öffentlichen Issuetracker nutzen, um Fehler oder Verbesserungsvorschläge zu melden: [https://issues.shopware.com/](https://issues.shopware.com/)

Markus

---

<div class="post-metadata">

**Author:** ![TobiasKassner](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/tobiaskassner/32/21642_2.png) [@TobiasKassner](https://forum.shopware.com/u/TobiasKassner)\
**Post date:** [20. Juli 2021 um 06:09 UTC](https://forum.shopware.com/t/error-500-einstellungen-cache-performance/89194/9 "2021-07-20T06:09:43Z")

</div>

@Partylook @SmartStylez

Das Problem wird vermutlich die PHP-Extension **opcache** sein. Shopware prüft nur ob diese auf dem Server aktiv ist und geht dann davon aus das alle Funktionen dieser Extension nutzbar sind, einige Hoster deaktivieren aber **einzelne Funktionen**.

Schaut mal in Eurer PHP-Info ob Ihr opcache\_get\_status unter disable\_functions, wenn ja müsstet Ihr das aktvieren (lassen) und das sollte es auch mit PHP8 funktionieren.

 ![phpinfo](https://europe1.discourse-cdn.com/flex013/uploads/shopware/original/2X/1/166d0bd768ae7f01aeb91be91d239f0d3ef1ff2d.png)

Ich habe dazu auch ein Issue angelegt: [SW-26152](https://issues.shopware.com/issues/SW-26152)

Gruß  
Tobi

---

<div class="post-metadata">

**Author:** ![SCOOPEX](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/scoopex/32/18328_2.png) [@SCOOPEX](https://forum.shopware.com/u/SCOOPEX)\
**Post date:** [20. Juli 2021 um 09:02 UTC](https://forum.shopware.com/t/error-500-einstellungen-cache-performance/89194/10 "2021-07-20T09:02:58Z")

</div>

Hallo zusammen,

opcache\_get\_status in einfachen Shared Hosting Umgebungen zu deaktivieren, ist auch korrekt, da es andernfalls zu einer Sicherheitslücke kommt, wodurch z.B. ein Kunde auf dem gleichen Server den OPCache eines anderen auslesen kann.

Grundsätzlich bedeutet dies jedoch nicht, dass OPCache nicht aktiv ist - der Status kann halt nur nicht ausgelesen werden.

Mehr zum Thema:

> **[Mitigating PHP’s long standing issue with OPCache leaking sensitive data](https://ma.ttias.be/mitigating-phps-long-standing-issue-opcache-leaking-sensitive-data/)**
>
> A very old security vulnerability has been fixed in PHP regarding the way it handles its OPCaches in environments where a single master process shares multiple PHP-FPM pools.

Viele Grüße

---

<div class="post-metadata">

**Author:** ![TobiasKassner](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/tobiaskassner/32/21642_2.png) [@TobiasKassner](https://forum.shopware.com/u/TobiasKassner)\
**Post date:** [20. Juli 2021 um 09:11 UTC](https://forum.shopware.com/t/error-500-einstellungen-cache-performance/89194/11 "2021-07-20T09:11:47Z")

</div>

> [@SCOOPEX](#):
>
> opcache\_get\_status in einfachen Shared Hosting Umgebungen zu deaktivieren, ist auch korrekt

Genau, deswegen bzw. da das durchaus legitim ist auch das Bug-Ticket.

---

<div class="post-metadata">

**Author:** ![Partylook](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/partylook/32/14203_2.png) [@Partylook](https://forum.shopware.com/u/Partylook)\
**Post date:** [20. Juli 2021 um 09:43 UTC](https://forum.shopware.com/t/error-500-einstellungen-cache-performance/89194/12 "2021-07-20T09:43:11Z")

</div>

Hallo Lars,

Dank Lars, wir haben doch kein Shared Hosting? Grüße Ron

---

<div class="post-metadata">

**Author:** ![Partylook](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/partylook/32/14203_2.png) [@Partylook](https://forum.shopware.com/u/Partylook)\
**Post date:** [20. Juli 2021 um 09:46 UTC](https://forum.shopware.com/t/error-500-einstellungen-cache-performance/89194/13 "2021-07-20T09:46:47Z")

</div>

Hallo Markus,

Das war mit:  
PHP 8.0.8  
MariaDB 10.3.28  
Nginx Server

Grüße Ron

---

<div class="post-metadata">

**Author:** ![SCOOPEX](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/scoopex/32/18328_2.png) [@SCOOPEX](https://forum.shopware.com/u/SCOOPEX)\
**Post date:** [20. Juli 2021 um 10:06 UTC](https://forum.shopware.com/t/error-500-einstellungen-cache-performance/89194/14 "2021-07-20T10:06:12Z")

</div>

Hi Ron,

das ist die Standard-Einstellung bei Plesk. Bei vServern/dedizierten Servern kannst Du den Eintrag in Plesk unter PHP Einstellungen der betroffenen Domain entfernen - unterhalb von opcache.enable die Zeile opcache\_disable\_status bei disable.functions rauslöschen und speichern.

Siehe

> **[How to ensure that Opcache is enabled?](https://support.plesk.com/hc/en-us/articles/115000935049-How-to-ensure-that-Opcache-is-enabled-)**
>
> Applicable to:
> 
> Plesk for Linux
> 
> 
> Question
> How to ensure that Opcache is enabled?
> Answer
> 
> 
> Check which PHP handler is used by the website at Domains \> example.com \> PHP Settings \> PHP supp...

Viele Grüße
