# Erreichbarkeit des Shops

**URL:** <https://forum.shopware.com/t/erreichbarkeit-des-shops/46146>\
**Category:** Installation/Einstieg\
**Created:** [4. Juni 2017 um 07:51 UTC](https://forum.shopware.com/t/erreichbarkeit-des-shops/46146 "2017-06-04T07:51:50Z")\
**Posts on this page:** 17\
**Page:** 1

<div class="post-metadata">

**Author:** ![fremd](https://avatars.discourse-cdn.com/v4/letter/f/bcef8e/32.png) [@fremd](https://forum.shopware.com/u/fremd)\
**Post date:** [4. Juni 2017 um 07:51 UTC](https://forum.shopware.com/t/erreichbarkeit-des-shops/46146/1 "2017-06-04T07:51:50Z")

</div>

Guten morgen

&nbsp;

ich habe soeben auf meinem Domainfactory Space Shopware erfolgreich installiert. Admin Backend proböemlos erreichbar. Startseite des Shops auch problemlos erreichbar jedoch saemlichte Unterseiten wie zb Impressum fuehren zum Internal Server Error. Wer ne Idee wo ich schrauben muss? Danke im Vorraus

Uli

---

<div class="post-metadata">

**Author:** ![NextMike](https://avatars.discourse-cdn.com/v4/letter/n/838e76/32.png) [@NextMike](https://forum.shopware.com/u/NextMike)\
**Post date:** [4. Juni 2017 um 08:18 UTC](https://forum.shopware.com/t/erreichbarkeit-des-shops/46146/2 "2017-06-04T08:18:44Z")

</div>

Ich würde hier anfangen:&nbsp;[http://community.shopware.com/config.php-Tweaks\_detail\_1801.html#Debug-Configuration](http://community.shopware.com/config.php-Tweaks_detail_1801.html#Debug-Configuration)

Auch Shopware und Betriebssystem Error-Logs kontrollieren.

---

<div class="post-metadata">

**Author:** ![fremd](https://avatars.discourse-cdn.com/v4/letter/f/bcef8e/32.png) [@fremd](https://forum.shopware.com/u/fremd)\
**Post date:** [4. Juni 2017 um 09:09 UTC](https://forum.shopware.com/t/erreichbarkeit-des-shops/46146/3 "2017-06-04T09:09:04Z")

</div>

sorry aber verstehe gerade null wie ich vorgehen muss

---

<div class="post-metadata">

**Author:** ![NextMike](https://avatars.discourse-cdn.com/v4/letter/n/838e76/32.png) [@NextMike](https://forum.shopware.com/u/NextMike)\
**Post date:** [4. Juni 2017 um 09:12 UTC](https://forum.shopware.com/t/erreichbarkeit-des-shops/46146/4 "2017-06-04T09:12:31Z")

</div>

> [@fremd schrieb:](https://forum.shopware.com/profile/23877/fremd "fremd")
> 
> sorry aber verstehe gerade null wie ich vorgehen muss

häng Dich rein und arbeite die Themen durch.&nbsp;

---

<div class="post-metadata">

**Author:** ![fremd](https://avatars.discourse-cdn.com/v4/letter/f/bcef8e/32.png) [@fremd](https://forum.shopware.com/u/fremd)\
**Post date:** [4. Juni 2017 um 09:36 UTC](https://forum.shopware.com/t/erreichbarkeit-des-shops/46146/5 "2017-06-04T09:36:49Z")

</div>

das Problem besteht leider weiterhin&nbsp;

&nbsp;

---

<div class="post-metadata">

**Author:** ![Misengo](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/misengo/32/21446_2.png) [@Misengo](https://forum.shopware.com/u/Misengo)\
**Post date:** [4. Juni 2017 um 09:42 UTC](https://forum.shopware.com/t/erreichbarkeit-des-shops/46146/6 "2017-06-04T09:42:12Z")

</div>

@fremd‍ wie NextMike schon geschrieben hat, füge zuerst in deiner config.php (_im Root Verzeichnis Deiner Shopware Installation - vermutlich musst du das in deinem FTP Programm machen, da du keinen Shell Zugriff hast_) folgenden Code ein:

&nbsp;

```
'front' => [
    'showException' => true,
    'throwExceptions' => true,
    'noErrorHandler' => false,
],
 
//Zeige Low-Level PHP-Fehler
'phpsettings' => [
    'display_errors' => 1,
],
 
// Template-Cache
'template' => [
    'forceCompile' => true,
],
 
// Backend-Cache
'cache' => [
    'backend' => 'Black-Hole',
    'backendOptions' => [],
    'frontendOptions' => [
        'write_control' => false
    ],
],
 
// Model-Cache
'model' => [
    'cacheProvider' => 'Array' // supports Apc, Array, Wincache and Xcache
],
 
// Http-Cache
'httpCache' => [
    'enabled' => true, // true or false
    'debug' => true,
]

```

&nbsp;

Danach siehst du die Errors welche&nbsp;dieses Verhalten auslösen. Ich vermute allerdings, dass es bei dir an einer fehlenden . **htaccess** Datei liegt. Prüfe mal ob vie FTP diese Datei im Rootverzeichniss liegt. Falls nicht kannst du diese [hier](https://github.com/shopware/shopware/blob/5.2/.htaccess)&nbsp;nochmal runterladen.

---

<div class="post-metadata">

**Author:** ![fremd](https://avatars.discourse-cdn.com/v4/letter/f/bcef8e/32.png) [@fremd](https://forum.shopware.com/u/fremd)\
**Post date:** [4. Juni 2017 um 10:01 UTC](https://forum.shopware.com/t/erreichbarkeit-des-shops/46146/7 "2017-06-04T10:01:35Z")

</div>

ich werde mein Glueck nochmals versuchen. Bis hierher erst mal vielen Dank.

---

<div class="post-metadata">

**Author:** ![fremd](https://avatars.discourse-cdn.com/v4/letter/f/bcef8e/32.png) [@fremd](https://forum.shopware.com/u/fremd)\
**Post date:** [4. Juni 2017 um 12:17 UTC](https://forum.shopware.com/t/erreichbarkeit-des-shops/46146/8 "2017-06-04T12:17:50Z")

</div>

das kriege ich beim Aufruf meines Shops wenn ich die Aenderungen an der config.php vornehme:

&nbsp;

```
Parse error: syntax error, unexpected '=>' (T_DOUBLE_ARROW) in /kunden/479065_88316/webseiten/allgaeu-wire.de/config.php on line 11

```

&nbsp;

---

<div class="post-metadata">

**Author:** ![NurIch](https://avatars.discourse-cdn.com/v4/letter/n/df705f/32.png) [@NurIch](https://forum.shopware.com/u/NurIch)\
**Post date:** [4. Juni 2017 um 13:22 UTC](https://forum.shopware.com/t/erreichbarkeit-des-shops/46146/9 "2017-06-04T13:22:07Z")

</div>

lade alles nochmal hoch und teste dann.

&nbsp;

---

<div class="post-metadata">

**Author:** ![pSypher](https://avatars.discourse-cdn.com/v4/letter/p/82dd89/32.png) [@pSypher](https://forum.shopware.com/u/pSypher)\
**Post date:** [4. Juni 2017 um 13:56 UTC](https://forum.shopware.com/t/erreichbarkeit-des-shops/46146/10 "2017-06-04T13:56:09Z")

</div>

Hier würde ich eine Agentur oder einen Freelancer empfehlen der dies für dich übernimmt, ein Online Shop ist eine komplexe Angelegenheit (Einrichtung, Sicherheit etc.) da sollte man schon Grundkenntnisse in diesen Bereichen haben. Richtest du deinen Online Shop falsch ein, so dass dort z.B Sicherheitslücken entstehen wird dass schnell teurer als wenn du jemanden dafür bezahlst der dies für dich übernimmt.

---

<div class="post-metadata">

**Author:** ![fremd](https://avatars.discourse-cdn.com/v4/letter/f/bcef8e/32.png) [@fremd](https://forum.shopware.com/u/fremd)\
**Post date:** [4. Juni 2017 um 14:01 UTC](https://forum.shopware.com/t/erreichbarkeit-des-shops/46146/11 "2017-06-04T14:01:35Z")

</div>

damit haette ich null Probeme. Hast du da evtl eine Empfehlung?

---

<div class="post-metadata">

**Author:** ![hth](https://avatars.discourse-cdn.com/v4/letter/h/b77776/32.png) [@hth](https://forum.shopware.com/u/hth)\
**Post date:** [4. Juni 2017 um 14:38 UTC](https://forum.shopware.com/t/erreichbarkeit-des-shops/46146/12 "2017-06-04T14:38:54Z")

</div>

> [@fremd schrieb:](https://forum.shopware.com/profile/23877/fremd "fremd")
> 
> das kriege ich beim Aufruf meines Shops wenn ich die Aenderungen an der config.php vornehme:
> 
> &nbsp;
> 
> Parse error: syntax error, unexpected ‚=\>‘ (T\_DOUBLE\_ARROW) in /kunden/479065\_88316/webseiten/allgaeu-wire.de/config.php on line 11
> 
> &nbsp;

Da hast Du einen Fehler in der config.php und wahrscheinlich&nbsp;die Debug-Konfiguration nicht sauber übertragen - evtl. auch die falsche PHP-Version. Das dürfte nicht mit deinem ursprünglichen Problem zusammenhängen, wenn nicht die PHP-Version die Ursache ist.&nbsp;

Eigentlich sollte Shopware ohne Probleme auf den df-Paketen laufen und nur eine Anpassung in der htaccess erfordern. Wir haben dies dort in der Vergangenheit schon öfters für Kunden installiert.

&nbsp;

---

<div class="post-metadata">

**Author:** ![Zocas](https://avatars.discourse-cdn.com/v4/letter/z/50afbb/32.png) [@Zocas](https://forum.shopware.com/u/Zocas)\
**Post date:** [4. Juni 2017 um 14:49 UTC](https://forum.shopware.com/t/erreichbarkeit-des-shops/46146/13 "2017-06-04T14:49:57Z")

</div>

Schau mal hier:&nbsp; [Shopware 5.1 auf domainFACTORY korrekt installieren](https://www.varia-creare.de/shopware-5-1-auf-domainfactory-df-eu-korrekt-installieren/)

---

<div class="post-metadata">

**Author:** ![TimmeHosting](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/timmehosting/32/15580_2.png) [@TimmeHosting](https://forum.shopware.com/u/TimmeHosting)\
**Post date:** [5. Juni 2017 um 21:53 UTC](https://forum.shopware.com/t/erreichbarkeit-des-shops/46146/14 "2017-06-05T21:53:32Z")

</div>

Bekommst Du Fehlermeldungen im Error-Log der Website bzw. im Shopware-Log?

![](https://europe1.discourse-cdn.com/flex013/uploads/shopware/original/1X/385eaa628505df573ebf33722f780335f53ac1b2.png)

Timme Hosting - schnelles nginx-Hosting

[www.timmehosting.de](https://timmehosting.de/)

---

<div class="post-metadata">

**Author:** ![fremd](https://avatars.discourse-cdn.com/v4/letter/f/bcef8e/32.png) [@fremd](https://forum.shopware.com/u/fremd)\
**Post date:** [8. Juni 2017 um 19:06 UTC](https://forum.shopware.com/t/erreichbarkeit-des-shops/46146/15 "2017-06-08T19:06:19Z")

</div>

leider keinen Hinweis.

---

<div class="post-metadata">

**Author:** ![NurIch](https://avatars.discourse-cdn.com/v4/letter/n/df705f/32.png) [@NurIch](https://forum.shopware.com/u/NurIch)\
**Post date:** [9. Juni 2017 um 19:36 UTC](https://forum.shopware.com/t/erreichbarkeit-des-shops/46146/16 "2017-06-09T19:36:19Z")

</div>

scheint doch jetzt zu laufen 🙂

---

<div class="post-metadata">

**Author:** ![AndreHerking](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/andreherking/32/7839_2.png) [@AndreHerking](https://forum.shopware.com/u/AndreHerking)\
**Post date:** [12. Juni 2017 um 13:19 UTC](https://forum.shopware.com/t/erreichbarkeit-des-shops/46146/17 "2017-06-12T13:19:43Z")

</div>

Den internen Serverfehler wirst du nur im Serverlog finden, da Shopware keine 500-Fehler protokollieren kann. Was sagt dein Hoster zu der Angelegenheit?
