# Docker 503 Error

**URL:** <https://forum.shopware.com/t/docker-503-error/59760>\
**Category:** Installation / Getting Started (EN)\
**Created:** [28. Mai 2019 um 12:32 UTC](https://forum.shopware.com/t/docker-503-error/59760 "2019-05-28T12:32:48Z")\
**Posts on this page:** 9\
**Page:** 1

<div class="post-metadata">

**Author:** ![Rearden](https://avatars.discourse-cdn.com/v4/letter/r/b19c9b/32.png) [@Rearden](https://forum.shopware.com/u/Rearden)\
**Post date:** [28. Mai 2019 um 12:32 UTC](https://forum.shopware.com/t/docker-503-error/59760/1 "2019-05-28T12:32:48Z")

</div>

Hello,

I’m trying to get up and running using docker. I can get through the installation, but when I go to localhost:8000, I get a 503 error. Any ideas?

Thanks

---

<div class="post-metadata">

**Author:** ![Rearden](https://avatars.discourse-cdn.com/v4/letter/r/b19c9b/32.png) [@Rearden](https://forum.shopware.com/u/Rearden)\
**Post date:** [28. Mai 2019 um 13:25 UTC](https://forum.shopware.com/t/docker-503-error/59760/2 "2019-05-28T13:25:24Z")

</div>

It only returns the error when I try to access php files. For example,&nbsp;localhost:8000/favicon.ico works. If I create an html file at localhost:8000/test.html that also works. But any php files I create return the 503 error.

This shows up in the logs whenever I try to access a PHP file:

[Tue May 28 13:24:02.426930 2019] [proxy:error] [pid 10330:tid 139800397223680] (111)Connection refused: AH00957: FCGI: attempt to connect to 127.0.0.1:9000 (127.0.0.1) failed  
[Tue May 28 13:24:02.426967 2019] [proxy\_fcgi:error] [pid 10330:tid 139800397223680] [client 172.18.0.1:52424] AH01079: failed to make connection to backend: 127.0.0.1  
&nbsp;

---

<div class="post-metadata">

**Author:** ![Rearden](https://avatars.discourse-cdn.com/v4/letter/r/b19c9b/32.png) [@Rearden](https://forum.shopware.com/u/Rearden)\
**Post date:** [28. Mai 2019 um 13:49 UTC](https://forum.shopware.com/t/docker-503-error/59760/3 "2019-05-28T13:49:19Z")

</div>

I also get this error every second:

[28-May-2019 13:48:30] ERROR: [pool www] please specify user and group other than root  
[28-May-2019 13:48:30] ERROR: [pool www] please specify user and group other than root  
[28-May-2019 13:48:30] ERROR: FPM initialization failed  
[28-May-2019 13:48:30] ERROR: FPM initialization failed  
&nbsp;

---

<div class="post-metadata">

**Author:** ![Misengo](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/misengo/32/21446_2.png) [@Misengo](https://forum.shopware.com/u/Misengo)\
**Post date:** [2. Juni 2019 um 11:41 UTC](https://forum.shopware.com/t/docker-503-error/59760/4 "2019-06-02T11:41:35Z")

</div>

Sounds like a typical permission / execute error. What OS are you using? Are you following the exact instructions here -\>&nbsp;[https://docs.shopware.com/en/shopware-platform-dev-en/getting-started/installation-guide](https://docs.shopware.com/en/shopware-platform-dev-en/getting-started/installation-guide) ?

&nbsp;

&nbsp;

---

<div class="post-metadata">

**Author:** ![Shopwareianer](https://avatars.discourse-cdn.com/v4/letter/s/b4bc9f/32.png) [@Shopwareianer](https://forum.shopware.com/u/Shopwareianer)\
**Post date:** [2. Juni 2019 um 12:04 UTC](https://forum.shopware.com/t/docker-503-error/59760/5 "2019-06-02T12:04:47Z")

</div>

I am having the same issue,&nbsp;i have to say i am using Docker for the first time.

In my case, i executed all commands with my non-root sudo user. But&nbsp;i am getting a 503 server error. I am running it on a remote Ubuntu 16 server.

I installed docker on my machine like described here:&nbsp;[https://www.digitalocean.com/community/tutorials/how-to-install-and-use-docker-on-ubuntu-16-04](https://www.digitalocean.com/community/tutorials/how-to-install-and-use-docker-on-ubuntu-16-04)

---

<div class="post-metadata">

**Author:** ![shyim](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/shyim/32/7681_2.png) [@shyim](https://forum.shopware.com/u/shyim)\
**Post date:** [2. Juni 2019 um 12:09 UTC](https://forum.shopware.com/t/docker-503-error/59760/6 "2019-06-02T12:09:02Z")

</div>

Just create a user and don’t use root!.&nbsp;

---

<div class="post-metadata">

**Author:** ![Shopwareianer](https://avatars.discourse-cdn.com/v4/letter/s/b4bc9f/32.png) [@Shopwareianer](https://forum.shopware.com/u/Shopwareianer)\
**Post date:** [2. Juni 2019 um 13:48 UTC](https://forum.shopware.com/t/docker-503-error/59760/7 "2019-06-02T13:48:54Z")

</div>

> [@Shyim schrieb:](https://forum.shopware.com/profile/20792/Shyim "Shyim")
> 
> Just create a user and don’t use root!.&nbsp;

If i just create a user without adding this user to the sudoers group i am getting the following error:&nbsp;

> Building app\_mysql  
> Couldn’t connect to Docker daemon at http+docker://localunixsocket - is it running?

So i have to use&nbsp;sudo ./psh.phar docker:start. Or did i a mistake within the default Docker installation?

&nbsp;

---

<div class="post-metadata">

**Author:** ![Shopwareianer](https://avatars.discourse-cdn.com/v4/letter/s/b4bc9f/32.png) [@Shopwareianer](https://forum.shopware.com/u/Shopwareianer)\
**Post date:** [2. Juni 2019 um 13:58 UTC](https://forum.shopware.com/t/docker-503-error/59760/8 "2019-06-02T13:58:41Z")

</div>

Okay, i solved it: I killed all containers ( docker kill $(docker ps -q) ), then I had to add the user to the docker group:&nbsp; **sudo usermod -aG docker user**

And then&nbsp; **sudo service docker start && docker-compose up -d**

After this i re-run all docker commands like **&nbsp;**./psh.phar docker:start …&nbsp;

Now it’s working.

---

<div class="post-metadata">

**Author:** ![Rearden](https://avatars.discourse-cdn.com/v4/letter/r/b19c9b/32.png) [@Rearden](https://forum.shopware.com/u/Rearden)\
**Post date:** [12. Juni 2019 um 15:44 UTC](https://forum.shopware.com/t/docker-503-error/59760/9 "2019-06-12T15:44:09Z")

</div>

> [@Misengo schrieb:](https://forum.shopware.com/profile/22532/Misengo "Misengo")
> 
> Sounds like a typical permission / execute error. What OS are you using? Are you following the exact instructions here -\>&nbsp;[https://docs.shopware.com/en/shopware-platform-dev-en/getting-started/installation-guide](https://docs.shopware.com/en/shopware-platform-dev-en/getting-started/installation-guide) ?

Yes, I followed those&nbsp;instructions but at the time they didn’t make it clear that I was supposed to run the install command inside the container…probably obvious&nbsp;to someone with experience using docker but this was my first time using it. I see now that the page has been updated to make this clear 🙂

I also added my user to the docker group so I didn’t have to use sudo. Everything seems to be working flawlessly now!
