# Deutsche Post Adapter unter Shopware 5.3 lässt sich nicht installieren

**URL:** <https://forum.shopware.com/t/deutsche-post-adapter-unter-shopware-5-3-lasst-sich-nicht-installieren/49293>\
**Category:** Plugins\
**Tags:** drittanbieter-plugin\
**Created:** [6. November 2017 um 16:18 UTC](https://forum.shopware.com/t/deutsche-post-adapter-unter-shopware-5-3-lasst-sich-nicht-installieren/49293 "2017-11-06T16:18:17Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![neonquelle](https://avatars.discourse-cdn.com/v4/letter/n/cdc98d/32.png) [@neonquelle](https://forum.shopware.com/u/neonquelle)\
**Post date:** [6. November 2017 um 16:18 UTC](https://forum.shopware.com/t/deutsche-post-adapter-unter-shopware-5-3-lasst-sich-nicht-installieren/49293/1 "2017-11-06T16:18:17Z")

</div>

Hi,&nbsp;

ich probiere gerade den Deutsche Post Adapter zu installieren, allerdings quttiert das error log dies mit folgender Meldung:

2017/11/06 17:04:14 [error] 13778#0: \*1771 FastCGI sent in stderr: “PHP message: PHP Fatal error:&nbsp; Uncaught Error: Call to a member function getId() on null in /engine/Shopware/Components/Snippet/DatabaseHandler.php:138  
Stack trace:  
#0 /engine/Shopware/Plugins/Community/Backend/ViisonDHL/ViisonCommon/PluginBootstrap.php(73): Shopware\Components\Snippet\DatabaseHandler-\>loadToDatabase(’/xxx…’)  
#1 /engine/Shopware/Plugins/Community/Backend/ViisonDHL/ViisonCommon/PluginBootstrap.php(57): ViisonCommon\_Plugin\_Bootstrap-\>importViisonCommonSnippetsIntoDb()  
#2 /engine/Shopware/Plugins/Community/Backend/ViisonDHL/Bootstrap.php(128): ViisonCommon\_Plugin\_Bootstrap-\>update(‘install’)  
#3 /engine/Shopware/Plugins/Community/Backend/ViisonDHL/Bootstrap.php(107): Shopware\_Plugins\_Backend\_ViisonDHL\_Bootstrap-\>update(‘install’)  
#4 /engine/Shopware/Components/Plugin/Namespace.php(255): Shopware\_Plugins” while reading response header from upstream, client: 79.205.100.106, server: [delivery.nginx.xxx.net](http://delivery.nginx.xxx.net), request: “POST /backend/PluginInstaller/installPlugin HTTP/1.1”, upstream: “fastcgi://127.0.0.1:9000”, host: “xxx”, referrer: “[https://xxx](https://xxx)”

Ich habe daraufhin alte Versionen ausprobiert und bis zur 1.0.6 lässt es sich problemlos installieren.&nbsp;

Eingesetzte Shopware Version 5.3.4 zusätzlich getestet auf 5.3.3&nbsp;

Testweise habe ich den DHL Adapter ausprobiert, auch dieser lässt sich nicht installieren bei gleicher Fehlermeldung.

Jemand eine Idee?&nbsp;

---

<div class="post-metadata">

**Author:** ![neonquelle](https://avatars.discourse-cdn.com/v4/letter/n/cdc98d/32.png) [@neonquelle](https://forum.shopware.com/u/neonquelle)\
**Post date:** [23. November 2017 um 08:51 UTC](https://forum.shopware.com/t/deutsche-post-adapter-unter-shopware-5-3-lasst-sich-nicht-installieren/49293/2 "2017-11-23T08:51:28Z")

</div>

Die Lösung ist gefunden. Es lag daran, dass wir zu sehr aufgeräumt haben 🙂

Wir hatten alle Sprachen bis auf Deutsch und Englisch aus der s\_core\_locales entfernt, hier wird aber wohl auf mehr zugegriffen. Nach einspielen des Backups dieser Tabelle verlief die Installation einwandfrei.&nbsp;

&nbsp;
