# Datenbankmigration (Update) 5.5.10 zu 5.6.2  ... bitte um eine gute Idee :-)

**URL:** https://forum.shopware.com/t/datenbankmigration-update-5-5-10-zu-5-6-2-bitte-um-eine-gute-idee/62351
**Category:** Administration
**Created:** [14. Oktober 2019 um 09:34 UTC](https://forum.shopware.com/t/datenbankmigration-update-5-5-10-zu-5-6-2-bitte-um-eine-gute-idee/62351 "2019-10-14T09:34:29Z")
**Posts on this page:** 7
**Page:** 1

<div class="post-metadata">

### Author: ![bauerpower](https://avatars.discourse-cdn.com/v4/letter/b/ba9def/32.png) [@bauerpower](https://forum.shopware.com/u/bauerpower)
#### Post date: [14. Oktober 2019 um 09:34 UTC](https://forum.shopware.com/t/datenbankmigration-update-5-5-10-zu-5-6-2-bitte-um-eine-gute-idee/62351/1 "2019-10-14T09:34:29Z")

</div>

so langsam verzweifle ich ☹

Ich habe eine Odyssee hinter mir… mit Ubuntu Updates und verschiedenen MSSQL Migrationen. Auch haben mich nicht kompatible Plugins so ein um das  
andere Mal ein Backup einspielen lassen…. Aber ich höre schon auf zu jammern ….

Durch die abgebrochenen Migrationen auf 5.6.2 habe ich wohl eine Inkonsistenz der Datenbank, d.h. eine&nbsp; **Mischung aus 5.5.1 und 5.6.2** ……

Das wäre alles nicht so schlimm …da ich ja gerne beim Migrationsassistenten die Tabellen vorher löschen kann (über phpmyadmin).&nbsp;  
Leider treten aber jetzt Fehlermeldungen auf die ich nicht mehr fixen kann&nbsp;L&nbsp;wie z.B. diese:  
&nbsp;

\*//  
Error&nbsp;Received the following error message:  
Could not apply migration (Migrations\_Migration1623). Error: SQLSTATE[42S21]: Column already exists: 1060 Duplicate column name ‘content\_type’  
Please try to fix this error and restart the update.  
**Response**  
{“valid”:false,“errorMsg”:"Could not apply migration (Migrations\_Migration1623). Error: SQLSTATE[42S21]: Column already exists: 1060 Duplicate column name ‘content\_type’ "}  
\*//

Ich bin mir bewusst was diese Fehlermeldung aussagt aber und mein Versuch diesen „Column“ zu löschen wurde prompt mit der nächsten Fehlermeldung beantwortet….  
**To make a long storry short: Gibt es eine Möglichkeit die durch den Migrationsassistenten (5.6.2) bearbeiteten Tabellen, Views …etc. zu reinitialisieren --\> auf 5.5.10?**

Vielen Dank für Eure Unterstützung

LG

&nbsp;

Jörg

PS: Hier noch die Systemkonfiguration:  
System: 5.5.10  
PHP: 7.2.19  
Ubuntu: 18.04.2  
Datenbank: Server-Version: 10.1.41-MariaDB

---

<div class="post-metadata">

### Author: ![R4M](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/r4m/32/9983_2.png) [@R4M](https://forum.shopware.com/u/R4M)
#### Post date: [14. Oktober 2019 um 09:47 UTC](https://forum.shopware.com/t/datenbankmigration-update-5-5-10-zu-5-6-2-bitte-um-eine-gute-idee/62351/2 "2019-10-14T09:47:26Z")

</div>

Also bei einer kaputten Datenbank ist es wohl eher ratsam erst einmal wieder ein Backup einzuspielen (sollte ja vorher gemacht worden sein).

Was in der Migration passiert kann man sich ja anschauen:

```
class Migrations_Migration1623 extends Shopware\Components\Migrations\AbstractMigration
{
    public function up($modus)
    {
        $this->addSql('ALTER TABLE `s_core_menu`
ADD `content_type` varchar(255) COLLATE \'utf8_unicode_ci\' NULL;
');

        $this->addSql('INSERT INTO `s_core_menu` (`parent`, `name`, `onclick`, `class`, `position`, `active`, `pluginID`, `controller`, `shortcut`, `action`, `content_type`)
VALUES (\'23\', \'Inhaltstypen\', NULL, \'sprite-application-form\', \'0\', \'1\', NULL, \'ContentTypeManager\', NULL, \'index\', NULL);');

        $this->addSql('CREATE TABLE `s_content_types` (
  `id` int NOT NULL AUTO_INCREMENT PRIMARY KEY,
  `internalName` varchar(100) NOT NULL,
  `name` varchar(100) NOT NULL,
  `source` varchar(100) DEFAULT NULL,
  `config` text NOT NULL
);');

        $this->addSql("INSERT IGNORE INTO `s_core_acl_resources` (name) VALUES ('contenttypemanager');");

        $this->addSql('SET @resourceId = LAST_INSERT_ID();');

        $this->addSql("INSERT IGNORE INTO `s_core_acl_privileges` (resourceID,name) VALUES (@resourceId, 'read');");
        $this->addSql("INSERT IGNORE INTO `s_core_acl_privileges` (resourceID,name) VALUES (@resourceId, 'edit');");
        $this->addSql("INSERT IGNORE INTO `s_core_acl_privileges` (resourceID,name) VALUES (@resourceId, 'delete');");
    }
}

```

Entsprechend könnte man es nachstellen.

&nbsp;

---

<div class="post-metadata">

### Author: ![bauerpower](https://avatars.discourse-cdn.com/v4/letter/b/ba9def/32.png) [@bauerpower](https://forum.shopware.com/u/bauerpower)
#### Post date: [14. Oktober 2019 um 09:55 UTC](https://forum.shopware.com/t/datenbankmigration-update-5-5-10-zu-5-6-2-bitte-um-eine-gute-idee/62351/3 "2019-10-14T09:55:45Z")

</div>

Hallo H4M,

danke für Deine schnelle Antwort. Bei den ersten 10 Fehlermeldungen habe ich mich auch über die Migrationsscripts durchgehangelt aber leider nimmt das&nbsp;  
wohl kein Ende … und ehrlicherweise bin ich dann wirklich etwas überfordert ☹ &nbsp;

Der Shop läuft rund … ich kann halt keine Updates mehr machen… &nbsp;daher dachte ich ggf. an eine leere 5.5.10 DB-Struktur

Nur mal so ein Gedanke…

LG

&nbsp;

Jörg&nbsp;

---

<div class="post-metadata">

### Author: ![R4M](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/r4m/32/9983_2.png) [@R4M](https://forum.shopware.com/u/R4M)
#### Post date: [14. Oktober 2019 um 10:16 UTC](https://forum.shopware.com/t/datenbankmigration-update-5-5-10-zu-5-6-2-bitte-um-eine-gute-idee/62351/4 "2019-10-14T10:16:34Z")

</div>

Wenn der Anschein besteht, dass die Datenbank derart versaut ist, dann wäre ggf. eine originale 5.5.10 Version angebracht - sofern noch nicht 1000000 Artikel schon eingepflegt.

---

<div class="post-metadata">

### Author: ![bauerpower](https://avatars.discourse-cdn.com/v4/letter/b/ba9def/32.png) [@bauerpower](https://forum.shopware.com/u/bauerpower)
#### Post date: [14. Oktober 2019 um 14:14 UTC](https://forum.shopware.com/t/datenbankmigration-update-5-5-10-zu-5-6-2-bitte-um-eine-gute-idee/62351/5 "2019-10-14T14:14:53Z")

</div>

… na 1 Milionen Artikel sind es noch nicht ganz… und der Gedanke einfach eine DB Version 5.5.10 (Struktur) zu nehmen kam mir auch schon…

Aber ich muss ja dann meine Daten in diese Umgebung transportieren und da habe ich die Sorge,&nbsp;dass mir das SQL stürzt da ggf. Tabellenerweiterungen mit Datensätzen vorhanden sind… und ich wüsste nicht wie ich das abfangen kann… ☹

oder können Fehler beim Import&nbsp;ignoriert werden?  
&nbsp;

Hoffe Du kannst meinen wirren Gedanken folgen…

Viele Grüsse&nbsp;

&nbsp;

Jörg

---

<div class="post-metadata">

### Author: ![R4M](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/r4m/32/9983_2.png) [@R4M](https://forum.shopware.com/u/R4M)
#### Post date: [15. Oktober 2019 um 06:54 UTC](https://forum.shopware.com/t/datenbankmigration-update-5-5-10-zu-5-6-2-bitte-um-eine-gute-idee/62351/6 "2019-10-15T06:54:26Z")

</div>

Ich kann das Ausmaß nur schwierig abschätzen, aber es wundert mich schon wie eine Datenbank so schlimm kaputt sein könnte. Vor einem Update macht man üblicherweise ein Backup und prüft die Plugins. Ansonsten muss man sich die Mühe machen und Tabelle zu Tabelle mit der aktuellen SW Version vergleichen und ggf. anpassen. So ein Spaß hatte ich kürzlich auch. Dauert zwar ein wenig, aber so gehen keine Daten verloren und Stück für Stück kann man den Shop wieder herrichten.

---

<div class="post-metadata">

### Author: ![bauerpower](https://avatars.discourse-cdn.com/v4/letter/b/ba9def/32.png) [@bauerpower](https://forum.shopware.com/u/bauerpower)
#### Post date: [19. Oktober 2019 um 16:49 UTC](https://forum.shopware.com/t/datenbankmigration-update-5-5-10-zu-5-6-2-bitte-um-eine-gute-idee/62351/7 "2019-10-19T16:49:39Z")

</div>

Hallo&nbsp;R4M,

habe das Problem mit recht viel Aufwand gelöst! Hoffe ich konnte dem Kollegen der ein ähnliches Problem hat  
zumindest etwas Hilfestellung geben.  
[https://forum.shopware.com/discussion/comment/257370/#Comment\_257370](https://forum.shopware.com/discussion/comment/257370/#Comment_257370)

Dir vielen Dank für Deinen super Support! “DANKE”

Liebe Grüsse

Jörg&nbsp;
