# Datenbank Migration bei Update auf 6.4.3.0

**URL:** <https://forum.shopware.com/t/datenbank-migration-bei-update-auf-6-4-3-0/89591>\
**Category:** Administration\
**Created:** [5. August 2021 um 10:06 UTC](https://forum.shopware.com/t/datenbank-migration-bei-update-auf-6-4-3-0/89591 "2021-08-05T10:06:49Z")\
**Posts on this page:** 9\
**Page:** 1

<div class="post-metadata">

**Author:** ![Olli-aus-Essen](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/olli-aus-essen/32/14451_2.png) [@Olli-aus-Essen](https://forum.shopware.com/u/Olli-aus-Essen)\
**Post date:** [5. August 2021 um 10:06 UTC](https://forum.shopware.com/t/datenbank-migration-bei-update-auf-6-4-3-0/89591/1 "2021-08-05T10:06:49Z")

</div>

Moin zusammen,

kann jemand in dem Zusammenhang mit dem folgenden Fehler bei einem Update auf 6.4.3.0 helfen?

Danke und viele Grüße,  
Oliver

## Error

Received the following error message:  
An exception occurred while executing ‚ALTER TABLE `order` DROP FOREIGN KEY `fk.order.created_by_id`‘: SQLSTATE[42000]: Syntax error or access violation: 1091 Can’t DROP FOREIGN KEY `fk.order.created_by_id`; check that it exists

Please try to fix this error and restart the update.

### Response

{„valid“:false,„errorMsg“:„An exception occurred while executing ‚ALTER TABLE `order` DROP FOREIGN KEY `fk.order.created_by_id`‘:\n\nSQLSTATE[42000]: Syntax error or access violation: 1091 Can’t DROP FOREIGN KEY `fk.order.created_by_id`; check that it exists“}

---

<div class="post-metadata">

**Author:** ![x8mm](https://avatars.discourse-cdn.com/v4/letter/x/0ea827/32.png) [@x8mm](https://forum.shopware.com/u/x8mm)\
**Post date:** [16. September 2021 um 07:24 UTC](https://forum.shopware.com/t/datenbank-migration-bei-update-auf-6-4-3-0/89591/2 "2021-09-16T07:24:13Z")

</div>

Moin moin,  
ich sehe ich bin nicht allein, habe gerade das selbe Szenario vor mir.  
Mein Update sollrte mich von v6.4.2.1 auf v6.4.4.1 bringen, leider mit selbem Fehler.

Auch hier ist schon ein Beitrag dazu, leider auch noch offen.

> [@Fehler beim Update: fk.order.created\_by\_id](https://forum.shopware.com/t/fehler-beim-update-fk-order-created-by-id/89661):
>
> Beim Versuch, auf 6.4.3.0 zu Updated, erhalte ich einen Fehler: Error Received the following error message: An exception occurred while executing 'ALTER TABLE `order` DROP FOREIGN KEY `fk.order.created_by_id`': SQLSTATE[42000]: Syntax error or access violation: 1091 Can't DROP FOREIGN KEY `fk.order.created_by_id`; check that it exists Please try to fix this error and restart the update. Response {"valid":false,"errorMsg":"An exception occurred while executing 'ALTER TABLE `order` DROP FOREIGN…

Hat sich zu dem Thema schon etwas herausfinden lassen?

Gruß J.

---

<div class="post-metadata">

**Author:** ![Olli-aus-Essen](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/olli-aus-essen/32/14451_2.png) [@Olli-aus-Essen](https://forum.shopware.com/u/Olli-aus-Essen)\
**Post date:** [16. September 2021 um 18:37 UTC](https://forum.shopware.com/t/datenbank-migration-bei-update-auf-6-4-3-0/89591/3 "2021-09-16T18:37:50Z")

</div>

Hey J.,

leider kein Feedback zu dem Problem. Wir haben alles in einer Nachtaktion neu aufgesetzt. Das war einfacher als ursprünglich gedacht; wir standen aber auch ganz am Anfang eines Projekts.

Habe mittlerweile großen Respekt vor den Updates.

Gruß,  
Oliver

---

<div class="post-metadata">

**Author:** ![benjamin.hedrich](https://avatars.discourse-cdn.com/v4/letter/b/e56c9b/32.png) [@benjamin.hedrich](https://forum.shopware.com/u/benjamin.hedrich)\
**Post date:** [17. September 2021 um 07:14 UTC](https://forum.shopware.com/t/datenbank-migration-bei-update-auf-6-4-3-0/89591/4 "2021-09-17T07:14:05Z")

</div>

Den Fehler da hatte ich auch mal und habe den gelöst in dem ich in der Migrationsdatei irgendwo das SQL Statement rausgenommen habe wo an dem Fremdschlüssel rumgefrickelt wird.

Man kann praktisch keine Updates mehr machen ohne diese vorher mal gestetest zu haben. (Live System Backuppen → Stage System deployen → Update testen → wenn OK auf dem Live System)

Ich entwickle Software seit vielen Jahren (nicht PHP), mir ist es bis heute nicht gelungen ein SW Update in 1h durchzuführen und ohne irgendwelche manuellen Eingriffe vornehmen zu müssen. Seien es nicht-gebaute JS/CSS bundels oder Fixes für Migrationen. Es ist für Laien praktisch unmöglich SW Updates durchzuführen. Wenn das Update mal im Wartungsmodus hängen bleibt, hat ein Laie keine Möglichkeit irgendwas sinnvolles zu tun außer sich Hilfe zu holen.

---

<div class="post-metadata">

**Author:** ![x8mm](https://avatars.discourse-cdn.com/v4/letter/x/0ea827/32.png) [@x8mm](https://forum.shopware.com/u/x8mm)\
**Post date:** [17. September 2021 um 09:28 UTC](https://forum.shopware.com/t/datenbank-migration-bei-update-auf-6-4-3-0/89591/5 "2021-09-17T09:28:43Z")

</div>

Hi Olli,  
Respekt ist immer gut 😊  
… den sollte man einer kostenlos bereitgestellten Open Source Software immer entgegenbringen, denn da läuft nie alles glatt.  
BG Jan

---

<div class="post-metadata">

**Author:** ![x8mm](https://avatars.discourse-cdn.com/v4/letter/x/0ea827/32.png) [@x8mm](https://forum.shopware.com/u/x8mm)\
**Post date:** [17. September 2021 um 09:39 UTC](https://forum.shopware.com/t/datenbank-migration-bei-update-auf-6-4-3-0/89591/6 "2021-09-17T09:39:10Z")

</div>

> [@benjamin.hedrich](#):
>
> (Live System Backuppen → Stage System deployen → Update testen → wenn OK auf dem Live System)

Schön dass du es erwähnst, genauso ists richtig und sollte beherzigt werden.  
Ich selber habe auf meinen Systemen zudem eine praktische Backup Funktion die mir per Knopfdruck eine DB und/oder ein Filesystem Backup erzeugt. So ist ein einfaches Rollback unkompliziert innerhalb von wenigen Minuten immer möglich. Kann das nur jedem ans Herzlegen, denn es spart im Fall des Fehles immens Zeit

> [@benjamin.hedrich](#):
>
> Den Fehler da hatte ich auch mal und habe den gelöst in dem ich in der Migrationsdatei irgendwo das SQL Statement rausgenommen habe wo an dem Fremdschlüssel rumgefrickelt wird.

…dem Ansatz hier werd ich mal nachgehen, vielleicht bringt er mich auch ans Ziel, Danke Dir

---

<div class="post-metadata">

**Author:** ![benjamin.hedrich](https://avatars.discourse-cdn.com/v4/letter/b/e56c9b/32.png) [@benjamin.hedrich](https://forum.shopware.com/u/benjamin.hedrich)\
**Post date:** [17. September 2021 um 11:24 UTC](https://forum.shopware.com/t/datenbank-migration-bei-update-auf-6-4-3-0/89591/7 "2021-09-17T11:24:06Z")

</div>

![Screenshot_20210917_132326](https://europe1.discourse-cdn.com/flex013/uploads/shopware/original/2X/b/bacf5e744a1317cc0b4b3da5508199b0e2164daf.png)  
Glaube da irgendwie. Kann mich nicht mehr richtig dran erinnern. Viel Glück!

---

<div class="post-metadata">

**Author:** ![x8mm](https://avatars.discourse-cdn.com/v4/letter/x/0ea827/32.png) [@x8mm](https://forum.shopware.com/u/x8mm)\
**Post date:** [5. Januar 2022 um 18:06 UTC](https://forum.shopware.com/t/datenbank-migration-bei-update-auf-6-4-3-0/89591/8 "2022-01-05T18:06:58Z")

</div>

Hallo zusammen,

falls über das Them noch einmal jemand stolpert hier die Lösung die ich nach Hinweis von Benjamin fand.

Comment Line # 17-23 in the following file:

```auto
/web/vendor/shopware/core/Migration/V6_4/Migration1625819412ChangeOrderCreatedByIdConstraint.ph

```

and line 17 and 18 in this file:

```auto
/web/vendor/shopware/core/Migration/V6_4/Migration1630074081AddDeleteCascadeToImportExportLogTable.php

```

Ursache des ganzen war das ich einen unbekannten abgebrochenen Update Versuch zuvor im System hatte und dadurch die Tabellen bereits neu waren. Mit dem dann Folgenden Updateversuch lief das System dann immer in den obigen Fehler.

Vielleicht hilf es ja noch einmal jemandem weiter.

---

<div class="post-metadata">

**Author:** ![cmichael](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/cmichael/32/17810_2.png) [@cmichael](https://forum.shopware.com/u/cmichael)\
**Post date:** [4. Mai 2023 um 09:56 UTC](https://forum.shopware.com/t/datenbank-migration-bei-update-auf-6-4-3-0/89591/9 "2023-05-04T09:56:02Z")

</div>

Hatte nahezu selbiges Problem und dieser Thread hier half mir bei der Lösung:

Migration von 6.3.4.1 auf 6.4.20.1

Ausführen von vendor/shopware/recovery/Update/index.php brach ab mit Can’t DROP FOREIGN KEY `fk.order_tag.tag_id`

Manuell per phpmadmin den fk.order\_tag.tag\_id gelöscht.

Unter ./vendor/shopware/core/Migration/V6\_4/Migration1642517958AddCascadeDeleteToTagRelations.php die Zeile #24 auskommentiert:

#$connection-\>executeStatement(‚ALTER TABLE `order_tag` DROP FOREIGN KEY `fk.order_tag.tag_id`;‘);

Übrigens habe ich festgestellt, dass das Statement auch nicht in phpmyadmin läuft und mit dem selben Fehler wir das recovery script abbricht. Benenne ich allerdings das Feld mal aus dumdiedeldei-so-blöd-kannst-du-net-denken um in fk\_order\_tag\_tag\_id (also Underscores statt Dots ) dann funktioniert das Statement in phpmyadmin. Vielleicht sollte man grundsätzlich keine Punkte in Schlüsselnamen verwenden?
