# Datenbank Fehler während Update. Benötige dringende Hilfe!

**URL:** <https://forum.shopware.com/t/datenbank-fehler-wahrend-update-benotige-dringende-hilfe/55247>\
**Category:** Programmierung\
**Created:** [19. September 2018 um 09:25 UTC](https://forum.shopware.com/t/datenbank-fehler-wahrend-update-benotige-dringende-hilfe/55247 "2018-09-19T09:25:13Z")\
**Posts on this page:** 7\
**Page:** 1

<div class="post-metadata">

**Author:** ![Test0r](https://avatars.discourse-cdn.com/v4/letter/t/82dd89/32.png) [@Test0r](https://forum.shopware.com/u/Test0r)\
**Post date:** [19. September 2018 um 09:25 UTC](https://forum.shopware.com/t/datenbank-fehler-wahrend-update-benotige-dringende-hilfe/55247/1 "2018-09-19T09:25:13Z")

</div>

Hallo zusammen,

ich möchte von 5.2.21 auf 5.4.6 updaten, allerdings erhalte ich während des Updates bei der Datenbank Migration folgenden Fehler:&nbsp;

{„valid“:false,„errorMsg“:"Could not apply migration (Migrations\_Migration1223). Error: SQLSTATE[23000]: Integrity constraint violation: 1062 Duplicate entry ‚1275-2‘ for key ‚element\_id‘ "}

Was muss ich machen?

Ich freue mich über jede Unterstützung.&nbsp;

&nbsp;

---

<div class="post-metadata">

**Author:** ![hsoebbing](https://avatars.discourse-cdn.com/v4/letter/h/898d66/32.png) [@hsoebbing](https://forum.shopware.com/u/hsoebbing)\
**Post date:** [19. September 2018 um 09:27 UTC](https://forum.shopware.com/t/datenbank-fehler-wahrend-update-benotige-dringende-hilfe/55247/2 "2018-09-19T09:27:05Z")

</div>

Schau mal in die Tabelle `s_core_config_elements` und schreibe mal wie die Zeile mit der ID 1275 aussieht. Eventuell müsstest Du diese löschen oder die Migration überspringen.

---

<div class="post-metadata">

**Author:** ![Test0r](https://avatars.discourse-cdn.com/v4/letter/t/82dd89/32.png) [@Test0r](https://forum.shopware.com/u/Test0r)\
**Post date:** [19. September 2018 um 10:56 UTC](https://forum.shopware.com/t/datenbank-fehler-wahrend-update-benotige-dringende-hilfe/55247/3 "2018-09-19T10:56:02Z")

</div>

Danke für die prompte Antwort. Das Problem in der Zeile mit der ID 1275 konnte ich beheben.&nbsp;

Update erneut gestartet, nun neuer Datenbank-Fehler während Update:&nbsp;

```
 {"valid":false,"errorMsg":"Could not apply migration (Migrations\_Migration907). Error: SQLSTATE[42S01]: Base table or view already exists: 1050 Table 's\_order\_basket\_signatures' already exists "}

```

&nbsp;

---

<div class="post-metadata">

**Author:** ![hsoebbing](https://avatars.discourse-cdn.com/v4/letter/h/898d66/32.png) [@hsoebbing](https://forum.shopware.com/u/hsoebbing)\
**Post date:** [19. September 2018 um 11:17 UTC](https://forum.shopware.com/t/datenbank-fehler-wahrend-update-benotige-dringende-hilfe/55247/4 "2018-09-19T11:17:36Z")

</div>

Deine DB hat nun einen inkonsistenten Stand, ich nehme an Du hast ein Backup eingespielt und das Update nochmal gemacht? In dem Fall sind vermutlich die Tabellen teilweise schon vorhanden.&nbsp;

In diesem konkreten Fall kannst Du in der Tabelle `s_schema_version` einen neuen Eintrag mit ID 907 machen (in dieser Tabelle werden die durchgeführten Migrationen gespeichert). Dadurch wird die Migration mit dieser Nummer als „Bereits durchgeführt“ markiert und er versucht es noch nochmal.

---

<div class="post-metadata">

**Author:** ![Test0r](https://avatars.discourse-cdn.com/v4/letter/t/82dd89/32.png) [@Test0r](https://forum.shopware.com/u/Test0r)\
**Post date:** [19. September 2018 um 11:29 UTC](https://forum.shopware.com/t/datenbank-fehler-wahrend-update-benotige-dringende-hilfe/55247/5 "2018-09-19T11:29:34Z")

</div>

Letzte Woche habe ich bereits versucht, den Shop upzudaten. Da hatte ich die o.g. Datenbank-Fehlermeldung (1062 Duplicate entry ‚1275-2‘ for key ‚element\_id‘ "}).

Nach wenigen Anpassungen an der Datenbank, die nicht zum Erfolg führten, habe ich ein Backup der Datenbank und der Dateien eingespielt. Heute wieder im Büro, Update gestartet, erneut&nbsp;Fehlermeldung (1062 Duplicate entry ‚1275-2‘ for key ‚element\_id‘ "}). Darauf ins&nbsp;Forum geschrieben, Du hast geantwortet, ich Fehler gelöst. Update erneut gestartet, neue Fehlermeldung (1050 Table ‚s\_order\_basket\_signatures‘ already exists ").&nbsp;

Kann denn die DB inkostent sein, obwohl ich das DB-Backup eingespiuelt habe?&nbsp;

---

<div class="post-metadata">

**Author:** ![hsoebbing](https://avatars.discourse-cdn.com/v4/letter/h/898d66/32.png) [@hsoebbing](https://forum.shopware.com/u/hsoebbing)\
**Post date:** [19. September 2018 um 11:32 UTC](https://forum.shopware.com/t/datenbank-fehler-wahrend-update-benotige-dringende-hilfe/55247/6 "2018-09-19T11:32:34Z")

</div>

Ja, das Backup stellt idR. nur die alten Tabellen wieder her, es löscht nicht neue Tabellen die im Backup nicht enthalten sind. Soll heißen: Alle alten Tabellen sind wieder auf dem Stand Deines Backups, aber zusätzlich hast Du bereits ein paar Tabellen die erst durch die Migrationen erstellt werden.

Einfach das Update mehrfach anwerfen und wenn eine Fehlermeldung wg. einer bereits bestehenden Tabelle erscheint kannst Du die testweise mal umbenennen und das Update erneut durchführen.

---

<div class="post-metadata">

**Author:** ![Test0r](https://avatars.discourse-cdn.com/v4/letter/t/82dd89/32.png) [@Test0r](https://forum.shopware.com/u/Test0r)\
**Post date:** [19. September 2018 um 11:42 UTC](https://forum.shopware.com/t/datenbank-fehler-wahrend-update-benotige-dringende-hilfe/55247/7 "2018-09-19T11:42:50Z")

</div>

Alles klar, logisch :). Danke!

in der Tabelle habe ich, wie bereits vermutet, einen Eiintrag&nbsp;mit der ID 907 -\>&nbsp;Start Date: 2018-09-19 13:14:16&nbsp; -\> Completete Date: NULL -\>&nbsp; name: add-signed-basket -\> Error: Siehe oben

Was muss ich hier jetzt genau ändern/umbenennen&nbsp;bzw. löschen?

&nbsp;
