# Cronjob setzt Rechte zurück

**URL:** <https://forum.shopware.com/t/cronjob-setzt-rechte-zuruck/15665>\
**Category:** Shopware 3.5\
**Tags:** resolved-topics\
**Created:** [19. September 2013 um 18:27 UTC](https://forum.shopware.com/t/cronjob-setzt-rechte-zuruck/15665 "2013-09-19T18:27:12Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![Agarwen](https://avatars.discourse-cdn.com/v4/letter/a/a9a28c/32.png) [@Agarwen](https://forum.shopware.com/u/Agarwen)\
**Post date:** [19. September 2013 um 18:27 UTC](https://forum.shopware.com/t/cronjob-setzt-rechte-zuruck/15665/1 "2013-09-19T18:27:12Z")

</div>

Hallo zusammen, ich habe ein Problem mit dem Cronjob. Der Cronjob ist unter Debian in der crontab eingetragen und läuft erst mal korrekt alle 5 Minuten. Ca. jede Stunde erhalten wir im Frontend folgende Meldung: `Fatal error: Uncaught exception 'UnexpectedValueException' with message 'RecursiveDirectoryIterator::\_\_construct(/var/www/vhosts/daehne.de/shop/cache/templates/cache/backend\_de\_DE\_d510a): failed to open dir: Permission denied' in /var/www/vhosts/daehne.de/shop/engine/Library/Smarty/sysplugins/smarty\_internal\_cacheresource\_file.php:180 Stack trace: #0 [internal function]: RecursiveDirectoryIterator-\>\_\_construct('/var/www/vhosts...', 0) #1 /var/www/vhosts/daehne.de/shop/engine/Library/Smarty/sysplugins/smarty\_internal\_cacheresource\_file.php(180): RecursiveDirectoryIterator-\>getChildren() #2 /var/www/vhosts/daehne.de/shop/engine/Library/Smarty/sysplugins/smarty\_internal\_cacheresource\_file.php(121): Smarty\_Internal\_CacheResource\_File-\>clear(Object(Enlight\_Template\_Manager), NULL, NULL, NULL, NULL) #3 /var/www/vhosts/daehne.de/shop/engine/Library/Smarty/Smarty.class.php(754): Smarty\_Internal\_CacheResource\_File-\>clearAll(Object(Enlight\_Template\_Manager), NULL) #4 /var/www/vhosts/daehne.de/shop/engine/Shopware/Plugins/Community/ in /var/www/vhosts/daehne.de/shop/engine/Library/Smarty/sysplugins/smarty\_internal\_cacheresource\_file.php on line 180` Bisher haben wir das nur mit setzen der Rechte im Filesystem lösen können. Ich bin für jeden Tipp dankbar.

---

<div class="post-metadata">

**Author:** ![hth](https://avatars.discourse-cdn.com/v4/letter/h/b77776/32.png) [@hth](https://forum.shopware.com/u/hth)\
**Post date:** [23. September 2013 um 09:40 UTC](https://forum.shopware.com/t/cronjob-setzt-rechte-zuruck/15665/2 "2013-09-23T09:40:46Z")

</div>

[quote=“Agarwen”]Hallo zusammen, ich habe ein Problem mit dem Cronjob. Der Cronjob ist unter Debian in der crontab eingetragen und läuft erst mal korrekt alle 5 Minuten. Ca. jede Stunde erhalten wir im Frontend folgende Meldung: `Fatal error: Uncaught exception 'UnexpectedValueException' with message 'RecursiveDirectoryIterator::\_\_construct(/var/www/vhosts/daehne.de/shop/cache/templates/cache/backend\_de\_DE\_d510a): failed to open dir: Permission denied' in /var/www/vhosts/daehne.de/shop/engine/Library/Smarty/sysplugins/smarty\_internal\_cacheresource\_file.php:180 Stack trace: #0 [internal function]: RecursiveDirectoryIterator-\>\_\_construct('/var/www/vhosts...', 0) #1 /var/www/vhosts/daehne.de/shop/engine/Library/Smarty/sysplugins/smarty\_internal\_cacheresource\_file.php(180): RecursiveDirectoryIterator-\>getChildren() #2 /var/www/vhosts/daehne.de/shop/engine/Library/Smarty/sysplugins/smarty\_internal\_cacheresource\_file.php(121): Smarty\_Internal\_CacheResource\_File-\>clear(Object(Enlight\_Template\_Manager), NULL, NULL, NULL, NULL) #3 /var/www/vhosts/daehne.de/shop/engine/Library/Smarty/Smarty.class.php(754): Smarty\_Internal\_CacheResource\_File-\>clearAll(Object(Enlight\_Template\_Manager), NULL) #4 /var/www/vhosts/daehne.de/shop/engine/Shopware/Plugins/Community/ in /var/www/vhosts/daehne.de/shop/engine/Library/Smarty/sysplugins/smarty\_internal\_cacheresource\_file.php on line 180` Bisher haben wir das nur mit setzen der Rechte im Filesystem lösen können. Ich bin für jeden Tipp dankbar.[/quote] Die CronJobs müssen mit den benötigten Rechten - die manuell im Filesyste gesetzt werden - laufen. Das ist eine Frage der Serverkonfiguration und nicht von Shopware.

---

<div class="post-metadata">

**Author:** ![Agarwen](https://avatars.discourse-cdn.com/v4/letter/a/a9a28c/32.png) [@Agarwen](https://forum.shopware.com/u/Agarwen)\
**Post date:** [23. September 2013 um 10:05 UTC](https://forum.shopware.com/t/cronjob-setzt-rechte-zuruck/15665/3 "2013-09-23T10:05:19Z")

</div>

Hallo hth, ich befürchte, dass ich mich missverständlich ausgedrückt habe. Wenn ich den Cronjob starte erhalte ich im Backend nur eine leere Backend-Seite. Wenn ich den Cronjob per Shell starte erhalte ich den HTML-Code dieser leeren Backend-Seite. Nachdem ich den Cronjob gestartet habe erhalte ich im Frontend diese Fehlermeldung, die auf Permissions hinweist. Zu Testzwecken habe ich den Service komplett mit chmod 777 belegt. Das ist natürlich nicht für den Livebetrieb aber zum testen war mir das egal. Leider hat das auch nichts gebracht ich habe immer noch eine leere Ausgabe-Seite nach der Durchführung des Cronjobs.

---

<div class="post-metadata">

**Author:** ![Agarwen](https://avatars.discourse-cdn.com/v4/letter/a/a9a28c/32.png) [@Agarwen](https://forum.shopware.com/u/Agarwen)\
**Post date:** [25. September 2013 um 12:09 UTC](https://forum.shopware.com/t/cronjob-setzt-rechte-zuruck/15665/4 "2013-09-25T12:09:33Z")

</div>

MEIN FEHLER Bei einem Update wurde anscheinend das Plugin Cron inaktiv geschaltet. Für alle mit dem gleichen Problem: Unter der Pluginverwaltung findet Ihr in den Shopware-Erweiterungen das Plugin Cron. Das muss natürlich „aktiv“ sein.
