# Cron (Media Garbage) funktioniert nicht /newsletter/cron hingegen schon

**URL:** <https://forum.shopware.com/t/cron-media-garbage-funktioniert-nicht-newsletter-cron-hingegen-schon/47093>\
**Category:** Allgemein\
**Created:** [24. Juli 2017 um 17:24 UTC](https://forum.shopware.com/t/cron-media-garbage-funktioniert-nicht-newsletter-cron-hingegen-schon/47093 "2017-07-24T17:24:51Z")\
**Posts on this page:** 17\
**Page:** 1

<div class="post-metadata">

**Author:** ![mobilize](https://avatars.discourse-cdn.com/v4/letter/m/7ba0ec/32.png) [@mobilize](https://forum.shopware.com/u/mobilize)\
**Post date:** [24. Juli 2017 um 17:24 UTC](https://forum.shopware.com/t/cron-media-garbage-funktioniert-nicht-newsletter-cron-hingegen-schon/47093/1 "2017-07-24T17:24:51Z")

</div>

Hallo,

habe die Cron Plugins installiert und versucht die Crons auszuführen, da  
ich zur Zeit \> 800.000 Bilder in Shopware habe, obwohl es nur ein Bruchteil  
davon geben dürfte.

Der Aufruf&nbsp;[https://www.meinshop.ch/backend/cron](https://www.meinshop.ch/backend/cron) funkioniert zwar, jedoch  
wird sofort eine leere Seite ausgegeben

[https://www.meinshop.ch/backend/newsletter/cron](https://www.meinshop.ch/backend/newsletter/cron) higegen gibt als Ergebnis  
“nothing to do”

Auch mit&nbsp;  
echo file\_get\_contents(‘[https://www.meinshop.ch/backend/cron](https://www.meinshop.ch/backend/cron)’);  
Echo "Newsletter  
";  
echo file\_get\_contents(‘[https://www.meinshop.ch/backend/newsletter/cron](https://www.meinshop.ch/backend/newsletter/cron)’);  
habe ich kein anderes Ergebnis bekommen.

Hat jemand einen Rat?

---

<div class="post-metadata">

**Author:** ![Moritz\_Naczenski](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/moritz_naczenski/32/7792_2.png) [@Moritz\_Naczenski](https://forum.shopware.com/u/Moritz_Naczenski)\
**Post date:** [24. Juli 2017 um 17:29 UTC](https://forum.shopware.com/t/cron-media-garbage-funktioniert-nicht-newsletter-cron-hingegen-schon/47093/2 "2017-07-24T17:29:43Z")

</div>

Hast du das Cron-Plugin denn installiert?  
Zudem solltest du den Cron über CLI ausführen, da dies deutlich performanter ist und auch nicht an Scriptlaufzeiten gebunden ist.

---

<div class="post-metadata">

**Author:** ![Sean](https://avatars.discourse-cdn.com/v4/letter/s/f0a364/32.png) [@Sean](https://forum.shopware.com/u/Sean)\
**Post date:** [24. Juli 2017 um 18:10 UTC](https://forum.shopware.com/t/cron-media-garbage-funktioniert-nicht-newsletter-cron-hingegen-schon/47093/3 "2017-07-24T18:10:57Z")

</div>

Sie können versuchen, [easycron.com](http://easycron.com) als Trigger, leicht zu finden Problem.

---

<div class="post-metadata">

**Author:** ![simkli](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/simkli/32/13124_2.png) [@simkli](https://forum.shopware.com/u/simkli)\
**Post date:** [24. Juli 2017 um 19:16 UTC](https://forum.shopware.com/t/cron-media-garbage-funktioniert-nicht-newsletter-cron-hingegen-schon/47093/4 "2017-07-24T19:16:43Z")

</div>

@Sean alle deine Beiträge machen Werbung für diese Seite.  
Aus meiner Sicht ist das Spam&nbsp;[https://forum.shopware.com/profile/comments/17780/Sean&nbsp](https://forum.shopware.com/profile/comments/17780/Sean&nbsp);  
Das ist hier nicht Sinn der Sache.

OnTopic:

> Der Aufruf&nbsp;[https://www.meinshop.ch/backend/cron](https://www.meinshop.ch/backend/cron)&nbsp;funkioniert zwar, jedoch  
> wird sofort eine leere Seite ausgegeben

Schalte mal das Error-Reporting an. Wenn die weiße Seite sofort kommt (ohne große Ladezeit \<30 Sekunden), tritt wahrscheinlich ein Fehler auf:  
[http://community.shopware.com/Fehlermeldungen-in-Shopware-debuggen\_detail\_1880.html#Frontend\_Error\_Reporter](http://community.shopware.com/Fehlermeldungen-in-Shopware-debuggen%5C_detail%5C_1880.html#Frontend%5C_Error%5C_Reporter)

Danach sollte statt der weißen Seite eine Fehlermeldung erscheinen

Viele Grüße  
&nbsp;

---

<div class="post-metadata">

**Author:** ![mobilize](https://avatars.discourse-cdn.com/v4/letter/m/7ba0ec/32.png) [@mobilize](https://forum.shopware.com/u/mobilize)\
**Post date:** [25. Juli 2017 um 07:45 UTC](https://forum.shopware.com/t/cron-media-garbage-funktioniert-nicht-newsletter-cron-hingegen-schon/47093/5 "2017-07-25T07:45:45Z")

</div>

> [@simkli schrieb:](https://forum.shopware.com/profile/16741/simkli "simkli")
> 
> @Sean alle deine Beiträge machen Werbung für diese Seite.  
> Aus meiner Sicht ist das Spam&nbsp;[https://forum.shopware.com/profile/comments/17780/Sean](https://forum.shopware.com/profile/comments/17780/Sean)&nbsp;  
> Das ist hier nicht Sinn der Sache.
> 
> OnTopic:
> 
> > Der Aufruf&nbsp;[https://www.meinshop.ch/backend/cron](https://www.meinshop.ch/backend/cron)&nbsp;funkioniert zwar, jedoch  
> > wird sofort eine leere Seite ausgegeben
> 
> Schalte mal das Error-Reporting an. Wenn die weiße Seite sofort kommt (ohne große Ladezeit \<30 Sekunden), tritt wahrscheinlich ein Fehler auf:  
> [http://community.shopware.com/Fehlermeldungen-in-Shopware-debuggen\_detail\_1880.html#Frontend\_Error\_Reporter](http://community.shopware.com/Fehlermeldungen-in-Shopware-debuggen_detail_1880.html?_ga=2.220105881.1068218074.1500915336-801348866.1500462204#Frontend_Error_Reporter)
> 
> Danach sollte statt der weißen Seite eine Fehlermeldung erscheinen
> 
> Viele Grüße  
> &nbsp;
> 
> Danke, ist aber schon eingeschaltet und trotzdem kommt nur eine weiße Seite.

---

<div class="post-metadata">

**Author:** ![mobilize](https://avatars.discourse-cdn.com/v4/letter/m/7ba0ec/32.png) [@mobilize](https://forum.shopware.com/u/mobilize)\
**Post date:** [25. Juli 2017 um 07:48 UTC](https://forum.shopware.com/t/cron-media-garbage-funktioniert-nicht-newsletter-cron-hingegen-schon/47093/6 "2017-07-25T07:48:12Z")

</div>

> [@Sean schrieb:](https://forum.shopware.com/profile/17780/Sean "Sean")
> 
> Sie können versuchen, [easycron.com](http://easycron.com) als Trigger, leicht zu finden Problem.
> 
> &nbsp;
> 
> Ergebis:
> 
> Date: Tue, 25 Jul 2017 07:47:15 GMT  
> Server: Apache  
> Cache-Control: private  
> X-Powered-By: PleskLin  
> Content-Length: 0  
> Content-Type: text/html; charset=UTF-8  
> &nbsp;
> 
> Zeit 1,2 Sekunden, HTTP 200

---

<div class="post-metadata">

**Author:** ![mobilize](https://avatars.discourse-cdn.com/v4/letter/m/7ba0ec/32.png) [@mobilize](https://forum.shopware.com/u/mobilize)\
**Post date:** [25. Juli 2017 um 07:48 UTC](https://forum.shopware.com/t/cron-media-garbage-funktioniert-nicht-newsletter-cron-hingegen-schon/47093/7 "2017-07-25T07:48:49Z")

</div>

> [@Moritz Naczenski schrieb:](https://forum.shopware.com/profile/14574/Moritz%20Naczenski "Moritz%20Naczenski")
> 
> Hast du das Cron-Plugin denn installiert?  
> Zudem solltest du den Cron über CLI ausführen, da dies deutlich performanter ist und auch nicht an Scriptlaufzeiten gebunden ist.
> 
> Ja, habe ich. Der Newsletter Cron läuft ja auch.

---

<div class="post-metadata">

**Author:** ![Moritz\_Naczenski](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/moritz_naczenski/32/7792_2.png) [@Moritz\_Naczenski](https://forum.shopware.com/u/Moritz_Naczenski)\
**Post date:** [25. Juli 2017 um 08:46 UTC](https://forum.shopware.com/t/cron-media-garbage-funktioniert-nicht-newsletter-cron-hingegen-schon/47093/8 "2017-07-25T08:46:28Z")

</div>

Der NewsletterCron ist auch ein ganz anderes System - die haben überhaupt nichts miteinander zu tun.

Wenn die Seite weiß ist, dann kann die Ursache auch sein, dass keine Tasks anstehen. Passt denn die “Nächste Ausführung” in den Grundeinstellungen und auch alle Crons sind aktiv die ausgeführt werden sollen?

---

<div class="post-metadata">

**Author:** ![mobilize](https://avatars.discourse-cdn.com/v4/letter/m/7ba0ec/32.png) [@mobilize](https://forum.shopware.com/u/mobilize)\
**Post date:** [25. Juli 2017 um 09:10 UTC](https://forum.shopware.com/t/cron-media-garbage-funktioniert-nicht-newsletter-cron-hingegen-schon/47093/9 "2017-07-25T09:10:53Z")

</div>

> [@Moritz Naczenski schrieb:](https://forum.shopware.com/profile/14574/Moritz%20Naczenski "Moritz%20Naczenski")
> 
> Der NewsletterCron ist auch ein ganz anderes System - die haben überhaupt nichts miteinander zu tun.
> 
> Wenn die Seite weiß ist, dann kann die Ursache auch sein, dass keine Tasks anstehen. Passt denn die „Nächste Ausführung“ in den Grundeinstellungen und auch alle Crons sind aktiv die ausgeführt werden sollen?
> 
> Danke für den Hinweis.
> 
> War aktiviert, ist jetzt deaktivert. Fehlermeldung:
> 
> array (  
> &nbsp; ‚error‘ =\> 'An exception occurred while executing 'INSERT INTO s\_media\_used  
> &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; SELECT DISTINCT NULL, m.id  
> &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; FROM s\_media m  
> &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; INNER JOIN s\_articles\_img  
> &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; ON s\_articles\_img.media\_id = m.id':
> 
> SQLSTATE[HY000]: General error: 1205 Lock wait timeout exceeded; try restarting transaction’,  
> )
> 
> &nbsp;

---

<div class="post-metadata">

**Author:** ![Moritz\_Naczenski](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/moritz_naczenski/32/7792_2.png) [@Moritz\_Naczenski](https://forum.shopware.com/u/Moritz_Naczenski)\
**Post date:** [25. Juli 2017 um 09:13 UTC](https://forum.shopware.com/t/cron-media-garbage-funktioniert-nicht-newsletter-cron-hingegen-schon/47093/10 "2017-07-25T09:13:24Z")

</div>

Sieht mir danach aus, als ob das einfach zu viele Daten für den Garbage Collector sind. Der deaktiviert sich bei Fehler der Cron, dass ist normal.

Du kannst es nochmal per SSH/Shopware Konsole probieren:&nbsp;[http://community.shopware.com/Shopware-CLI-Nuetzliche-Befehle--Tricks\_detail\_1990.html#Core\_Befehle](http://community.shopware.com/Shopware-CLI-Nuetzliche-Befehle--Tricks_detail_1990.html#Core_Befehle)

Wenn das nicht läuft, dann ist die Datenmenge selbst zu groß. Am besten auch sicherstellen, dass du eine aktuelle 5.2.27 nutzt, im Verlauf der 5.2 gab es da auch Optimierungen.&nbsp;

---

<div class="post-metadata">

**Author:** ![mobilize](https://avatars.discourse-cdn.com/v4/letter/m/7ba0ec/32.png) [@mobilize](https://forum.shopware.com/u/mobilize)\
**Post date:** [25. Juli 2017 um 09:13 UTC](https://forum.shopware.com/t/cron-media-garbage-funktioniert-nicht-newsletter-cron-hingegen-schon/47093/11 "2017-07-25T09:13:58Z")

</div>

> [@mobilize schrieb:](https://forum.shopware.com/profile/23769/mobilize "mobilize")
> 
> > [@Moritz Naczenski schrieb:](https://forum.shopware.com/profile/14574/Moritz%20Naczenski "Moritz%20Naczenski")
> > 
> > Der NewsletterCron ist auch ein ganz anderes System - die haben überhaupt nichts miteinander zu tun.
> > 
> > Wenn die Seite weiß ist, dann kann die Ursache auch sein, dass keine Tasks anstehen. Passt denn die „Nächste Ausführung“ in den Grundeinstellungen und auch alle Crons sind aktiv die ausgeführt werden sollen?
> > 
> > Danke für den Hinweis.
> > 
> > War aktiviert, ist jetzt deaktivert. Fehlermeldung:
> > 
> > array (  
> > &nbsp; ‚error‘ =\> 'An exception occurred while executing 'INSERT INTO s\_media\_used  
> > &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; SELECT DISTINCT NULL, m.id  
> > &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; FROM s\_media m  
> > &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; INNER JOIN s\_articles\_img  
> > &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; ON s\_articles\_img.media\_id = m.id':
> > 
> > SQLSTATE[HY000]: General error: 1205 Lock wait timeout exceeded; try restarting transaction’,  
> > )
> > 
> > Sehe auch, dass die Tabelle&nbsp;s\_media\_used gar nicht existiert.

---

<div class="post-metadata">

**Author:** ![mobilize](https://avatars.discourse-cdn.com/v4/letter/m/7ba0ec/32.png) [@mobilize](https://forum.shopware.com/u/mobilize)\
**Post date:** [25. Juli 2017 um 09:25 UTC](https://forum.shopware.com/t/cron-media-garbage-funktioniert-nicht-newsletter-cron-hingegen-schon/47093/12 "2017-07-25T09:25:59Z")

</div>

> [@Moritz Naczenski schrieb:](https://forum.shopware.com/profile/14574/Moritz%20Naczenski "Moritz%20Naczenski")
> 
> Sieht mir danach aus, als ob das einfach zu viele Daten für den Garbage Collector sind. Der deaktiviert sich bei Fehler der Cron, dass ist normal.
> 
> Du kannst es nochmal per SSH/Shopware Konsole probieren:&nbsp;[http://community.shopware.com/Shopware-CLI-Nuetzliche-Befehle–Tricks\_detail\_1990.html#Core\_Befehle](http://community.shopware.com/Shopware-CLI-Nuetzliche-Befehle--Tricks_detail_1990.html?_ga=2.31967678.1068218074.1500915336-801348866.1500462204#Core_Befehle)
> 
> Wenn das nicht läuft, dann ist die Datenmenge selbst zu groß. Am besten auch sicherstellen, dass du eine aktuelle 5.2.27 nutzt, im Verlauf der 5.2 gab es da auch Optimierungen.&nbsp;
> 
> Danke, teste ich und gebe dann Status …

---

<div class="post-metadata">

**Author:** ![Simpliby](https://avatars.discourse-cdn.com/v4/letter/s/838e76/32.png) [@Simpliby](https://forum.shopware.com/u/Simpliby)\
**Post date:** [26. Januar 2018 um 14:15 UTC](https://forum.shopware.com/t/cron-media-garbage-funktioniert-nicht-newsletter-cron-hingegen-schon/47093/13 "2018-01-26T14:15:23Z")

</div>

Gab oder gibt es hier neue Erkenntnisse? Wir bekommen beim Ausführen von sw:media:cleanup über SSH unter SW 5.3.4 ebenfalls die u.a. Fehlermeldung

&nbsp;

Kann es sein, dass auf Grund der Datenmenge die temporäre Tabelle s\_media\_used nicht fertigerstellt werden kann?

Kontakt mit unserem Hoster gab auch keine Timeout Probleme o.ä.

&nbsp;

Vielen Dank vorab!

&nbsp;

&nbsp;

&nbsp;

array (  
&nbsp; ‘error’ =\> 'An exception occurred while executing ‘INSERT INTO s\_media\_used  
&nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; SELECT DISTINCT NULL, m.id  
&nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; FROM s\_media m  
&nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; INNER JOIN s\_articles\_img  
&nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; ON s\_articles\_img.media\_id = m.id’:

SQLSTATE[HY000]: General error: 1205 Lock wait timeout exceeded; try restarting transaction’,  
)

---

<div class="post-metadata">

**Author:** ![MenStuff](https://avatars.discourse-cdn.com/v4/letter/m/34f0e0/32.png) [@MenStuff](https://forum.shopware.com/u/MenStuff)\
**Post date:** [26. Januar 2018 um 14:22 UTC](https://forum.shopware.com/t/cron-media-garbage-funktioniert-nicht-newsletter-cron-hingegen-schon/47093/14 "2018-01-26T14:22:55Z")

</div>

> [@mobilize schrieb:](https://forum.shopware.com/profile/23769/mobilize "mobilize")
> 
> > [@Sean schrieb:](https://forum.shopware.com/profile/17780/Sean "Sean")
> > 
> > Sie können versuchen, [easycron.com](http://easycron.com) als Trigger, leicht zu finden Problem.
> > 
> > &nbsp;
> > 
> > Ergebis:
> > 
> > Date: Tue, 25 Jul 2017 07:47:15 GMT  
> > Server: Apache  
> > Cache-Control: private  
> > X-Powered-By: PleskLin  
> > Content-Length: 0  
> > Content-Type: text/html; charset=UTF-8  
> > &nbsp;
> > 
> > Zeit 1,2 Sekunden, HTTP 200
> > 
> > &nbsp;
> > 
> > &nbsp;
> > 
> > Es scheint sich hier um ein Server mit Plesk zu handeln.
> > 
> > &nbsp;
> > 
> > Die Cronjobs am besten über „geplante Aufgaben „
> > 
> > über die domain machen, das läuft besser und gibt auch ein Ergebnis aus.

---

<div class="post-metadata">

**Author:** ![Simpliby](https://avatars.discourse-cdn.com/v4/letter/s/838e76/32.png) [@Simpliby](https://forum.shopware.com/u/Simpliby)\
**Post date:** [26. Januar 2018 um 15:45 UTC](https://forum.shopware.com/t/cron-media-garbage-funktioniert-nicht-newsletter-cron-hingegen-schon/47093/15 "2018-01-26T15:45:35Z")

</div>

… um cronjobs, etc. als mögliche fehlerursache auszuschliessen haben wir&nbsp; sw:media:cleanup doch direkt über SSH Shell aufgerufen&nbsp; !

m.E. wird auf Grund zu großer Datenmengen die Tabelle s\_media\_used nicht korrekt erstellt. Der Rest sind dann die o.g. Folgefehler. Gibt es hier seitens Shopware eine Angabe was der Garbage Collector an Artikel/Bilder bewältigen kann? Und gibt bei größeren Datenbanken einen Workaround für solch eine Beschränkung?

Vielen Dank vorab!

---

<div class="post-metadata">

**Author:** ![ShopwareUser44](https://avatars.discourse-cdn.com/v4/letter/s/85f322/32.png) [@ShopwareUser44](https://forum.shopware.com/u/ShopwareUser44)\
**Post date:** [4. Mai 2018 um 15:57 UTC](https://forum.shopware.com/t/cron-media-garbage-funktioniert-nicht-newsletter-cron-hingegen-schon/47093/16 "2018-05-04T15:57:46Z")

</div>

Auch wir haben das Problem. Garbage Collector funktioniert nicht. Gibt es hier Neuigkeiten? 5.3.3

---

<div class="post-metadata">

**Author:** ![Simpliby](https://avatars.discourse-cdn.com/v4/letter/s/838e76/32.png) [@Simpliby](https://forum.shopware.com/u/Simpliby)\
**Post date:** [1. August 2018 um 01:47 UTC](https://forum.shopware.com/t/cron-media-garbage-funktioniert-nicht-newsletter-cron-hingegen-schon/47093/17 "2018-08-01T01:47:20Z")

</div>

Gibt es hier Neuigkeiten bzw. ist mit neuerer SW Version ein Fix geplant?
