# Column already exists: 1060 Duplicate column name 'width'

**URL:** <https://forum.shopware.com/t/column-already-exists-1060-duplicate-column-name-width/38079>\
**Category:** Installation/Einstieg\
**Created:** [9. Juli 2016 um 20:45 UTC](https://forum.shopware.com/t/column-already-exists-1060-duplicate-column-name-width/38079 "2016-07-09T20:45:37Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![Patrick\_Duke](https://avatars.discourse-cdn.com/v4/letter/p/b3f665/32.png) [@Patrick\_Duke](https://forum.shopware.com/u/Patrick_Duke)\
**Post date:** [9. Juli 2016 um 20:45 UTC](https://forum.shopware.com/t/column-already-exists-1060-duplicate-column-name-width/38079/1 "2016-07-09T20:45:37Z")

</div>

Habe nun 3 Shopware Updates auf 5.2.1 gemacht. Doch bei der letzten&nbsp; (von 5.0.4) tritt folgender fehler beim Update auf. Seh ich das richtig das die Spalte “width” bereits vorhanden ist? Ja ok… aber in welcher Tabelle? Wie kann man dies umgehen?  
&nbsp;

```
Error
Received the following error message:
Could not apply migration: SQLSTATE[42S21]: Column already exists: 1060 Duplicate column name 'width'

Please try to fix this error and restart the update.
Response

{"valid":false,"errorMsg":"Could not apply migration: SQLSTATE[42S21]: Column already exists: 1060 Duplicate column name 'width'"}

```

&nbsp;

---

<div class="post-metadata">

**Author:** ![Patrick\_Duke](https://avatars.discourse-cdn.com/v4/letter/p/b3f665/32.png) [@Patrick\_Duke](https://forum.shopware.com/u/Patrick_Duke)\
**Post date:** [10. Juli 2016 um 16:10 UTC](https://forum.shopware.com/t/column-already-exists-1060-duplicate-column-name-width/38079/2 "2016-07-10T16:10:13Z")

</div>

Vielleicht noch ein Hinweis: In der Tabelle s\_schema\_version steht ist bei der Fehlermeldung in der Spalte „name“ folgende drin: **add-media-meta**

**Hilft das vielleicht weiter?**

---

<div class="post-metadata">

**Author:** ![Patrick\_Duke](https://avatars.discourse-cdn.com/v4/letter/p/b3f665/32.png) [@Patrick\_Duke](https://forum.shopware.com/u/Patrick_Duke)\
**Post date:** [10. Juli 2016 um 16:44 UTC](https://forum.shopware.com/t/column-already-exists-1060-duplicate-column-name-width/38079/3 "2016-07-10T16:44:59Z")

</div>

Ok Problem gelöst.

im update-assets Ordner war das file “613-add-media-meta.php”

In diesem Wollte er die Spalten “width” und “height” anlegen obwohl diese bei version 5.0.4 eigentlich noch gar nicht drin sein dürften. Daher hat er abgebrochen.

Habe in dieser Datei nun auf width2 und height2 geändert und das Update ging problemlos.  
Danach die alten Spalten gelöscht und die width2 durch width und height2 durch height in der Tabelle geändert.
