# Cloning the website and redeploying results in 500 internal server error

**URL:** <https://forum.shopware.com/t/cloning-the-website-and-redeploying-results-in-500-internal-server-error/72749>\
**Category:** Installation / Getting Started (EN)\
**Created:** [13. Februar 2021 um 08:13 UTC](https://forum.shopware.com/t/cloning-the-website-and-redeploying-results-in-500-internal-server-error/72749 "2021-02-13T08:13:30Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![Achilles](https://avatars.discourse-cdn.com/v4/letter/a/dc4da7/32.png) [@Achilles](https://forum.shopware.com/u/Achilles)\
**Post date:** [13. Februar 2021 um 08:13 UTC](https://forum.shopware.com/t/cloning-the-website-and-redeploying-results-in-500-internal-server-error/72749/1 "2021-02-13T08:13:30Z")

</div>

Hallo everyone,

i have a quick question here, i’m trying to make a a mirror version of the shop for testing purposes&nbsp;

so i copied all the files, exported the db etc and reinstalled everything on a new host account, changed the .env file and im getting this error&nbsp;

![](https://europe1.discourse-cdn.com/flex013/uploads/shopware/original/2X/4/4f0fe378c8d972d68c628be8b9cf5752fa42beef.png)

if anyone has an idea on what can be wrong here i would appreciate&nbsp;any advice&nbsp;

thanks everyone and stay safe&nbsp;

---

<div class="post-metadata">

**Author:** ![SmartStylez](https://avatars.discourse-cdn.com/v4/letter/s/a88e4f/32.png) [@SmartStylez](https://forum.shopware.com/u/SmartStylez)\
**Post date:** [13. Februar 2021 um 10:17 UTC](https://forum.shopware.com/t/cloning-the-website-and-redeploying-results-in-500-internal-server-error/72749/2 "2021-02-13T10:17:20Z")

</div>

Why don’t you use this?&nbsp;[https://store.shopware.com/en/emz2686169189745f/test-environment-1-click-install.html](https://store.shopware.com/en/emz2686169189745f/test-environment-1-click-install.html)

---

<div class="post-metadata">

**Author:** ![Achilles](https://avatars.discourse-cdn.com/v4/letter/a/dc4da7/32.png) [@Achilles](https://forum.shopware.com/u/Achilles)\
**Post date:** [13. Februar 2021 um 10:24 UTC](https://forum.shopware.com/t/cloning-the-website-and-redeploying-results-in-500-internal-server-error/72749/3 "2021-02-13T10:24:27Z")

</div>

i had tried to use it, first run i had an issue with the memory\_limit in php had to go in the php files and add&nbsp;ini\_set(‚memory\_limit‘, ‚128M‘);  
so after i solved that issue i open the link and then it says 404 not found, which i think is becuse .htaccess file, so yeah that it an option but i also had a problem there

---

<div class="post-metadata">

**Author:** ![Achilles](https://avatars.discourse-cdn.com/v4/letter/a/dc4da7/32.png) [@Achilles](https://forum.shopware.com/u/Achilles)\
**Post date:** [12. August 2021 um 07:55 UTC](https://forum.shopware.com/t/cloning-the-website-and-redeploying-results-in-500-internal-server-error/72749/4 "2021-08-12T07:55:39Z")

</div>

so i found out what was wrong, if you go to config-\>jwt  
there is two files  
private.pem  
public.pem  
they need to have the permission 600 or 660
