# Cache Warmup mittels PHP-Script über Plesk Cron schlägt fehl - Connection refused

**URL:** https://forum.shopware.com/t/cache-warmup-mittels-php-script-uber-plesk-cron-schlagt-fehl-connection-refused/59282
**Category:** Programmierung
**Created:** [28. April 2019 um 08:53 UTC](https://forum.shopware.com/t/cache-warmup-mittels-php-script-uber-plesk-cron-schlagt-fehl-connection-refused/59282 "2019-04-28T08:53:56Z")
**Posts on this page:** 14
**Page:** 1

<div class="post-metadata">

### Author: ![mdsw](https://avatars.discourse-cdn.com/v4/letter/m/94ad74/32.png) [@mdsw](https://forum.shopware.com/u/mdsw)
#### Post date: [28. April 2019 um 08:53 UTC](https://forum.shopware.com/t/cache-warmup-mittels-php-script-uber-plesk-cron-schlagt-fehl-connection-refused/59282/1 "2019-04-28T08:53:56Z")

</div>

Hallo Community,&nbsp;

ich versuche über einen Cronjob im Hosting (plesk-Oberfläche ohne SSH !) einen Cron einzurichten, welcher eine PHP-Datei ausführt. Shell-Skripte lassen sich scheinbar nicht ausführen.

In dieser PHP-Datei ( **cron\_cache\_warmup.php** ) wird der Cache geleert und danach aufgewärmt:

_Hierzu muss man erläutern, dass ich zunächst beide exec-Befehle ausgeführt habe, bis ich -c entdeckt habe um vor dem Aufwärmen den Cache zu leeren._

&nbsp;

**Manuell:**  
Führe ich nun den Cronjob im Plesk manuell aus über den Button “Jetzt ausführen”, wird die cron\_cache\_warmup.php angesprochen und ausgeführt. Der Cache wird dann aufgewärmt.

**Geplant:**  
Für den geplanten Task, welcher automatisch nachts durchgeführt werden soll, erhalte ich im Shopware Log Fehlermeldungen und der Cache wird nicht aufgewärmt.

**Fehlermeldungen:**

```
Warm up http-cache error with shopId 1 cURL error 7: Failed to connect to DOMAINNAME.de port 443: Connection refused

```

_Die Fehlermeldung erhalte ich für alle Subshops. Es sind 16226&nbsp;Fehlermeldungen innerhalb von 15 Sekunden.&nbsp;_

 ![](https://europe1.discourse-cdn.com/flex013/uploads/shopware/original/2X/c/cf0af23469130e9bad7dab5d15428fa3e2063f98.png)

---

<div class="post-metadata">

### Author: ![scriptfarm](https://avatars.discourse-cdn.com/v4/letter/s/2acd7d/32.png) [@scriptfarm](https://forum.shopware.com/u/scriptfarm)
#### Post date: [28. April 2019 um 12:16 UTC](https://forum.shopware.com/t/cache-warmup-mittels-php-script-uber-plesk-cron-schlagt-fehl-connection-refused/59282/2 "2019-04-28T12:16:05Z")

</div>

Laut Fehlermeldung meckert er weil er keine Verbindung über den Port 443 bekommt, diese ist Standartmässig der PORT für SSL/TLS  
Versuche doch mal über https, bzw…passe den Curl Connect dementsprechend an.

&nbsp;

&nbsp;

&nbsp;

&nbsp;

---

<div class="post-metadata">

### Author: ![mdsw](https://avatars.discourse-cdn.com/v4/letter/m/94ad74/32.png) [@mdsw](https://forum.shopware.com/u/mdsw)
#### Post date: [29. April 2019 um 07:44 UTC](https://forum.shopware.com/t/cache-warmup-mittels-php-script-uber-plesk-cron-schlagt-fehl-connection-refused/59282/3 "2019-04-29T07:44:28Z")

</div>

Hi @scriptfarm‍

danke für die Info.

Blöd gefragt (weil ohne Ahnung): cUrl kann ich nur per SSH Zugriff anpassen? Den habe ich nämlich nicht.  
Muss ich dann mit dem Hoster korrespondieren oder kann ich das doch irgendwie selbst machen?  
&nbsp;

---

<div class="post-metadata">

### Author: ![scriptfarm](https://avatars.discourse-cdn.com/v4/letter/s/2acd7d/32.png) [@scriptfarm](https://forum.shopware.com/u/scriptfarm)
#### Post date: [29. April 2019 um 09:12 UTC](https://forum.shopware.com/t/cache-warmup-mittels-php-script-uber-plesk-cron-schlagt-fehl-connection-refused/59282/4 "2019-04-29T09:12:31Z")

</div>

Naja ob es direkt an Curl liegt, weiss ich nicht, jedenfalls heisst die Fehlermeldung so.

Auch die Benutzer-und Ausführungsrechte dieser Datei sollten stimmen und einen Chmod 755 haben, per FTP Client anpassen.

Eventuell wird es daran liegen.

---

<div class="post-metadata">

### Author: ![mdsw](https://avatars.discourse-cdn.com/v4/letter/m/94ad74/32.png) [@mdsw](https://forum.shopware.com/u/mdsw)
#### Post date: [30. April 2019 um 07:04 UTC](https://forum.shopware.com/t/cache-warmup-mittels-php-script-uber-plesk-cron-schlagt-fehl-connection-refused/59282/5 "2019-04-30T07:04:37Z")

</div>

Hallo @scriptfarm‍

ich habe die Rechte der Datei auf 755 gesetzt und einen Cron geplant. Die Rechte waren tatsächlich nicht ausreichend.  
Ich werden berichten ob es klappt.

**Andere Frage:**  
Ich habe parallel mehrere Shops liegen. Ein parallel liegender Shop wurde einmalig manuell aufgewärmt. Nach ca. 1-2 Tagen ist der Cache allerdings nicht mehr aufgewärmt. Ich habe den Cache nicht manuell invalidiert und war auch nicht im Backend in dieser Zeit.

1. **Frage:** Leert sich der Cache von selbst und man muss jede Nacht aufwärmen? Unter Einstellungen \> Caches / Performance \> Einstellungen \> HTTP-Cache gibt es ja Cache Zeiten für die Controller… hat das was damit zu tun?
2. Häufig kann ich mit die Daten für den Cache auch nicht mehr ansehen. (siehe Screenshot). Das Hosting sollte aber leistungstechnisch mind. ausreichend sein.

&nbsp;

&nbsp;

&nbsp;

 ![](https://europe1.discourse-cdn.com/flex013/uploads/shopware/original/2X/4/4ad2229251d048cd56e5bb79abdf53e6e5f37647.jpeg) ![](https://europe1.discourse-cdn.com/flex013/uploads/shopware/original/2X/c/c8098856fc0308bdb6f65701228b4fb0e09683b1.jpeg)

---

<div class="post-metadata">

### Author: ![mdsw](https://avatars.discourse-cdn.com/v4/letter/m/94ad74/32.png) [@mdsw](https://forum.shopware.com/u/mdsw)
#### Post date: [30. April 2019 um 10:13 UTC](https://forum.shopware.com/t/cache-warmup-mittels-php-script-uber-plesk-cron-schlagt-fehl-connection-refused/59282/6 "2019-04-30T10:13:15Z")

</div>

An den Dateirechten liegt es scheinbar nicht. Die Fehlermeldungen im Log lauten:

```
Warm up http-cache error with shopId 1 Server error response

```

&nbsp;

```
Warm up http-cache error with shopId 1 cURL error 7: Failed to connect to DOMAINNAME.de port 443: Connection refused

```

&nbsp;

---

<div class="post-metadata">

### Author: ![scriptfarm](https://avatars.discourse-cdn.com/v4/letter/s/2acd7d/32.png) [@scriptfarm](https://forum.shopware.com/u/scriptfarm)
#### Post date: [30. April 2019 um 15:10 UTC](https://forum.shopware.com/t/cache-warmup-mittels-php-script-uber-plesk-cron-schlagt-fehl-connection-refused/59282/7 "2019-04-30T15:10:14Z")

</div>

Kannst Du die **…warmup.php** über den Browser aufrufen, merkwürdig ist das es wohl direkt über Plesk funktioniert.

Dann scheint doch wohl was an dem Pfad nicht zu stimmen

---

<div class="post-metadata">

### Author: ![oldschool](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/oldschool/32/26605_2.png) [@oldschool](https://forum.shopware.com/u/oldschool)
#### Post date: [30. April 2019 um 17:01 UTC](https://forum.shopware.com/t/cache-warmup-mittels-php-script-uber-plesk-cron-schlagt-fehl-connection-refused/59282/8 "2019-04-30T17:01:31Z")

</div>

Moin,

&nbsp;

eigentlich einfach.

Mit deinem Script, greifst du auf Port 80 zu.

Cron versucht auf Port 443 zuzugreifen. Connection refused` = Firewall`

&nbsp;

Hast Du zugrief auf die Console ?

---

<div class="post-metadata">

### Author: ![StefanPoensgen](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/stefanpoensgen/32/14750_2.png) [@StefanPoensgen](https://forum.shopware.com/u/StefanPoensgen)
#### Post date: [30. April 2019 um 20:04 UTC](https://forum.shopware.com/t/cache-warmup-mittels-php-script-uber-plesk-cron-schlagt-fehl-connection-refused/59282/9 "2019-04-30T20:04:43Z")

</div>

Versuch mal im Plesk Cron Manager unter Befehl direkt folgendes auszuführen

/opt/plesk/php/7.2/bin/php ~/httpdocs/shopwareshop/bin/console sw:cron:run

Unter “Einstellungen für geplante Aufgaben” musst du ggf. Crontab-Shell noch auf bin/bash (chrooted) stellen

&nbsp;

Sollte das ganze immer noch nicht gehen, kommst du evtl. nicht drum rum per SSH paar Dinge zu erledigen.

[https://support.plesk.com/hc/en-us/articles/213909205-Website-shows-cURL-error-77-Problem-with-the-SSL-CA-cert-](https://support.plesk.com/hc/en-us/articles/213909205-Website-shows-cURL-error-77-Problem-with-the-SSL-CA-cert-)

[https://support.plesk.com/hc/en-us/articles/115000963789-Unable-to-perform-curl-request-under-chrooted-user-on-CentOS-Unable-to-initialize-NSS](https://support.plesk.com/hc/en-us/articles/115000963789-Unable-to-perform-curl-request-under-chrooted-user-on-CentOS-Unable-to-initialize-NSS)

&nbsp;

&nbsp;

Bei mir sieht das ganze so aus&nbsp;

 ![](https://europe1.discourse-cdn.com/flex013/uploads/shopware/original/2X/e/ed02d034cc4b4b875d46398b1e7d206bb5bb60c9.png)

---

<div class="post-metadata">

### Author: ![mdsw](https://avatars.discourse-cdn.com/v4/letter/m/94ad74/32.png) [@mdsw](https://forum.shopware.com/u/mdsw)
#### Post date: [2. Mai 2019 um 13:37 UTC](https://forum.shopware.com/t/cache-warmup-mittels-php-script-uber-plesk-cron-schlagt-fehl-connection-refused/59282/10 "2019-05-02T13:37:44Z")

</div>

Hallo zusammen.

@scriptfarm‍ ich kann die Datei aufrufen. Es erscheint eine weiße Seite. Ich kann aber nicht sagen, ob nun der Befehl ausgeführt wird, da ich im Backend unter Performance Cache nur den 0 - communication failure Fehler&nbsp;erhalte. Erst wenn ich den Cache einmal leere, funktioniert die Anzeige wieder. Nach erneutem Ausführen der PHP-Datei über den Browser scheint kein Cache aufgewämt zu werden.

@NahtlosShop‍ nein ich habe leider keinen SSH Zugang…&nbsp;

@StefanPoensgen‍ Ich kann diesen Befehl nicht ausführen, weil php nicht gefunden wird…&nbsp;Unter “Einstellungen für geplante Aufgaben” kann ich nur die Zeitzone einstellen.

&nbsp;

---

<div class="post-metadata">

### Author: ![scriptfarm](https://avatars.discourse-cdn.com/v4/letter/s/2acd7d/32.png) [@scriptfarm](https://forum.shopware.com/u/scriptfarm)
#### Post date: [2. Mai 2019 um 14:08 UTC](https://forum.shopware.com/t/cache-warmup-mittels-php-script-uber-plesk-cron-schlagt-fehl-connection-refused/59282/11 "2019-05-02T14:08:53Z")

</div>

Am Anfang sagtest Du, das der Cache ausgewärmt wird, wenn Du alles manuell über Plesk mit dem Button “Jetzt ausführen” startest.

Wenn dem so ist, sollte das ja im Grunde heissen, das der Cron Befehl soweit passt, nur der zeitliche Aufruf über PHP nicht.

---

<div class="post-metadata">

### Author: ![mdsw](https://avatars.discourse-cdn.com/v4/letter/m/94ad74/32.png) [@mdsw](https://forum.shopware.com/u/mdsw)
#### Post date: [2. Mai 2019 um 14:18 UTC](https://forum.shopware.com/t/cache-warmup-mittels-php-script-uber-plesk-cron-schlagt-fehl-connection-refused/59282/12 "2019-05-02T14:18:31Z")

</div>

Genau - mit “Jetzt ausführen” im Plesk wird der Cache aufgewärmt. Beim geplanten Cron erscheinen die Fehler. Ich habe das jetzt mal an den Hoster weitergeleitet…&nbsp;

---

<div class="post-metadata">

### Author: ![mdsw](https://avatars.discourse-cdn.com/v4/letter/m/94ad74/32.png) [@mdsw](https://forum.shopware.com/u/mdsw)
#### Post date: [3. Mai 2019 um 07:51 UTC](https://forum.shopware.com/t/cache-warmup-mittels-php-script-uber-plesk-cron-schlagt-fehl-connection-refused/59282/13 "2019-05-03T07:51:23Z")

</div>

Ich habe vom Hoster die Info bekommen, den Pfad einmal komplett auszuschreiben:&nbsp;/var/www/vhosts/DOMAIN/SHOPORDNER/…

Das habe ich gemacht und werde es mit dem geplant Cron testen.

---

<div class="post-metadata">

### Author: ![mdsw](https://avatars.discourse-cdn.com/v4/letter/m/94ad74/32.png) [@mdsw](https://forum.shopware.com/u/mdsw)
#### Post date: [3. Mai 2019 um 10:29 UTC](https://forum.shopware.com/t/cache-warmup-mittels-php-script-uber-plesk-cron-schlagt-fehl-connection-refused/59282/14 "2019-05-03T10:29:58Z")

</div>

Der Tipp vom Hoster hat ebenfalls nicht das gewünschte Ergebnis gebracht. Manuell funktioniert es, per Cron funktioniert es nicht - auch nicht mit komplettem Pfad…

Ich bekomme per Mail ja auch immer einen Fehler ausgegeben. Im Betreff der Mail steht vll. was hilfreiches:&nbsp;

```
/opt/plesk/php/7.2/bin/php -f 'httpdocs/SHOPORDNER/cron_cache_warmup.php' > /dev/null

```

&nbsp;
