# Cache Aufwärmen - Fehlermeldungen bei inaktiven Artikeln

**URL:** <https://forum.shopware.com/t/cache-aufwarmen-fehlermeldungen-bei-inaktiven-artikeln/41749>\
**Category:** Allgemein\
**Created:** [27. November 2016 um 09:48 UTC](https://forum.shopware.com/t/cache-aufwarmen-fehlermeldungen-bei-inaktiven-artikeln/41749 "2016-11-27T09:48:07Z")\
**Posts on this page:** 19\
**Page:** 1

<div class="post-metadata">

**Author:** ![Kerstin83](https://avatars.discourse-cdn.com/v4/letter/k/49beb7/32.png) [@Kerstin83](https://forum.shopware.com/u/Kerstin83)\
**Post date:** [27. November 2016 um 09:48 UTC](https://forum.shopware.com/t/cache-aufwarmen-fehlermeldungen-bei-inaktiven-artikeln/41749/1 "2016-11-27T09:48:07Z")

</div>

Liebes Forum 🙂 🙂

Beim Aufwärmen des Caches wird für jeden Artikel, der inaktiv gestellt ist eine Fehlermeldung verursacht und - wenn man das eingestellt hat - eine Fehlermeldung an den Shopbetreiber geschickt. Das ist ziemlich lästig.

Kann man das irgendwie umgehen ?

Liebe Grüße

Kerstin

---

<div class="post-metadata">

**Author:** ![Uwe868](https://avatars.discourse-cdn.com/v4/letter/u/f08c70/32.png) [@Uwe868](https://forum.shopware.com/u/Uwe868)\
**Post date:** [27. November 2016 um 10:18 UTC](https://forum.shopware.com/t/cache-aufwarmen-fehlermeldungen-bei-inaktiven-artikeln/41749/2 "2016-11-27T10:18:14Z")

</div>

Bei mir ist das genau so. &nbsp;Und externe PlugIn’s (&nbsp;[Cache Aufwärmen](https://forum.shopware.com/discussion/42411/cache-aufwaermen-fehlermeldungen-bei-inaktiven-artikeln)&nbsp;) deaktivieren sich auch von alleine.

---

<div class="post-metadata">

**Author:** ![Moritz\_Naczenski](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/moritz_naczenski/32/7792_2.png) [@Moritz\_Naczenski](https://forum.shopware.com/u/Moritz_Naczenski)\
**Post date:** [27. November 2016 um 11:25 UTC](https://forum.shopware.com/t/cache-aufwarmen-fehlermeldungen-bei-inaktiven-artikeln/41749/3 "2016-11-27T11:25:20Z")

</div>

Hallo,

der Cache-Warmer holt sich alle URLs aus der s\_core\_rewrite\_urls und ruft die einmal auf. Der ist da insofern einfach “simpel”, da gibt es keine Logik das zu verhindern.

Moritz

---

<div class="post-metadata">

**Author:** ![Kerstin83](https://avatars.discourse-cdn.com/v4/letter/k/49beb7/32.png) [@Kerstin83](https://forum.shopware.com/u/Kerstin83)\
**Post date:** [27. November 2016 um 11:43 UTC](https://forum.shopware.com/t/cache-aufwarmen-fehlermeldungen-bei-inaktiven-artikeln/41749/4 "2016-11-27T11:43:45Z")

</div>

könnte man die Einträge in der&nbsp;s\_core\_rewrite\_urls löschen oder ist das gefährlich&nbsp;?

---

<div class="post-metadata">

**Author:** ![Moritz\_Naczenski](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/moritz_naczenski/32/7792_2.png) [@Moritz\_Naczenski](https://forum.shopware.com/u/Moritz_Naczenski)\
**Post date:** [27. November 2016 um 11:45 UTC](https://forum.shopware.com/t/cache-aufwarmen-fehlermeldungen-bei-inaktiven-artikeln/41749/5 "2016-11-27T11:45:59Z")

</div>

Das Problem ist ja, dass Shopware die URL dann nicht kennt. Die werden ja für Weiterleitungen und Statuscodes benutzt. Würde ich erstmal von abraten.

---

<div class="post-metadata">

**Author:** ![Kerstin83](https://avatars.discourse-cdn.com/v4/letter/k/49beb7/32.png) [@Kerstin83](https://forum.shopware.com/u/Kerstin83)\
**Post date:** [27. November 2016 um 11:49 UTC](https://forum.shopware.com/t/cache-aufwarmen-fehlermeldungen-bei-inaktiven-artikeln/41749/6 "2016-11-27T11:49:00Z")

</div>

ok, danke. Dann muss ich wohl damit leben. ☹

---

<div class="post-metadata">

**Author:** ![Toric](https://avatars.discourse-cdn.com/v4/letter/t/bbe5ce/32.png) [@Toric](https://forum.shopware.com/u/Toric)\
**Post date:** [29. November 2016 um 06:56 UTC](https://forum.shopware.com/t/cache-aufwarmen-fehlermeldungen-bei-inaktiven-artikeln/41749/7 "2016-11-29T06:56:43Z")

</div>

Hallo Kerstin,

ich bekomme diese Meldungen nur dann, wenn ich den Cache manuell über das BE aufwärme. Beim Cronjob nicht. Im Logfile sehe ich dann nur noch Warnungen, die scheinbar dadurch verursacht werden, aber es kommen keine Emails mehr dazu.

Bekommst du die Mails auch beim Cronjob?

LG

---

<div class="post-metadata">

**Author:** ![raschu](https://avatars.discourse-cdn.com/v4/letter/r/839c29/32.png) [@raschu](https://forum.shopware.com/u/raschu)\
**Post date:** [14. Januar 2017 um 08:26 UTC](https://forum.shopware.com/t/cache-aufwarmen-fehlermeldungen-bei-inaktiven-artikeln/41749/8 "2017-01-14T08:26:46Z")

</div>

Hallo,

das Problem scheint sich auch auf GoogleSearch auszuwirken: es entstehen dort Crawling-Fehler mit 404-Fehlercode, wenn Artikel inaktiv gesetzt werden.

Der 404-Fehler wird ja auch beim Cache aufwärmen erzeugt und in der Error-Meldung angezeigt.

Ruft man den Artikel über die “normale, inaktive” URL auf ([https://meineSeite.de/123/inaktiverArtikel](https://meineSeite.de/123/inaktiverArtikel)), so wird im Frontend die Seite “Dieser Artikel ist leider nicht mehr verfügbar!” angezeigt und ähnliche Alternativ-Artikel werden aufgelistet. Da ist ja auch eine feine Lösung.

Hier dürfte dann aber nicht der Fehlercode 404 verwendet werden, sondern entweder 302 oder besser 301 und die Seite “Dieser Artikel ist leider…” müsste die neue Artikelseite für den inaktiven Artiekl bezeichnen.

Beim Inaktiv-Setzen des Artikels im Backend müsste dann also automatisch die Seite “Dieser Artikel ist leider nicht mehr verfügbar” als “neue” URL für den inaktiven Artiekl gesetzt werden.

Nur weiß ich leider nicht die URL für die genannte Seite, da im Browser die nicht mehr vorhandene URL des inaktiven Artikels steht.

---

<div class="post-metadata">

**Author:** ![Toric](https://avatars.discourse-cdn.com/v4/letter/t/bbe5ce/32.png) [@Toric](https://forum.shopware.com/u/Toric)\
**Post date:** [14. Januar 2017 um 08:57 UTC](https://forum.shopware.com/t/cache-aufwarmen-fehlermeldungen-bei-inaktiven-artikeln/41749/9 "2017-01-14T08:57:54Z")

</div>

Hallo,

die Meldung „Dieser Artikel ist leider nicht mehr verfügbar!“&nbsp; hatte ich bisher 2-3 mal in der Einrichtungs- und Anfangsphase des Shops, danach nicht mehr. Wann die Meldung angezeigt wird, konnte ich bisher nicht herausfinden.

Bisher habe ich für die 404-Fehler manuell eine 301 Weiterleitung auf einen ähnlichen/vergleichbaren Artikel gemacht, da der Inaktive ja definitiv nicht wieder vorhanden sein wird. Anders sieht es aus, wenn er nur vorübergehend ausverkauft ist. Dann setzt man ihn aber nicht inaktiv, sondern nur den Lagerbestand auf 0. Dann wird der Artikel zwar angezeigt, kann aber nicht bestellt werden.

Ich muss mir mal in Ruhe überlegen, was für den Kunden sinnvoller ist. Die Meldung „nicht verfügbar“ oder die 301 Umleitung auf den Alternativartikel bzw. eine Kategorie mit Alternativen. 301 finde ich da fast besser, einziger Nachteil, dass die htacces sich aufbläht.

Allerdings hat das Problem nichts mit dem eigentlich Post hier zu tun. Da geht es nur um interne Warnungen.

LG

---

<div class="post-metadata">

**Author:** ![raschu](https://avatars.discourse-cdn.com/v4/letter/r/839c29/32.png) [@raschu](https://forum.shopware.com/u/raschu)\
**Post date:** [14. Januar 2017 um 09:36 UTC](https://forum.shopware.com/t/cache-aufwarmen-fehlermeldungen-bei-inaktiven-artikeln/41749/10 "2017-01-14T09:36:22Z")

</div>

Hallo Toric,

die internen Warnungen bedeuten ja, dass beim Crawlen der Suchmaschinen der 404 Fehler bei inaktiven Artiekeln generell angemahnt wird.

Und dass der HTP-Cache-Aufwärmer die Error-Meldungen produziert, erfolgt ja wegen den inaktiven Artikeln. Also sind wir hier schon irgendwie richtig ![Smile](https://forum.shopware.com/plugins/CKEditor/plugins/smiley/images/smile.png "Smile")

Wir haben immer auf „inaktiv“ gesetzt, wenn ein Artikel z.b. nicht lieferbar ist (z.B. weil er vom Hersteller aus dem Sortiment genommen wurde).

Die Shopware-Lösung mit der „Ähnliche Artikel“ ist doch eine schöne Lösung, nur dürfte hier nicht der Fehler 404 erzeugt werden.

Der inaktive Artikel ist nun mal ruckzuck im Suchindex der Suchmaschinen - einmal drin ist er schwer wieder raus zu bekommen, dass will ich vermeiden.

Bisher dachte ich auch, dass die Seite „Dieser Artikel ist leider nicht mehr verfügbar!“ keine Fehlerseite mit 404-Fehler ist - ist sie aber.

Kann mir jemand sagen, unter welcher URL die Seite „Dieser Artikel ist leider nicht mehr verfügbar!“ zu finden ist? Dann richte ich eine 301 Weiterleitung auf diese Seite für inaktive Artikel ein und die interne Error-Meldung dürfte weg sein.

---

<div class="post-metadata">

**Author:** ![frimipiso](https://avatars.discourse-cdn.com/v4/letter/f/a587f6/32.png) [@frimipiso](https://forum.shopware.com/u/frimipiso)\
**Post date:** [14. Januar 2017 um 10:13 UTC](https://forum.shopware.com/t/cache-aufwarmen-fehlermeldungen-bei-inaktiven-artikeln/41749/11 "2017-01-14T10:13:09Z")

</div>

Hi zusammen,

&nbsp;

dazu gabe ich eine Frage: wie kommt Google darauf, die inaktiven Artikel zu crawlen und zu indizieren? Stehen die in der Sitemap? Wir sind gerade auf Shopware umgezogen und google meckert die inaktiven Artikel an. Beim Cacheprewarming gibts dafür auch Fehler.

Cia

&nbsp;

Jens

---

<div class="post-metadata">

**Author:** ![Toric](https://avatars.discourse-cdn.com/v4/letter/t/bbe5ce/32.png) [@Toric](https://forum.shopware.com/u/Toric)\
**Post date:** [14. Januar 2017 um 10:31 UTC](https://forum.shopware.com/t/cache-aufwarmen-fehlermeldungen-bei-inaktiven-artikeln/41749/12 "2017-01-14T10:31:37Z")

</div>

Wenn es die URL mal gab und diese google bekannt ist (bei mir z.B. weil sie in alten Shopsystem vorhanden war) wird sie immer mal wieder heimgesucht. Auch wenn sie längst nicht mehr in der sitemap steht. Liegt daran, dass die URL mal im Index war oder auch weil sie von anderen Seiten verlinkt wurde.

Mir werden seit einem Jahr 404-Fehler in den wmt angezeigt, bei denen unter „verlinkt über“ mein alter Shop angezeigt wird, also URLs die es seit einem Jahr nicht mehr gibt.

Google ist da absolut nicht auf dem aktuellen Stand (auch bei der Statistik eingehene Links zu sehen).

---

<div class="post-metadata">

**Author:** ![raschu](https://avatars.discourse-cdn.com/v4/letter/r/839c29/32.png) [@raschu](https://forum.shopware.com/u/raschu)\
**Post date:** [14. Januar 2017 um 10:33 UTC](https://forum.shopware.com/t/cache-aufwarmen-fehlermeldungen-bei-inaktiven-artikeln/41749/13 "2017-01-14T10:33:48Z")

</div>

Ich werde mal ein Ticket eröffnen.

Das ist ne Sache, da sollte das Shopware-Team mal eine generelle Lösung finden. Inaktiv setzen muss ja nicht gleich einen 404-Fehler erzeugen. Da kann man ja sicher einen gleichzeitigen Eintrag in die s\_core\_rewrite\_urls auf die „Artikel ist leider nicht mehr verfügbar!“-Seite machen.

---

<div class="post-metadata">

**Author:** ![Toric](https://avatars.discourse-cdn.com/v4/letter/t/bbe5ce/32.png) [@Toric](https://forum.shopware.com/u/Toric)\
**Post date:** [14. Januar 2017 um 10:41 UTC](https://forum.shopware.com/t/cache-aufwarmen-fehlermeldungen-bei-inaktiven-artikeln/41749/14 "2017-01-14T10:41:50Z")

</div>

Möglicherweise ist ein Artikel nicht inaktiv, sondern abschließend gelöscht. Das kann man vielleicht nicht trennen.

Also ein inaktiver oder gelöschter Artikel zeigt immder die „nicht Verfügbarmeldung“ an und erzeugt keine 404. Wenn man das nicht möchte, wird durch eine manuelle 301er Umleitung auf die gewünschte Seite verwiesen.

Was passiert dann mit allen anderen nicht mehr vorhandenen URLs (gelöschte Kategorien, Blogbeiträge, Shopseiten…)?

---

<div class="post-metadata">

**Author:** ![raschu](https://avatars.discourse-cdn.com/v4/letter/r/839c29/32.png) [@raschu](https://forum.shopware.com/u/raschu)\
**Post date:** [14. Januar 2017 um 10:43 UTC](https://forum.shopware.com/t/cache-aufwarmen-fehlermeldungen-bei-inaktiven-artikeln/41749/15 "2017-01-14T10:43:58Z")

</div>

@ Toric:

Das “alte” URLs sauber umgeleitet werden sollten, gehört zum guten SEO. Je weniger Crawling-Fehler desto besser - am besten gar keine, sonst geht es mit Sicherheit ins Ranking mit ein.

Für diese Fälle gibt es ja die 301-Umleitungen in der s\_core\_rewrite\_urls: wird die URL z.B. eines Artikels geändert (passiert z.B. wenn der Artikelname geändert wird, s. SEO-Einstellungen im Backend) wird laut Shopware-Doku sauber auf die neue URL mittels Eintrag in die s\_core\_rewrite\_urls umgeleitet. So entsteht dann kein Crawlingfehler, google findet die “alte” URL und stellt auf die “neue” um - alles gut.

Aber eben nicht bei inaktiven Artikeln…

---

<div class="post-metadata">

**Author:** ![Kerstin83](https://avatars.discourse-cdn.com/v4/letter/k/49beb7/32.png) [@Kerstin83](https://forum.shopware.com/u/Kerstin83)\
**Post date:** [14. Januar 2017 um 11:30 UTC](https://forum.shopware.com/t/cache-aufwarmen-fehlermeldungen-bei-inaktiven-artikeln/41749/16 "2017-01-14T11:30:11Z")

</div>

> Ich werde mal ein Ticket eröffnen.

Verlinke doch mal dasTicket.

---

<div class="post-metadata">

**Author:** ![raschu](https://avatars.discourse-cdn.com/v4/letter/r/839c29/32.png) [@raschu](https://forum.shopware.com/u/raschu)\
**Post date:** [14. Januar 2017 um 11:58 UTC](https://forum.shopware.com/t/cache-aufwarmen-fehlermeldungen-bei-inaktiven-artikeln/41749/17 "2017-01-14T11:58:09Z")

</div>

ticket ist hier: [http://issues.shopware.com/issues/SW-17461](http://issues.shopware.com/issues/SW-17461)

---

<div class="post-metadata">

**Author:** ![useg](https://avatars.discourse-cdn.com/v4/letter/u/df705f/32.png) [@useg](https://forum.shopware.com/u/useg)\
**Post date:** [14. Januar 2017 um 12:22 UTC](https://forum.shopware.com/t/cache-aufwarmen-fehlermeldungen-bei-inaktiven-artikeln/41749/18 "2017-01-14T12:22:41Z")

</div>

> [@Kerstin83 schrieb:](https://forum.shopware.com/profile/10989/Kerstin83 "Kerstin83")
> 
> > Ich werde mal ein Ticket eröffnen.
> 
> Verlinke doch mal dasTicket.

Hallo Kerstin, ich war gerade auf dem Ticket und habe gevotet, aber ich war der erste, hast du da nur Verfolgen geklickt statt voten&nbsp;?

Uwe

---

<div class="post-metadata">

**Author:** ![Kerstin83](https://avatars.discourse-cdn.com/v4/letter/k/49beb7/32.png) [@Kerstin83](https://forum.shopware.com/u/Kerstin83)\
**Post date:** [14. Januar 2017 um 13:13 UTC](https://forum.shopware.com/t/cache-aufwarmen-fehlermeldungen-bei-inaktiven-artikeln/41749/19 "2017-01-14T13:13:57Z")

</div>

Ja stimmt, bzw. habe ich auch nicht verfolgen geklickt. Ich wollte nach dem Kommentar voten, hat dann aber nicht geklappt, weil ich mein Passwort nicht parat hatte. Der Kommentar war also etwas voreilig 🙂

Hole ich aber nach.

Kerstin
