# Bildpfad \<g:image\_link\> im englischen xml Feed führt immer zu 404 Error

**URL:** <https://forum.shopware.com/t/bildpfad-g-image-link-im-englischen-xml-feed-fuehrt-immer-zu-404-error/103331>\
**Category:** Shopware 6 (German)\
**Created:** [15. März 2024 um 06:44 UTC](https://forum.shopware.com/t/bildpfad-g-image-link-im-englischen-xml-feed-fuehrt-immer-zu-404-error/103331 "2024-03-15T06:44:37Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![shopware14](https://avatars.discourse-cdn.com/v4/letter/s/4bbf92/32.png) [@shopware14](https://forum.shopware.com/u/shopware14)\
**Post date:** [15. März 2024 um 06:44 UTC](https://forum.shopware.com/t/bildpfad-g-image-link-im-englischen-xml-feed-fuehrt-immer-zu-404-error/103331/1 "2024-03-15T06:44:37Z")

</div>

Hallo,

für die Werbung auf Google-Produkte habe ich einen deutsch- und einen eglischsprachigen Verkaufskanal zur Erstellung von zwei XML-Dateien angelegt.

Beide Feeds verwenden ein identisches XML-Template mit folgender Konfiguration für den Bildlink:

\<g:image\_link\>{{ product.cover.media.url }}\</g:image\_link\>

Leider werden für den englischen Feed Bildlinks erstellt, die alle zu einen 404 Error führen.

Woran kann das liegen?

Danke

---

<div class="post-metadata">

**Author:** ![shopware14](https://avatars.discourse-cdn.com/v4/letter/s/4bbf92/32.png) [@shopware14](https://forum.shopware.com/u/shopware14)\
**Post date:** [15. März 2024 um 06:54 UTC](https://forum.shopware.com/t/bildpfad-g-image-link-im-englischen-xml-feed-fuehrt-immer-zu-404-error/103331/2 "2024-03-15T06:54:01Z")

</div>

Ich stelle gerade fest, dass Problem hängt damit zusammen, dass im Bildlink das „/en/“ mit eingefügt wird, weil es sich um eine englischsprachigen Verkaufskanal handelt.

Grundsätzlich ist das ja auch korrekt, aber die Produktbilder sind nur ohne das „/en/“ erreichbar.  
Warum sind Bilder nicht in beiden Sprach-URLs verfügbar und warum wird das bei der Feed Erstellung nicht berücksichtigt?

Habe ich eine Einstellung übersehen?

---

<div class="post-metadata">

**Author:** ![shopware14](https://avatars.discourse-cdn.com/v4/letter/s/4bbf92/32.png) [@shopware14](https://forum.shopware.com/u/shopware14)\
**Post date:** [15. März 2024 um 12:18 UTC](https://forum.shopware.com/t/bildpfad-g-image-link-im-englischen-xml-feed-fuehrt-immer-zu-404-error/103331/3 "2024-03-15T12:18:04Z")

</div>

Leider funktioniert folgende Ersetzung nicht:  
{{ product.cover.media.url|replace({‚/en/‘: ‚/‘}) }}

Diese Ersetzung hingegen schon:  
{{ product.cover.media.url|replace({‚/media/‘: ‚/‘}) }}

Man kann offenbar bei folgendem Beispiel  
[https://www.shop.de/en/media/15/ag/9d/08154711/1000.jpg](https://www.shop.de/en/media/15/ag/9d/08154711/1000.jpg)

keine Änderung am URL-Teistring vor /media/ vornehmen.

Leider habe ich keine weitere Idee, was man jetzt noch machen könnte, um den Sprach-Suffix aus der URL zu entfernen. Über Vorschläge würde ich mich deshalb sehr freuen.

Danke

---

<div class="post-metadata">

**Author:** ![shopware14](https://avatars.discourse-cdn.com/v4/letter/s/4bbf92/32.png) [@shopware14](https://forum.shopware.com/u/shopware14)\
**Post date:** [15. März 2024 um 15:28 UTC](https://forum.shopware.com/t/bildpfad-g-image-link-im-englischen-xml-feed-fuehrt-immer-zu-404-error/103331/4 "2024-03-15T15:28:31Z")

</div>

Also, die Sache über das Template zu lösen war mir leider nicht möglich.  
Stattdessen ist jetzt als Workaround, bis zu einem möglichen Bugfix, folgende RewriteRule in der /public/.htaccess implementiert:

RewriteRule ^en/media/(.\*) media/$1 [L]

Den Bug habe ich unabhängig davon im Shopware issuetracker gemeldet.  
Mal abwarten, ob und wann er gefixt wird.

---

<div class="post-metadata">

**Author:** ![Max\_Shop](https://avatars.discourse-cdn.com/v4/letter/m/58f4c7/32.png) [@Max\_Shop](https://forum.shopware.com/u/Max_Shop)\
**Post date:** [15. März 2024 um 16:02 UTC](https://forum.shopware.com/t/bildpfad-g-image-link-im-englischen-xml-feed-fuehrt-immer-zu-404-error/103331/5 "2024-03-15T16:02:32Z")

</div>

Die Lokalisierung läuft nachrangig und ändert alle erkannten lokalen URLs.

Da müsstest du im Source Code ran, oder wie du das notgedrungen gelöst hast über die .htaccess

---

<div class="post-metadata">

**Author:** ![shopware14](https://avatars.discourse-cdn.com/v4/letter/s/4bbf92/32.png) [@shopware14](https://forum.shopware.com/u/shopware14)\
**Post date:** [15. März 2024 um 16:17 UTC](https://forum.shopware.com/t/bildpfad-g-image-link-im-englischen-xml-feed-fuehrt-immer-zu-404-error/103331/6 "2024-03-15T16:17:31Z")

</div>

Ja, dass der Verkaufskanal mit dem Sprach-Suffix nachrangig generiert wird, ist an der Stelle ein echtes Problem. Das hat mich jetzt einige unnötige Stunden gekostet.

Sollte ein Fix kommen, werde ich die Regel dann einfach wieder entfernen.
