# Bestellstatus-Link in Mails führt nach Anmeldung zu Error 500

**URL:** <https://forum.shopware.com/t/bestellstatus-link-in-mails-fuehrt-nach-anmeldung-zu-error-500/94797>\
**Category:** Shopware 6 (German)\
**Created:** [11. Juni 2022 um 20:02 UTC](https://forum.shopware.com/t/bestellstatus-link-in-mails-fuehrt-nach-anmeldung-zu-error-500/94797 "2022-06-11T20:02:10Z")\
**Posts on this page:** 14\
**Page:** 1

<div class="post-metadata">

**Author:** ![sebian](https://avatars.discourse-cdn.com/v4/letter/s/dbc845/32.png) [@sebian](https://forum.shopware.com/u/sebian)\
**Post date:** [11. Juni 2022 um 20:02 UTC](https://forum.shopware.com/t/bestellstatus-link-in-mails-fuehrt-nach-anmeldung-zu-error-500/94797/1 "2022-06-11T20:02:11Z")

</div>

Hallo, habe folgendes Problem:  
Der Link zum aktuellen Bestellstatus der per in den E-Mails versandt wird funktioniert zwar, die Anmeldung führt dann aber zu einem Error 500. Für Gastbesteller die sich mit E-Mail und Postleitzahl einloggen funktioniert alles. Es betrifft nur Kunden mit Account. In den Logs steht folgendes:

```auto

11. Juni 2022, 21:15:57	php	CRITICAL	Uncaught Error: ContainerOZVgsku\ErrorController_b437ad9::error(): Argument #2 ($request) must be of type Symfony\Component\HttpFoundation\Request, null given, called in /www/htdocs/w0175526/shopware/hofladen_v1/vendor/shopware/storefront/Framework/Routing/StorefrontSubscriber.php on line 225 {"exception":"[object] (TypeError(code: 0): ContainerOZVgsku\\ErrorController_b437ad9::error(): Argument #2 ($request) must be of type Symfony\\Component\\HttpFoundation\\Request, null given, called in /www/htdocs/w0175526/shopware/hofladen_v1/vendor/shopware/storefront/Framework/Routing/StorefrontSubscriber.php on line 225 at /www/htdocs/w0175526/shopware/hofladen_v1/var/cache/prod_h84b76c92cfd3c5b1c15b98e16d202590/ContainerOZVgsku/proxy-classes.php:1645)"} []

11. Juni 2022, 21:15:57	request	CRITICAL	Uncaught PHP Exception LogicException: "Cannot change the name of an active session." at /www/htdocs/w0175526/shopware/hofladen_v1/vendor/symfony/http-foundation/Session/Storage/Proxy/AbstractProxy.php line 113 {"exception":"[object] (LogicException(code: 0): Cannot change the name of an active session. at /www/htdocs/w0175526/shopware/hofladen_v1/vendor/symfony/http-foundation/Session/Storage/Proxy/AbstractProxy.php:113)"} []

11. Juni 2022, 21:15:57	php	CRITICAL	Uncaught Exception: Cannot change the name of an active session. {"exception":"[object] (LogicException(code: 0): Cannot change the name of an active session. at /www/htdocs/w0175526/shopware/hofladen_v1/vendor/symfony/http-foundation/Session/Storage/Proxy/AbstractProxy.php:113)"} []

```

Fällt dazu jemandem etwas ein? Der Shop läuft unter PHP 8.1 falls das hilft.

Sebastian

---

<div class="post-metadata">

**Author:** ![tarkka.ch](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/tarkka.ch/32/13452_2.png) [@tarkka.ch](https://forum.shopware.com/u/tarkka.ch)\
**Post date:** [14. Juni 2022 um 09:11 UTC](https://forum.shopware.com/t/bestellstatus-link-in-mails-fuehrt-nach-anmeldung-zu-error-500/94797/2 "2022-06-14T09:11:11Z")

</div>

> [@sebian](#):
>
> `/shopware/hofladen_v1/var/cache/prod_h84b76c92cfd3c5b1c15b98e16d202590`

Schon mal diesen Ordner prod\_ … gelöscht?

---

<div class="post-metadata">

**Author:** ![sebian](https://avatars.discourse-cdn.com/v4/letter/s/dbc845/32.png) [@sebian](https://forum.shopware.com/u/sebian)\
**Post date:** [14. Juni 2022 um 19:27 UTC](https://forum.shopware.com/t/bestellstatus-link-in-mails-fuehrt-nach-anmeldung-zu-error-500/94797/3 "2022-06-14T19:27:14Z")

</div>

Hallo Tarkka,

hatte diesen Ordner noch nicht gelöscht. Habe das gerade versucht.  
Hat den Fehler leider nicht beseitigt. Das Verhalten ist exakt gleich geblieben.  
Anmeldung über den Link aus der E-Mail führt zu Fehler 500, wenn ein Kundenkonto vorhanden ist.

---

<div class="post-metadata">

**Author:** ![sebian](https://avatars.discourse-cdn.com/v4/letter/s/dbc845/32.png) [@sebian](https://forum.shopware.com/u/sebian)\
**Post date:** [19. Juni 2022 um 17:06 UTC](https://forum.shopware.com/t/bestellstatus-link-in-mails-fuehrt-nach-anmeldung-zu-error-500/94797/4 "2022-06-19T17:06:21Z")

</div>

Auch ein Update auf 6.4.12.0 hat leider an der Problematik nichts verändert.  
Gastbesteller können sich über den Link nach Eingabe ihrer E-Mail und der PLZ weiterhin problemlos ihre Bestellung ansehen.  
Kunden mit Kundenkonto erhalten nach dem Login mit E-Mail und Passwort eine Fehler 500 Seite.

Der Link mit dem deepLinkCode muss demnach ja in Ordnung sein?!?  
Wo könnte da noch der Fehler in Verbindung mit den Kundenaccounts liegen?

---

<div class="post-metadata">

**Author:** ![Max\_Shop](https://avatars.discourse-cdn.com/v4/letter/m/58f4c7/32.png) [@Max\_Shop](https://forum.shopware.com/u/Max_Shop)\
**Post date:** [19. Juni 2022 um 17:21 UTC](https://forum.shopware.com/t/bestellstatus-link-in-mails-fuehrt-nach-anmeldung-zu-error-500/94797/5 "2022-06-19T17:21:39Z")

</div>

Habe den **Cannot change the name of an active session.** -Bug auch in einem Projekt, jedoch in einem völlig unterschiedlichen Kontext. Shopware-Support Antwort war sinngemäß: „da wird wohl ein Fehler im individuellen Script sein“.

Hast du individuelle Plugins, die in einen der Prozesse eingreifen oder ist alles standard?

---

<div class="post-metadata">

**Author:** ![sebian](https://avatars.discourse-cdn.com/v4/letter/s/dbc845/32.png) [@sebian](https://forum.shopware.com/u/sebian)\
**Post date:** [19. Juni 2022 um 17:35 UTC](https://forum.shopware.com/t/bestellstatus-link-in-mails-fuehrt-nach-anmeldung-zu-error-500/94797/6 "2022-06-19T17:35:39Z")

</div>

Hallo Max\_Shop,  
es sind ein paar Erweiterungen aus dem Store installiert. Eigentlich sollte sich aber keines in die Anmeldung einmischen. Es gibt keine eigenen Erweiterungen.  
Wenn es hilft, schreibe ich gerne, welche Erweiterungen installiert sind.

---

<div class="post-metadata">

**Author:** ![Max\_Shop](https://avatars.discourse-cdn.com/v4/letter/m/58f4c7/32.png) [@Max\_Shop](https://forum.shopware.com/u/Max_Shop)\
**Post date:** [20. Juni 2022 um 08:54 UTC](https://forum.shopware.com/t/bestellstatus-link-in-mails-fuehrt-nach-anmeldung-zu-error-500/94797/7 "2022-06-20T08:54:21Z")

</div>

Das wäre nett, falls du mir diese per PN schreiben würdest. Ich möchte keinen falschen Verdacht auf die Plugins lenken.

Und falls möglich… die error.log Einträge in Zusammenhang mit dem Fehler. Dann könnte ich diese Vergleichen und wie finden ggf. den Fehler.

---

<div class="post-metadata">

**Author:** ![sebian](https://avatars.discourse-cdn.com/v4/letter/s/dbc845/32.png) [@sebian](https://forum.shopware.com/u/sebian)\
**Post date:** [23. Juni 2022 um 06:27 UTC](https://forum.shopware.com/t/bestellstatus-link-in-mails-fuehrt-nach-anmeldung-zu-error-500/94797/8 "2022-06-23T06:27:06Z")

</div>

Aktueller Stand: Deaktivieren des PayPal-Plugins macht den Link wieder benutzbar!

---

<div class="post-metadata">

**Author:** ![reutli](https://avatars.discourse-cdn.com/v4/letter/r/7bcc69/32.png) [@reutli](https://forum.shopware.com/u/reutli)\
**Post date:** [27. Oktober 2022 um 13:07 UTC](https://forum.shopware.com/t/bestellstatus-link-in-mails-fuehrt-nach-anmeldung-zu-error-500/94797/9 "2022-10-27T13:07:16Z")

</div>

Hallo Leute,  
haben das Problem ebenfalls… nur dass das Deaktivieren des PayPal Plugins ja keine Lösung in einem Shop sein dürfte…  
Leider ging der thread hier nicht weiter… Wie habt Ihr den Fehler nunmehr gelöst?

---

<div class="post-metadata">

**Author:** ![sebian](https://avatars.discourse-cdn.com/v4/letter/s/dbc845/32.png) [@sebian](https://forum.shopware.com/u/sebian)\
**Post date:** [27. Oktober 2022 um 17:19 UTC](https://forum.shopware.com/t/bestellstatus-link-in-mails-fuehrt-nach-anmeldung-zu-error-500/94797/10 "2022-10-27T17:19:01Z")

</div>

Also für uns hat die Lösung von @robert.lang aus dem [Issuetracker](https://issues.shopware.com/issues/NEXT-21801) geholfen. Vielen Dank dafür.  
Es wurde in der config/packages/storefront.yaml der CSRF-Mode auf ajax umgestellt.

---

<div class="post-metadata">

**Author:** ![reutli](https://avatars.discourse-cdn.com/v4/letter/r/7bcc69/32.png) [@reutli](https://forum.shopware.com/u/reutli)\
**Post date:** [30. Oktober 2022 um 15:42 UTC](https://forum.shopware.com/t/bestellstatus-link-in-mails-fuehrt-nach-anmeldung-zu-error-500/94797/11 "2022-10-30T15:42:30Z")

</div>

Wird das denn nicht mit der nächsten Version wieder überschrieben?

---

<div class="post-metadata">

**Author:** ![sebian](https://avatars.discourse-cdn.com/v4/letter/s/dbc845/32.png) [@sebian](https://forum.shopware.com/u/sebian)\
**Post date:** [31. Oktober 2022 um 05:50 UTC](https://forum.shopware.com/t/bestellstatus-link-in-mails-fuehrt-nach-anmeldung-zu-error-500/94797/12 "2022-10-31T05:50:27Z")

</div>

Nein. Es handelt sich dabei um eine Konfigurationsdatei extra für Änderungen wie diese.

---

<div class="post-metadata">

**Author:** ![tout-bombard-barker](https://avatars.discourse-cdn.com/v4/letter/t/45deac/32.png) [@tout-bombard-barker](https://forum.shopware.com/u/tout-bombard-barker)\
**Post date:** [21. Dezember 2022 um 08:34 UTC](https://forum.shopware.com/t/bestellstatus-link-in-mails-fuehrt-nach-anmeldung-zu-error-500/94797/13 "2022-12-21T08:34:37Z")

</div>

Wir hatten das gleiche Problem mit dem Bestellstatus-Link und haben aufgrund dieser Diskussion den CSRF-Mode auf „ajax“ umgestellt. Das Problem war damit behoben.

Nun haben wir aber 1,5 Wochen herum gesucht, warum man bei PayPal-Checkout auf einmal nicht mehr mit Kreditkarte bezahlen konnte. Ursache war genau diese Umstellung.

Daher ist die Konfiguration wieder rausgeflogen und leben erst mal mit damit SHOPWARE\_HTTP\_CACHE\_ENABLED=0 zu setzen, wie es im [IssueTracker](https://issues.shopware.com/issues/NEXT-21801) als Problem beschrieben wird.

---

<div class="post-metadata">

**Author:** ![sebian](https://avatars.discourse-cdn.com/v4/letter/s/dbc845/32.png) [@sebian](https://forum.shopware.com/u/sebian)\
**Post date:** [21. Dezember 2022 um 09:54 UTC](https://forum.shopware.com/t/bestellstatus-link-in-mails-fuehrt-nach-anmeldung-zu-error-500/94797/14 "2022-12-21T09:54:36Z")

</div>

> [@tout-bombard-barker](#):
>
> PayPal-Checkout auf einmal nicht mehr mit Kreditkarte bezahlen konnte. Ursache war genau diese Umstellung.

Ja, so war es bei uns auch. Auch eine andere Erweiterung hat durch die Umstellung nicht mehr funktioniert. Sehr ärgerlich, das ganze.
