# Berechtigungsprobleme nach Shop Umzug

**URL:** <https://forum.shopware.com/t/berechtigungsprobleme-nach-shop-umzug/95632>\
**Category:** Shopware 6 (German)\
**Tags:** administration\
**Created:** [3. August 2022 um 08:40 UTC](https://forum.shopware.com/t/berechtigungsprobleme-nach-shop-umzug/95632 "2022-08-03T08:40:48Z")\
**Posts on this page:** 9\
**Page:** 1

<div class="post-metadata">

**Author:** ![Prazi](https://avatars.discourse-cdn.com/v4/letter/p/c6cbf5/32.png) [@Prazi](https://forum.shopware.com/u/Prazi)\
**Post date:** [3. August 2022 um 08:40 UTC](https://forum.shopware.com/t/berechtigungsprobleme-nach-shop-umzug/95632/1 "2022-08-03T08:40:48Z")

</div>

Hallo zusammen, ich habe letzte Woche meinen Shop von einer Domain auf eine andere verschoben.  
Jetzt habe ich das Problem, dass ich jedes mal, wenn ich eine Bestellung abgeben möchte folgende Fehlermeldung erhalte:

# User Notice: Key file „file:///var/www/vhosts/meine-webseite.de/httpdocs/config/jwt/private.pem“ permissions are not correct, recommend changing to 600 or 660 instead of 644

Das Wechseln der Berechtigungen hat leider nicht gebracht und danach hatte die Webseite keinen Inhalt mehr außer Header und Footer.

Hatte das Problem schonmal jemand oder hätte eine Idee, was noch das problem sei könnte?

Vielen Dank im Vorraus  
Prazi

---

<div class="post-metadata">

**Author:** ![Max\_Shop](https://avatars.discourse-cdn.com/v4/letter/m/58f4c7/32.png) [@Max\_Shop](https://forum.shopware.com/u/Max_Shop)\
**Post date:** [3. August 2022 um 08:48 UTC](https://forum.shopware.com/t/berechtigungsprobleme-nach-shop-umzug/95632/2 "2022-08-03T08:48:21Z")

</div>

Nicht nur die Datei-Rechte, sondern auch den Datei-Owner geändert?

---

<div class="post-metadata">

**Author:** ![Prazi](https://avatars.discourse-cdn.com/v4/letter/p/c6cbf5/32.png) [@Prazi](https://forum.shopware.com/u/Prazi)\
**Post date:** [3. August 2022 um 08:54 UTC](https://forum.shopware.com/t/berechtigungsprobleme-nach-shop-umzug/95632/3 "2022-08-03T08:54:34Z")

</div>

Hallo Max,

der Benutzer hat Les- und Schreibrechte, falls du das meinst.

---

<div class="post-metadata">

**Author:** ![SCOOPEX](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/scoopex/32/18328_2.png) [@SCOOPEX](https://forum.shopware.com/u/SCOOPEX)\
**Post date:** [3. August 2022 um 09:15 UTC](https://forum.shopware.com/t/berechtigungsprobleme-nach-shop-umzug/95632/4 "2022-08-03T09:15:27Z")

</div>

Hallo,

offenbar verwendest Du einen Server mit Plesk.

Die Berechtigungen des httpdocs Verzeichnisses inkl. aller Unterordner müssen auf Deinen FTP Hauptbenutzer (in dessen Kontext laufen auch die PHP Prozesse) gesetzt werden.

Lautet dieser z.B. meinewebseite, so musst Du entsprechend den Besitzer und die Gruppe anpassen.

Also z.B. mit Deinem root Account

cd /var/www/vhosts/meine-webseite.de/  
chown -R meinewebseite:psacln httpdocs

Viele Grüße

---

<div class="post-metadata">

**Author:** ![Prazi](https://avatars.discourse-cdn.com/v4/letter/p/c6cbf5/32.png) [@Prazi](https://forum.shopware.com/u/Prazi)\
**Post date:** [3. August 2022 um 09:57 UTC](https://forum.shopware.com/t/berechtigungsprobleme-nach-shop-umzug/95632/5 "2022-08-03T09:57:36Z")

</div>

Hallo Scoopex,

Ich habe jetzt mal nachgeschaut, bevor ich den Befehl ausgeführt habe, wer der Benutzer von meiner httpdocs ist und dort kommt folgendes raus:

drwxr-xr-x 12 meine\_webseite psaserv 4096 Aug 2 17:53 httpdocs

Viele Grüße

---

<div class="post-metadata">

**Author:** ![SCOOPEX](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/scoopex/32/18328_2.png) [@SCOOPEX](https://forum.shopware.com/u/SCOOPEX)\
**Post date:** [3. August 2022 um 10:05 UTC](https://forum.shopware.com/t/berechtigungsprobleme-nach-shop-umzug/95632/6 "2022-08-03T10:05:59Z")

</div>

Hallo,

ändere mal die Gruppe:

```auto
chown -R meine_webseite:psacln httpdocs

```

Viele Grüße

---

<div class="post-metadata">

**Author:** ![Prazi](https://avatars.discourse-cdn.com/v4/letter/p/c6cbf5/32.png) [@Prazi](https://forum.shopware.com/u/Prazi)\
**Post date:** [3. August 2022 um 10:46 UTC](https://forum.shopware.com/t/berechtigungsprobleme-nach-shop-umzug/95632/7 "2022-08-03T10:46:04Z")

</div>

Hallo,

selbst nachdem ich jetzt den Cache gelöscht habe, kommt immernoch die selbe Fehlermeldung…

hast du vielleicht eine Idee, ob es in irgendeiner Weise Sinn ergibt, nach dem Umzug die private.pem neu erstellen zu lassen o.Ä.?

---

<div class="post-metadata">

**Author:** ![SCOOPEX](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/scoopex/32/18328_2.png) [@SCOOPEX](https://forum.shopware.com/u/SCOOPEX)\
**Post date:** [3. August 2022 um 11:01 UTC](https://forum.shopware.com/t/berechtigungsprobleme-nach-shop-umzug/95632/8 "2022-08-03T11:01:54Z")

</div>

Hm, vielleicht hilft Dir das hier weiter:

> **[Shopware 6: Key path config/jwt/public.pem does not exist or is not readable...](https://erikpoehler.com/2021/06/10/shopware-6-key-path-config-jwt-public-pem-does-not-exist-or-is-not-readable/)**
>
> Having the wrong permissions for Shopware 6's JWT certificates and folder can result in an error messsage. Here's a quick fix.

Viele Grüße

---

<div class="post-metadata">

**Author:** ![Prazi](https://avatars.discourse-cdn.com/v4/letter/p/c6cbf5/32.png) [@Prazi](https://forum.shopware.com/u/Prazi)\
**Post date:** [3. August 2022 um 11:28 UTC](https://forum.shopware.com/t/berechtigungsprobleme-nach-shop-umzug/95632/9 "2022-08-03T11:28:40Z")

</div>

Hallo,

Vielen Dank für die Hilfe.

folgender Artikel hat jetzt endlcih den Fehler entfernt.

> [@Installation Error](https://forum.shopware.com/t/installation-error/60462/5):
>
> The directory&nbsp;jwt has not set the x flag by default. chmod +x config/jwt solved it in my case.
