# Bei plugin-Installation feststellen, welches theme beim User aktiv ist

**URL:** https://forum.shopware.com/t/bei-plugin-installation-feststellen-welches-theme-beim-user-aktiv-ist/44386
**Category:** Programmierung
**Created:** [10. März 2017 um 10:25 UTC](https://forum.shopware.com/t/bei-plugin-installation-feststellen-welches-theme-beim-user-aktiv-ist/44386 "2017-03-10T10:25:28Z")
**Posts on this page:** 3
**Page:** 2

<div class="post-metadata">

### Author: ![HolleWolle](https://avatars.discourse-cdn.com/v4/letter/h/e95f7d/32.png) [@HolleWolle](https://forum.shopware.com/u/HolleWolle)
#### Post date: [15. März 2017 um 13:12 UTC](https://forum.shopware.com/t/bei-plugin-installation-feststellen-welches-theme-beim-user-aktiv-ist/44386/21 "2017-03-15T13:12:01Z")

</div>

Na also, nun funktioniert es endlich, nachdem ich alles so umsortiert habe wie von Dir beschrieben. In Deiner Beschreibung weiter oben habe ich das wohl falsch verstanden.

---

<div class="post-metadata">

### Author: ![HolleWolle](https://avatars.discourse-cdn.com/v4/letter/h/e95f7d/32.png) [@HolleWolle](https://forum.shopware.com/u/HolleWolle)
#### Post date: [16. März 2017 um 12:13 UTC](https://forum.shopware.com/t/bei-plugin-installation-feststellen-welches-theme-beim-user-aktiv-ist/44386/22 "2017-03-16T12:13:50Z")

</div>

Tja, also nun funktioniert alles einwandfrei, aber sobald ich den Cache im Backend leere stürzen sowohl Frontend als auch Backend ab.  
503 Service Unavailable  
Die Fehlermeldungen sind gleich eine ganze Lawine und beginnen hiermit:

mod\_fcgid: stderr: PHP Fatal error: Uncaught exception ‘ReflectionException’ with message ‘Class SwagExtendCustomProducts\Subscriber\Backend does not exist’ in [/var/www/vhosts/xxx.de/httpdocs/xxx/custom/plugins/ShyimProfiler/Components/CompilerPass/EventSubscriberCompilerPass.php](https://h803.aix-cloud.de:8443/smb/file-manager/code-editor?currentDir=%2Fhttpdocs%2Fmopsix%2Fvar%2Fwww%2Fvhosts%2Fnature-vibes.de%2Fhttpdocs%2Fmopsix%2Fcustom%2Fplugins%2FShyimProfiler%2FComponents%2FCompilerPass&file=EventSubscriberCompilerPass.php&redirect=%2Fsmb%2Flog-file%2Fbrowser%2Fid%2F115 "Klicken Sie, um die Datei anzuzeigen."):42, referer: [http://www.xxx.com/backend/](http://www.xxx.com/backend/)

Was hat das nun wieder zu bedeuten?

Kann es sein, dass das mit der Registrierung des template-Verzeichnisses zu tun hat?  
Nun mache ich das ja so:

&nbsp;

```
public static function getSubscribedEvents()
    {
        return array(
			'Enlight_Controller_Action_PreDispatch_Frontend' => 'onGetControllerPath',
		);
    }

public function onGetControllerPath (\Enlight_Controller_ActionEventArgs $args)
	{
		/** @var \Enlight_Controller_Action $controller */
        $controller = $args->get('subject');
        $view = $controller->View();
        $this->container->get('Template')->addTemplateDir(
        $this->getPath() . '/Resources/views/'
        );
	}

```

Die template-Dateien liegen in custom\plugins\MeinPlugin\Resources\views\frontend.  
Muss ich den Pfad da eventuell noch genauer anpassen?

Das alles mal auskommentiert, also die onGetControllerPath und den ‘Enlight\_Controller\_Action\_PreDispatch\_Frontend’ =\> ‘onGetControllerPath’, nützt nichts, auch nicht das Reparieren der foreign keys…

---

<div class="post-metadata">

### Author: ![HolleWolle](https://avatars.discourse-cdn.com/v4/letter/h/e95f7d/32.png) [@HolleWolle](https://forum.shopware.com/u/HolleWolle)
#### Post date: [17. März 2017 um 08:38 UTC](https://forum.shopware.com/t/bei-plugin-installation-feststellen-welches-theme-beim-user-aktiv-ist/44386/23 "2017-03-17T08:38:36Z")

</div>

Also, ich komme da gerade echt nicht mehr mit.  
Folgende Fehlermeldung wird mir u.a. angezeigt:

Fehler: Das Verzeichnis /var/www/vhosts/xxx-xxx.de/httpdocs/xxx/var/www/vhosts/xxx-xxx.de/httpdocs/xxx/custom/plugins/ShyimProfiler/Components/CompilerPass kann nicht gefunden werden: filemng failed: filemng: stat failed: No such file or directory System error 2: No such file or directory

Wenn ich den ShyimProfiler nun deinstalliere stürzen Frontend und Backend weiterhin ab sobald ich den Cache vom shop leere. Einzig das Löschen meines plugins vom Server behebt die Sache wieder. Ich verstehe aber nicht wo dort der Fehler liegen kann zumal das plugin ja nun einwandfrei funktioniert. Das Problem taucht immer erst beim Leeren des caches auf.

Hat da irgendjemand einen Tipp woran das liegen könnte?

EDIT: Habe das Problem selber gelöst, es gab einen falschen Eintrag in der services.xml

&nbsp;

&nbsp;

&nbsp;

[Vorherige Seite](https://forum.shopware.com/t/bei-plugin-installation-feststellen-welches-theme-beim-user-aktiv-ist/44386.md?page=1)
