# Auf einmal 500er Fehler und Frontend down :(

**URL:** <https://forum.shopware.com/t/auf-einmal-500er-fehler-und-frontend-down/54609>\
**Category:** Administration\
**Created:** [14. August 2018 um 15:37 UTC](https://forum.shopware.com/t/auf-einmal-500er-fehler-und-frontend-down/54609 "2018-08-14T15:37:48Z")\
**Posts on this page:** 13\
**Page:** 1

<div class="post-metadata">

**Author:** ![NurIch](https://avatars.discourse-cdn.com/v4/letter/n/df705f/32.png) [@NurIch](https://forum.shopware.com/u/NurIch)\
**Post date:** [14. August 2018 um 15:37 UTC](https://forum.shopware.com/t/auf-einmal-500er-fehler-und-frontend-down/54609/1 "2018-08-14T15:37:48Z")

</div>

Hallo,

&nbsp;

keine Änderungen aber auf einmal Shop weg.

Ging los mit sporadischen 500er im backend

dann Frontend weg.

Chache geleer, Logging angestellt aber einzige was kommt:

Fatal error: Cannot redeclare Shopware\Models\Attribute\Customer::getArvAllowReminder() in /var/www/clients/client18/web32/web/var/cache/production\_201807181357/doctrine/attributes/Customer.php on line _403_

Cache gelöscht aber wird nicht besser.

Sicherheitsmodus mit Plugins proboert, aber bringt auch nix ☹

Wer hat eine Idee?

Danke

---

<div class="post-metadata">

**Author:** ![Moritz\_Naczenski](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/moritz_naczenski/32/7792_2.png) [@Moritz\_Naczenski](https://forum.shopware.com/u/Moritz_Naczenski)\
**Post date:** [14. August 2018 um 15:39 UTC](https://forum.shopware.com/t/auf-einmal-500er-fehler-und-frontend-down/54609/2 "2018-08-14T15:39:59Z")

</div>

Also die Ursache ist erstmal ein Plugin, was die Spalte „getArvAllowReminder“ erzeugt hat. Typischerweise bei Plugin-Deinstallation. Am besten gehst du mal in die Freitextfeld-Verwaltung und generierst das Model für die Tabelle s\_user\_attributes neu (da müsstest du in der Übersicht auch das Feld finden). Wenn das nichts hilft, sind wahrscheinlich die Foreign Keys defekt:&nbsp;[https://community.shopware.com/Foreign-Keys-reparieren\_detail\_954.html](https://community.shopware.com/Foreign-Keys-reparieren_detail_954.html)

---

<div class="post-metadata">

**Author:** ![NurIch](https://avatars.discourse-cdn.com/v4/letter/n/df705f/32.png) [@NurIch](https://forum.shopware.com/u/NurIch)\
**Post date:** [14. August 2018 um 15:48 UTC](https://forum.shopware.com/t/auf-einmal-500er-fehler-und-frontend-down/54609/3 "2018-08-14T15:48:22Z")

</div>

würde passen

Bewertungsreminder heute gelöscht ☹

Super Sache so ein Amokplugin.

Warum aber erst Stunden später?

&nbsp;

Und wie lange sollte das generien dauern?

---

<div class="post-metadata">

**Author:** ![Moritz\_Naczenski](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/moritz_naczenski/32/7792_2.png) [@Moritz\_Naczenski](https://forum.shopware.com/u/Moritz_Naczenski)\
**Post date:** [14. August 2018 um 15:52 UTC](https://forum.shopware.com/t/auf-einmal-500er-fehler-und-frontend-down/54609/4 "2018-08-14T15:52:58Z")

</div>

> [@NurIch schrieb:](https://forum.shopware.com/profile/17259/NurIch "NurIch")
> 
> würde passen
> 
> Bewertungsreminder heute gelöscht ![:(](https://dub1.discourse-cdn.com/flex013/resources/emoji/frowning.png ":(")
> 
> Super Sache so ein Amokplugin.
> 
> Warum aber erst Stunden später?
> 
> &nbsp;
> 
> Und wie lange sollte das generien dauern?

3 Sekunden oder sowas. Das geht ganz schnell.

Du könntest auch unter /var/cache/production\_…/doctrine/attributes die customer.php mal löschen und schauen, ob die neu erzeugt wird, nachdem du das Frontend aufrufst - wenn nicht, dann hast du wahrscheinlich die Foreign-Keys defekt. Ist die Spalte denn noch da?

Am besten machst du, wenn das nix bringt, mal die Foreign-Key Reparatur.&nbsp;

---

<div class="post-metadata">

**Author:** ![NurIch](https://avatars.discourse-cdn.com/v4/letter/n/df705f/32.png) [@NurIch](https://forum.shopware.com/u/NurIch)\
**Post date:** [14. August 2018 um 15:57 UTC](https://forum.shopware.com/t/auf-einmal-500er-fehler-und-frontend-down/54609/5 "2018-08-14T15:57:25Z")

</div>

Spalte ist noch da ☹

die Datei hatte ich schon gelöscht kam aber selber Fehler wieder.

---

<div class="post-metadata">

**Author:** ![NurIch](https://avatars.discourse-cdn.com/v4/letter/n/df705f/32.png) [@NurIch](https://forum.shopware.com/u/NurIch)\
**Post date:** [14. August 2018 um 16:02 UTC](https://forum.shopware.com/t/auf-einmal-500er-fehler-und-frontend-down/54609/6 "2018-08-14T16:02:23Z")

</div>

Okay foreign keys gemacht

Spalten sind noch immer da ☹

Jetzt wäre guter Rat mal teuer.

---

<div class="post-metadata">

**Author:** ![NurIch](https://avatars.discourse-cdn.com/v4/letter/n/df705f/32.png) [@NurIch](https://forum.shopware.com/u/NurIch)\
**Post date:** [14. August 2018 um 16:21 UTC](https://forum.shopware.com/t/auf-einmal-500er-fehler-und-frontend-down/54609/7 "2018-08-14T16:21:42Z")

</div>

Spalten von Hand gelöscht direkt in der DB

jetzt läuft es erstmal wieder

&nbsp;

---

<div class="post-metadata">

**Author:** ![spirotech](https://avatars.discourse-cdn.com/v4/letter/s/ed8c4c/32.png) [@spirotech](https://forum.shopware.com/u/spirotech)\
**Post date:** [14. August 2018 um 16:22 UTC](https://forum.shopware.com/t/auf-einmal-500er-fehler-und-frontend-down/54609/8 "2018-08-14T16:22:57Z")

</div>

Ich würde dann mal das entfernte Plugin wieder installieren (nur installieren nicht aktivieren). Dann sollte es auf jeden Fall wieder funktionieren.

Ansonsten Spalte aus Datenbank entfernen und Model neu generieren.

VG  
spiro

---

<div class="post-metadata">

**Author:** ![NurIch](https://avatars.discourse-cdn.com/v4/letter/n/df705f/32.png) [@NurIch](https://forum.shopware.com/u/NurIch)\
**Post date:** [14. August 2018 um 16:40 UTC](https://forum.shopware.com/t/auf-einmal-500er-fehler-und-frontend-down/54609/9 "2018-08-14T16:40:19Z")

</div>

Hier geht nix mehr ☹

Habe auch gedacht, Plugin wieder rein und gut ist.

Aber komme nicht mal mehr an Bestellungen ran ☹

---

<div class="post-metadata">

**Author:** ![Moritz\_Naczenski](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/moritz_naczenski/32/7792_2.png) [@Moritz\_Naczenski](https://forum.shopware.com/u/Moritz_Naczenski)\
**Post date:** [14. August 2018 um 16:48 UTC](https://forum.shopware.com/t/auf-einmal-500er-fehler-und-frontend-down/54609/10 "2018-08-14T16:48:18Z")

</div>

Schick mir mal Zugangsdaten ([forum@shopware.de](mailto:forum@shopware.de)) - Dann schau ich mal drauf.

Am besten wäre Backend, FTP und Datenbank/PHPMyAdmin.&nbsp;

---

<div class="post-metadata">

**Author:** ![NurIch](https://avatars.discourse-cdn.com/v4/letter/n/df705f/32.png) [@NurIch](https://forum.shopware.com/u/NurIch)\
**Post date:** [14. August 2018 um 17:06 UTC](https://forum.shopware.com/t/auf-einmal-500er-fehler-und-frontend-down/54609/11 "2018-08-14T17:06:25Z")

</div>

Okay Backup hat micht gerettet.

Zwar Tag kaputt, aber man kann es wieder nachstellen 🙂

---

<div class="post-metadata">

**Author:** ![BestShopPossible](https://avatars.discourse-cdn.com/v4/letter/b/6bbea6/32.png) [@BestShopPossible](https://forum.shopware.com/u/BestShopPossible)\
**Post date:** [15. August 2018 um 08:11 UTC](https://forum.shopware.com/t/auf-einmal-500er-fehler-und-frontend-down/54609/12 "2018-08-15T08:11:28Z")

</div>

> keine Änderungen aber auf einmal Shop weg.

> &nbsp;Bewertungsreminder heute gelöscht

---

<div class="post-metadata">

**Author:** ![NurIch](https://avatars.discourse-cdn.com/v4/letter/n/df705f/32.png) [@NurIch](https://forum.shopware.com/u/NurIch)\
**Post date:** [16. August 2018 um 12:51 UTC](https://forum.shopware.com/t/auf-einmal-500er-fehler-und-frontend-down/54609/13 "2018-08-16T12:51:05Z")

</div>

Ja weil der Abstand zwischen dem auslösen und der Änderung länger war als nur 5mins.

Wurde erst ausgelöst als Kunde bei Bestellung angab das er bewerten möchte.

12h dazwischen
