# APC Konfiguration

**URL:** <https://forum.shopware.com/t/apc-konfiguration/27890>\
**Category:** Administration\
**Created:** [3. Juni 2015 um 17:28 UTC](https://forum.shopware.com/t/apc-konfiguration/27890 "2015-06-03T17:28:44Z")\
**Posts on this page:** 10\
**Page:** 1

<div class="post-metadata">

**Author:** ![kinday](https://avatars.discourse-cdn.com/v4/letter/k/5e9695/32.png) [@kinday](https://forum.shopware.com/u/kinday)\
**Post date:** [3. Juni 2015 um 17:28 UTC](https://forum.shopware.com/t/apc-konfiguration/27890/1 "2015-06-03T17:28:44Z")

</div>

Hallo ich habe versucht in Shopware 5 das APC zu aktivieren. /etc/php5/conf.d/apc.ini ein: extension=apc.so apc.shm\_size = 512M und auch in der “config.php” folgendes eingetragen: `<?php return array (
  'db' => array ( 'host' =\> 'localhost', 'port' =\> '3306', 'username' =\> 'USER', 'password' =\> 'PASS', 'dbname' =\> 'DB', ), // Backend-Cache 'cache' =\> array( 'backend' =\> 'apc', 'backendOptions' =\> array(), 'frontendOptions' =\> array(), ), // Model-Cache 'model' =\> array( 'cacheProvider' =\> 'Apc' // supports Apc, Array, Wincache and Xcache ), 'httpCache' =\> array( 'enabled' =\> true, // Module aktivieren / deaktivieren - Muss z.B. für Varnish deaktiviert werden 'debug' =\> false, // Debug-Modus aktivieren - Cache-Informationen werden in den Header geschrieben 'stale\_if\_error' =\> false, // Im Fehlerfall eine ältere Version ausliefern ), );` Leider bekomme immer immer eine leere weiße Seite. Den Cache-Ordner habe ich auch gelöscht und neu hochgeladen, leider ohne Erfolg. Hat sich bei Shopware 5 was geändert? LG Mirko

---

<div class="post-metadata">

**Author:** ![SebastianKloepper](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/sebastiankloepper/32/21435_2.png) [@SebastianKloepper](https://forum.shopware.com/u/SebastianKloepper)\
**Post date:** [3. Juni 2015 um 17:48 UTC](https://forum.shopware.com/t/apc-konfiguration/27890/2 "2015-06-03T17:48:35Z")

</div>

Hi, du brauchst in der config.php eigentlich nur die Zugangsdaten zur DB. Alles Andere kann da erstmal raus. APC aktiviert/nutzt Shopware automatisch, wenn es auf dem Hosting aktiv ist Sebastian

---

<div class="post-metadata">

**Author:** ![kinday](https://avatars.discourse-cdn.com/v4/letter/k/5e9695/32.png) [@kinday](https://forum.shopware.com/u/kinday)\
**Post date:** [3. Juni 2015 um 18:02 UTC](https://forum.shopware.com/t/apc-konfiguration/27890/3 "2015-06-03T18:02:50Z")

</div>

Hallo Danke für die schnelle Antwort. Auch wenn ich nur die DB drin steht wird der Shop immer Leere Seite ohne Fehler und das Backend ist dann Blaue Seite aber kein Login. Error.log: `[Wed Jun 03 16:31:31 2015] [error] [client 85.180.205.236] PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php5/20100525/apc.so' - /usr/lib/php5/20100525/apc.so: cannot open shared object file: No such file or directory in Unknown on line 0, referer: http://www.domain...` Datei ist aber vorhanden. LG

---

<div class="post-metadata">

**Author:** ![SebastianKloepper](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/sebastiankloepper/32/21435_2.png) [@SebastianKloepper](https://forum.shopware.com/u/SebastianKloepper)\
**Post date:** [3. Juni 2015 um 18:18 UTC](https://forum.shopware.com/t/apc-konfiguration/27890/4 "2015-06-03T18:18:00Z")

</div>

Das wird dann aber am Hosting liegen. APC scheint wohl nicht richtig zu laufen Sebastian

---

<div class="post-metadata">

**Author:** ![kinday](https://avatars.discourse-cdn.com/v4/letter/k/5e9695/32.png) [@kinday](https://forum.shopware.com/u/kinday)\
**Post date:** [3. Juni 2015 um 18:21 UTC](https://forum.shopware.com/t/apc-konfiguration/27890/5 "2015-06-03T18:21:50Z")

</div>

Kannst du was mit der Fehlermeldung anfangen? Habe es so installiert: aptitude update aptitude install php-apc und in Datei /etc/php5/conf.d/apc.ini ein: extension=apc.so apc.shm\_size = 512M eingetragen. PHP Version 5.4.39-0+deb7u2 LG Mirko

---

<div class="post-metadata">

**Author:** ![TimmeHosting](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/timmehosting/32/15580_2.png) [@TimmeHosting](https://forum.shopware.com/u/TimmeHosting)\
**Post date:** [4. Juni 2015 um 00:14 UTC](https://forum.shopware.com/t/apc-konfiguration/27890/6 "2015-06-04T00:14:39Z")

</div>

Wie ist denn die Ausgabe von `ls -la /usr/lib/php5/20100525/`?

---

<div class="post-metadata">

**Author:** ![kinday](https://avatars.discourse-cdn.com/v4/letter/k/5e9695/32.png) [@kinday](https://forum.shopware.com/u/kinday)\
**Post date:** [8. Juni 2015 um 09:54 UTC](https://forum.shopware.com/t/apc-konfiguration/27890/7 "2015-06-08T09:54:04Z")

</div>

Ausgabe: `root@kd01:~# ls -la /usr/lib/php5/20100525/ insgesamt 1316 drwxr-xr-x 2 root root 4096 Jun 3 16:38 . drwxr-xr-x 4 root root 4096 Mai 5 22:38 .. -rw-r--r-- 1 root root 159304 Sep 4 2012 apc.so -rw-r--r-- 1 root root 72048 Mär 25 09:47 curl.so -rw-r--r-- 1 root root 104576 Mär 25 09:47 gd.so -rw-r--r-- 1 root root 415328 Apr 3 2012 imagick.so -rw-r--r-- 1 root root 100480 Mär 25 09:47 imap.so -rw-r--r-- 1 root root 43192 Mär 25 09:47 mcrypt.so -rw-r--r-- 1 root root 141528 Mär 25 09:47 mysqli.so -rw-r--r-- 1 root root 55432 Mär 25 09:47 mysql.so -rw-r--r-- 1 root root 35224 Mär 25 09:47 pdo\_mysql.so -rw-r--r-- 1 root root 113072 Mär 25 09:47 pdo.so -rw-r--r-- 1 root root 31128 Mär 25 09:47 pdo\_sqlite.so -rw-r--r-- 1 root root 48584 Mär 25 09:47 sqlite3.so root@kd01:~# ` Wenn ich APC aktiviere kommt im Backend nur der Login, nach eingabe kann ich nur noch den blauen Hintergrund von der Administration sehen, aber keine Menüs oder der gleichen. Fontend ist nur eine weiße leere Seite. Zusätzlich bekomme ich per Email alle Sekunde folgende Fehlermeldung: `ERROR Message: exception 'Zend\_Session\_Exception' with message 'Zend\_Session::start() - /var/www/KD01/htdocs/dildo-discount.com/engine/Library/Zend/Db/Table/Abstract.php(Line:839): Error #1024 Failed saving metadata to metadataCache' in /var/www/KD01/htdocs/dildo-discount.com/engine/Library/Zend/Session.php:506 Stack trace: #0 /var/www/KD01/htdocs/dildo-discount.com/engine/Shopware/Components/DependencyInjection/Bridge/Session.php(77): Zend\_Session::start(Array) #1 /var/www/KD01/htdocs/dildo-discount.com/cache/production\_201505261453/proxies/ShopwareProductionProjectContainer.php(556): Shopware\Components\DependencyInjection\Bridge\Session-\>factory(Object(ShopwareProductionProjectContainer)) #2 /var/www/KD01/htdocs/dildo-discount.com/vendor/symfony/dependency-injection/Symfony/Component/DependencyInjection/Container.php(326): ShopwareProductionProjectContainer-\>getSessionService() #3 /var/www/KD01/htdocs/dildo-discount.com/engine/Shopware/Components/DependencyInjection/Container.php(253): Symfony\Component\DependencyInjection\Container-\>get('session') #4 /var/www/KD01/htdocs/dildo-discount.com/engine/Shopware/Components/DependencyInjection/Container.php(188): Shopware\Components\DependencyInjection\Container-\>load('session') #5 /var/www/KD01/htdocs/dildo-discount.com/engine/Shopware/Bundle/StoreFrontBundle/Service/Core/ContextService.php(171): Shopware\Components\DependencyInjection\Container-\>get('session') #6 /var/www/KD01/htdocs/dildo-discount.com/engine/Shopware/Models/Shop/Shop.php(711): Shopware\Bundle\StoreFrontBundle\Service\Core\ContextService-\>initializeShopContext() #7 /var/www/KD01/htdocs/dildo-discount.com/engine/Shopware/Plugins/Default/Core/Router/Bootstrap.php(129): Shopware\Models\Shop\Shop-\>registerResources(Object(Shopware\_Proxies\_ShopwareBootstrapProxy)) #8 /var/www/KD01/htdocs/dildo-discount.com/engine/Library/Enlight/Event/Handler/Plugin.php(149): Shopware\_Plugins\_Core\_Router\_Bootstrap-\>onRouteStartup(Object(Enlight\_Controller\_EventArgs)) #9 /var/www/KD01/htdocs/dildo-discount.com/engine/Library/Enlight/Event/EventManager.php(211): Enlight\_Event\_Handler\_Plugin-\>execute(Object(Enlight\_Controller\_EventArgs)) #10 /var/www/KD01/htdocs/dildo-discount.com/engine/Library/Enlight/Controller/Front.php(162): Enlight\_Event\_EventManager-\>notify('Enlight\_Control...', Object(Enlight\_Controller\_EventArgs)) #11 /var/www/KD01/htdocs/dildo-discount.com/engine/Shopware/Kernel.php(143): Enlight\_Controller\_Front-\>dispatch() #12 /var/www/KD01/htdocs/dildo-discount.com/vendor/symfony/http-kernel/Symfony/Component/HttpKernel/HttpCache/HttpCache.php(490): Shopware\Kernel-\>handle(Object(Symfony\Component\HttpFoundation\Request), 1, true) #13 /var/www/KD01/htdocs/dildo-discount.com/engine/Shopware/Components/HttpCache/AppCache.php(255): Symfony\Component\HttpKernel\HttpCache\HttpCache-\>forward(Object(Symfony\Component\HttpFoundation\Request), true, NULL) #14 /var/www/KD01/htdocs/dildo-discount.com/vendor/symfony/http-kernel/Symfony/Component/HttpKernel/HttpCache/HttpCache.php(447): Shopware\Components\HttpCache\AppCache-\>forward(Object(Symfony\Component\HttpFoundation\Request), true) #15 /var/www/KD01/htdocs/dildo-discount.com/vendor/symfony/http-kernel/Symfony/Component/HttpKernel/HttpCache/HttpCache.php(347): Symfony\Component\HttpKernel\HttpCache\HttpCache-\>fetch(Object(Symfony\Component\HttpFoundation\Request), true) #16 /var/www/KD01/htdocs/dildo-discount.com/engine/Shopware/Components/HttpCache/AppCache.php(178): Symfony\Component\HttpKernel\HttpCache\HttpCache-\>lookup(Object(Symfony\Component\HttpFoundation\Request), true) #17 /var/www/KD01/htdocs/dildo-discount.com/vendor/symfony/http-kernel/Symfony/Component/HttpKernel/HttpCache/HttpCache.php(211): Shopware\Components\HttpCache\AppCache-\>lookup(Object(Symfony\Component\HttpFoundation\Request), true) #18 /var/www/KD01/htdocs/dildo-discount.com/engine/Shopware/Components/HttpCache/AppCache.php(114): Symfony\Component\HttpKernel\HttpCache\HttpCache-\>handle(Object(Symfony\Component\HttpFoundation\Request), 1, true) #19 /var/www/KD01/htdocs/dildo-discount.com/shopware.php(101): Shopware\Components\HttpCache\AppCache-\>handle(Object(Symfony\Component\HttpFoundation\Request)) #20 {main} Time: 2015-06-08T09:45:15.844666+0200 Channel: core request: { "uri": "/de/sextoys/vibratoren/aufladbare-vibratoren/3651/jojo-jellyfish-in-violett?c=180", "method": "GET", "query": { "c": "180" }, "post": [] } session: No session data available shopId: 1 shopName: Deutsch ` Bitte um Hilfe…danke

---

<div class="post-metadata">

**Author:** ![kinday](https://avatars.discourse-cdn.com/v4/letter/k/5e9695/32.png) [@kinday](https://forum.shopware.com/u/kinday)\
**Post date:** [14. Juni 2015 um 20:50 UTC](https://forum.shopware.com/t/apc-konfiguration/27890/8 "2015-06-14T20:50:22Z")

</div>

Habe schon alles ausprobiert, aber sobald ich APC aktiviere bekomme ich nur Error per Email und weiße Seite…

---

<div class="post-metadata">

**Author:** ![kinday](https://avatars.discourse-cdn.com/v4/letter/k/5e9695/32.png) [@kinday](https://forum.shopware.com/u/kinday)\
**Post date:** [16. Juni 2015 um 10:14 UTC](https://forum.shopware.com/t/apc-konfiguration/27890/9 "2015-06-16T10:14:33Z")

</div>

Kann mir keiner weiterhelfen?

---

<div class="post-metadata">

**Author:** ![Heiner\_Lohaus](https://avatars.discourse-cdn.com/v4/letter/h/b5a626/32.png) [@Heiner\_Lohaus](https://forum.shopware.com/u/Heiner_Lohaus)\
**Post date:** [16. Juni 2015 um 10:28 UTC](https://forum.shopware.com/t/apc-konfiguration/27890/10 "2015-06-16T10:28:49Z")

</div>

Ja, nein. Keiner kann dir helfen. Der Fehler liegt auf deinem System. Dein APC ist defekt. Das besagt auch die Fehler-eMail. Vielleicht musst du deine OS-Version vom APCu deinstallieren und es über PCEL manuell installieren: Beispiel: [http://www.phpgangsta.de/apcu-der-neue-user-cache](http://www.phpgangsta.de/apcu-der-neue-user-cache) Das “-beta” kannst/musst du weg lassen. Heiner
