# Andauernder ERROR Code: 405

**URL:** <https://forum.shopware.com/t/andauernder-error-code-405/41151>\
**Category:** Allgemein\
**Created:** [7. November 2016 um 11:26 UTC](https://forum.shopware.com/t/andauernder-error-code-405/41151 "2016-11-07T11:26:07Z")\
**Posts on this page:** 8\
**Page:** 1

<div class="post-metadata">

**Author:** ![plasmatixx](https://avatars.discourse-cdn.com/v4/letter/p/e99b99/32.png) [@plasmatixx](https://forum.shopware.com/u/plasmatixx)\
**Post date:** [7. November 2016 um 11:26 UTC](https://forum.shopware.com/t/andauernder-error-code-405/41151/1 "2016-11-07T11:26:07Z")

</div>

**Ich habe alles Caches (auch proxi) gelöscht.**

**Trotzdem erhalte ich permantent diese untenstehende Fehlermeldung per Email.**

**Hat einer eine Idee?**

Fehlermeldung 1:

**------------**

**ERROR**

**Message:**

Reverse proxy returned invalid status code

**Time:**

2016-11-07T11:43:17.713784+0100

**Channel:**

core

**Context:**

{

&nbsp; &nbsp; “response”: “”,

&nbsp; &nbsp; “code”: 405

}

**request:**

{

&nbsp; &nbsp; “uri”: “/backend/Cache/clearCache”,

&nbsp; &nbsp; “method”: “POST”,

&nbsp; &nbsp; “query”: {

&nbsp; &nbsp; &nbsp; &nbsp; “module”: “backend”,

&nbsp; &nbsp; &nbsp; &nbsp; “controller”: “Cache”,

&nbsp; &nbsp; &nbsp; &nbsp; “action”: “clearCache”

&nbsp; &nbsp; },

&nbsp; &nbsp; “post”: {

&nbsp; &nbsp; &nbsp; &nbsp; “\_\_csrf\_token”: “BGKwaHyDDi5oIJLKO1epkTZSSwHMSs”,

&nbsp; &nbsp; &nbsp; &nbsp; “cache”: {

&nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; “config”: “on”,

&nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; “template”: “on”,

&nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; “theme”: “on”,

&nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; “http”: “on”,

&nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; “proxy”: “on”,

&nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; “search”: “on”,

&nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; “router”: “on”

&nbsp; &nbsp; &nbsp; &nbsp; }

&nbsp; &nbsp; }

}

**shop:**

No shop data available

**session:**

{

&nbsp; &nbsp; “userId”: “50”,

&nbsp; &nbsp; “roleId”: “1”

}

* * *

Fehlermeldung 2:

**----------**

**ERROR**

**Message:**

Reverse proxy returned invalid status code

**Time:**

2016-11-07T11:43:17.725071+0100

**Channel:**

core

**Context:**

{

&nbsp; &nbsp; “response”: “”,

&nbsp; &nbsp; “code”: 405

}

**request:**

{

&nbsp; &nbsp; “uri”: “/backend/Cache/clearCache”,

&nbsp; &nbsp; “method”: “POST”,

&nbsp; &nbsp; “query”: {

&nbsp; &nbsp; &nbsp; &nbsp; “module”: “backend”,

&nbsp; &nbsp; &nbsp; &nbsp; “controller”: “Cache”,

&nbsp; &nbsp; &nbsp; &nbsp; “action”: “clearCache”

&nbsp; &nbsp; },

&nbsp; &nbsp; “post”: {

&nbsp; &nbsp; &nbsp; &nbsp; “\_\_csrf\_token”: “BGKwaHyDDi5oIJLKO1epkTZSSwHMSs”,

&nbsp; &nbsp; &nbsp; &nbsp; “cache”: {

&nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; “config”: “on”,

&nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; “template”: “on”,

&nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; “theme”: “on”,

&nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; “http”: “on”,

&nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; “proxy”: “on”,

&nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; “search”: “on”,

&nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; “router”: “on”

&nbsp; &nbsp; &nbsp; &nbsp; }

&nbsp; &nbsp; }

}

**shop:**

No shop data available

**session:**

{

&nbsp; &nbsp; “userId”: “50”,

&nbsp; &nbsp; “roleId”: “1”

}

---

<div class="post-metadata">

**Author:** ![plasmatixx](https://avatars.discourse-cdn.com/v4/letter/p/e99b99/32.png) [@plasmatixx](https://forum.shopware.com/u/plasmatixx)\
**Post date:** [7. November 2016 um 11:27 UTC](https://forum.shopware.com/t/andauernder-error-code-405/41151/2 "2016-11-07T11:27:33Z")

</div>

Ach ja, im&nbsp;Einsatz ist die aktuellste Shopware Version 5.2.9

---

<div class="post-metadata">

**Author:** ![Moritz\_Naczenski](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/moritz_naczenski/32/7792_2.png) [@Moritz\_Naczenski](https://forum.shopware.com/u/Moritz_Naczenski)\
**Post date:** [7. November 2016 um 11:35 UTC](https://forum.shopware.com/t/andauernder-error-code-405/41151/3 "2016-11-07T11:35:55Z")

</div>

Shopware sendet zur invalidierung des Caches einen BAN-Request an den Server. Der wird vom Server abgelehnt.

Du kannst entweder die Cache-Invalidierung im Performance-Modul deaktivieren oder deinen Hoster fragen, warum der Server mit einem 405 antwortet.

---

<div class="post-metadata">

**Author:** ![plasmatixx](https://avatars.discourse-cdn.com/v4/letter/p/e99b99/32.png) [@plasmatixx](https://forum.shopware.com/u/plasmatixx)\
**Post date:** [7. November 2016 um 12:05 UTC](https://forum.shopware.com/t/andauernder-error-code-405/41151/4 "2016-11-07T12:05:38Z")

</div>

Danke dir!

Hat das deaktivierten der&nbsp;Cache-Invalidierung im Performance-Modul denn grundsätzlich Nachteile?

Gruß  
Stefan

---

<div class="post-metadata">

**Author:** ![Moritz\_Naczenski](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/moritz_naczenski/32/7792_2.png) [@Moritz\_Naczenski](https://forum.shopware.com/u/Moritz_Naczenski)\
**Post date:** [7. November 2016 um 12:58 UTC](https://forum.shopware.com/t/andauernder-error-code-405/41151/5 "2016-11-07T12:58:04Z")

</div>

Für dich konkret jetzt erstmal nicht - denn es funktioniert ja aktuell anscheinend nicht.

Generell ist die Cache-Invalidierung dafür da, dass wenn du im Backend etwas speicherst (bspw. einen Artikel) du den Cache nicht löschen musst, sondern der Cache für diesen einen Artikel automatisch invalidiert wird, d.h. deine Änderungen werden direkt sichtbar.

---

<div class="post-metadata">

**Author:** ![foodloose](https://avatars.discourse-cdn.com/v4/letter/f/45deac/32.png) [@foodloose](https://forum.shopware.com/u/foodloose)\
**Post date:** [11. Januar 2017 um 17:23 UTC](https://forum.shopware.com/t/andauernder-error-code-405/41151/6 "2017-01-11T17:23:29Z")

</div>

Hallo Moritz,

ich habe bei mir die „Automatische Cache-Invalidierung“ deaktiviert, der Fehler tritt trotzdem weiterhin auf.&nbsp;

Mittwald sieht den Fehler in meiner Installation, nicht bei deren Server, siehe auch mein Kommentar hier:&nbsp;[https://forum.shopware.com/discussion/comment/182774/](https://forum.shopware.com/discussion/comment/182774/)

Viele Grüße

Simon

---

<div class="post-metadata">

**Author:** ![dogado\_shops](https://avatars.discourse-cdn.com/v4/letter/d/b4bc9f/32.png) [@dogado\_shops](https://forum.shopware.com/u/dogado_shops)\
**Post date:** [11. Januar 2017 um 21:13 UTC](https://forum.shopware.com/t/andauernder-error-code-405/41151/7 "2017-01-11T21:13:15Z")

</div>

Habt ihr versucht, die CSRF Protection probeweise abzuschalten ?&nbsp;

In Euren Fehlermeldungen finden sich zumindest entsprechende Hinweise auf das CSRF Token.  
Häufig sind Zahlungsanbieter-Plugins die Ursache.

Siehe [CSRF Protection](https://developers.shopware.com/developers-guide/csrf-protection/)

---

<div class="post-metadata">

**Author:** ![myartstore](https://avatars.discourse-cdn.com/v4/letter/m/7ea924/32.png) [@myartstore](https://forum.shopware.com/u/myartstore)\
**Post date:** [18. Januar 2017 um 14:42 UTC](https://forum.shopware.com/t/andauernder-error-code-405/41151/8 "2017-01-18T14:42:34Z")

</div>

Problem wird mit Update auf 5.2.14 beseitigt
