# Advanced Import/Export-Modul: Import Error - Kann Datei zum Lesen nicht öffnen

**URL:** <https://forum.shopware.com/t/advanced-import-export-modul-import-error-kann-datei-zum-lesen-nicht-offnen/34133>\
**Category:** Plugins\
**Tags:** offizielle-shopware-\
**Created:** [2. Februar 2016 um 09:25 UTC](https://forum.shopware.com/t/advanced-import-export-modul-import-error-kann-datei-zum-lesen-nicht-offnen/34133 "2016-02-02T09:25:48Z")\
**Posts on this page:** 13\
**Page:** 1

<div class="post-metadata">

**Author:** ![PeterR](https://avatars.discourse-cdn.com/v4/letter/p/9de0a6/32.png) [@PeterR](https://forum.shopware.com/u/PeterR)\
**Post date:** [2. Februar 2016 um 09:25 UTC](https://forum.shopware.com/t/advanced-import-export-modul-import-error-kann-datei-zum-lesen-nicht-offnen/34133/1 "2016-02-02T09:25:48Z")

</div>

Hallo zusammen,

ich nutze seit einiger Zeit das Import/Export-Advanced Modul in Shopware 5.1.2.

Beim Import von Bildern per CSV-Datei erhalte ich folgende Fehlermeldung:&nbsp;

_Import Error_

_Kann&nbsp;[http://PfadzumBild.jpg](http://pfadzumbild.jpg/)&nbsp;nicht zum Lesen öffnen_

Verwunderlich ist, dass der Import mit dem selbem Profil, dem selben Ordner auf dem Server schon funktioniert hat. Die Dateirechte für den Ordner, in dem die Bilder liegen, sowie die Rechte der Bilder selber stehen auf -rwxrwxrwx. Funktioniert trotzdem nicht.

Von meiner lokalen Testumgebung auf meinem PC kann ich auf den selben Link jedoch zugreifen und die Bilder werden importiert.

Der http-Link lässt sich auch im Browser öffnen und das jpg erscheint.

&nbsp;

Habt ihr einen Hinweis, wo der Fehler liegen könnte?

Viele Grüße,

Peter

---

<div class="post-metadata">

**Author:** ![Moritz\_Naczenski](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/moritz_naczenski/32/7792_2.png) [@Moritz\_Naczenski](https://forum.shopware.com/u/Moritz_Naczenski)\
**Post date:** [2. Februar 2016 um 09:33 UTC](https://forum.shopware.com/t/advanced-import-export-modul-import-error-kann-datei-zum-lesen-nicht-offnen/34133/2 "2016-02-02T09:33:43Z")

</div>

Hallo,

hast du allow\_url\_fopen auf dem Server aktiv? Das wird zwingend zum Bildimport benötigt. Ob das aktiv ist, kannst du in der Systeminfo prüfen.

Ansonsten darf es bspw. keinen .htaccess-Schutz geben.

Moritz

---

<div class="post-metadata">

**Author:** ![PeterR](https://avatars.discourse-cdn.com/v4/letter/p/9de0a6/32.png) [@PeterR](https://forum.shopware.com/u/PeterR)\
**Post date:** [2. Februar 2016 um 09:53 UTC](https://forum.shopware.com/t/advanced-import-export-modul-import-error-kann-datei-zum-lesen-nicht-offnen/34133/3 "2016-02-02T09:53:09Z")

</div>

Hallo Moritz,

danke für deine schnelle Antwort.

allow\_url\_fopen ist aktiv, allow\_url\_include ist nicht aktiv.

Wie checke ich den .htacces-Schutz. Die Datei „.htaccess“ gibt es schon im Root-Verzeichnis von Shopware.

&nbsp;

Danke!

Peter

---

<div class="post-metadata">

**Author:** ![PeterR](https://avatars.discourse-cdn.com/v4/letter/p/9de0a6/32.png) [@PeterR](https://forum.shopware.com/u/PeterR)\
**Post date:** [4. Februar 2016 um 08:14 UTC](https://forum.shopware.com/t/advanced-import-export-modul-import-error-kann-datei-zum-lesen-nicht-offnen/34133/4 "2016-02-04T08:14:55Z")

</div>

Hat sonst niemand eine Idee, wo die Ursache liegen könnte?

---

<div class="post-metadata">

**Author:** ![Dr.Rivera](https://avatars.discourse-cdn.com/v4/letter/d/b38774/32.png) [@Dr.Rivera](https://forum.shopware.com/u/Dr.Rivera)\
**Post date:** [8. Februar 2016 um 11:28 UTC](https://forum.shopware.com/t/advanced-import-export-modul-import-error-kann-datei-zum-lesen-nicht-offnen/34133/5 "2016-02-08T11:28:36Z")

</div>

Hallo,

ob ich dir helfen kann, weiß ich nicht. Es ist so, dass ich versuche, beim import export plugin den Durchblick zu erreichen. Das benötigt jedoch offensichtlich Zeit…

Nun, ich hatte auch die Fehlermeldung mit "_nicht zum Lesen öffnen"_ beim Import von Bildern bekommen. Bei mir lag es am Verzeichnisschutz, den ich für die Domain angelegt hatte. Nach dem Entfernen des Verzeichnis-Schutzes konnte ich Bilder importieren.

Ich habe unter meiner Domain den Ordner “bilder” angelegt. Dorthin habe ich dann die Bilder per FTP hochgeladen. Nach dem Import wurden automatisch die Thumbnails erstellt und die Bilder sind im Medienordner unter Artikel drinnen.

Bei mir fehlt jedoch jetzt ein Bild unter “zuletzt angesehen”…Das muss ich noch herausbekommen…

Gründsätzlich muss ich sagen, dass ich bei diversen Versuchen auch auf Granit gebissen haben.

Vor allem mit dem Exportieren der Testdaten. Das anschließende Importieren ist manchmal unmöglich.

Vieleicht gibt es noch etwas Unterstützung von Leuten hier, die mit dem Plugin schon etwas vertrauter sind.

&nbsp;

Grüße

---

<div class="post-metadata">

**Author:** ![PeterR](https://avatars.discourse-cdn.com/v4/letter/p/9de0a6/32.png) [@PeterR](https://forum.shopware.com/u/PeterR)\
**Post date:** [10. Februar 2016 um 09:35 UTC](https://forum.shopware.com/t/advanced-import-export-modul-import-error-kann-datei-zum-lesen-nicht-offnen/34133/6 "2016-02-10T09:35:56Z")

</div>

Wo genau fehlt dir das Bild?

---

<div class="post-metadata">

**Author:** ![d.meier](https://avatars.discourse-cdn.com/v4/letter/d/a3d4f5/32.png) [@d.meier](https://forum.shopware.com/u/d.meier)\
**Post date:** [11. Februar 2016 um 19:07 UTC](https://forum.shopware.com/t/advanced-import-export-modul-import-error-kann-datei-zum-lesen-nicht-offnen/34133/7 "2016-02-11T19:07:14Z")

</div>

Also ich habe das gleiche Problem. Wenn jedoch&nbsp;die Bilder auf&nbsp;einem anderen Server -\>ohne SSL

---

<div class="post-metadata">

**Author:** ![Dr.Rivera](https://avatars.discourse-cdn.com/v4/letter/d/b38774/32.png) [@Dr.Rivera](https://forum.shopware.com/u/Dr.Rivera)\
**Post date:** [13. Februar 2016 um 15:00 UTC](https://forum.shopware.com/t/advanced-import-export-modul-import-error-kann-datei-zum-lesen-nicht-offnen/34133/8 "2016-02-13T15:00:24Z")

</div>

> [@PeterR schrieb:](https://forum.shopware.com/profile/22959/PeterR "PeterR")
> 
> Wo genau fehlt dir das Bild?

Hallo,

danke für die Nachfrage. Es fehlt bei mir kein Bild, war ein cache Problem.

Interessant fände ich noch die Frage, welche Erfahrungen die User hier gemacht haben mit Import und Export Aktionen unter PHP 7.&nbsp; Alles problemlos?

&nbsp;

Grüße

---

<div class="post-metadata">

**Author:** ![TitusKurth](https://avatars.discourse-cdn.com/v4/letter/t/ccd318/32.png) [@TitusKurth](https://forum.shopware.com/u/TitusKurth)\
**Post date:** [19. Februar 2016 um 07:25 UTC](https://forum.shopware.com/t/advanced-import-export-modul-import-error-kann-datei-zum-lesen-nicht-offnen/34133/9 "2016-02-19T07:25:38Z")

</div>

Um noch einmal bei der&nbsp;Urspünglichen Frage zu helfen:

* * *

_Import Error_

_Kann&nbsp;[http://PfadzumBild.jpg](http://pfadzumbild.jpg/)&nbsp;nicht zum Lesen öffnen_

* * *

Bei mir war hinter der Pfadangabe ein Leerzeichen, dieses wurde von Shopware zu einem „\_“ umgewandelt.  
Das Leerzeichen habe ich entfernt, und schon geht es.

---

<div class="post-metadata">

**Author:** ![PeterR](https://avatars.discourse-cdn.com/v4/letter/p/9de0a6/32.png) [@PeterR](https://forum.shopware.com/u/PeterR)\
**Post date:** [19. Februar 2016 um 13:28 UTC](https://forum.shopware.com/t/advanced-import-export-modul-import-error-kann-datei-zum-lesen-nicht-offnen/34133/10 "2016-02-19T13:28:29Z")

</div>

Danke für den Tip. An das hatten wir auch schon gedacht, leider ohne Erfolg.  
Als Workaround haben wir folgende Lösung:  
Wir speichern die Bilder in einem Verzeichnis einer anderen Domain (und damit anderer Server)  
Von dort importieren wir dann die Bilder ohne Probleme  
Funktioniert zwar aber gerne würde ich mir den Zwischenschritt sparen. Sollte noch jemand einen Hinweis haben, warum der direkte Inmport der Bilder&nbsp;scheitert, wäre ich sehr dankbar.  
Viele Grüße, Peter

---

<div class="post-metadata">

**Author:** ![TitusKurth](https://avatars.discourse-cdn.com/v4/letter/t/ccd318/32.png) [@TitusKurth](https://forum.shopware.com/u/TitusKurth)\
**Post date:** [19. Februar 2016 um 15:01 UTC](https://forum.shopware.com/t/advanced-import-export-modul-import-error-kann-datei-zum-lesen-nicht-offnen/34133/11 "2016-02-19T15:01:52Z")

</div>

Im Wiki steht auch das die Bilder nicht im Media Verzeichnis gespeichert sein sollen.

Schick doch bitte mal einen solchen Link, dann kann ich mir das mal ansehen.&nbsp;

---

<div class="post-metadata">

**Author:** ![lampenstar](https://avatars.discourse-cdn.com/v4/letter/l/e47c2d/32.png) [@lampenstar](https://forum.shopware.com/u/lampenstar)\
**Post date:** [13. Juli 2016 um 10:08 UTC](https://forum.shopware.com/t/advanced-import-export-modul-import-error-kann-datei-zum-lesen-nicht-offnen/34133/12 "2016-07-13T10:08:48Z")

</div>

Wir haben leider das gleiche Problem, hat hier inzwischen jemand einen “Fehler” gefunden?

Evtl. eine Server einstellung?

```
Import Error
Kann http://xxx.net/xxx/xxx.jpg nicht zum Lesen öffnen

```

&nbsp;

---

<div class="post-metadata">

**Author:** ![vhafner](https://avatars.discourse-cdn.com/v4/letter/v/5f8ce5/32.png) [@vhafner](https://forum.shopware.com/u/vhafner)\
**Post date:** [20. November 2016 um 09:13 UTC](https://forum.shopware.com/t/advanced-import-export-modul-import-error-kann-datei-zum-lesen-nicht-offnen/34133/13 "2016-11-20T09:13:04Z")

</div>

ha, &nbsp;habe nun das selbe problem gehabt, aber die lösung gefunden: SSL-verschlüsselung!!

einfach mit https:// aufrufen statt mit http://

&nbsp;
