# Admin only: Redis connection refused

**URL:** https://forum.shopware.com/t/admin-only-redis-connection-refused/103405
**Category:** Shopware 6 (German)
**Tags:** general, installation--gettin, administration
**Created:** [21. März 2024 um 23:14 UTC](https://forum.shopware.com/t/admin-only-redis-connection-refused/103405 "2024-03-21T23:14:13Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![Nico-CP](https://avatars.discourse-cdn.com/v4/letter/n/f1d935/32.png) [@Nico-CP](https://forum.shopware.com/u/Nico-CP)
#### Post date: [21. März 2024 um 23:14 UTC](https://forum.shopware.com/t/admin-only-redis-connection-refused/103405/1 "2024-03-21T23:14:13Z")

</div>

Hallo zusammen,

ich habe kürzlich meinen Cache auf Redis umgestellt. Soweit sieht alles gut aus, der Redis-Server läuft auf localhost:6379, die framework.yaml ist angepasst, die redis-cli gibt „OK“ und auch ein „PONG“ zurück.  
Ich kann den Cache leeren und sehe auch sonst keine Probleme.

Nur in Erweiterungen beim installieren, aktualisieren oder deinstallieren von Plugins bekomme ich den Fehler:  
_Internal Server Error_  
_Redis connection failed: Connection refused_

Shopware Version: 6.5.8.7  
Redis Version: 7.2.3

Ich habe keine Änderung an der redis.conf vorgenommen. Was man so im Internet zu dem Fehler findet, habe ich geprüft / probiert. Z.B. ob der user „redis“ Zugang zu _/var/log/redis_ oder _/etc/redis_ hat.  
Alle Framework.yaml settings verweisen auf redis://localhost:6379/0.  
Firewall an/aus. Telnet localhost 6379 funktioniert auch.

Ich finde leider auch so gar keine relevanten Logeinträge zu Redis auf dem Server.

Any ideas?

Danke euch!  
Nico

---

<div class="post-metadata">

### Author: ![Nico-CP](https://avatars.discourse-cdn.com/v4/letter/n/f1d935/32.png) [@Nico-CP](https://forum.shopware.com/u/Nico-CP)
#### Post date: [22. März 2024 um 15:59 UTC](https://forum.shopware.com/t/admin-only-redis-connection-refused/103405/2 "2024-03-22T15:59:01Z")

</div>

Okay ich glaube ich habe den Fehler nun selbst gefunden.  
Meine _vendor/shopware/core/Framework/Resources/config/packages/shopware.yaml_ hatte in der redis\_url vom http\_cache noch „redis://redis“ stehen, statt die korrekten Daten zu verwenden. 🤦‍♂️

Jetzt scheint das Problem gelöst.

---

<div class="post-metadata">

### Author: ![system](https://europe1.discourse-cdn.com/flex013/uploads/shopware/original/3X/2/9/29c7587ba660f00e4995d1743162782e5d6d8653.svg) [@system](https://forum.shopware.com/u/system)
#### Post date: [21. April 2024 um 15:59 UTC](https://forum.shopware.com/t/admin-only-redis-connection-refused/103405/3 "2024-04-21T15:59:57Z")

</div>

Dieses Thema wurde automatisch 30 Tage nach der letzten Antwort geschlossen. Es sind keine neuen Antworten mehr erlaubt.
