# Admin Login Fehler nach Update auf 6.5

**URL:** <https://forum.shopware.com/t/admin-login-fehler-nach-update-auf-6-5/100792>\
**Category:** Shopware 6 (German)\
**Tags:** administration, update\
**Created:** [9. August 2023 um 15:55 UTC](https://forum.shopware.com/t/admin-login-fehler-nach-update-auf-6-5/100792 "2023-08-09T15:55:58Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![fischer1](https://avatars.discourse-cdn.com/v4/letter/f/a5b964/32.png) [@fischer1](https://forum.shopware.com/u/fischer1)\
**Post date:** [9. August 2023 um 15:55 UTC](https://forum.shopware.com/t/admin-login-fehler-nach-update-auf-6-5/100792/1 "2023-08-09T15:55:59Z")

</div>

Ich habe ein seltsames Problem:  
Nach Update auf 6.5.x ist es nicht mehr möglich mit meinem „normalen“ Adminaccount auf das Backend zuzugreifen. „bin/console system:generate-jwt-secret --force“ und auch Zurücksetzen des Passworts per ssh hat nicht funktioniert. Im Shop gibt es jedoch noch andere Admins, bei denen funktioniert der Zugang noch.

Doch jetzt wird es strange (für mich zumindest):

1. Ich gehe mit einem der funktionierenden Admins ins Backend und lege neue Adminaccount(s) an.
2. Daraufhin der Versuch mit dem neuen Admin anzumelden: Fehlgeschlagen!
3. Passwort Vergessen Funktion gibt folgenden Fehler: Failed to acquire the „oauth-neueradmin-188.193.254.100“ lock.
4. Der Versuch über eine andere IP (Netzwerk meines Nachbars) mich mit dem neuen Admin anzumelden funktioniert!

Meine Frage:  
Gibt es irgendwo im System eine Blacklist in der meine aktuelle IP Adresse steht?

---

<div class="post-metadata">

**Author:** ![tauchservice](https://avatars.discourse-cdn.com/v4/letter/t/ac8455/32.png) [@tauchservice](https://forum.shopware.com/u/tauchservice)\
**Post date:** [21. August 2023 um 09:35 UTC](https://forum.shopware.com/t/admin-login-fehler-nach-update-auf-6-5/100792/2 "2023-08-21T09:35:15Z")

</div>

Das gleiche Problem tauch bei mir leider nach einem Update von 6.4.20.0 auf 6.5.4.0 auf.  
(Symfony\Component\Lock\Exception\LockStorageException(code: 0): fopen(/tmp/sf.oauth--.mdQ0oTU.lock)

Ein zweiter Admin kann ohne Probleme arbeiten, mein User funktioniert in einem anderen Netz auch problemlos.

Aber auch bei erfolgreichem Login werden solche Zeilen erzeugt  
(Symfony\Component\Lock\Exception\LockStorageException(code: 0): fopen(/tmp/sf.message\_queue\_consume\_async.XFTuaDS.lock)

/tmp ist ganz normal beschreibbar und es liegt auch keine gleichnahmige Datei dort rum…

---

<div class="post-metadata">

**Author:** ![tauchservice](https://avatars.discourse-cdn.com/v4/letter/t/ac8455/32.png) [@tauchservice](https://forum.shopware.com/u/tauchservice)\
**Post date:** [25. August 2023 um 07:29 UTC](https://forum.shopware.com/t/admin-login-fehler-nach-update-auf-6-5/100792/3 "2023-08-25T07:29:12Z")

</div>

Soo… ich habe für mich eine Lösung gefunden.  
Bei mir hat es eine Ergänzung in der .env.local gelöst  
LOCK\_DSN=flock:///www/htdocs/xxxx/domain.tld/var/lock

Den Order lock muss man im var Verzeichniss mit anlegen!

Bei mir (Hoster All-Inkl) ist der /tmp Bereich der PHP Session nicht der gleiche, wie man in der SSH Console findet… Augenscheinlich scheint es in diesem anderen /tmp Bereich zu Konflikten zu kommen. Seit ich File Lock Beriech umgebogen habe, ist das Problem nicht mehr aufgetaucht.

---

<div class="post-metadata">

**Author:** ![kweb](https://avatars.discourse-cdn.com/v4/letter/k/e19adc/32.png) [@kweb](https://forum.shopware.com/u/kweb)\
**Post date:** [12. September 2023 um 13:51 UTC](https://forum.shopware.com/t/admin-login-fehler-nach-update-auf-6-5/100792/4 "2023-09-12T13:51:51Z")

</div>

Danke! Ich bin fast verzeifelt!

---

<div class="post-metadata">

**Author:** ![fischer1](https://avatars.discourse-cdn.com/v4/letter/f/a5b964/32.png) [@fischer1](https://forum.shopware.com/u/fischer1)\
**Post date:** [12. September 2023 um 14:23 UTC](https://forum.shopware.com/t/admin-login-fehler-nach-update-auf-6-5/100792/5 "2023-09-12T14:23:17Z")

</div>

Auch von mir ein dickes Dankeschön. Endlich komme ich wieder in meinen Shop.

---

<div class="post-metadata">

**Author:** ![PlasticSurf](https://avatars.discourse-cdn.com/v4/letter/p/3e96dc/32.png) [@PlasticSurf](https://forum.shopware.com/u/PlasticSurf)\
**Post date:** [24. Oktober 2023 um 21:59 UTC](https://forum.shopware.com/t/admin-login-fehler-nach-update-auf-6-5/100792/6 "2023-10-24T21:59:18Z")

</div>

Ja, fetten Dank auch von mir.
