# 503 Service Unavailable nach Update

**URL:** <https://forum.shopware.com/t/503-service-unavailable-nach-update/43187>\
**Category:** Installation/Einstieg\
**Created:** [27. Januar 2017 um 16:01 UTC](https://forum.shopware.com/t/503-service-unavailable-nach-update/43187 "2017-01-27T16:01:57Z")\
**Posts on this page:** 9\
**Page:** 1

<div class="post-metadata">

**Author:** ![ARJ](https://avatars.discourse-cdn.com/v4/letter/a/ecae2f/32.png) [@ARJ](https://forum.shopware.com/u/ARJ)\
**Post date:** [27. Januar 2017 um 16:01 UTC](https://forum.shopware.com/t/503-service-unavailable-nach-update/43187/1 "2017-01-27T16:01:57Z")

</div>

Moin moin,&nbsp;

habe vorhin das Update auf 5.2.16 gestartet und bekomme jetzt eine&nbsp;503 Service Unavailable&nbsp;Fehlermeldung.

Zuerst war das wegen der nicht unterstützte PHP Version:  
**Error  
Your server is running PHP version 5.5.24 but Shopware 5 requires at least PHP 5.6.4**

**Fehler  
Auf Ihrem Server läuft PHP version 5.5.24, Shopware 5 benötigt mindestens PHP 5.6.4**

Jetzt habe ich PHP auf 7.0.15 umgestellt und bekomme folgende Fehlermeldung:  
**Fatal error: Uncaught UnexpectedValueException: DirectoryIterator::** \_\_construct(/var/www/vhosts/my-domain.com/httpdocs/custom/plugins): failed to open dir: No such file or directory in /var/www/vhosts/my-domain.com/httpdocs/engine/Shopware/Bundle/PluginInstallerBundle/Service/PluginInitializer.php:67 Stack trace: #0 /var/www/vhosts/my-domain.com/httpdocs/engine/Shopware/Bundle/PluginInstallerBundle/Service/PluginInitializer.php(67): DirectoryIterator-\>\_\_construct(’/var/www/vhosts…’) #1 /var/www/vhosts/my-domain.com/httpdocs/engine/Shopware/Kernel.php(305): Shopware\Bundle\PluginInstallerBundle\Service\PluginInitializer-\>initializePlugins() #2 /var/www/vhosts/my-domain.com/httpdocs/engine/Shopware/Kernel.php(270): Shopware\Kernel-\>initializePlugins() #3 /var/www/vhosts/my-domain.com/httpdocs/engine/Shopware/Components/HttpCache/AppCache.php(249): Shopware\Kernel-\>boot() #4 /var/www/vhosts/my-domain.com/httpdocs/vendor/symfony/http-kernel/HttpCache/HttpCache.php(258): Shopware\Components\HttpCache\AppCache-\>f in /var/www/vhosts/my-domain.com/httpdocs/engine/Shopware/Bundle/PluginInstallerBundle/Service/PluginInitializer.php on line 67  
503 Service Unavailable

Weiss jemand rat?

---

<div class="post-metadata">

**Author:** ![SebastianKloepper](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/sebastiankloepper/32/21435_2.png) [@SebastianKloepper](https://forum.shopware.com/u/SebastianKloepper)\
**Post date:** [27. Januar 2017 um 17:32 UTC](https://forum.shopware.com/t/503-service-unavailable-nach-update/43187/2 "2017-01-27T17:32:43Z")

</div>

Hallo,

die Meldung sagt jetzt nur, dass ein Ordner fehlt oder nicht volle Lese- und Schreibrechte besitzt. In dem Falle geht es laut der Meldung um den Ordner

/custom/plugins

Sebastian

---

<div class="post-metadata">

**Author:** ![mybabyshop24](https://avatars.discourse-cdn.com/v4/letter/m/f14d63/32.png) [@mybabyshop24](https://forum.shopware.com/u/mybabyshop24)\
**Post date:** [31. Januar 2017 um 07:30 UTC](https://forum.shopware.com/t/503-service-unavailable-nach-update/43187/3 "2017-01-31T07:30:32Z")

</div>

Hallo,

ich habe ein ähnliches Problem. Nach dem Update auf 5.2.16 erhalte ich im Backend nur noch - 503 Service Unavailable -&nbsp;

Das Frontend funktioniert.&nbsp;Weiss jemand rat?

&nbsp;

&nbsp;

---

<div class="post-metadata">

**Author:** ![sschreier](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/sschreier/32/23296_2.png) [@sschreier](https://forum.shopware.com/u/sschreier)\
**Post date:** [31. Januar 2017 um 07:33 UTC](https://forum.shopware.com/t/503-service-unavailable-nach-update/43187/4 "2017-01-31T07:33:11Z")

</div>

> [@mybabyshop24 schrieb:](https://forum.shopware.com/profile/2911/mybabyshop24 "mybabyshop24")
> 
> Hallo,
> 
> ich habe ein ähnliches Problem. Nach dem Update auf 5.2.16 erhalte ich im Backend nur noch - 503 Service Unavailable -&nbsp;
> 
> Das Frontend funktioniert.&nbsp;Weiss jemand rat?

Hallo,

am besten einfach die Shopware - Debug - Parameter der eigenen **config.php** - Datei ergänzen und sich die „richtige“ Fehlermeldung ausgeben lassen: [Debugging Shopware](https://developers.shopware.com/developers-guide/debugging/#default-log-output) .

Beste Grüße

Sebastian

---

<div class="post-metadata">

**Author:** ![mybabyshop24](https://avatars.discourse-cdn.com/v4/letter/m/f14d63/32.png) [@mybabyshop24](https://forum.shopware.com/u/mybabyshop24)\
**Post date:** [31. Januar 2017 um 08:46 UTC](https://forum.shopware.com/t/503-service-unavailable-nach-update/43187/5 "2017-01-31T08:46:10Z")

</div>

Hallo,

danke aber von sowas hab ich keine Ahnung das geht ja in Richtung Programmierung.&nbsp;Mit welchen Programmen muss ich die Dateien öffnen?

&nbsp;

&nbsp;

---

<div class="post-metadata">

**Author:** ![sschreier](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/sschreier/32/23296_2.png) [@sschreier](https://forum.shopware.com/u/sschreier)\
**Post date:** [31. Januar 2017 um 08:48 UTC](https://forum.shopware.com/t/503-service-unavailable-nach-update/43187/6 "2017-01-31T08:48:39Z")

</div>

> [@mybabyshop24 schrieb:](https://forum.shopware.com/profile/2911/mybabyshop24 "mybabyshop24")
> 
> Hallo,
> 
> danke aber von sowas hab ich keine Ahnung das geht ja in Richtung Programmierung.&nbsp;Mit welchen Programmen muss ich die Dateien öffnen?

Hallo,

du kannst die Datei problemlos mit einem Texteditor oder einem anderen kostenlosen Bearbeitungsprogramm (Notepad++) öffnen und bearbeiten / ergänzen. Das hat auch nichts mit programmieren zu tun, man muss einfach nur den bestehenden Inhalt um die dort aufgelisteten Zeilen ergänzen, fertig. Andernfalls würde ich dir empfehlen, einen Betreuer für den Shop zu suchen, weil man schon wenigstens die Debug - Parameter von Shopware hinterlegen können sollte (weil man sonst nie eine Aussage geben kann, woran es liegen könnte, den jeder bräuchte zumindestens die „richtige Fehlermeldung“). Andernfalls lohnt sich auch ein Blick ins log - Verzeichnis auf dem Server.

Beste Grüße

Sebastian

---

<div class="post-metadata">

**Author:** ![mybabyshop24](https://avatars.discourse-cdn.com/v4/letter/m/f14d63/32.png) [@mybabyshop24](https://forum.shopware.com/u/mybabyshop24)\
**Post date:** [31. Januar 2017 um 09:47 UTC](https://forum.shopware.com/t/503-service-unavailable-nach-update/43187/7 "2017-01-31T09:47:15Z")

</div>

Hallo Sebastian,

also ich habe das jetzt nach Anweisung gemacht und jetzt bekomme ich folgendes zu sehen:

Die Seite&nbsp;[www.levia-dessous-shop.de](http://www.levia-dessous-shop.de)&nbsp;funktioniert nicht

**[www.levia-dessous-shop.de](http://www.levia-dessous-shop.de)** &nbsp;kann diese Anfrage momentan nicht verarbeiten.

HTTP ERROR 500

---

<div class="post-metadata">

**Author:** ![ARJ](https://avatars.discourse-cdn.com/v4/letter/a/ecae2f/32.png) [@ARJ](https://forum.shopware.com/u/ARJ)\
**Post date:** [31. Januar 2017 um 12:26 UTC](https://forum.shopware.com/t/503-service-unavailable-nach-update/43187/8 "2017-01-31T12:26:20Z")

</div>

Hi,

HTTP ERROR 500 heißt so viel wie da ist was grundsäzliches auf dem Web-Server falsch gelaufen somit kann der Server den Browser nicht bedienen. An deiner stelle würde ich ein Backup zurückspielen und das Update neu starten.&nbsp;

Wichtig wäre dabei, dass du zuerst dein PHP Version auf die erforderliche Version 5.6.4 bringst. Das war das Problem bei mir. Wenn du das Update startet und vorher die PHP Version nicht stimmen sollte, beginnt das Update und bricht irgendwann ab. Nachträgliches update von PHP bringt dann auch nichts, da in Datenbank bereits einige Tabellen angelegt werden und das erneute Update von Shopware daran sich stört und alles nicht weiter geht.&nbsp;

Ich habe es so gelöst, dass ich auf dem Server Shopware -Daten und DB gelöscht habe, ein Backup auf dem Server zurück gespielt, PHP auf neuen Version gebracht und dann erst das Update von Shopware neu gestartet habe. Bis auf kleinigkeiten wegen eines PlugIns läuft alles ohne Probleme, das PlugIn habe ich auch bereits hinbekommen.

Viel Erfolg

---

<div class="post-metadata">

**Author:** ![mybabyshop24](https://avatars.discourse-cdn.com/v4/letter/m/f14d63/32.png) [@mybabyshop24](https://forum.shopware.com/u/mybabyshop24)\
**Post date:** [31. Januar 2017 um 12:32 UTC](https://forum.shopware.com/t/503-service-unavailable-nach-update/43187/9 "2017-01-31T12:32:43Z")

</div>

Hallo ARJ,

vielen Dank werde es versuchen.

&nbsp;
