# 500 Internal Server Error - Pluginmanager nach SW Update 5.1 auf 5.2

**URL:** <https://forum.shopware.com/t/500-internal-server-error-pluginmanager-nach-sw-update-5-1-auf-5-2/42439>\
**Category:** Administration\
**Created:** [27. Dezember 2016 um 21:21 UTC](https://forum.shopware.com/t/500-internal-server-error-pluginmanager-nach-sw-update-5-1-auf-5-2/42439 "2016-12-27T21:21:37Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![dschu87](https://avatars.discourse-cdn.com/v4/letter/d/bbe5ce/32.png) [@dschu87](https://forum.shopware.com/u/dschu87)\
**Post date:** [27. Dezember 2016 um 21:21 UTC](https://forum.shopware.com/t/500-internal-server-error-pluginmanager-nach-sw-update-5-1-auf-5-2/42439/1 "2016-12-27T21:21:37Z")

</div>

Hallo zusammen,

nach dem update von Shopware 5.1 auf 5.2.12 bekomme ich nun leider jedes mal beim starten des Plugin-Managers folgende Fehlermeldung:

“500 Internal Server Error Internal Server Error The server encountered an internal error or misconfiguration and was unable to complete your request. Please contact the server administrator, [no address given] and inform them of the time the error occurred, and anything you might have done that may have caused the error. More information about this error may be available in the server error log. Was hat dieser Fehler zu bedeuten? Dieser Fehler kann viele verschiedene Ursachen haben. Die h�ufigsten Fehler sind: bei PHP das Script hat zu viel CPU-Ressourcen verbraucht und wurde beendet das Script hat zu viel Memory-Ressourcen verbraucht und wurde beendet. In diesem Fall finden Sie eine Zeile �hnlich wie diese in Ihrem error.log “Unable to allocate X bytes” .htaccess Datei mit falschen Befehlen (mehr Informationen im error.log) weitere Informationen finden Sie in der Datei error.log im Ordner logs bei Perl und anderen Scriptsprachen das Script hat zu viel CPU-Ressourcen verbraucht und wurde beendet das Script hat zu viel Memory-Ressourcen verbraucht und wurde beendet. In diesem Fall finden Sie eine Zeile �hnlich wie diese in Ihrem error.log “Unable to allocate X bytes” Script wurde nicht im ASCII Modus hochgeladen Script hat falsche Rechte (korrekt: 755) der Pfad zum Interpreter in der 1. Zeile ist nicht korrekt .htaccess Datei mit falschen Befehlen (mehr Informationen im error.log) weitere Informationen finden Sie in der Datei error.log im Ordner logs”

Zudem werden mir unter den installierten Plugins keine Plugins angezeigt und ich&nbsp;kann keine Plugins Aktualisieren (die Daten werden zwar geladen, danach&nbsp;passiert aber nichts…). Das führt dazu, dass ich den Shop noch nicht wieder in den Betriebmodus setzten kann.

Leider konnte ich in den Logs nichts sehen und die htaccess scheint mir auch fehlerfrei zu sein. Habt ihr eine Ahnung was ich machen kann?&nbsp;

---

<div class="post-metadata">

**Author:** ![steinsoftware](https://avatars.discourse-cdn.com/v4/letter/s/b487fb/32.png) [@steinsoftware](https://forum.shopware.com/u/steinsoftware)\
**Post date:** [28. Dezember 2016 um 07:31 UTC](https://forum.shopware.com/t/500-internal-server-error-pluginmanager-nach-sw-update-5-1-auf-5-2/42439/2 "2016-12-28T07:31:10Z")

</div>

Tja die Lösung steht tatsächlich in den Error-Logs.

---

<div class="post-metadata">

**Author:** ![dschu87](https://avatars.discourse-cdn.com/v4/letter/d/bbe5ce/32.png) [@dschu87](https://forum.shopware.com/u/dschu87)\
**Post date:** [28. Dezember 2016 um 08:28 UTC](https://forum.shopware.com/t/500-internal-server-error-pluginmanager-nach-sw-update-5-1-auf-5-2/42439/3 "2016-12-28T08:28:22Z")

</div>

Die Error-Logs habe ich mir angeschaut. Ich erhallte in der Error-Log die Fehlermeldung “End of script output before headers: php5.6”\_.&nbsp;\_Meine Vermuting ist, dass Schreib- oder Leseberechtigungen für ein Plugin oder ähnliches fehlen. Leider ist das nur eine Vermutung und ich konnte bislang noch nicht herausfinden wo genau welche Berechtigungen fehlen sollen&nbsp;bzw. ob das überhaupt der Fall ist.&nbsp;

---

<div class="post-metadata">

**Author:** ![dschu87](https://avatars.discourse-cdn.com/v4/letter/d/bbe5ce/32.png) [@dschu87](https://forum.shopware.com/u/dschu87)\
**Post date:** [28. Dezember 2016 um 08:35 UTC](https://forum.shopware.com/t/500-internal-server-error-pluginmanager-nach-sw-update-5-1-auf-5-2/42439/4 "2016-12-28T08:35:11Z")

</div>

Wenn ich außerdem mal die Console von Chrome öffne erhalte ich folgende Fehlermeldung:

"Die nachfolgenden Hinweise sollten Ihnen weiterhelfen.

The provided CSRF-Token is invalid. If you’re sure that the request should be valid, the called controller action needs to be whitelisted using the CSRFWhitelistAware interface. in engine/Shopware/Components/CSRFTokenValidator.php on line 118

Stack trace:

```
 #0 [internal function]: Shopware\Components\CSRFTokenValidator-\>checkBackendTokenValidation(Object(Enlight\_Controller\_ActionEventArgs)) #1 engine/Library/Enlight/Event/Handler/Default.php(91): call\_user\_func(Array, Object(Enlight\_Controller\_ActionEventArgs)) #2 engine/Library/Enlight/Event/EventManager.php(214): Enlight\_Event\_Handler\_Default-\>execute(Object(Enlight\_Controller\_ActionEventArgs)) #3 engine/Library/Enlight/Controller/Action.php(143): Enlight\_Event\_EventManager-\>notify('Enlight\_Control...', Object(Enlight\_Controller\_ActionEventArgs)) #4 engine/Library/Enlight/Controller/Dispatcher/Default.php(523): Enlight\_Controller\_Action-\>dispatch('localListingAct...') #5 engine/Library/Enlight/Controller/Front.php(223): Enlight\_Controller\_Dispatcher\_Default-\>dispatch(Object(Enlight\_Controller\_Request\_RequestHttp), Object(Enlight\_Controller\_Response\_ResponseHttp)) #6 engine/Shopware/Kernel.php(178): Enlight\_Controller\_Front-\>dispatch() #7 vendor/symfony/http-kernel/HttpCache/HttpCache.php(487): Shopware\Kernel-\>handle(Object(Symfony\Component\HttpFoundation\Request), 1, true) #8 engine/Shopware/Components/HttpCache/AppCache.php(255): Symfony\Component\HttpKernel\HttpCache\HttpCache-\>forward(Object(Symfony\Component\HttpFoundation\Request), true, NULL) #9 vendor/symfony/http-kernel/HttpCache/HttpCache.php(258): Shopware\Components\HttpCache\AppCache-\>forward(Object(Symfony\Component\HttpFoundation\Request), true) #10 engine/Shopware/Components/HttpCache/AppCache.php(103): Symfony\Component\HttpKernel\HttpCache\HttpCache-\>pass(Object(Symfony\Component\HttpFoundation\Request), true) #11 shopware.php(113): Shopware\Components\HttpCache\AppCache-\>handle(Object(Symfony\Component\HttpFoundation\Request)) #12 {main}"

```

&nbsp;

Könnte das auch was damit zusammenhängen?

&nbsp;

---

<div class="post-metadata">

**Author:** ![R4M](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/r4m/32/9983_2.png) [@R4M](https://forum.shopware.com/u/R4M)\
**Post date:** [3. Januar 2017 um 14:34 UTC](https://forum.shopware.com/t/500-internal-server-error-pluginmanager-nach-sw-update-5-1-auf-5-2/42439/5 "2017-01-03T14:34:20Z")

</div>

> nach dem update von Shopware 5.1 auf 5.2.12

Eventuell VOR dem Update mal die Plugins überprüft ob die für 5.2. noch kompatible sind?&nbsp;

Siehe: [http://community.shopware.com/\_detail\_1921\_441.html](http://community.shopware.com/_detail_1921_441.html)

Zum Testen mal in die config.php

```
'csrfProtection' => [
    'frontend' => false,
    'backend' => false
],

```

&nbsp;

---

<div class="post-metadata">

**Author:** ![dschu87](https://avatars.discourse-cdn.com/v4/letter/d/bbe5ce/32.png) [@dschu87](https://forum.shopware.com/u/dschu87)\
**Post date:** [16. Januar 2017 um 12:04 UTC](https://forum.shopware.com/t/500-internal-server-error-pluginmanager-nach-sw-update-5-1-auf-5-2/42439/6 "2017-01-16T12:04:23Z")

</div>

Letztendlich musste ich ein Plugin komplett deaktivieren und von Hand aus der Datenbank und dem Server löschen.
