# 500 internal Server Error bei Strato Managed Server

**URL:** <https://forum.shopware.com/t/500-internal-server-error-bei-strato-managed-server/7139>\
**Category:** Shopware 3.5\
**Tags:** installation--gettin\
**Created:** [16. Mai 2012 um 15:31 UTC](https://forum.shopware.com/t/500-internal-server-error-bei-strato-managed-server/7139 "2012-05-16T15:31:42Z")\
**Posts on this page:** 9\
**Page:** 1

<div class="post-metadata">

**Author:** ![Artur\_Nietsch](https://avatars.discourse-cdn.com/v4/letter/a/ed8c4c/32.png) [@Artur\_Nietsch](https://forum.shopware.com/u/Artur_Nietsch)\
**Post date:** [16. Mai 2012 um 15:31 UTC](https://forum.shopware.com/t/500-internal-server-error-bei-strato-managed-server/7139/1 "2012-05-16T15:31:42Z")

</div>

Hallo Shopware Community, mein erster Beitrag beginnt mit einem Problem: Nach erfolgreicher Installation von Shopware auf einem Strato Managed Server kommt beim Aufruf der Startseite zwar Inhalt, aber ohne Template etc. und wenn man einen Link z.B. Impressum anklickt, dann erhalte ich einen 500 internal Server Error. Die Anforderungen bei der Installation werden alle erfüllt und die Installation läuft ohne Probleme durch. Der Adminbereich vom Shop kann ebenfalls nicht aufgerufen werden. Telefonisch konnte mir seitens Strato und Shopware keiner helfen, daher hoffe ich auf die Community. Es handelt sich um die Domain [www.artur-nietsch.com](http://www.artur-nietsch.com) (ich teste weiter) Liegt es evtl an den htaccess Einstellungen? [code]  
RewriteEngine on

#RewriteBase /shopware/

RewriteRule shopware.dll shopware.php  
RewriteRule files/documents/.\* engine [NC,L]  
RewriteRule application.yaml engine [NC,L]  
RewriteRule images/ayww/(.\*) images/banner/1 RewriteRule sitemap.xml(.\*) shopware.php?controller=SitemapXml RewriteRule templates/.\*(css|js) engine/backend/php/sCacheTemplate.php?file=0 [NC,L] RewriteRule engine/core/php/sAjaxSearch.php engine/backend/php/sAjaxSearch.php [NC,L]  
RewriteRule engine/core/php/campaigns.php$ engine/backend/php/campaigns.php [NC,L]

RewriteCond %{REQUEST\_URI} !(engine/|images/|files/|templates/|.js$|.css$|.jpg$|.png$)  
RewriteCond %{REQUEST\_FILENAME} !-f  
RewriteCond %{REQUEST\_FILENAME} !-d  
RewriteRule ^(.\*)$ shopware.php [PT,L,QSA]  
DirectoryIndex index.php DirectoryIndex shopware.php  
Deny from all  
Options -Indexes # Options -MultiViews # php\_value memory\_limit 128M # php\_value max\_execution\_time 18000 # php\_flag magic\_quotes\_gpc off # php\_flag session.auto\_start off # php\_flag suhosin.session.cryptua off # php\_flag zend.ze1\_compatibility\_mode Off # AddType x-mapp-php5 .php # AddHandler x-mapp-php5 .php[/code] Der Shop ist im Verzeichnis htdocs/xy installiert Vielen Dank.

---

<div class="post-metadata">

**Author:** ![Lucas\_Schluter](https://avatars.discourse-cdn.com/v4/letter/l/a8b319/32.png) [@Lucas\_Schluter](https://forum.shopware.com/u/Lucas_Schluter)\
**Post date:** [16. Mai 2012 um 16:27 UTC](https://forum.shopware.com/t/500-internal-server-error-bei-strato-managed-server/7139/2 "2012-05-16T16:27:26Z")

</div>

Hallo, werden die Shopware Systemanforderungen vom Server erfüllt? Dies kann man ganz einfach mit dem System Check Tool prüfen. Am Besten auch direkt nach Erfüllung der Anforderungen ein neues Unterverzeichnis erstellen und dort erneut das Check Tool ausführen. Hier müssen dann auch direkt die Anforderungen erfüllt werden. Mehr Infos gibt es unter [http://wiki.shopware.de/SystemCheck-Too … l\_135.html](http://wiki.shopware.de/SystemCheck-Tool%5C_detail%5C_135.html) Wenn die Systemanforderungen erfüllt werden, einfach noch einmal eine ganz neue Installation durchführen. Beste Grüße

---

<div class="post-metadata">

**Author:** ![Artur\_Nietsch](https://avatars.discourse-cdn.com/v4/letter/a/ed8c4c/32.png) [@Artur\_Nietsch](https://forum.shopware.com/u/Artur_Nietsch)\
**Post date:** [16. Mai 2012 um 17:24 UTC](https://forum.shopware.com/t/500-internal-server-error-bei-strato-managed-server/7139/3 "2012-05-16T17:24:22Z")

</div>

[quote=“Lucas Schlüter”]Hallo, werden die Shopware Systemanforderungen vom Server erfüllt? Dies kann man ganz einfach mit dem System Check Tool prüfen. Am Besten auch direkt nach Erfüllung der Anforderungen ein neues Unterverzeichnis erstellen und dort erneut das Check Tool ausführen. Hier müssen dann auch direkt die Anforderungen erfüllt werden. [/quote] - Werden im Hauptordner erfüllt: [http://www.artur-nietsch.com/check.php](http://www.artur-nietsch.com/check.php) - Werden im Unterordner nicht erfüllt: [http://www.artur-nietsch.com/test/check.php](http://www.artur-nietsch.com/test/check.php) Erörtert habe ich mit dem Shopware Service, dass es an folgendem liegen könnte: php.ini - Verlinkung / Vererbung muss für Unterordner beim Server automatisiert gegeben sein. Wenn man den Pfad wie folgt aufruft: [http://www.artur-nietsch.com/shopware.php](http://www.artur-nietsch.com/shopware.php) , dann wird die Index mehr oder weniger angezeigt. Die Subverlinkung funktioniert leider weiter nicht. Evtl. liegt es an der htaccess konfiguration? Folgenden Server nutze ich bei Strato: (Level 3 [https://www.strato-pro.com/ger/managed-server/#/linux/](https://www.strato-pro.com/ger/managed-server/#/linux/) Es würde wirklich freuen, wenn jemand eine Lösung zur Hand hat. Bin auch telefonisch erreichbar unter 02923-9725788 Besten Dank

---

<div class="post-metadata">

**Author:** ![SebastianKloepper](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/sebastiankloepper/32/21435_2.png) [@SebastianKloepper](https://forum.shopware.com/u/SebastianKloepper)\
**Post date:** [16. Mai 2012 um 18:18 UTC](https://forum.shopware.com/t/500-internal-server-error-bei-strato-managed-server/7139/4 "2012-05-16T18:18:19Z")

</div>

Hi, kannst du in der htaccess mal testweise die Zeile Options -Indexes auskommentieren?

---

<div class="post-metadata">

**Author:** ![Artur\_Nietsch](https://avatars.discourse-cdn.com/v4/letter/a/ed8c4c/32.png) [@Artur\_Nietsch](https://forum.shopware.com/u/Artur_Nietsch)\
**Post date:** [16. Mai 2012 um 18:25 UTC](https://forum.shopware.com/t/500-internal-server-error-bei-strato-managed-server/7139/5 "2012-05-16T18:25:01Z")

</div>

`#RewriteBase /shopware/` Was fällt da auf? --\> Ist # nicht ein Zeichen für auskommentieren? Frage: weshalb wird die .htaccess mit auskommentierter “RewriteBase” Zeile bei der Neuinstallation ausgeliefert… Die Testversion scheint nun zu FUNKTIONIEREN! 🙂 weshalb dies keinem Techniker aufgefallen ist? Fazit: Ich installiere Shopware nochmals neu und schaue, ob es wirklich daran gelegen hat. Meldung folgt.

---

<div class="post-metadata">

**Author:** ![SebastianKloepper](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/sebastiankloepper/32/21435_2.png) [@SebastianKloepper](https://forum.shopware.com/u/SebastianKloepper)\
**Post date:** [16. Mai 2012 um 18:28 UTC](https://forum.shopware.com/t/500-internal-server-error-bei-strato-managed-server/7139/6 "2012-05-16T18:28:30Z")

</div>

Hi, der RewriteBase wird bei 99% der Pakete nicht benötigt. Daher wird die htaccess standardmäßig mit dieser Option deaktiviert ausgeliefert. Wichtige FAQ’s kannst du z.B. im Installations-Tutorial finden: [http://wiki.shopware.de/Installation-3. … ovider\_FAQ](http://wiki.shopware.de/Installation-3.5%5C_detail%5C_518.html#Provider%5C_FAQ)

---

<div class="post-metadata">

**Author:** ![Artur\_Nietsch](https://avatars.discourse-cdn.com/v4/letter/a/ed8c4c/32.png) [@Artur\_Nietsch](https://forum.shopware.com/u/Artur_Nietsch)\
**Post date:** [16. Mai 2012 um 18:53 UTC](https://forum.shopware.com/t/500-internal-server-error-bei-strato-managed-server/7139/7 "2012-05-16T18:53:16Z")

</div>

Problem gelöst: [www.artur-nietsch.com](http://www.artur-nietsch.com) Die Installation ist wie im Vorfeld auch erfolgreich durchgelaufen. Weshalb die Startseite zwar aufgerufen werden konnte und alle anderen Pfade nicht? Lösung: nach der frischen Installation ist in der .htaccess die Zeile #RewriteBase /shopware/ mit einem „#“ Zeichen auskommentiert. Geändert in: RewriteBase / Das wars. Muss nun nur noch das Strato Ticket auflösen 🙂 und bei Shopware im Kundenservice bescheid geben… da werden einige schmunzeln … ich auch…

---

<div class="post-metadata">

**Author:** ![shank23](https://avatars.discourse-cdn.com/v4/letter/s/5fc32e/32.png) [@shank23](https://forum.shopware.com/u/shank23)\
**Post date:** [12. Februar 2014 um 00:51 UTC](https://forum.shopware.com/t/500-internal-server-error-bei-strato-managed-server/7139/8 "2014-02-12T00:51:19Z")

</div>

Hab genau das selbe Problem, hast du im FTP das Zeichen weg gemacht oder hast du die komplette CMS gelöscht und dann neu instaliert aber ohne das Zeichen ?

---

<div class="post-metadata">

**Author:** ![Artur\_Nietsch](https://avatars.discourse-cdn.com/v4/letter/a/ed8c4c/32.png) [@Artur\_Nietsch](https://forum.shopware.com/u/Artur_Nietsch)\
**Post date:** [12. Februar 2014 um 09:37 UTC](https://forum.shopware.com/t/500-internal-server-error-bei-strato-managed-server/7139/9 "2014-02-12T09:37:03Z")

</div>

Hi, mittlerweile habe ich mich von Strato verabschiedet und bin nun bei [Profihost](http://www.profihost.com/partnerprogramm/click.pl?p=nietsch), dem Hoster, der auch Shopware selbst hostet. Hier brauche ich mich nicht mehr um solche Sonderfälle zu kümmern. Shopware läuft einfach! Wenn nicht, dann ist der Kundenservice von Profihost immer zur Stelle. Bei Strato habe ich diese Änderung direkt in der .htaccess per FTP geändert.
