# 500 Error wenn man auf Cache / Performance geht

**URL:** https://forum.shopware.com/t/500-error-wenn-man-auf-cache-performance-geht/98491
**Category:** Administration
**Created:** [10. Februar 2023 um 14:06 UTC](https://forum.shopware.com/t/500-error-wenn-man-auf-cache-performance-geht/98491 "2023-02-10T14:06:14Z")
**Posts on this page:** 20
**Page:** 1

<div class="post-metadata">

### Author: ![nadjak](https://avatars.discourse-cdn.com/v4/letter/n/ec9cab/32.png) [@nadjak](https://forum.shopware.com/u/nadjak)
#### Post date: [10. Februar 2023 um 14:06 UTC](https://forum.shopware.com/t/500-error-wenn-man-auf-cache-performance-geht/98491/1 "2023-02-10T14:06:14Z")

</div>

Hallo,  
wenn ich im BE auf Cache / Performance gehe bekomme ich einen 500 - Internal Server Error.  
Woran kann das liegen?  
Kann das ein Zusammenspiel mit dem invalid Token haben der immer wieder bei Bestellungen kommt?

Danke und VG  
NAdja

---

<div class="post-metadata">

### Author: ![SmartStylez](https://avatars.discourse-cdn.com/v4/letter/s/a88e4f/32.png) [@SmartStylez](https://forum.shopware.com/u/SmartStylez)
#### Post date: [10. Februar 2023 um 14:11 UTC](https://forum.shopware.com/t/500-error-wenn-man-auf-cache-performance-geht/98491/2 "2023-02-10T14:11:10Z")

</div>

Welche PHP-Version ist im Einsatz?

---

<div class="post-metadata">

### Author: ![nadjak](https://avatars.discourse-cdn.com/v4/letter/n/ec9cab/32.png) [@nadjak](https://forum.shopware.com/u/nadjak)
#### Post date: [10. Februar 2023 um 14:13 UTC](https://forum.shopware.com/t/500-error-wenn-man-auf-cache-performance-geht/98491/3 "2023-02-10T14:13:04Z")

</div>

Die PHP-Version ist 8.0.17  
VG Nadja

---

<div class="post-metadata">

### Author: ![SmartStylez](https://avatars.discourse-cdn.com/v4/letter/s/a88e4f/32.png) [@SmartStylez](https://forum.shopware.com/u/SmartStylez)
#### Post date: [10. Februar 2023 um 14:16 UTC](https://forum.shopware.com/t/500-error-wenn-man-auf-cache-performance-geht/98491/4 "2023-02-10T14:16:51Z")

</div>

Dann stell’ mal bitte testweise auf Version 7 um. Mit PHP 8 haben wir leider das gleiche Problem.

---

<div class="post-metadata">

### Author: ![sonic](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/sonic/32/25728_2.png) [@sonic](https://forum.shopware.com/u/sonic)
#### Post date: [10. Februar 2023 um 14:22 UTC](https://forum.shopware.com/t/500-error-wenn-man-auf-cache-performance-geht/98491/5 "2023-02-10T14:22:40Z")

</div>

Ich glaube nicht, dass das pauschal an PHP 8 liegt, dann müsste das ja jeden treffen, der auf PHP 8 ist. Bei mir unter 8.0.26 und 8.1.13 kommt das Modul ohne zu meckern.  
Ein Hinweis die Tage war auf das Plugin SwagEssentials, ich glaube aber nicht, dass das installiert ist.  
Um nicht die Glaskugel befragen zu müssen, wären genauere Fehlermeldungen schon wichtig. Der 500 ist ja kein anonymer Fehlercode.  
Also dazu Errorlog in PHP aktivieren und dann den Log auslesen.

> **[Shopware 5 - Tutorials & FAQs - Fehlermeldungen in Shopware debuggen](https://docs.shopware.com/de/shopware-5-de/tutorials-und-faq/fehlermeldungen-in-shopware-debuggen)**
>
> Auf dieser Seite findest Du einige hilfreiche Informationen, welche Dir bei dem Debugging von Fehlermeldungen und der Ermittlung der Ursache helfen werden.

Ggf. auch mal in die Console vom Chrome gucken: F12 und dann unter Tab Konsole mal gucken.

---

<div class="post-metadata">

### Author: ![nadjak](https://avatars.discourse-cdn.com/v4/letter/n/ec9cab/32.png) [@nadjak](https://forum.shopware.com/u/nadjak)
#### Post date: [10. Februar 2023 um 14:22 UTC](https://forum.shopware.com/t/500-error-wenn-man-auf-cache-performance-geht/98491/6 "2023-02-10T14:22:50Z")

</div>

Tatsache!  
Aber das kann doch nicht sein! PHP 7.4 ist aus dem Support raus.  
VG Nadja

---

<div class="post-metadata">

### Author: ![SmartStylez](https://avatars.discourse-cdn.com/v4/letter/s/a88e4f/32.png) [@SmartStylez](https://forum.shopware.com/u/SmartStylez)
#### Post date: [10. Februar 2023 um 14:23 UTC](https://forum.shopware.com/t/500-error-wenn-man-auf-cache-performance-geht/98491/7 "2023-02-10T14:23:58Z")

</div>

Wir haben auch schon alles Mögliche versucht. Fakt ist, dass der Fehler nur mit PHP 8 auftritt und zwar mit allen uns zur Verfügung stehenden Versionen.

---

<div class="post-metadata">

### Author: ![SCOOPEX](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/scoopex/32/18328_2.png) [@SCOOPEX](https://forum.shopware.com/u/SCOOPEX)
#### Post date: [10. Februar 2023 um 14:29 UTC](https://forum.shopware.com/t/500-error-wenn-man-auf-cache-performance-geht/98491/8 "2023-02-10T14:29:49Z")

</div>

Kann ich ebenfalls nicht bestätigen - PHP 8.0.27 im Einsatz - Modul geht als auch der Checkout.

Fehler 500 lassen sich jedoch debuggen, wie von @sonic beschrieben.

Viele Grüße

---

<div class="post-metadata">

### Author: ![nadjak](https://avatars.discourse-cdn.com/v4/letter/n/ec9cab/32.png) [@nadjak](https://forum.shopware.com/u/nadjak)
#### Post date: [10. Februar 2023 um 14:30 UTC](https://forum.shopware.com/t/500-error-wenn-man-auf-cache-performance-geht/98491/9 "2023-02-10T14:30:32Z")

</div>

Ich hab nur die PHP 8.0.16 zur Verfügung. Daher kan nich es mit anderen 8er Versionen nicht testen.  
Im Error-File steht folgendes:  
PHP Fatal error: Uncaught Error: Call to undefined function Shopware\Components\opcache\_get\_status() in /PFAD/engine/Shopware/Components/CacheManager.php:418, referer: DOMAIN/backend/  
mod\_fcgid: stderr: Stack trace:, referer:DOMAIN/backend/  
mod\_fcgid: stderr: #0 /PFAD/engine/Shopware/Controllers/Backend/Cache.php(83): Shopware\Components\CacheManager-\>getOpCacheCacheInfo(), referer: DOAMIN/backend/  
mod\_fcgid: stderr: #1 /PFAD/engine/Library/Enlight/Controller/Action.php(187): Shopware\_Controllers\_Backend\_Cache-\>getInfoAction(), referer:DOMAIN/backend/  
mod\_fcgid: stderr: #2 /PFAD/engine/Library/Enlight/Controller/Dispatcher/Default.php(467): Enlight\_Controller\_Action-\>dispatch(‚getInfoAction‘), referer: DOMAIN/backend/  
mod\_fcgid: stderr: #3 /PFAD/engine/Library/Enlight/Controller/Front.php(225): Enlight\_Controller\_Dispatcher\_Default-\>dispatch(Object(Enlight\_Controller\_Request\_RequestHttp), Object(Enlight\_Controller\_Response\_ResponseHttp)), referer: DOMAIN/backend/  
mod\_fcgid: stderr: #4 /PFAD/engine/Shopware/Kernel.php(197): Enlight\_Controller\_Front-\>dispatch(), referer:DOMAIN/backend/  
mod\_fcgid: stderr: #5 /PFAD/vendor/symfony/http-kernel/HttpCache/SubRequestHandler.php(85): Shopware\Kernel-\>handle(Object(Symfony\Component\HttpFoundation\Request), 1, true), referer: DOMAIN/backend/  
mod\_fcgid: stderr: #6 /PFAD/vendor/symfony/http-kernel/HttpCache/HttpCache.php(479): Symfony\Component\HttpKernel\HttpCache\SubRequestHandler::handle(Object(Shopware\Kernel), Object(Symfony\Component\HttpFoundation\Request), 1, true), referer: DOAMIN/backend/  
mod\_fcgid: stderr: #7 /PFAD/engine/Shopware/Components/HttpCache/AppCache.php(266): Symfony\Component\HttpKernel\HttpCache\HttpCache-\>forward(Object(Symfony\Component\HttpFoundation\Request), true, NULL), referer: DOMAIN/backend/  
mod\_fcgid: stderr: #8 /PFAD/vendor/symfony/http-kernel/HttpCache/HttpCache.php(269): Shopware\Components\HttpCache\AppCache-\>forward(Object(Symfony\Component\HttpFoundation\Request), true), referer:DOMAIN/backend/  
mod\_fcgid: stderr: #9 /PFAD/engine/Shopware/Components/HttpCache/AppCache.php(106): Symfony\Component\HttpKernel\HttpCache\HttpCache-\>pass(Object(Symfony\Component\HttpFoundation\Request), true), referer: DOMAIN/backend/  
mod\_fcgid: stderr: #10 /PFAD/shopware.php(122): Shopware\Components\HttpCache\AppCache-\>handle(Object(Symfony\Component\HttpFoundation\Request)), referer: DOMAIN/backend/  
mod\_fcgid: stderr: #11 {main}, referer: DOMAIN/backend/  
mod\_fcgid: stderr: thrown in /PFAD/engine/Shopware/Components/CacheManager.php on line 418, referer: DOMAIN/backend/

---

<div class="post-metadata">

### Author: ![sonic](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/sonic/32/25728_2.png) [@sonic](https://forum.shopware.com/u/sonic)
#### Post date: [10. Februar 2023 um 14:32 UTC](https://forum.shopware.com/t/500-error-wenn-man-auf-cache-performance-geht/98491/10 "2023-02-10T14:32:42Z")

</div>

Wollte gerade ergänzen: Könnte auch am opcache liegen, da kommt der Log.  
Da klemmt(e) es in der Tat bei Shopware und unvollständiger PHP-Installation vom Hoster.  
Welche SW-Version hast Du?

---

<div class="post-metadata">

### Author: ![SmartStylez](https://avatars.discourse-cdn.com/v4/letter/s/a88e4f/32.png) [@SmartStylez](https://forum.shopware.com/u/SmartStylez)
#### Post date: [10. Februar 2023 um 14:34 UTC](https://forum.shopware.com/t/500-error-wenn-man-auf-cache-performance-geht/98491/11 "2023-02-10T14:34:15Z")

</div>

An der gleichen Stelle scheint es bei uns auch zu haken. Nur gehe ich davon aus, dass dies bei einem offiziellen Hoster richtig konfiguriert sein sollte, zumal es ja mit Version 7 problemlos funktioniert.

---

<div class="post-metadata">

### Author: ![sonic](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/sonic/32/25728_2.png) [@sonic](https://forum.shopware.com/u/sonic)
#### Post date: [10. Februar 2023 um 14:34 UTC](https://forum.shopware.com/t/500-error-wenn-man-auf-cache-performance-geht/98491/12 "2023-02-10T14:34:28Z")

</div>

> [@Performance Cache Tab hat keine Werte nach umstellung auf PHP 8.0.27](https://forum.shopware.com/t/performance-cache-tab-hat-keine-werte-nach-umstellung-auf-php-8-0-27/98306/8):
>
> Hab den Fehler nun gefunden. Es lag an opcache. Dies ist wohl zwingend nötig laut Shopware um das anzeigen zu können. (Hab ich auf irgendeiner Shopware Seite gelesen) opcache war in Plesk unter den PHP Einstellungen deaktiviert opcache.enable war auf „on“, aber gleich drunter bei disable\_functions stand „opcache\_get\_status (Standard)“ drinnen. nachdem ich das gelöscht habe ging es wieder. Hoffe das stört andere Sachen in Shopware nicht. Ist echt schon extrem was man alles wissen/können …

---

<div class="post-metadata">

### Author: ![sonic](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/sonic/32/25728_2.png) [@sonic](https://forum.shopware.com/u/sonic)
#### Post date: [10. Februar 2023 um 14:36 UTC](https://forum.shopware.com/t/500-error-wenn-man-auf-cache-performance-geht/98491/13 "2023-02-10T14:36:46Z")

</div>

Bei PHP 7 war der opcache von Zend ein Zusatzmodul, ab 8 ist es Bestandteil von PHP (wenn ich das richtig in Erinnerung habe). Das macht in der Einrichtung und „Erkennung“ schon einen Unterschied.

---

<div class="post-metadata">

### Author: ![SCOOPEX](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/scoopex/32/18328_2.png) [@SCOOPEX](https://forum.shopware.com/u/SCOOPEX)
#### Post date: [10. Februar 2023 um 14:37 UTC](https://forum.shopware.com/t/500-error-wenn-man-auf-cache-performance-geht/98491/14 "2023-02-10T14:37:51Z")

</div>

Schau’ mal in die PHP Einstellungen, falls Plesk im Einsatz ist als Web-Verwaltung.

Plesk hat im Standard aus Sicherheitsgründen bei disable\_functions „opcache\_get\_status“ drin - daran stört sich das Shopware Cache Modul und Du musst die Zeile einfach leeren - dann ist der Fehler weg. Das Invalid Token wird vermutlich an einem Plugin liegen.

Vorher:

 ![Bildschirm­foto 2023-02-10 um 15.35.34](https://europe1.discourse-cdn.com/flex013/uploads/shopware/original/3X/3/e/3e6603766047a62009028df012f49a3b2f304807.png)

Nachher:

 ![Bildschirm­foto 2023-02-10 um 15.35.41](https://europe1.discourse-cdn.com/flex013/uploads/shopware/original/3X/2/8/28aa57c8d619e2eac034db4ecda89bafc430c7ed.png)

---

<div class="post-metadata">

### Author: ![SmartStylez](https://avatars.discourse-cdn.com/v4/letter/s/a88e4f/32.png) [@SmartStylez](https://forum.shopware.com/u/SmartStylez)
#### Post date: [10. Februar 2023 um 14:42 UTC](https://forum.shopware.com/t/500-error-wenn-man-auf-cache-performance-geht/98491/15 "2023-02-10T14:42:38Z")

</div>

Auf diese Zeile habe ich leider keinen Zugriff…

---

<div class="post-metadata">

### Author: ![SCOOPEX](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/scoopex/32/18328_2.png) [@SCOOPEX](https://forum.shopware.com/u/SCOOPEX)
#### Post date: [10. Februar 2023 um 14:46 UTC](https://forum.shopware.com/t/500-error-wenn-man-auf-cache-performance-geht/98491/16 "2023-02-10T14:46:49Z")

</div>

Dann hast Du vermutlich einfaches Shared Hosting.

Evtl. ändert der Hoster die Einstellung für Dich, wobei es halt im Shared Hosting eine Sicherheitslücke darstellt, da sich mit der Funktion halt der gesamte OPCache auslesen lässt (also auch der von anderen Kunden auf dem System).

Der OPCache selbst funktioniert, Du kannst halt nur den Status im Shared Hosting abfragen - und genau das macht Shopware in dem Modul.

---

<div class="post-metadata">

### Author: ![nadjak](https://avatars.discourse-cdn.com/v4/letter/n/ec9cab/32.png) [@nadjak](https://forum.shopware.com/u/nadjak)
#### Post date: [10. Februar 2023 um 14:47 UTC](https://forum.shopware.com/t/500-error-wenn-man-auf-cache-performance-geht/98491/17 "2023-02-10T14:47:03Z")

</div>

Genau das scheint auch bei mir das Problem zu sein. Ich seh zwar, dass es bei disable\_functions drin ist, aber ich kann die Zeile nicht bearbeiten. Wo kann ich das in Plesk machen?  
 ![grafik](https://europe1.discourse-cdn.com/flex013/uploads/shopware/original/3X/4/8/481787d835b6f4d6bb001b5bb49792798116f2ea.png)

---

<div class="post-metadata">

### Author: ![SmartStylez](https://avatars.discourse-cdn.com/v4/letter/s/a88e4f/32.png) [@SmartStylez](https://forum.shopware.com/u/SmartStylez)
#### Post date: [10. Februar 2023 um 14:48 UTC](https://forum.shopware.com/t/500-error-wenn-man-auf-cache-performance-geht/98491/18 "2023-02-10T14:48:13Z")

</div>

Okay, danke und unter PHP 7 wurde das Ganze anders gemanaged, weil die Einstellung die gleiche ist, es dort aber zu funktionieren scheint?

---

<div class="post-metadata">

### Author: ![nadjak](https://avatars.discourse-cdn.com/v4/letter/n/ec9cab/32.png) [@nadjak](https://forum.shopware.com/u/nadjak)
#### Post date: [10. Februar 2023 um 14:49 UTC](https://forum.shopware.com/t/500-error-wenn-man-auf-cache-performance-geht/98491/19 "2023-02-10T14:49:21Z")

</div>

ok, das bedeutet, dass ich nur den Status nicht auslesen kann, aber der Cache an sich funktioniert. Das wäre mir ja egal. Solange es sonst keinen Einfluss hat.

Ich habe auch noch das Problem des „invalide Token“ beim abschicken der Bestellung ([Fehler beim Checkout - Invalides Formular-Token! - #54 von nadjak](https://forum.shopware.com/t/fehler-beim-checkout-invalides-formular-token/95693/54)). Das kann damit aber nichts zu tun haben oder?

VG Nadja

---

<div class="post-metadata">

### Author: ![SCOOPEX](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/scoopex/32/18328_2.png) [@SCOOPEX](https://forum.shopware.com/u/SCOOPEX)
#### Post date: [10. Februar 2023 um 14:50 UTC](https://forum.shopware.com/t/500-error-wenn-man-auf-cache-performance-geht/98491/20 "2023-02-10T14:50:47Z")

</div>

Ja genau - bei PHP 8.1 ist der „Fehler“ soweit ich mich erinnere wieder weg.

[Nächste Seite](https://forum.shopware.com/t/500-error-wenn-man-auf-cache-performance-geht/98491.md?page=2)
