# 5.7.7, PHP 8.1 und der Pluginmanager

**URL:** https://forum.shopware.com/t/5-7-7-php-8-1-und-der-pluginmanager/92314
**Category:** Allgemein
**Created:** [11. Januar 2022 um 13:29 UTC](https://forum.shopware.com/t/5-7-7-php-8-1-und-der-pluginmanager/92314 "2022-01-11T13:29:51Z")
**Posts on this page:** 20
**Page:** 1

<div class="post-metadata">

### Author: ![Pyro](https://avatars.discourse-cdn.com/v4/letter/p/71e660/32.png) [@Pyro](https://forum.shopware.com/u/Pyro)
#### Post date: [11. Januar 2022 um 13:29 UTC](https://forum.shopware.com/t/5-7-7-php-8-1-und-der-pluginmanager/92314/1 "2022-01-11T13:29:52Z")

</div>

Hallo,

nach dem Update auf die 5.7.7 wollte ich noch mal das Thema PHP 8.1 angehen.  
Soweit scheint alles zu funktionieren, nur der Shopware eigene Pluginmanager bringt beim starten die 500 - Meldung.  
Ein Logging bringt auch nicht mehr Informationen. Hab noch mal auf 7.4 umgestellt und den gesicherten Modus aktiviert, dann wieder auf 8.1, bekomme aber den gleichen Fehler.

Jemand eine Idee wie ich rausbekommen was mir die 500 - sagen will?

Gruß Dirk

 ![image](https://europe1.discourse-cdn.com/flex013/uploads/shopware/original/2X/9/98c2c2cd22818570e350e1b666109746aefaade7.png)

---

<div class="post-metadata">

### Author: ![Michael\_Telgmann](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/michael_telgmann/32/20289_2.png) [@Michael\_Telgmann](https://forum.shopware.com/u/Michael_Telgmann)
#### Post date: [11. Januar 2022 um 13:34 UTC](https://forum.shopware.com/t/5-7-7-php-8-1-und-der-pluginmanager/92314/2 "2022-01-11T13:34:04Z")

</div>

Hallo Dirk,

vielleicht hilft dir dieser Artikel beim Herausfinden des Fehlers: [Shopware 5 - Tutorials & FAQs - Fehlermeldungen in Shopware debuggen](https://docs.shopware.com/de/shopware-5-de/tutorials-und-faq/fehlermeldungen-in-shopware-debuggen)

Viele Grüße aus Schöppingen  
Michael Telgmann

---

<div class="post-metadata">

### Author: ![d.garding](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/d.garding/32/10544_2.png) [@d.garding](https://forum.shopware.com/u/d.garding)
#### Post date: [11. Januar 2022 um 14:10 UTC](https://forum.shopware.com/t/5-7-7-php-8-1-und-der-pluginmanager/92314/3 "2022-01-11T14:10:07Z")

</div>

Hallo Dirk,

hier mal meine DebugConfig:

Vllt. hilft sie dir!

EDIT: ich habe das gerade bei mir einmal gegentestet… Ich habe keine Probleme!  
EDIT2: OK… mit DebugConfig habe ich auch Probleme.

```auto

    'errorHandler' => [
        'throwOnRecoverableError' => false,
    ],
    'front' => [
        'noErrorHandler' => true,
        'throwExceptions' => true,
    ],
    'phpsettings' => [
        'display_errors' => 1,
    ],
    'template' => [
        'forceCompile' => true,
    ],
    'httpcache' => [
        'enabled' => false,
        'debug' => true,
    ],
    'cache' => [
        'frontendOptions' => [
            'write_control' => false
        ],
        'backend' => 'Black-Hole',
        'backendOptions' => [],
    ],
    'extjs' => [
       'developer_mode' => true,
     ],
    'model' => [
        'cacheProvider' => 'Array'
    ],
    'csrfProtection' => [
        'backend' => true,
        'frontend' => true
    ]

```

LG

Dennis Garding

---

<div class="post-metadata">

### Author: ![Pyro](https://avatars.discourse-cdn.com/v4/letter/p/71e660/32.png) [@Pyro](https://forum.shopware.com/u/Pyro)
#### Post date: [11. Januar 2022 um 14:30 UTC](https://forum.shopware.com/t/5-7-7-php-8-1-und-der-pluginmanager/92314/4 "2022-01-11T14:30:43Z")

</div>

Hallo,

das PHP Error Log wird alle 2 Sekunden mit dem folgenden Eintrag gefüllt. Der eigentliche Aufruf des Pluginmanagers erzeugt keinen Eintrag.

Der wird damit sicher nichts zu tun haben?  
[11-Jan-2022 15:28:42 Europe/Berlin] PHP Deprecated: Return type of Zend\_Db\_Statement\_Pdo::getIterator() should either be compatible with IteratorAggregate::getIterator(): Traversable, or the #[\ReturnTypeWillChange] attribute should be used to temporarily suppress the notice in /html/shopware/engine/Library/Zend/Db/Statement/Pdo.php on line 254

---

<div class="post-metadata">

### Author: ![Steffffi](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/steffffi/32/13846_2.png) [@Steffffi](https://forum.shopware.com/u/Steffffi)
#### Post date: [11. Januar 2022 um 14:35 UTC](https://forum.shopware.com/t/5-7-7-php-8-1-und-der-pluginmanager/92314/5 "2022-01-11T14:35:28Z")

</div>

> [@Pyro](#):
>
> den gesicherten Modus aktiviert,

Wie wird denn dieser aktiviert? per SQL? Und wenn, wo?

---

<div class="post-metadata">

### Author: ![SmartStylez](https://avatars.discourse-cdn.com/v4/letter/s/a88e4f/32.png) [@SmartStylez](https://forum.shopware.com/u/SmartStylez)
#### Post date: [11. Januar 2022 um 14:37 UTC](https://forum.shopware.com/t/5-7-7-php-8-1-und-der-pluginmanager/92314/6 "2022-01-11T14:37:11Z")

</div>

Im Backend bei den Plugins kannst du ihn unten aktivieren.

---

<div class="post-metadata">

### Author: ![Steffffi](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/steffffi/32/13846_2.png) [@Steffffi](https://forum.shopware.com/u/Steffffi)
#### Post date: [11. Januar 2022 um 14:37 UTC](https://forum.shopware.com/t/5-7-7-php-8-1-und-der-pluginmanager/92314/7 "2022-01-11T14:37:33Z")

</div>

Gerade gefunden, danke.

---

<div class="post-metadata">

### Author: ![Steffffi](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/steffffi/32/13846_2.png) [@Steffffi](https://forum.shopware.com/u/Steffffi)
#### Post date: [11. Januar 2022 um 14:51 UTC](https://forum.shopware.com/t/5-7-7-php-8-1-und-der-pluginmanager/92314/8 "2022-01-11T14:51:56Z")

</div>

> [@SmartStylez](#):
>
> Im Backend bei den Plugins kannst du ihn unten aktivieren.

Wo wäre das ganze in der Datenbank, für den Fall, der Shop startet mit Plugins nicht mehr?

---

<div class="post-metadata">

### Author: ![d.garding](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/d.garding/32/10544_2.png) [@d.garding](https://forum.shopware.com/u/d.garding)
#### Post date: [11. Januar 2022 um 14:55 UTC](https://forum.shopware.com/t/5-7-7-php-8-1-und-der-pluginmanager/92314/9 "2022-01-11T14:55:37Z")

</div>

Hallo,

ihr müsst eig. nur tun was die Fehlermeldung sagt =)

#[\ReturnTypeWillChange] über die methode einfügen… dann wird das ignoriert.

```auto
/**
     * Required by IteratorAggregate interface
     *
     * @return IteratorIterator
     */
    #[\ReturnTypeWillChange]
    public function getIterator()
    {
        return new IteratorIterator($this->_stmt);
    }

```

---

<div class="post-metadata">

### Author: ![R4M](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/r4m/32/9983_2.png) [@R4M](https://forum.shopware.com/u/R4M)
#### Post date: [11. Januar 2022 um 15:21 UTC](https://forum.shopware.com/t/5-7-7-php-8-1-und-der-pluginmanager/92314/10 "2022-01-11T15:21:26Z")

</div>

> [@d.garding](#):
>
> `#[\ReturnTypeWillChange]`

Was macht überhaupt diese Zeile hier? Im Original von SW ist das gar nicht. Wird da am Core gefummelt?

---

<div class="post-metadata">

### Author: ![phil](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/phil/32/13661_2.png) [@phil](https://forum.shopware.com/u/phil)
#### Post date: [11. Januar 2022 um 20:37 UTC](https://forum.shopware.com/t/5-7-7-php-8-1-und-der-pluginmanager/92314/11 "2022-01-11T20:37:31Z")

</div>

[New `#[ReturnTypeWillChange]` attribute - PHP 8.1 • PHP.Watch](https://php.watch/versions/8.1/ReturnTypeWillChange) 😉

LG Phil

---

<div class="post-metadata">

### Author: ![d.garding](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/d.garding/32/10544_2.png) [@d.garding](https://forum.shopware.com/u/d.garding)
#### Post date: [13. Januar 2022 um 06:12 UTC](https://forum.shopware.com/t/5-7-7-php-8-1-und-der-pluginmanager/92314/12 "2022-01-13T06:12:37Z")

</div>

Hallo,

wenn du diese Zeilen nicht im Original SW findest dann ist beim Update was schief gelaufen… da sollten eig. jede menge davon sein. Ohne ist SW in 8.1 nicht lauffähig.

ggf. das nochmal überprüfen

LG  
Dennis Garding

---

<div class="post-metadata">

### Author: ![sonic](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/sonic/32/25728_2.png) [@sonic](https://forum.shopware.com/u/sonic)
#### Post date: [13. Januar 2022 um 08:19 UTC](https://forum.shopware.com/t/5-7-7-php-8-1-und-der-pluginmanager/92314/13 "2022-01-13T08:19:18Z")

</div>

Achja?

> <https://github.com/shopware/shopware/blob/5.7/engine/Library/Zend/Db/Statement/Pdo.php#L249-L257>

Sehe ich derzeit nicht im Code

---

<div class="post-metadata">

### Author: ![d.garding](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/d.garding/32/10544_2.png) [@d.garding](https://forum.shopware.com/u/d.garding)
#### Post date: [13. Januar 2022 um 09:25 UTC](https://forum.shopware.com/t/5-7-7-php-8-1-und-der-pluginmanager/92314/14 "2022-01-13T09:25:12Z")

</div>

Ein missverständniss… ich meine Allgemein im SW code Nicht in dieser Datei. 😅

In der fehlt es natürlich…

---

<div class="post-metadata">

### Author: ![sonic](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/sonic/32/25728_2.png) [@sonic](https://forum.shopware.com/u/sonic)
#### Post date: [13. Januar 2022 um 09:35 UTC](https://forum.shopware.com/t/5-7-7-php-8-1-und-der-pluginmanager/92314/15 "2022-01-13T09:35:12Z")

</div>

😚 👍  
alles klar 😉

---

<div class="post-metadata">

### Author: ![Pyro](https://avatars.discourse-cdn.com/v4/letter/p/71e660/32.png) [@Pyro](https://forum.shopware.com/u/Pyro)
#### Post date: [3. Februar 2022 um 07:25 UTC](https://forum.shopware.com/t/5-7-7-php-8-1-und-der-pluginmanager/92314/16 "2022-02-03T07:25:54Z")

</div>

Hallo,

ich muss hier noch mal fragen, da mittlerweile, unter 8.0 zumindest, alles andere und alle Plugins funktionieren, bis eben der Aufruf des Shopware eigenen Pluginmanagers. Das Logging zeigt nichts.  
Gibt es noch Ansätze wo eben diese .500 Meldung herkommen kann? Es scheint auch nur die Auflistung der installierten Plugins zu betreffen.

Über Ideen / Ansätze wäre ich dankbar.

Gruß Dirk

---

<div class="post-metadata">

### Author: ![Shaan](https://avatars.discourse-cdn.com/v4/letter/s/35a633/32.png) [@Shaan](https://forum.shopware.com/u/Shaan)
#### Post date: [3. Februar 2022 um 14:42 UTC](https://forum.shopware.com/t/5-7-7-php-8-1-und-der-pluginmanager/92314/17 "2022-02-03T14:42:41Z")

</div>

Ich habe den gleichen Fehler.

Könnt vielleich auch an einem Theme wie dem von TC-Inovation liegen.

---

<div class="post-metadata">

### Author: ![Pyro](https://avatars.discourse-cdn.com/v4/letter/p/71e660/32.png) [@Pyro](https://forum.shopware.com/u/Pyro)
#### Post date: [3. Februar 2022 um 19:20 UTC](https://forum.shopware.com/t/5-7-7-php-8-1-und-der-pluginmanager/92314/18 "2022-02-03T19:20:43Z")

</div>

Wir nutzen das SW Standard

---

<div class="post-metadata">

### Author: ![R4M](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/r4m/32/9983_2.png) [@R4M](https://forum.shopware.com/u/R4M)
#### Post date: [4. Februar 2022 um 09:52 UTC](https://forum.shopware.com/t/5-7-7-php-8-1-und-der-pluginmanager/92314/19 "2022-02-04T09:52:43Z")

</div>

> [@Pyro](#):
>
> Gibt es noch Ansätze wo eben diese .500 Meldung herkommen kann?

Sofern es Error 500 Fehlermeldungen sind sollte im Error\_Log des **Servers** etwas zu finden sein. Nicht mit Shopware Log verwechseln.

---

<div class="post-metadata">

### Author: ![Pyro](https://avatars.discourse-cdn.com/v4/letter/p/71e660/32.png) [@Pyro](https://forum.shopware.com/u/Pyro)
#### Post date: [5. Februar 2022 um 06:30 UTC](https://forum.shopware.com/t/5-7-7-php-8-1-und-der-pluginmanager/92314/21 "2022-02-05T06:30:08Z")

</div>

Das Problem waren Reste vom alten HeidelPay Backend Modul in den Default Plugins.  
Komplett gelöscht und Fehler weg.

Muss wohl besser aufräumen.  
Danke.

[Nächste Seite](https://forum.shopware.com/t/5-7-7-php-8-1-und-der-pluginmanager/92314.md?page=2)
