# 5.3.2, unser Freund, der unknown tag "s"

**URL:** https://forum.shopware.com/t/5-3-2-unser-freund-der-unknown-tag-s/47972
**Category:** Administration
**Created:** [31. August 2017 um 18:38 UTC](https://forum.shopware.com/t/5-3-2-unser-freund-der-unknown-tag-s/47972 "2017-08-31T18:38:05Z")
**Posts on this page:** 20
**Page:** 7

<div class="post-metadata">

### Author: ![R4M](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/r4m/32/9983_2.png) [@R4M](https://forum.shopware.com/u/R4M)
#### Post date: [18. Oktober 2017 um 10:33 UTC](https://forum.shopware.com/t/5-3-2-unser-freund-der-unknown-tag-s/47972/121 "2017-10-18T10:33:31Z")

</div>

Ich weiß nicht ob es von Bedeutung ist, aber langsam vermute ich, immer wenn der Shop ein Error 500 ausgibt, steht auch die selbe Fehlermeldung “unknown tag s” in Log. Wie ich darauf komme?

Eben versuche ich ein Template anzupassen. Hier wollte ich per Include ein anderes TPL einbinden was sich jedoch im selben Theme befindet. Hat nicht funktioniert. Der Shop brach mit Error 500 ab. Witzig ist die Fehlermeldung im error\_log, genau “unknown tag s”. Hier hätte ich jetzt eine andere Fehlermeldung erwartet, wie File nicht gefunden oder sonstiges. Aber “unknown tag s” in diesem Zusammenhang?

**Das ist etwas sehr komisch! Hat hier schlichtweg die Fehlerausgabe (Error handling) von Shopware eine Macke? Kann es sein, dass bei bestimmten Fällen nicht die eigentliche Fehlermeldung ausgegeben wird, sondern selber diesen “tag s” Fehler verursacht?**

---

<div class="post-metadata">

### Author: ![DennisM](https://avatars.discourse-cdn.com/v4/letter/d/5daacb/32.png) [@DennisM](https://forum.shopware.com/u/DennisM)
#### Post date: [18. Oktober 2017 um 10:38 UTC](https://forum.shopware.com/t/5-3-2-unser-freund-der-unknown-tag-s/47972/122 "2017-10-18T10:38:21Z")

</div>

Würde sich mit der Vermtung, dass es kein bestimmter Fehler ist bestätigen.

Eventuell sind es verschiedene Fehler, welche einfach nicht richtig deklariert sind.

---

<div class="post-metadata">

### Author: ![hth](https://avatars.discourse-cdn.com/v4/letter/h/b77776/32.png) [@hth](https://forum.shopware.com/u/hth)
#### Post date: [18. Oktober 2017 um 11:28 UTC](https://forum.shopware.com/t/5-3-2-unser-freund-der-unknown-tag-s/47972/123 "2017-10-18T11:28:53Z")

</div>

> [@R4M schrieb:](https://forum.shopware.com/profile/17170/R4M "R4M")
> 
> Ich weiß nicht ob es von Bedeutung ist, aber langsam vermute ich, immer wenn der Shop ein Error 500 ausgibt, steht auch die selbe Fehlermeldung „unknown tag s“ in Log. Wie ich darauf komme?
> 
> Eben versuche ich ein Template anzupassen. Hier wollte ich per Include ein anderes TPL einbinden was sich jedoch im selben Theme befindet. Hat nicht funktioniert. Der Shop brach mit Error 500 ab. Witzig ist die Fehlermeldung im error\_log, genau „unknown tag s“. Hier hätte ich jetzt eine andere Fehlermeldung erwartet, wie File nicht gefunden oder sonstiges. Aber „unknown tag s“ in diesem Zusammenhang?
> 
> **Das ist etwas sehr komisch! Hat hier schlichtweg die Fehlerausgabe (Error handling) von Shopware eine Macke? Kann es sein, dass bei bestimmten Fällen nicht die eigentliche Fehlermeldung ausgegeben wird, sondern selber diesen „tag s“ Fehler verursacht?**

Zumindest kann es ein Folgefehler eines 500er sein. Ich habe einen Fall in den Serverlogs gefunden, bei dem nach mehrfachem Artikel in den Warenkorb legen und&nbsp;&nbsp;Artikel im Ajax-Warenkorb wieder löschen ein 500er Fehler beim Zurückgehen zum Artikel entstanden ist. Auf den folgt dann direkt ein unknown s-tag Fehler auf der Error-Template-Seite. Wobei diese komplett unverändert ist und der entsprechende Textbaustein ebenfalls. Der nächste unknown s-tag entsteht anschließend auf der Artikeldetailseite zu der vom Warenkorb zurückgekehrt wird.&nbsp;

Der Shop funktioniert offensichtlich dennoch. Auch die Artikeldetailseite (ist eine Variante) wurde von derselben IP später erneut angesprochen. Die IP hat später weiter Artikel in den Warenkorb gelegt und auch den kompletten Checkout durchlaufen und erst auf der Paypal-Seite abgebrochen (wahrscheinlich Kauf auf Rechnung). Parallel waren andere IPs aktiv.

Wo seht ihr eigentlich die Fehler? Beide oben beschriebenen Fehler sind bei dem Shop nicht im Shopware-Log gewesen.

Könnt ihr das eigentlich auf einen Gerätetyp anhand der Logfiles zurückverfolgen - hier war es ein Android7-System

---

<div class="post-metadata">

### Author: ![Moritz\_Naczenski](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/moritz_naczenski/32/7792_2.png) [@Moritz\_Naczenski](https://forum.shopware.com/u/Moritz_Naczenski)
#### Post date: [18. Oktober 2017 um 13:21 UTC](https://forum.shopware.com/t/5-3-2-unser-freund-der-unknown-tag-s/47972/124 "2017-10-18T13:21:55Z")

</div>

> [@R4M schrieb:](https://forum.shopware.com/profile/17170/R4M "R4M")
> 
> **Das ist etwas sehr komisch! Hat hier schlichtweg die Fehlerausgabe (Error handling) von Shopware eine Macke? Kann es sein, dass bei bestimmten Fällen nicht die eigentliche Fehlermeldung ausgegeben wird, sondern selber diesen „tag s“ Fehler verursacht?**

Ja, dass vermute ich aktuell auch. Ich glaube es ist eher eine Macke am Errorhandling, was viele einzelne Fehler versteckt und weniger ein allgemeines Ding. Habe hier gerade ein Plugin was ebenfalls diesen Fehler verursacht, sobald man das Errorhandling ersetzt und sich die Exeption direkt im Errorhandler ausliest, bekommt man auch einen anderen Fehler.&nbsp; Bei mir hilft es aber auch konkret, die Smarty Security zu deaktivieren:

```
'template_security' => [
        'enabled' => false,    
],

```

Das hat aktuell aber noch den Nachteil, dass dann die Dokumentenerstellung im Backend nicht funktioniert, dazu gibt es einen Pull-Request:&nbsp;

> <https://github.com/shopware/shopware/pull/1281>
>
> \<!--
> Thank you for contributing to Shopware! Please fill out this description t…emplate to help us to process your pull request.
> 
> Please make sure to fulfil our contribution guideline (https://docs.shopware.com/en/shopware-platform-dev-en/contribution/contribution-guideline?category=shopware-platform-dev-en/contribution).
> 
> Do your changes need to be mentioned in the documentation?
> Add notes on your change right now in the documentation files in /src/Docs/Resources and add them to the pull request as well. 
> \--\>
> 
> \### 1. Why is this change necessary?
> 
> 
> \### 2. What does this change do, exactly?
> 
> 
> \### 3. Describe each step to reproduce the issue or behaviour.
> 
> 
> \### 4. Please link to the relevant issues (if any).
> 
> 
> \### 5. Checklist
> 
> \- \[\] I have written tests and verified that they fail without my change
> \- \[\] I have squashed any insignificant commits
> \- \[\] I have written or adjusted the documentation according to my changes
> \- \[\] This change has comments for package types, values, functions, and non-obvious lines of code
> \- \[\] I have read the contribution requirements and fulfil them.

&nbsp;

Funktioniert aber wahrscheinlich nur, wenn die zugrundeliegende Fehlermeldung auch ein Security-Error ist.

---

<div class="post-metadata">

### Author: ![R4M](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/r4m/32/9983_2.png) [@R4M](https://forum.shopware.com/u/R4M)
#### Post date: [18. Oktober 2017 um 13:24 UTC](https://forum.shopware.com/t/5-3-2-unser-freund-der-unknown-tag-s/47972/125 "2017-10-18T13:24:31Z")

</div>

> Wo seht ihr eigentlich die Fehler?

Ich kann jetzt nur für mich sprechen: Im error\_log zur jeweiligen Domain. Nicht im Shopware Log!&nbsp;

[Update]

Die Sache mit „template\_security“ in der config hatte übrigens bei uns nicht geholfen.

---

<div class="post-metadata">

### Author: ![SwNewbie](https://avatars.discourse-cdn.com/v4/letter/s/8797f3/32.png) [@SwNewbie](https://forum.shopware.com/u/SwNewbie)
#### Post date: [18. Oktober 2017 um 14:28 UTC](https://forum.shopware.com/t/5-3-2-unser-freund-der-unknown-tag-s/47972/126 "2017-10-18T14:28:39Z")

</div>

so, also auch wir nun dabei… gestern von 5.2.24 auf 5.3.3 gegangen und zack… haben wir den Salat… auf die Schnelle nur getestet: PAYPAL PLUS aktiv, Artikel mit Bestand 0 via Vorauskasse bestellt, nach Abschluss weiße Seite mit Status 500. Dann Paypal Plus deaktiviert, den gleichen Artikel wieder auf Bestand 0 gesetzt und wieder per Vorauskasse bestellt und alles lief glatt.

```
2017/10/18 16:08:30 [error] 10627#10627: *351154 FastCGI sent in stderr: "PHP message: PHP Fatal error: Uncaught exception 'SmartyCompilerException' with message 'Syntax Error in template "/var/www/clients/client1/web2/web/themes/Frontend/Bare/frontend/index/index.tpl" on line 7 "&lt;html class=&quot;no-js&quot; lang=&quot;{s name='IndexXmlLang'}{/s}&quot; itemscope=&quot;itemscope&quot; itemtype=&quot;http://schema.org/WebPage&quot;&gt;" unknown tag "s"' in /var/www/clients/client1/web2/web/engine/Library/Smarty/sysplugins/smarty_internal_templatecompilerbase.php:657
Stack trace:
#0 /var/www/clients/client1/web2/web/engine/Library/Smarty/sysplugins/smarty_internal_templatecompilerbase.php(443): Smarty_Internal_TemplateCompilerBase->trigger_template_error('unknown tag "s"', 7)
#1 /var/www/clients/client1/web2/web/engine/Library/Smarty/sysplugins/smarty_internal_templateparser.php(2388): Smarty_Internal_TemplateCompilerBase->compileTag('s', Array)
#2 /var/www/clients/client1/web2/web/engine/Library/Smarty/sy" while reading response header from upstream, client: 217.7.241.85, server: domain.de, request: "POST /checkout/finish HTTP/1.1", upstream: "fastcgi://unix:/var/lib/php5-fpm/web2.sock:", host: "www.domain.de", referrer: "https://www.domain.de/checkout"
2017/10/18 16:08:37 [error] 10620#10620: *351187 FastCGI sent in stderr: "PHP message: PHP Fatal error: Uncaught exception 'SmartyCompilerException' with message 'Syntax Error in template "/var/www/clients/client1/web2/web/themes/Frontend/Bare/frontend/index/index.tpl" on line 7 "&lt;html class=&quot;no-js&quot; lang=&quot;{s name='IndexXmlLang'}{/s}&quot; itemscope=&quot;itemscope&quot; itemtype=&quot;http://schema.org/WebPage&quot;&gt;" unknown tag "s"' in /var/www/clients/client1/web2/web/engine/Library/Smarty/sysplugins/smarty_internal_templatecompilerbase.php:657
Stack trace:
#0 /var/www/clients/client1/web2/web/engine/Library/Smarty/sysplugins/smarty_internal_templatecompilerbase.php(443): Smarty_Internal_TemplateCompilerBase->trigger_template_error('unknown tag "s"', 7)
#1 /var/www/clients/client1/web2/web/engine/Library/Smarty/sysplugins/smarty_internal_templateparser.php(2388): Smarty_Internal_TemplateCompilerBase->compileTag('s', Array)
#2 /var/www/clients/client1/web2/web/engine/Library/Smarty/sy" while reading response header from upstream, client: 217.7.241.85, server: domain.de, request: "GET /checkout/finish HTTP/1.1", upstream: "fastcgi://unix:/var/lib/php5-fpm/web2.sock:", host: "www.domain.de"
2017/10/18 16:08:39 [error] 10620#10620: *351187 FastCGI sent in stderr: "PHP message: PHP Fatal error: Uncaught exception 'SmartyCompilerException' with message 'Syntax Error in template "/var/www/clients/client1/web2/web/themes/Frontend/Bare/frontend/index/index.tpl" on line 7 "&lt;html class=&quot;no-js&quot; lang=&quot;{s name='IndexXmlLang'}{/s}&quot; itemscope=&quot;itemscope&quot; itemtype=&quot;http://schema.org/WebPage&quot;&gt;" unknown tag "s"' in /var/www/clients/client1/web2/web/engine/Library/Smarty/sysplugins/smarty_internal_templatecompilerbase.php:657
Stack trace:
#0 /var/www/clients/client1/web2/web/engine/Library/Smarty/sysplugins/smarty_internal_templatecompilerbase.php(443): Smarty_Internal_TemplateCompilerBase->trigger_template_error('unknown tag "s"', 7)
#1 /var/www/clients/client1/web2/web/engine/Library/Smarty/sysplugins/smarty_internal_templateparser.php(2388): Smarty_Internal_TemplateCompilerBase->compileTag('s', Array)
#2 /var/www/clients/client1/web2/web/engine/Library/Smarty/sy" while reading response header from upstream, client: 217.7.241.85, server: domain.de, request: "GET /checkout/finish HTTP/1.1", upstream: "fastcgi://unix:/var/lib/php5-fpm/web2.sock:", host: "www.domain.de"

```

es scheint ja was mit dem “/themes/Frontend/Bare/frontend/index/index.tpl” zu tun haben, an der betreffenden Zeile steht ein  
&nbsp;

&nbsp;

---

<div class="post-metadata">

### Author: ![octodelta](https://avatars.discourse-cdn.com/v4/letter/o/da6949/32.png) [@octodelta](https://forum.shopware.com/u/octodelta)
#### Post date: [18. Oktober 2017 um 14:58 UTC](https://forum.shopware.com/t/5-3-2-unser-freund-der-unknown-tag-s/47972/127 "2017-10-18T14:58:21Z")

</div>

Mal ein&nbsp;ganz simpler Versuch: da bei uns meistens auch diese Zeile moniert wird, haben wir diese nun wie folgt geändert:

Ursprünglich:&nbsp;

```
;

```

Neu:&nbsp;

```
;

```

Vielleicht können wir dann diesen problematischen “tag s” umgehen.

---

<div class="post-metadata">

### Author: ![vc-nm](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/vc-nm/32/8114_2.png) [@vc-nm](https://forum.shopware.com/u/vc-nm)
#### Post date: [18. Oktober 2017 um 15:03 UTC](https://forum.shopware.com/t/5-3-2-unser-freund-der-unknown-tag-s/47972/128 "2017-10-18T15:03:24Z")

</div>

Das funktioniert leider nicht - dann meckert er an dem nächsten Textbaustein rum. Das hatte ich so ziemlich als erstes getestet… Hat nichts gebracht bei mir

---

<div class="post-metadata">

### Author: ![gwdgensert](https://avatars.discourse-cdn.com/v4/letter/g/e9a140/32.png) [@gwdgensert](https://forum.shopware.com/u/gwdgensert)
#### Post date: [18. Oktober 2017 um 15:03 UTC](https://forum.shopware.com/t/5-3-2-unser-freund-der-unknown-tag-s/47972/129 "2017-10-18T15:03:29Z")

</div>

> [@octodelta schrieb:](https://forum.shopware.com/profile/24283/octodelta "octodelta")
> 
> Mal ein&nbsp;ganz simpler Versuch: da bei uns meistens auch diese Zeile moniert wird, haben wir diese nun wie folgt geändert:
> 
> Ursprünglich:&nbsp;
> 
> [WebPage - Schema.org Type](http://schema.org/WebPage)"\>;
> 
> Neu:&nbsp;
> 
> [WebPage - Schema.org Type](http://schema.org/WebPage)"\>;
> 
> Vielleicht können wir dann diesen problematischen „tag s“ umgehen.

Das wurde schon versucht, der Fehler entsteht dann direkt beim nächsten s-Tag. Wenn es so einfach wäre, dann würden wir hier vermutlich nicht seit Monaten rumeiern…&nbsp; ![Wink](https://europe1.discourse-cdn.com/flex013/uploads/shopware/original/1X/b3785da0cbf2c8566cb535dcf55b2730b5224899.png "Wink")

---

<div class="post-metadata">

### Author: ![octodelta](https://avatars.discourse-cdn.com/v4/letter/o/da6949/32.png) [@octodelta](https://forum.shopware.com/u/octodelta)
#### Post date: [18. Oktober 2017 um 15:10 UTC](https://forum.shopware.com/t/5-3-2-unser-freund-der-unknown-tag-s/47972/130 "2017-10-18T15:10:34Z")

</div>

Ok, war ja nur ein Versuch&nbsp; ![Wink](https://europe1.discourse-cdn.com/flex013/uploads/shopware/original/1X/b3785da0cbf2c8566cb535dcf55b2730b5224899.png "Wink")

---

<div class="post-metadata">

### Author: ![SwNewbie](https://avatars.discourse-cdn.com/v4/letter/s/8797f3/32.png) [@SwNewbie](https://forum.shopware.com/u/SwNewbie)
#### Post date: [18. Oktober 2017 um 15:31 UTC](https://forum.shopware.com/t/5-3-2-unser-freund-der-unknown-tag-s/47972/131 "2017-10-18T15:31:29Z")

</div>

Jemand schon Browser/Betriebssystem untersucht?

Ich habe mehrfach versucht etwas über ihren Online Shop zu bestellen, aber beim Übergang zur Zahlung, ebenfalls bei “direkt zu Paypal”, landet man auf einer weissen Seite. Safari und Chrome Browser.

&nbsp;

---

<div class="post-metadata">

### Author: ![SwNewbie](https://avatars.discourse-cdn.com/v4/letter/s/8797f3/32.png) [@SwNewbie](https://forum.shopware.com/u/SwNewbie)
#### Post date: [18. Oktober 2017 um 15:36 UTC](https://forum.shopware.com/t/5-3-2-unser-freund-der-unknown-tag-s/47972/132 "2017-10-18T15:36:40Z")

</div>

im Chrome/Windows sieht es bei uns sporadisch beim PP Plus Plugin so aus:

 ![](https://europe1.discourse-cdn.com/flex013/uploads/shopware/original/2X/3/313d512603e5af9e032858bba229ccc1bb88c2e8.png)

---

<div class="post-metadata">

### Author: ![SwNewbie](https://avatars.discourse-cdn.com/v4/letter/s/8797f3/32.png) [@SwNewbie](https://forum.shopware.com/u/SwNewbie)
#### Post date: [18. Oktober 2017 um 16:05 UTC](https://forum.shopware.com/t/5-3-2-unser-freund-der-unknown-tag-s/47972/133 "2017-10-18T16:05:00Z")

</div>

[https://www.shopwaredemo.de/kochlust-provence/essen/oele-gewuerze/essig-oel/?p=1&o=1&n=12&s=](https://www.shopwaredemo.de/kochlust-provence/essen/oele-gewuerze/essig-oel/?p=1&o=1&n=12&s=)

[https://www.shopwaredemo.de/kochlust-provence/essen/oele-gewuerze/essig-oel/?p=1&o=1&s=&n=12](https://www.shopwaredemo.de/kochlust-provence/essen/oele-gewuerze/essig-oel/?p=1&o=1&s=&n=12)

[https://www.shopwaredemo.de/kochlust-provence/essen/oele-gewuerze/essig-oel/?p=1&o=&s=1&n=](https://www.shopwaredemo.de/kochlust-provence/essen/oele-gewuerze/essig-oel/?p=1&o=&s=1&n=)

wenn man beim Herstellerfilter beim s= nichts anhängt, gibts auch einen 500er. o kann ich leer lassen, n auch, aber nicht s

---

<div class="post-metadata">

### Author: ![SebastianKloepper](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/sebastiankloepper/32/21435_2.png) [@SebastianKloepper](https://forum.shopware.com/u/SebastianKloepper)
#### Post date: [18. Oktober 2017 um 16:07 UTC](https://forum.shopware.com/t/5-3-2-unser-freund-der-unknown-tag-s/47972/134 "2017-10-18T16:07:40Z")

</div>

@SwNewbie‍ Das hat jetzt allerdings gar nichts mit dem besprochenen Verhalten, welches hier behandelt wird, zu tun.&nbsp;  
Es wäre daher super, wenn wir uns hier wirklich auf das eine Thema beschränken könnten 😉

---

<div class="post-metadata">

### Author: ![SwNewbie](https://avatars.discourse-cdn.com/v4/letter/s/8797f3/32.png) [@SwNewbie](https://forum.shopware.com/u/SwNewbie)
#### Post date: [18. Oktober 2017 um 16:10 UTC](https://forum.shopware.com/t/5-3-2-unser-freund-der-unknown-tag-s/47972/135 "2017-10-18T16:10:35Z")

</div>

o.k., ist mir nur aufgefallen, weil ich auf der Suche nach dem ominösen s bin, es kostet leider aktuell verdammt viel Geld…

---

<div class="post-metadata">

### Author: ![Chris\_tian](https://avatars.discourse-cdn.com/v4/letter/c/ee59a6/32.png) [@Chris\_tian](https://forum.shopware.com/u/Chris_tian)
#### Post date: [18. Oktober 2017 um 17:38 UTC](https://forum.shopware.com/t/5-3-2-unser-freund-der-unknown-tag-s/47972/136 "2017-10-18T17:38:59Z")

</div>

> [@Moritz Naczenski schrieb:](https://forum.shopware.com/profile/14574/Moritz%20Naczenski "Moritz%20Naczenski")
> 
> > [@R4M schrieb:](https://forum.shopware.com/profile/17170/R4M "R4M")
> > 
> > **Das ist etwas sehr komisch! Hat hier schlichtweg die Fehlerausgabe (Error handling) von Shopware eine Macke? Kann es sein, dass bei bestimmten Fällen nicht die eigentliche Fehlermeldung ausgegeben wird, sondern selber diesen „tag s“ Fehler verursacht?**
> 
> Ja, dass vermute ich aktuell auch. Ich glaube es ist eher eine Macke am Errorhandling, was viele einzelne Fehler versteckt und weniger ein allgemeines Ding. Habe hier gerade ein Plugin was ebenfalls diesen Fehler verursacht, sobald man das Errorhandling ersetzt und sich die Exeption direkt im Errorhandler ausliest, bekommt man auch einen anderen Fehler.&nbsp; Bei mir hilft es aber auch konkret, die Smarty Security zu deaktivieren:
> 
> ‚template\_security‘ =\> [  
> ‚enabled‘ =\> false,  
> ],
> 
> Das hat aktuell aber noch den Nachteil, dass dann die Dokumentenerstellung im Backend nicht funktioniert, dazu gibt es einen Pull-Request:&nbsp;
> 
> [https://github.com/shopware/shopware/pull/1281](https://github.com/shopware/shopware/pull/1281)
> 
> &nbsp;
> 
> Funktioniert aber wahrscheinlich nur, wenn die zugrundeliegende Fehlermeldung auch ein Security-Error ist.

&nbsp;

Das Problem mit der Dokumentenerstellung gibt es auch in Verbindung mit Pickware und dem PayPal Ratenzahlung-Plugin in Verbindung mit Pcikware. Hier ist es auch so, dass auf einmal nach einem undefinierbarem Zeitraum kein Rechnungsdruck mehr möglich ist. Wird das Plugin PayPal Ratenzahlung deaktiviert funktioniert die Rechnungserstellung auf einmal wieder.&nbsp;

Eventuell gibt es hier einen Zusammenhang?

---

<div class="post-metadata">

### Author: ![SwNewbie](https://avatars.discourse-cdn.com/v4/letter/s/8797f3/32.png) [@SwNewbie](https://forum.shopware.com/u/SwNewbie)
#### Post date: [19. Oktober 2017 um 05:46 UTC](https://forum.shopware.com/t/5-3-2-unser-freund-der-unknown-tag-s/47972/137 "2017-10-19T05:46:56Z")

</div>

Aktueller Statuts: wir haben gestern um 17:34 Paypal Plus abgeschaltet und dazu unter “Einstellungen -\> Performance -\> Einstellungen -\> HTTP-Cache”

httpCache deaktiviert

Automatische-Cache-Unvalidierung deaktiviert.

Dadruch ist der Shop in den Bearbietungsmodus gegangen und die error.log vom Server hat keinen Fehler mehr aufgezeichnet. Wir werden weiter beobachten.

---

<div class="post-metadata">

### Author: ![SwNewbie](https://avatars.discourse-cdn.com/v4/letter/s/8797f3/32.png) [@SwNewbie](https://forum.shopware.com/u/SwNewbie)
#### Post date: [19. Oktober 2017 um 08:12 UTC](https://forum.shopware.com/t/5-3-2-unser-freund-der-unknown-tag-s/47972/138 "2017-10-19T08:12:24Z")

</div>

so, gegen 08:30 nach die vor:

httpCache deaktiviert

Automatische-Cache-Unvalidierung deaktiviert.

Paypal Plus aktiviert, inzwischen 18 x

```
FastCGI sent in stderr: "PHP message: PHP Fatal error: Uncaught exception 'SmartyCompilerException' with message 'Syntax Error in template "/var/www/clients/client1/web2/web/themes/Frontend/Bare/frontend/index/index.tpl" on line 7

```

Jetzt um 10:11 PayPal Plus deaktiviert… Ich weiß das haben andere auch schon getestet und probiert, nur hier kann das scheinbar auch nachgestellt werden.

---

<div class="post-metadata">

### Author: ![R4M](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/r4m/32/9983_2.png) [@R4M](https://forum.shopware.com/u/R4M)
#### Post date: [19. Oktober 2017 um 08:23 UTC](https://forum.shopware.com/t/5-3-2-unser-freund-der-unknown-tag-s/47972/139 "2017-10-19T08:23:38Z")

</div>

Das mit dem PayPal Plus halte ich in diesem Falle nur für den Auslöser einer (anderen) Fehlermeldung, jedoch aber NICHT die Ursache zum eigentlichen Problem. Wer die Beiträge hier verfolgt hat, erkennt auch, dass der&nbsp;“tag s” Fehler bei ganz unterschiedlichen Gegebenheiten statt fand. Meine (aktuelle) Vermutung liegt immer noch beim Errorhandling vom Shop selber und ggf. in Verbindung mit dem Cachehandling. Dieser “tag s” Fehler ist vermutlich nur ein Folgefehler, jedoch aber nicht der Fehler der eigentlich kommen sollte. Vermutlich ist dieser “tag s” Fehler zur Standardmeldung mutiert, wenn irgendwo ein Error 500 auftritt, oder wird automatisch zum Error 500 🙂

---

<div class="post-metadata">

### Author: ![SwNewbie](https://avatars.discourse-cdn.com/v4/letter/s/8797f3/32.png) [@SwNewbie](https://forum.shopware.com/u/SwNewbie)
#### Post date: [19. Oktober 2017 um 08:27 UTC](https://forum.shopware.com/t/5-3-2-unser-freund-der-unknown-tag-s/47972/140 "2017-10-19T08:27:22Z")

</div>

> Vermutlich ist dieser „tag s“ Fehler zur Standardmeldung mutiert, wenn irgendwo ein Error 500 auftritt 🙂

vermutlich, ja. Aber mit dem Cache scheinst Du gefühlt nicht so verkehrt zu liegen.

[Vorherige Seite](https://forum.shopware.com/t/5-3-2-unser-freund-der-unknown-tag-s/47972.md?page=6)

[Nächste Seite](https://forum.shopware.com/t/5-3-2-unser-freund-der-unknown-tag-s/47972.md?page=8)
