# 5.3.2, unser Freund, der unknown tag "s"

**URL:** <https://forum.shopware.com/t/5-3-2-unser-freund-der-unknown-tag-s/47972>\
**Category:** Administration\
**Created:** [31. August 2017 um 18:38 UTC](https://forum.shopware.com/t/5-3-2-unser-freund-der-unknown-tag-s/47972 "2017-08-31T18:38:05Z")\
**Posts on this page:** 20\
**Page:** 11

<div class="post-metadata">

**Author:** ![Chris\_tian](https://avatars.discourse-cdn.com/v4/letter/c/ee59a6/32.png) [@Chris\_tian](https://forum.shopware.com/u/Chris_tian)\
**Post date:** [7. November 2017 um 13:11 UTC](https://forum.shopware.com/t/5-3-2-unser-freund-der-unknown-tag-s/47972/201 "2017-11-07T13:11:58Z")

</div>

> [@Hansi10 schrieb:](https://forum.shopware.com/profile/5296/Hansi10 "Hansi10")
> 
> Hallo, habe nun auch vor 4 Tagen das Update auf 5.3.4 gemacht. Anfangs lief mein Template nicht richtig, konnte aber den Fehler in meinem Theme finden. Jetzt schien alles zu laufen, bis ich bemerkt habe, dass ein Fehler auftritt, wenn man im Offcanvas Warenkorb auf „Warenkorb bearbeiten“ klickt. Folgendes wird ausgegeben:
> 
> Fatal error: Uncaught exception ‚SmartyException‘ with message ‚directory ‚/[Pfad]themes/Frontend/MeinTheme‘ not allowed by security setting‘ in /[Pfad]engine/Library/Smarty/sysplugins/smarty\_security.php:381  
> Stack trace:  
> #0 /[Pfad]engine/Library/Smarty/sysplugins/smarty\_internal\_resource\_file.php(33): Smarty\_Security-\>isTrustedResourceDir(‚/[Pfad]\_…‘)  
> #1 /[Pfad]engine/Library/Smarty/sysplugins/smarty\_resource.php(532): Smarty\_Internal\_Resource\_File-\>populate(Object(Smarty\_Template\_Source), NULL)  
> #2 /[Pfad]engine/Library/Smarty/sysplugins/smarty\_internal\_resource\_extends.php(41): Smarty\_Resource::source(NULL, Object(Enlight\_Template\_Manager), ‚‘)  
> #3 /[Pfad]engine/Library/Enlight/Components/Snippet/Resource.php(76): Smarty\_Intern in /[Pfad]engine/Library/Smarty/sysplugins/smarty\_security.php on line381
> 
> Beim Responsive-Theme ist der Fehler nicht. Muss also irgendwie an meinem Template liegen bzw. an einer Einstellung. An den Plugins liegt es vermutlich nicht, weil ich die meisten testweise deaktiviert habe (z.B. PayPal Plus).
> 
> Wie ich gesehen habe, läuft ansonsten alles so ziemlich fehlerfrei.
> 
> Gruß
> 
> Hansi

Sind alle Plugins aktuell? Ich hatte ein ähnliches Problem mit dem Plugin „Varianten-Vorschau im Listing“&nbsp;

---

<div class="post-metadata">

**Author:** ![Hansi10](https://avatars.discourse-cdn.com/v4/letter/h/73ab20/32.png) [@Hansi10](https://forum.shopware.com/u/Hansi10)\
**Post date:** [7. November 2017 um 14:50 UTC](https://forum.shopware.com/t/5-3-2-unser-freund-der-unknown-tag-s/47972/202 "2017-11-07T14:50:40Z")

</div>

> Sind alle Plugins aktuell? Ich hatte ein ähnliches Problem mit dem Plugin „Varianten-Vorschau im Listing“&nbsp;

Ich habe eigentlich nur „Google Enhanded Ecommerce“ als Drittanbieter-Plugin installiert. Dieses habe ich schon testweise deaktiviert. Alles andere sind die shopware AG notwendigen Plugins von Cron über Shopware Import/Export bis zu InputFilter. Alles ist auf dem aktuellsten Stand. Ich schau mir noch mal mein eigenes Template genauer an. Vielleicht habe ich da einen Fehler eingebaut. Ich habe nur gehofft, man kann aus der Fehlermeldung evtl. wie in einem Kaffeesatz lesen, wo es denn hakt.

---

<div class="post-metadata">

**Author:** ![NextMike](https://avatars.discourse-cdn.com/v4/letter/n/838e76/32.png) [@NextMike](https://forum.shopware.com/u/NextMike)\
**Post date:** [7. November 2017 um 15:05 UTC](https://forum.shopware.com/t/5-3-2-unser-freund-der-unknown-tag-s/47972/203 "2017-11-07T15:05:20Z")

</div>

Suche mal nach “not allowed by security setting”

---

<div class="post-metadata">

**Author:** ![Hansi10](https://avatars.discourse-cdn.com/v4/letter/h/73ab20/32.png) [@Hansi10](https://forum.shopware.com/u/Hansi10)\
**Post date:** [7. November 2017 um 15:31 UTC](https://forum.shopware.com/t/5-3-2-unser-freund-der-unknown-tag-s/47972/204 "2017-11-07T15:31:24Z")

</div>

Ok, ich habe die SmartySecurity abgestellt und damit vorerst Ruhe - wohlwissentlich, dass beim nächsten Update der Fehler vermutlich wieder auftritt. Es sei denn, es wäre ein SWAG-Problem gewesen, welches dann behoben wäre?

Danke.

---

<div class="post-metadata">

**Author:** ![NextMike](https://avatars.discourse-cdn.com/v4/letter/n/838e76/32.png) [@NextMike](https://forum.shopware.com/u/NextMike)\
**Post date:** [7. November 2017 um 15:42 UTC](https://forum.shopware.com/t/5-3-2-unser-freund-der-unknown-tag-s/47972/205 "2017-11-07T15:42:21Z")

</div>

Du könntest schauen welche Anpassungen am Theme das Problem verursachen.

---

<div class="post-metadata">

**Author:** ![Hansi10](https://avatars.discourse-cdn.com/v4/letter/h/73ab20/32.png) [@Hansi10](https://forum.shopware.com/u/Hansi10)\
**Post date:** [7. November 2017 um 16:11 UTC](https://forum.shopware.com/t/5-3-2-unser-freund-der-unknown-tag-s/47972/206 "2017-11-07T16:11:09Z")

</div>

Vielleicht verursacht dies einen Templatefehler: Ich habe auf der Detailseite einen Block überschrieben und deshalb bei meinem Theme unter frontend/detail eine index.tpl erstellt mit folgendem Verweis:

```
{extends file='parent:frontend/detail/index.tpl'}

```

Der Verweis aus der index.tpl aus Bare/frontend/detail lautet aber so:

```
{extends file='frontend/index/index.tpl'}

```

Warum ich das damals so gelöst hatte, weiß ich jetzt nicht mehr, aber ich vermute dass evtl. meine Überschreibung an dieser Stelle verkehrt ist?

---

<div class="post-metadata">

**Author:** ![sonic](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/sonic/32/25728_2.png) [@sonic](https://forum.shopware.com/u/sonic)\
**Post date:** [7. November 2017 um 16:13 UTC](https://forum.shopware.com/t/5-3-2-unser-freund-der-unknown-tag-s/47972/207 "2017-11-07T16:13:50Z")

</div>

Erste&nbsp;Zeile ist schon richtig.  
&nbsp;

```
{extends file='parent:frontend/detail/index.tpl'}

```

BARE hat ja kein parent zum Überschreiben, ändern, sondern eben nur die Dateien aus dem eigenen Pfad.

---

<div class="post-metadata">

**Author:** ![SwNewbie](https://avatars.discourse-cdn.com/v4/letter/s/8797f3/32.png) [@SwNewbie](https://forum.shopware.com/u/SwNewbie)\
**Post date:** [7. November 2017 um 16:18 UTC](https://forum.shopware.com/t/5-3-2-unser-freund-der-unknown-tag-s/47972/208 "2017-11-07T16:18:56Z")

</div>

Wenn ich das richtig sehe (kann mich auch komplett irren) ist bei allen Fehler der Punkt

```
directory 

```

dabei, und diese SmartyFunktion wird in den&nbsp;

```
engine/Library/Smarty/sysplugins/smarty_security.php

```

als unzulässig eingestuft. Sprich wird diese Funktion irgendwo benutzt?

---

<div class="post-metadata">

**Author:** ![ronecker](https://avatars.discourse-cdn.com/v4/letter/r/d2c977/32.png) [@ronecker](https://forum.shopware.com/u/ronecker)\
**Post date:** [8. November 2017 um 11:46 UTC](https://forum.shopware.com/t/5-3-2-unser-freund-der-unknown-tag-s/47972/209 "2017-11-08T11:46:57Z")

</div>

> [@SwNewbie schrieb:](https://forum.shopware.com/profile/22583/SwNewbie "SwNewbie")
> 
> Wenn ich das richtig sehe (kann mich auch komplett irren) ist bei allen Fehler der Punkt
> 
> directory
> 
> dabei, und diese SmartyFunktion wird in den&nbsp;
> 
> engine/Library/Smarty/sysplugins/smarty\_security.php
> 
> als unzulässig eingestuft. Sprich wird diese Funktion irgendwo benutzt?

Sehr gute Analyse, „directory“ ist nicht in den erlaubten Funktionen enthalten.  
Sollte sie zwingend erforderlich sein, dann kann sie in der Datei „/engine/Shopware/Configs/smarty\_functions.php“ hinzugefügt werden.

---

<div class="post-metadata">

**Author:** ![ronecker](https://avatars.discourse-cdn.com/v4/letter/r/d2c977/32.png) [@ronecker](https://forum.shopware.com/u/ronecker)\
**Post date:** [8. November 2017 um 12:00 UTC](https://forum.shopware.com/t/5-3-2-unser-freund-der-unknown-tag-s/47972/210 "2017-11-08T12:00:48Z")

</div>

Und um zum eigentlich Thema zurück zu kommen.

Für das Plugin “SwagVatIdValidation” wurde die Version 1.1.6 mit dem Hinweis auf diesen Fehler  
[http://store.shopware.com/swag161736212188/umsatzsteuer-id-pruefung.html](http://store.shopware.com/swag161736212188/umsatzsteuer-id-pruefung.html)

Damit wären alle bisher bekannten Plugins, die diesen Fehler erzeugt haben aktualisiert.  
Ich möchte mich noch einmal bei allen Beteiligten hier im Thema bedanken, ohne Euch wären bestimmt noch viele weite Shopware-Kunden verzweifelt.  
Auch ein Danke an Shopware, für die Hilfe bei der Fehlersuche und die raschen Updates.

Drücken wir jetzt alle mal die Daumen das es das war.

---

<div class="post-metadata">

**Author:** ![Hansi10](https://avatars.discourse-cdn.com/v4/letter/h/73ab20/32.png) [@Hansi10](https://forum.shopware.com/u/Hansi10)\
**Post date:** [8. November 2017 um 12:04 UTC](https://forum.shopware.com/t/5-3-2-unser-freund-der-unknown-tag-s/47972/211 "2017-11-08T12:04:15Z")

</div>

Wer erzwingt aber nun die Funktion „directory“? Ich war das bestimmt nicht ;-). Kann dann ja nur von einem Fremd-Plugin bzw. SWAG-Plugin kommen. Oder könnte das evtl. mit einer https-Umleitung oder sonstwas zusammenhängen?

---

<div class="post-metadata">

**Author:** ![Moritz\_Naczenski](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/moritz_naczenski/32/7792_2.png) [@Moritz\_Naczenski](https://forum.shopware.com/u/Moritz_Naczenski)\
**Post date:** [8. November 2017 um 12:06 UTC](https://forum.shopware.com/t/5-3-2-unser-freund-der-unknown-tag-s/47972/212 "2017-11-08T12:06:10Z")

</div>

Schick mir mal dein Theme und wie ich das nachstellen kann an [forum@shopware.com](mailto:forum@shopware.com)

---

<div class="post-metadata">

**Author:** ![Moritz\_Naczenski](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/moritz_naczenski/32/7792_2.png) [@Moritz\_Naczenski](https://forum.shopware.com/u/Moritz_Naczenski)\
**Post date:** [8. November 2017 um 14:18 UTC](https://forum.shopware.com/t/5-3-2-unser-freund-der-unknown-tag-s/47972/213 "2017-11-08T14:18:56Z")

</div>

> [@Hansi10 schrieb:](https://forum.shopware.com/profile/5296/Hansi10 "Hansi10")
> 
> Hallo, habe nun auch vor 4 Tagen das Update auf 5.3.4 gemacht. Anfangs lief mein Template nicht richtig, konnte aber den Fehler in meinem Theme finden. Jetzt schien alles zu laufen, bis ich bemerkt habe, dass ein Fehler auftritt, wenn man im Offcanvas Warenkorb auf „Warenkorb bearbeiten“ klickt. Folgendes wird ausgegeben:
> 
> Fatal error: Uncaught exception ‚SmartyException‘ with message ‚directory ‚/[Pfad]themes/Frontend/MeinTheme‘ not allowed by security setting‘ in /[Pfad]engine/Library/Smarty/sysplugins/smarty\_security.php:381  
> Stack trace:  
> #0 /[Pfad]engine/Library/Smarty/sysplugins/smarty\_internal\_resource\_file.php(33): Smarty\_Security-\>isTrustedResourceDir(‚/[Pfad]\_…‘)  
> #1 /[Pfad]engine/Library/Smarty/sysplugins/smarty\_resource.php(532): Smarty\_Internal\_Resource\_File-\>populate(Object(Smarty\_Template\_Source), NULL)  
> #2 /[Pfad]engine/Library/Smarty/sysplugins/smarty\_internal\_resource\_extends.php(41): Smarty\_Resource::source(NULL, Object(Enlight\_Template\_Manager), ‚‘)  
> #3 /[Pfad]engine/Library/Enlight/Components/Snippet/Resource.php(76): Smarty\_Intern in /[Pfad]engine/Library/Smarty/sysplugins/smarty\_security.php on line381
> 
> Beim Responsive-Theme ist der Fehler nicht. Muss also irgendwie an meinem Template liegen bzw. an einer Einstellung. An den Plugins liegt es vermutlich nicht, weil ich die meisten testweise deaktiviert habe (z.B. PayPal Plus).
> 
> Wie ich gesehen habe, läuft ansonsten alles so ziemlich fehlerfrei.
> 
> Gruß
> 
> Hansi

&nbsp;

Bei dir ist die Datei /frontend/checkout/table\_footer.tpl fehlerhaft. Dort ist das Extends nicht richtig:

```
{extends file='parent:frontend/checkout/cart'}

```

Sollte ausreichen, wenn du das abänderst:

```
{extends file='parent:frontend/checkout/table_footer.tpl'}

```

&nbsp;

---

<div class="post-metadata">

**Author:** ![Hansi10](https://avatars.discourse-cdn.com/v4/letter/h/73ab20/32.png) [@Hansi10](https://forum.shopware.com/u/Hansi10)\
**Post date:** [8. November 2017 um 15:22 UTC](https://forum.shopware.com/t/5-3-2-unser-freund-der-unknown-tag-s/47972/214 "2017-11-08T15:22:31Z")

</div>

Danke Moritz! Da darf ich mal sagen: “Super Service”. Ich habe die template security wieder aktiviert und der Fehler ist weg. Künftig werde ich bei solchen Fehlern mein Theme genauer inspizieren. Jetzt weiß ich aber, wo man anfangen muß.

---

<div class="post-metadata">

**Author:** ![ronecker](https://avatars.discourse-cdn.com/v4/letter/r/d2c977/32.png) [@ronecker](https://forum.shopware.com/u/ronecker)\
**Post date:** [8. November 2017 um 17:38 UTC](https://forum.shopware.com/t/5-3-2-unser-freund-der-unknown-tag-s/47972/215 "2017-11-08T17:38:09Z")

</div>

Ich möchte nochmal kurz das Post von DennisG&nbsp;hervorheben, effektiv war das die Lösung. Durch Anpassung der config.php konnte die Fehlerbehandlung umgestellt und damit eine brauchbare Fehlermeldung in den Logdateien ausgegeben werden.  
Dankeschön.

> [@DennisG schrieb:](https://forum.shopware.com/profile/24750/DennisG "DennisG")
> 
> Das ist natürlich nur eine Notlösung… Wird bei einm Update wieder überschrieben. Ihr solltet wenn dieser Fehler reproduzierbar ist die Shopware Config.php anpassen.
> 
> ‚phpsettings‘ =\> [  
> ‚display\_errors‘ =\> 1,  
> ],  
> // Frontend display Exceptions  
> ‚front‘ =\> [  
> ‚noErrorHandler‘ =\> true,  
> ‚throwExceptions‘ =\> true,  
> ],
> 
> (Cache leeren) und dann den Fehler Reproduzieren. Durch die anpassung der ShopConfig solltet ihr eine Richtige Fehlermeldung bekommen die aussagekräfig ist. Also welches Plugin zu früh versucht ein Template zu laden bzw. zu Spät das Template Directory registriert.&nbsp;

---

<div class="post-metadata">

**Author:** ![SwNewbie](https://avatars.discourse-cdn.com/v4/letter/s/8797f3/32.png) [@SwNewbie](https://forum.shopware.com/u/SwNewbie)\
**Post date:** [10. November 2017 um 07:24 UTC](https://forum.shopware.com/t/5-3-2-unser-freund-der-unknown-tag-s/47972/216 "2017-11-10T07:24:59Z")

</div>

Nur als Hinweis, PP+ in der aktuellen Version ist mit einem BUG versehen: [Shopware Issuetracker](https://issues.shopware.com/issues/PT-8619). Betrifft in erster Linie Mobil, hier werden die PP+ Zahlungsarten ggf. nicht angezeigt bzw. geladen. Haben wir gestern entdeckt und wurde heute vom Support bestätigt.

---

<div class="post-metadata">

**Author:** ![Str33tfight3r](https://avatars.discourse-cdn.com/v4/letter/s/5f9b8f/32.png) [@Str33tfight3r](https://forum.shopware.com/u/Str33tfight3r)\
**Post date:** [15. November 2017 um 09:47 UTC](https://forum.shopware.com/t/5-3-2-unser-freund-der-unknown-tag-s/47972/217 "2017-11-15T09:47:36Z")

</div>

Bei uns lag es am Template.

Kann man herausfinden, wo in welcher Änderung sich der Fehler verbirgt?

---

<div class="post-metadata">

**Author:** ![motorg](https://avatars.discourse-cdn.com/v4/letter/m/ed655f/32.png) [@motorg](https://forum.shopware.com/u/motorg)\
**Post date:** [15. November 2017 um 13:42 UTC](https://forum.shopware.com/t/5-3-2-unser-freund-der-unknown-tag-s/47972/218 "2017-11-15T13:42:12Z")

</div>

Ich hab jetzt nicht alles gelesen. Ist die Fehlerursache inzwischen bekannt und behoben oder noch nicht. Plane aktuell das Update von 5.2.20 auf 5.3.x&nbsp;

---

<div class="post-metadata">

**Author:** ![Mika\_Ka](https://avatars.discourse-cdn.com/v4/letter/m/58956e/32.png) [@Mika\_Ka](https://forum.shopware.com/u/Mika_Ka)\
**Post date:** [17. November 2017 um 10:58 UTC](https://forum.shopware.com/t/5-3-2-unser-freund-der-unknown-tag-s/47972/219 "2017-11-17T10:58:15Z")

</div>

Folgendes Problem auch hier.

Nach Upgrade auf 5.3.4 bekam ich seit heute Morgen auch immer wieder Fehlermeldungen (s.u.)

Vorauszuschicken wäre, dass ich gestern Nachmittag PaypalPlus installiert habe, was im Weiteren keine Probleme gebracht hatte.

Erst nach dem Upgrade auf 5.3.4 kam es zur Fehlermeldung.

Im Übrigen ging das soweit, dass offenbar sogar die SEO-URL´s der Bog-Beiträge einen 404-Fehler ausgelöst hatten. Das War dann allerdings nach Neu-Aufbau des SEO-Index und anschließender Neu-Kompilierung der Shop-Dateien behoben.&nbsp;

Nicht jedoch der unten aufgeführte Fehler, der sich jedoch mit einer weiteren Meldung „abgewechselt“ habe, die ich leider vergessen habe, zu kopieren.

Es lässt sich jedoch bemerken, dass die Fehlermeldungen tatsächlich dann auftraten, wenn aus dem Offcanvas-Warenkorb auf „Warenkorb bearbeiten“ und dann zurück auf die Startseite des Shops gewechselt wurde (Kategorie- und Detailseiten funktionierten weiterhin wie gewohnt).&nbsp;

Der&nbsp;auf Seite 5 dieses Threads gepostete Workaround

> [@DennisG schrieb:](https://forum.shopware.com/profile/24750/DennisG "DennisG")
> 
> Das Entfernen / ausschalten der SmartySecurity und danach Cach leeren sollte eigentlich helfen. Alternativ sollte es helfen wenn ihr in der
> 
> Datei: **_&nbsp;/…engine/Library/Smarty/sysplugins/smarty\_security.php_**
> 
> die Methode: **_isTrustedResourceDir_** anpasst und einfach ein return true einbaut.
> 
> public function isTrustedResourceDir($filepath)  
> {  
> return true; //
> 
> Zur weitern Fehleranalyse könnt ihr auch das Plugin von shyim installieren:&nbsp;[https://github.com/shyim/whoops-for-shopware](https://github.com/shyim/whoops-for-shopware)
> 
> Aktuell gehen wir davon aus das dieser Check vor dem hinzufügen der Template Ordner von Plugins läuft und dadurch der Fehler geworfen wird.

hat hier zunächst einmal Abhilfe geschaffen.

Hier noch die Fehlermeldung der Vollständigkeit halber.&nbsp;

> **Fatal error** : Uncaught SmartyCompilerException: Syntax Error in template „/var/www/clients/client2042/web4262/web/themes/Frontend/Bare/frontend/index/index.tpl“ on line 7 „\<html class="no-js" lang="{s name=‚IndexXmlLang‘}{/s}" itemscope="itemscope" itemtype="[http://schema.org/WebPage&quot;&gt;](http://schema.org/WebPage&quot;&gt;)“ unknown tag „s“ in /var/www/clients/client2042/web4262/web/engine/Library/Smarty/sysplugins/smarty\_internal\_templatecompilerbase.php:657 Stack trace: #0 /var/www/clients/client2042/web4262/web/engine/Library/Smarty/sysplugins/smarty\_internal\_templatecompilerbase.php(443): Smarty\_Internal\_TemplateCompilerBase-\>trigger\_template\_error(‚unknown tag „s“‘, 7) #1 /var/www/clients/client2042/web4262/web/engine/Library/Smarty/sysplugins/smarty\_internal\_templateparser.php(2388): Smarty\_Internal\_TemplateCompilerBase-\>compileTag(‚s‘, Array) #2 /var/www/clients/client2042/web4262/web/engine/Library/Smarty/sysplugins/smarty\_internal\_templa in&nbsp; **/var/www/clients/client2042/web4262/web/engine/Library/Smarty/sysplugins/smarty\_internal\_templatecompilerbase.php** &nbsp;on line&nbsp; **657**

**Edit:**

jetzt habe ich eben gemerkt, dass die o.g. zweite Fehlermeldung noch ein einem anderen Browser-Fenster vorhanden war:

> **Fatal error** : Uncaught SmartyException: directory ‚/var/www/clients/client2042/web4262/web/engine/Shopware/Plugins/Community/Frontend/KamoProductShortDescription/Views/frontend/listing/product-box/box-basic.tpl‘ not allowed by security setting in /var/www/clients/client2042/web4262/web/engine/Library/Smarty/sysplugins/smarty\_security.php:381 Stack trace: #0 /var/www/clients/client2042/web4262/web/engine/Library/Smarty/sysplugins/smarty\_internal\_resource\_file.php(33): Smarty\_Security-\>isTrustedResourceDir(‚/var/www/client…‘) #1 /var/www/clients/client2042/web4262/web/engine/Library/Smarty/sysplugins/smarty\_resource.php(532): Smarty\_Internal\_Resource\_File-\>populate(Object(Smarty\_Template\_Source), NULL) #2 /var/www/clients/client2042/web4262/web/engine/Library/Smarty/sysplugins/smarty\_internal\_resource\_extends.php(41): Smarty\_Resource::source(NULL, Object(Enlight\_Template\_Manager), ‚/var/www/client…‘) #3 /var/www/clients/client2042/web4262/web/engine/Library/Enlight/Components/Snippet/Resource.php(76): Smarty\_Internal\_Res in&nbsp; **/var/www/clients/client2042/web4262/web/engine/Library/Smarty/sysplugins/smarty\_security.php** &nbsp;on line&nbsp; **381**

---

<div class="post-metadata">

**Author:** ![sschreier](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/sschreier/32/23296_2.png) [@sschreier](https://forum.shopware.com/u/sschreier)\
**Post date:** [17. November 2017 um 11:58 UTC](https://forum.shopware.com/t/5-3-2-unser-freund-der-unknown-tag-s/47972/220 "2017-11-17T11:58:33Z")

</div>

Hallo,

dort hast du doch aber schon einen Übeltäter: Das Plugin KamoProductShortDescription nutzt eine Funktion, die aufgrund der Security Einstellungen von Shopware 5.3 nicht mehr zugelassen ist. Hier musst du also entweder das Plugin deaktivieren oder den Hersteller des Plugins anschreiben, das er das Problem beseitigen soll.

Bei der oberen Meldung dagegen würde ich mal in der genannten Datei nachsehen und dies prüfen.

Beste Grüße

Sebastian

[Vorherige Seite](https://forum.shopware.com/t/5-3-2-unser-freund-der-unknown-tag-s/47972.md?page=10)

[Nächste Seite](https://forum.shopware.com/t/5-3-2-unser-freund-der-unknown-tag-s/47972.md?page=12)
